16:00:14 <gmann> #startmeeting tc
16:00:14 <opendevmeet> Meeting started Wed Nov 16 16:00:14 2022 UTC and is due to finish in 60 minutes.  The chair is gmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:14 <opendevmeet> The meeting name has been set to 'tc'
16:00:20 <gmann> #topic Roll call
16:00:23 <gmann> o/
16:00:33 <knikolla> o/
16:01:35 <JayF> o/
16:02:31 <gmann> let's wait for couple of min for other members to join.
16:02:40 <arne_wiebalck> o/
16:03:04 <gmann> dansmith spotz noonedeadpunk rosmaita ping for meeting
16:03:12 <rosmaita> o/
16:03:24 <gmann> in Absence section, slaweq - 16.11.2022
16:04:43 <gmann> we have 5 members so let's start
16:04:51 <gmann> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Next_Meeting
16:04:56 <gmann> ^^ today meeting agenda
16:05:05 <jungleboyj> Howdy.
16:05:10 <noonedeadpunk> o/
16:05:22 <gmann> #topic Follow up on past action items
16:05:32 <gmann> we have two action item from previous meeting
16:05:33 <gmann> gmann to check with foundation about zoom pro account if any and can be shared with TC monthly video call
16:05:48 <gmann> I sent email but did not get response yet so I will keep it open
16:05:50 <gmann> #action gmann to check with foundation about zoom pro account if any and can be shared with TC monthly video call
16:06:02 <gmann> rosmaita to continue his research/survey on translation things and update in TC meetings
16:06:10 <gmann> rosmaita: any update on this?
16:06:16 <rosmaita> yes
16:06:34 <rosmaita> i put together a draft survey, could use some eyes/comments on it
16:06:52 <rosmaita> here comes a really long url
16:06:56 <rosmaita> #link https://forms.zohopublic.com/rosmaitafossdev/form/OpenStacktranslationsusageandcontributionsurvey/formperma/9W0PYjoo61tAShU9B1GQj3m52K43uty-KtXDhIlOUe4
16:07:01 <rosmaita> but that's what you get for free
16:07:24 <rosmaita> while doing this, i learned that there has been a lot of consolidation in the free survey industry
16:07:45 <rosmaita> and most options have a free level that is practically useless
16:07:54 <fungi> i take it limesurvey didn't pan out
16:08:06 <gmann> ohk
16:08:14 <rosmaita> no, limesurvey only allows 25 responses a month
16:08:41 <rosmaita> wufoo only allows 100 "entries" a month (whch would be about 20 responses)
16:08:59 <rosmaita> pabbly.com only allows 100 submissions on a form
16:09:06 <rosmaita> typeform only 10 responses
16:09:15 <rosmaita> but zoho.com allows 500 submissions/month
16:09:18 <fungi> ouch, yeah i guess i only lightly tested limesurvey's hosted version before i set up one to run in opendev (but then nobody used it, so we turned it off)
16:09:24 <rosmaita> hence, that's what i picked
16:09:55 <rosmaita> google forms allow unlimited responses, but are not available worldwide
16:10:07 <rosmaita> (just for the record)
16:10:30 <gmann> thanks that is good info to consider in future.
16:10:36 <rosmaita> fungi: would be good if you could review what i say there about opendev infra supporting an instance
16:10:46 <rosmaita> (i took it from a clarkb email, so is probably correct)
16:11:09 <fungi> rosmaita: will check, thanks
16:12:14 <fungi> rosmaita: lgtm
16:12:26 <rosmaita> gmann: do we have time to look it over now, or should i say please get me comments by <date>
16:12:36 <rosmaita> fungi: ty
16:12:40 <fungi> either way though, there's still work for someone to (re)implement the import/export automation, even for the hosted weblate
16:12:53 <gmann> rosmaita: not now, you can continue and we can track it when ever you are ready via tracker
16:13:19 <rosmaita> ok, everyone, please give me comments before Friday at 1700 UTC
16:13:35 <fungi> rosmaita: oh, zanata is the correct spelling, not zenata
16:13:41 <fungi> minor nit
16:13:51 <rosmaita> thanks, i must be confused with ZenDesk!
16:14:03 <gmann> +1, let's get the response and once we have the data then we can discuss and decide
16:14:47 <gmann> anything else on this ?
16:14:53 <rosmaita> nope
16:15:00 <gmann> thanks
16:15:02 <gmann> #topic Gate health check
16:15:06 <gmann> any news on gate?
16:15:33 <gmann> I have not monitored gate this week much as working on RBAC/service role testing and also migration to jammy
16:16:00 <fungi> moments ago we found out ovh is having an incident impacting some of their swift services, so we merged a change to temporarily stop uploading job logs there, but some builds in the past hour or so ended with post_failure
16:16:23 <gmann> ok
16:17:13 <fungi> early utc saturday we had a transient bug with our weekly rolling zuul upgrade which caused builds to end with retry_limit results, but by mit-saturday utc it was resolved (once the scheduelrs were running the same version as the executors). we merged a fix for that so other zuul deployments won't hit it
16:17:26 <noonedeadpunk> Well, I found out that sahara if installed with Zed u-c (or with master) is not usable due to jsonschema version
16:18:11 <noonedeadpunk> But that;s  not gate specific thing, but more project health I guess
16:18:20 <gmann> ohk, not sure we have many active maintainer in sahara but we fixed jsonschema things in other repo during Zed i think
16:18:23 <fungi> the recent round of branch eols also raised some new errors in projects which didn't eol those branches but were consuming branch-specific jobs from ones that did
16:18:26 <noonedeadpunk> Patch exists but was -1 on CR
16:18:49 <fungi> worth revisiting whether transition from em to eol is really something we can leave up to individual projects
16:19:21 <gmann> devstack is another example in that where we need to fix it to use the EOL tag for project moved to EOL
16:19:39 <noonedeadpunk> well at very least I think that projects with trailing releases must EOL after all other projects as well
16:19:59 <fungi> yes, there is implied work for other teams when we do integration testing between projects but allow them to eol branches on different schedules
16:20:05 <noonedeadpunk> Yeah, for reason gmann said actually
16:20:14 <gmann> not sure how easy or difficult to have a coordinated transition to EOL but release team knows better
16:20:45 <JayF> I'll note that forcing teams to remain in "EM" when they wish to EOL will still push back that job-fixing-work on other teams if they aren't maintaining CI for that EM release.
16:21:05 <fungi> agreed, i feel like we leave em branches open far too long
16:21:08 <gmann> I will say they are moving from EM to EOL so if EM is broken due to some project EOL then it is good indication to EM projects also to do
16:21:12 <JayF> There's no way to get around it: one project not-caring about an older release impacts any it cross-gates with; whether that's via EOL tag or just neglect
16:21:19 <gmann> JayF: +1 yeah
16:21:49 <gmann> in devstack also, we were discussing the same. let devstack EM branch broken and if anyone backporting and need devstack then they can fix it
16:22:08 <rosmaita> well, when a project goes EOL on a branch, in devstack you can tell it to check out the eol tag instead of the stable branch
16:22:09 <gmann> that is overall approach to EM anyays
16:22:33 <gmann> rosmaita: yeah but that is extra work we need to do
16:22:52 <JayF> and it leaves no path if that job starts failing due to bit rot or other reasons
16:23:02 <gmann> I am not denying to do that but instead anyone maintaining the branches as EM can do
16:23:02 <JayF> I actually think hard-failures might be preferable to testing against code you could never fix
16:23:26 <JayF> but I'm not the one zuul is screaming at when the yaml doesn't parse :)
16:23:31 * dansmith stumbles in late
16:24:06 <gmann> this Friday (Nov 18) we will merge the base jobs moving to Jammy. and project can pin failing job to Focal nodeset for time being
16:24:07 <gmann> #linkk https://lists.openstack.org/pipermail/openstack-discuss/2022-November/031205.html
16:24:23 <gmann> noonedeadpunk i think let's stick to the deadline and not delay that.
16:24:31 <dansmith> agree
16:24:34 <gmann> ceph and swift fixes are still not merged
16:24:56 <gmann> and horizon nodejs also failing
16:25:31 <dansmith> do we need a patch to pin ceph stuff on focal ahead of friday?
16:25:43 <noonedeadpunk> gmann: well, in OSA we also need to switch all projects to eol tag before marking osa as eol
16:25:46 <fungi> yeah, the sooner that is switched the more time projects have to fix up problems they don't already know about. allowing projects which are aware of problems and haven't fixed them yet to delay that would be a poor prioritization, in my opinion
16:25:46 <gmann> yeah to get devstack patch merge
16:25:57 <gmann> dansmith: I will try to push one today
16:26:00 <noonedeadpunk> otherwise, we will reference branches that does not exist
16:26:06 <dansmith> gmann: okay
16:26:50 <noonedeadpunk> ah, you meant schedule about jammy transition
16:26:52 <gmann> noonedeadpunk: ok but you can just wait for all project to go EOL and keep OSA EM as broken ?
16:26:53 <noonedeadpunk> sorry
16:27:30 <noonedeadpunk> yeah, I jsut haven't switched to the new topic yet :)
16:27:49 <gmann> ohk, sorry for jumping to next
16:28:25 <noonedeadpunk> nah, it's fine, sorry for being slow :)
16:28:26 <gmann> noonedeadpunk: for jammy migration, I know you fix is up for ceph job but it seems some other failure there. swift one is still not merged too
16:29:18 <noonedeadpunk> tbh I'm not sure what should be passing and what's not - jobs are marked as NV so hard to say kind of. I would expect NFS to pass though. I think it's a usecase with ganesha
16:29:20 <gmann> this is swift fix timburke mentioned in swift channel #link https://review.opendev.org/c/openstack/swift/+/863441
16:29:27 <noonedeadpunk> Can look into that if it's supposed to work
16:29:36 <gmann> sure
16:30:00 <noonedeadpunk> oh no, "//" again
16:30:26 <gmann> but let's do the migration on Friday, I will keep pinning nodeset patches ready meanwhile
16:30:30 <gmann> yeah
16:31:07 <gmann> anything else on gate health?
16:31:44 <gmann> #topic 2023.1 TC tracker checks
16:31:46 <gmann> #link https://etherpad.opendev.org/p/tc-2023.1-tracker
16:31:59 <gmann> rosmaita already provided updates on i18 SIG
16:32:11 <gmann> one update form me on TC chair process which is merged now
16:32:42 <gmann> and upgrade path patch is up for review #link https://review.opendev.org/c/openstack/governance/+/860599
16:33:04 <gmann> noonedeadpunk ^^ updated it as per your review comment, please have a look
16:33:15 <gmann> any updates form anyone on their assigned items?
16:34:15 <gmann> ok, if nothing else let's move to next topic
16:34:19 <gmann> #topic TC stop using storyboard?
16:34:30 <gmann> #link https://storyboard.openstack.org/#!/project/923
16:35:11 <gmann> we discussed it in last week meeting, and many of us even were not aware that it exist
16:35:38 <gmann> and defer this topic to this meeting as we were not having majority of TC in the meeting
16:35:44 <knikolla> I remember that there was a push for everyone to use Storyboard many years ago
16:35:55 <gmann> yeah
16:36:12 <knikolla> Am I correct in assuming that push is not happening anymore and that Storyboard is not really seeing developmnet?
16:36:16 <gmann> in TC we are using tracker in eytherpad which is much easy and also for many goal tracking also
16:37:04 <gmann> well, most of the projects decided to move to LP like ironic, placement. so not sure that it is good idea to move them back to SB again
16:37:15 <noonedeadpunk> Well, during PTG there were couple of topics on different tracks to move out from storyboard as well
16:37:21 <gmann> but we are not deciding to shutdown SB for now
16:37:27 <gmann> yeah
16:37:32 <fungi> yes, this is less about whether projects are using storyboard and more that the process doug originally devised for goal tracking isn't being used and hasn't been for years
16:37:39 <gmann> let's see how project goes and prefer over time
16:38:03 <gmann> for TC SB, we can decide if we want to stop using SB or not
16:38:05 <knikolla> ++, just trying to get more context on where we stand as a community
16:38:08 <noonedeadpunk> I personally find SB quite hard to use
16:38:09 <JayF> I think it'd be a positive change to just remove this tracking of governance from storyboard, and migrate it to "nothing" (our etherpad?)
16:38:19 <gmann> yeah
16:38:39 <dansmith> yep, NFO, move on
16:39:01 <gmann> I would like to have a vote here for the record, any more question/discussion before I start voting?
16:39:30 <fungi> the vote is specifically about deactivating the openstack/governance repo in storyboard.openstack.org, right?
16:39:43 <gmann> yes
16:39:54 * dansmith readies his voting finger
16:39:54 <knikolla> and not moving to launchpad
16:39:55 <knikolla> ?
16:40:05 <gmann> yes
16:40:25 <dansmith> I think we identified that we don't need either because most of us didn't even know the SB stuff was a thing
16:40:28 <dansmith> which I'm in favor of
16:40:57 <gmann> ok, let's start the voting, putting all together
16:41:04 <gmann> #startvote TC stop tracking things on storyboard, close the governance project in SB, and not moving to LP? Yes, No
16:41:04 <opendevmeet> Begin voting on: TC stop tracking things on storyboard, close the governance project in SB, and not moving to LP? Valid vote options are Yes, No.
16:41:04 <opendevmeet> Vote using '#vote OPTION'. Only your last vote counts.
16:41:23 <knikolla> #vote Yes
16:41:26 <gmann> #vote Yes
16:41:30 <rosmaita> i don't think we need the "not moving to LP" in there
16:41:31 <dansmith> #vote Yes
16:41:31 <noonedeadpunk> #vote Yes
16:41:34 <rosmaita> seems extraneous
16:41:40 <JayF> #vote Yes
16:41:40 <noonedeadpunk> +1 to that
16:41:42 <gmann> rosmaita: just to make sure
16:41:58 <rosmaita> make sure of what, though?
16:41:59 <noonedeadpunk> Or answers should be not boolean
16:42:01 <gmann> rosmaita: usually closing SB means moving to LP
16:42:19 <knikolla> there might be ambiguity in the need for an issue tracking mechanism for governance, and the SB/LP has been a binary usually.
16:42:20 <rosmaita> well, i don't see any reason not to move to LP if it would be useful
16:42:24 <gmann> for now we do not need to move to LP
16:42:42 <rosmaita> right, but i don't see why that needs to be part of this vote
16:42:46 <gmann> rosmaita: we do not have such requirement to move to LP right?
16:42:50 <fungi> for the record, it wasn't really issue tracking that it was being used for anyway, it was task tracking
16:43:04 <rosmaita> right, there is no obligation to use LP
16:43:11 <fungi> (back when it was used at all)
16:43:20 <rosmaita> but i don't see why we would want to say we are not going there as part of not using SB
16:43:24 <dansmith> I think so many projects are "moving back to LP from SB", and knikolla asked about it,
16:43:31 <dansmith> so the clarification seems to make sense to me
16:43:32 <gmann> rosmaita: if we use then we need to open project there and tack it too right
16:44:03 <gmann> yeah, stop SB should not mean we are moving to LP and for TC it is kind of different than other project
16:44:16 <dansmith> rosmaita: you know we're just talking about the TC's task tracking and not anything binding for other projects right?
16:44:23 <gmann> so it should not be read as TC is stopping SB and they will be on LP
16:44:53 <gmann> yeah this is specific for TC only
16:45:08 <JayF> "TC will stop formally tracking status in storyboard, leaving TC with no storyboard usage or migration to perform" <-- would this wording be more clear?
16:45:16 <knikolla> if we make a songs album, it should be on LP
16:45:24 <JayF> I think we all agree just confusion over the wording, yeah?
16:45:45 <fungi> the tc hasn't really been doing goal task tracking in storyboard for years, so it already stopped long ago. this is about cleanup
16:46:09 <rosmaita> i would be ok with "TC stop tracking things on storyboard and close the governance project in SB"
16:46:19 <JayF> ++
16:46:50 <gmann> ok let's do that way. and as we are not using LP, leave that separate
16:46:52 <noonedeadpunk> well, for me if we're adding LP part it would make sense to ask if we're closing SB and migrating nowhere, not closing SB or moving to LP
16:47:22 <gmann> "TC stop tracking things on storyboard and close the governance project in SB and not migrating to any other tracking tool for now" ?
16:47:24 <noonedeadpunk> As if it occurs that there're majority to use bug tracking system, but not SB, we're cutting these votes right now
16:48:00 <fungi> the tc no longer has any process relying on the presence of the openstack/governance project in storyboard. it's probably not accurate to vote to stop doing something that already isn't being done
16:48:06 <gmann> everyone agree on "TC stop tracking things on storyboard and close the governance project in SB and not migrating to any other tracking tool for now" ?
16:48:25 <noonedeadpunk> I'm fine with that
16:48:26 <dansmith> sure?
16:48:33 <rosmaita> ok
16:48:44 <knikolla> alright
16:48:57 <gmann> ok let me end vote first and restart. I do not think we have command to cancel the vote, please let me know if we do/?
16:49:34 <JayF> #vote invalid
16:49:34 <opendevmeet> JayF: invalid is not a valid option. Valid options are Yes, No.
16:49:45 <JayF> heh there's no way to abstain after the fact
16:50:04 <gmann> this poll/vote is abandon and we are restring the new vote
16:50:08 <rosmaita> yeah, it enforces the options very strictly
16:50:08 <gmann> #endvote
16:50:08 <opendevmeet> Voted on "TC stop tracking things on storyboard, close the governance project in SB, and not moving to LP?" Results are
16:50:08 <opendevmeet> Yes (5): gmann, dansmith, JayF, knikolla, noonedeadpunk
16:50:23 <JayF> Can you #note that the vote before was invalid?
16:50:31 <JayF> somethign that'll show up in the summarized-log
16:50:54 <fungi> the meetbot manual seems to completely skip over voting commands
16:51:14 <gmann> #note previous vote was abandon and we are restarting the new vote on SB.
16:51:17 <gmann> done
16:51:25 <JayF> Thanks
16:51:30 <gmann> #startvote TC stop tracking things on storyboard, close the governance project in SB, and not migrating to any other tracking tool for now? Yes, No
16:51:30 <opendevmeet> Begin voting on: TC stop tracking things on storyboard, close the governance project in SB, and not migrating to any other tracking tool for now? Valid vote options are Yes, No.
16:51:30 <opendevmeet> Vote using '#vote OPTION'. Only your last vote counts.
16:51:39 <dansmith> #vote Yes
16:51:41 <knikolla> #vote Yes
16:51:43 <gmann> #vote Yes
16:51:43 <rosmaita> #vote Yes
16:51:47 <noonedeadpunk> #vote Yes
16:51:51 <JayF> #vote Yes
16:52:00 <arne_wiebalck> #vote Yes
16:52:43 <gmann> I think all tc-members present here voted.
16:52:49 <gmann> #endvote
16:52:49 <opendevmeet> Voted on "TC stop tracking things on storyboard, close the governance project in SB, and not migrating to any other tracking tool for now?" Results are
16:52:49 <opendevmeet> Yes (7): gmann, rosmaita, arne_wiebalck, dansmith, JayF, knikolla, noonedeadpunk
16:53:03 <fungi> i'll take care of the steps for closing down the openstack/governance repository in sb later today
16:53:06 <gmann> cool, I will start the cleanup work on SB
16:53:26 <gmann> frickler: let me close the open tasks there in case we have clear cleanup
16:53:30 <gmann> fungi: ^^
16:53:36 <gmann> frickler: please ignore
16:53:39 <fungi> but yes, you probably need to patch some governance documentation which refers to it
16:54:01 <gmann> yeah, also some open story/tasks too
16:54:08 <gmann> ok, moving next
16:54:13 <gmann> #topic Recurring tasks check
16:54:19 <gmann> Bare 'recheck' state
16:54:30 <gmann> #link https://etherpad.opendev.org/p/recheck-weekly-summary
16:54:49 <gmann> slaweq added this week summary in ^^ etherpad
16:55:23 <gmann> which does not look bad. any discussion on this?
16:55:51 <gmann> #topic Open Reviews
16:55:53 <gmann> #link https://review.opendev.org/q/projects:openstack/governance+is:open
16:56:12 <gmann> need one more vote in this #link https://review.opendev.org/c/openstack/governance/+/862637
16:56:27 <gmann> other open review are either waiting for deps or already talked about in meeting
16:56:32 <JayF> FYI: I abandoned my proposal for video meetings; I appreciate everyone giving their feedback about the idea in writing but there was a clear consensus against it.
16:56:47 <rosmaita> oh, i was wondering what happened to that
16:56:53 <gmann> ack
16:57:38 <gmann> reminder that we have Board + OpenStack syncup call today at 20 UTC (i think 3 hr from now) #link https://etherpad.opendev.org/p/2022-11-board-openstack-sync
16:57:45 <knikolla> thanks for writing it JayF . It was really helpful to get additional points of view. I'll be doing some more research into how other communities do it.
16:57:48 <gmann> please plan to join
16:58:19 <gmann> +1
16:58:37 <gmann> we are on time, 2 min left. anything else?
16:58:54 <knikolla> I'll be on vacation all of next week.
16:59:07 <gmann> knikolla: ack. thanks for update
16:59:29 <gmann> ok, let's close then. thanks everyone for joining
16:59:31 <gmann> #endmeeting