18:01:09 <JayF> #startmeeting tc
18:01:09 <opendevmeet> Meeting started Tue Sep  5 18:01:09 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:09 <opendevmeet> The meeting name has been set to 'tc'
18:01:13 <JayF> Hi all, welcome to the weekly meeting of the OpenStack Technical Committee
18:01:15 <JayF> A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct
18:01:17 <JayF> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:23 <JayF> #topic Roll Call
18:01:25 <JayF> o/
18:01:25 <gmann> o/
18:01:40 <rosmaita> o/
18:02:03 <JayF> o/
18:02:52 <slaweq> o/
18:03:13 <spotz[m]> o/
18:03:28 <dansmith> o/
18:03:44 <JayF> #topic Gate Health Check
18:06:56 <JayF> Dan reports better than average gate health. A few recurring failures but mostly steady from last week. Cinder is trying to fix an issue and will discuss more details at their meeting tomorrow.
18:08:37 <fungi> not going to interrupt the call, but we had a zuul bug which came in with our automated upgrade on saturday which caused changes with zuul configuration for projects with deprecation warnings to not get tested. it was fixed yesterday a few hours after the problem was noticed
18:09:18 <JayF> #note Devstack has removed support for Ubuntu Focal. Ubuntu Focal is not in the testing interface for this cycle. Projects using focal-based jobs need to move those jobs to newer, support devstack.
18:09:24 <fungi> also yesterday opendev updated the default ansible version to 8 on the zuul executors for the openstack tenant. if any related problems are identified, please reach out
18:09:41 <JayF> #note OpenDev zuul executors using Ansible 8 by default now.
18:09:54 <dansmith> JayF: to be clear, not better than average.. better than recent, more like average :)
18:10:34 <fungi> and zuul is switching from facebook-re2 to google-re2 so is deprecating lookarounds in regular expressions (and has added a negate option for regexes as an alternative). these warnings are non-blocking and informational for now
18:10:44 <JayF> #topic OpenStack Elections
18:10:53 <JayF> #link https://governance.openstack.org/election/
18:14:55 <fungi> traditionally, the i18n team's electorate consisted (almost entirely) of non-code contributors, for example
18:15:39 <fungi> non-code contributor additions cutoff has always been when the governance repo gets tagged (so that the election officials have a reference point for what entries are valid)
18:15:49 <JayF> yeah, that was last week :(
18:16:15 <JayF> #note Call for extra-ACs was not done timely enough to prod PTLs to update their lists. We will call for this update to happen at the beginning of the cycle.
18:16:36 <spotz[m]> I know I asked for the repos to be expanded to include goverance, maybe we could have it expanded to include translations?
18:17:55 <fungi> spotz[m]: there isn't one, that's the problem
18:18:00 <JayF> #action gmann to ensure that a call for extra-ACs is included in future election/governance operational documentation to ensure it's difficult to miss in the future.
18:19:19 <fungi> i18n contributors can be extracted from the translation platform, but requires a translation manager who has the privileged access to export that activity data
18:20:07 <fungi> it is and has been a manual process which the i18n ptl typically performed
18:20:40 <frickler> re "Devstack has removed support for Ubuntu Focal", nova moved first with bumping libvirt reqs beyond what is in focal, blocking devstack and others's gate. I've already complained to them about bad timing doing this the last minute before library freeze
18:20:50 <JayF> #action JayF to contact i18n SIG about extra-ACs
18:21:18 <JayF> #topic Open Discussion and Reviews
18:21:25 <JayF> #link https://openinfra.dev/ptg/
18:21:35 <JayF> #note Please register as an attendee for the PTG
18:21:48 <JayF> #link https://review.opendev.org/q/projects:openstack/governance+is:open
18:22:06 <JayF> User Survey analysis and improvements are patches in governance good to review.
18:22:14 <frickler> why is registering considered so important? they didn't even do double-opt-in last time I checked
18:23:08 <JayF> I am unsure; the foundation organizes PTGs and I'm passing along requirements laid out by them -- including preregistration.
18:23:46 <frickler> but your wording makes it sound like the TC endorses those reqs
18:24:37 <spotz[m]> Frickler do you want to join the call? https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
18:24:43 <JayF> frickler: we are in zoom meeting this week, I am proxying your comments but discussion in both places at the same time is not trivial
18:24:55 <frickler> nope. certainly not on zoom, but also not otherwise
18:25:41 <frickler> feel free to defer my questions until the meeting is done if you prefer that
18:26:47 <JayF> frickler: re: PTG, I encourage people to do the things that are requested by the folks doing logistics because I assume they wouldn't put an unneeded requirement in there. The details of how a PTG is organized is not something I have time to understand completely.
18:27:28 <fungi> frickler: for the libvirt bump, should the tc have been reminding teams sooner that focal is not in the pti for 2023.2 and teams can/should drop their focal jobs?
18:28:02 <frickler> fungi: well focal not being in the PTI doesn't mean that projects are not allowed to support it
18:28:33 <fungi> i guess i'm unclear on what the responsibility is to teams for supporting things that aren't covered in the pti but other teams want to test anyway
18:28:35 <frickler> I think a general reminder would be in order to do bumps affecting a lot of projects early in the cycle
18:29:19 <clarkb> I argued in an email to the openstack-discuss list recently that not only should they be done in the cylce but they should be done knowing that things will break and then work through it from there
18:29:31 <clarkb> rip bandaids off and then move forward
18:30:35 <frickler> being more strict against projects with broken CI and/or a backlog of release relevant patches might also be a good idea, yes, but somewhat orthogonal to the other thing
18:38:44 <JayF> #endmeeting