18:00:27 <JayF> #startmeeting tc
18:00:27 <opendevmeet> Meeting started Tue Oct 17 18:00:27 2023 UTC and is due to finish in 60 minutes. The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:27 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:27 <opendevmeet> The meeting name has been set to 'tc'
18:00:35 <spotz[m]> o/
18:00:36 <gmann> o/
18:00:37 <JayF> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:42 <JayF> #topic Roll call
18:00:48 <JayF> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee.
18:00:56 <slaweq> o/
18:00:57 <dansmith> o/
18:01:07 <rosmaita> o/
18:01:11 <JayF> #info James Page has noted an absense for today's meeting.
18:01:30 <knikolla> o/
18:01:40 <JayF> Going to allow until 1805 utc for any other folks to arrive.
18:03:42 <frickler> \o
18:04:00 <JayF> Alright, moving on.
18:04:09 <JayF> #topic Follow up on tracked action items
18:04:28 <JayF> First one is me, I've made no progress and am pushing it forward. Still on track to have something to present by next video meeting.
18:04:35 <JayF> #action JayF Before next video meeting, write up a short document on pros/cons of moving TC video meetings to jitsi-meet.
18:05:04 <JayF> knikolla: anything further to update on DB usage patterns in keystone devstack? I will not be pulling this action forward as we'll be discussing in PTG next week.
18:05:23 <knikolla> no updates from me this week.
18:05:36 <JayF> Ack, thank you. As noted, not going to push it forward as that will be discussed at PTG.
18:05:52 <JayF> #info knikolla research into keystone db usage in devstack will be topic at PTG next week
18:06:16 <JayF> next up, slaweq was going to sync with a potential monasca ptl candidate to inform the inactivity proposal
18:06:35 <slaweq> I sent email to the Monasca team
18:06:51 <slaweq> but I got no reply
18:06:53 <slaweq> and also patch which marks Monasca as inactive is now merged
18:07:21 <JayF> #info slaweq reports Monasca team was nonresponsive to email; Monasca project was marked inactive by TC resolution earlier this week.
18:07:50 <slaweq> we can remove it from inactive list if there will be any volunteer(s) for it before Milestone 2
18:07:53 <JayF> If anyone interested in that project reads this log, you're welcome to reverse that action along with taking actions needed to restore CI and maintain the project.
18:08:03 <JayF> looks like we're on the same page slaweq :D
18:08:17 <JayF> Thank you for reaching out to them and for writing up that proposal.
18:08:27 <gmann> do we want to retire it if no leader?
18:08:28 <slaweq> yw :)
18:08:51 <JayF> gmann: I'd personally prefer discuss that once we get past the M-2 milestone without any volunteers.
18:08:53 <gmann> inactive marking is ok but question is should we wait for m-2 with clear no maintainer?
18:09:02 <slaweq> gmann according to the inactive projects policy, if there will be no volunteers before Milestone 2, we should
18:09:24 <gmann> yeah that is true but this is case of no PTL where we might want to take action soon?
18:09:36 <slaweq> I have some reminders set for myself to try to ping people before this deadline
18:09:52 <JayF> I think the waiting period is sensible to ensure people have time to get the information if they aren't plugged into the community, and I see little/no benefit to rushing.
18:10:04 <slaweq> JayF++
18:10:22 <JayF> In fact, it occurs to me we might not have even mailed the list about the merge of that resolution. I'll check and if not, will do that after the meeting.
18:10:53 <JayF> Last action item to review; rosmaita was going to engage i18n sig about possibility of translating governance docs
18:11:14 <rosmaita> they are in the middle of the weblate migration
18:11:22 <rosmaita> #link https://meetings.opendev.org/irclogs/%23openstack-i18n/%23openstack-i18n.2023-10-13.log.html
18:11:43 <JayF> Thanks for the update.
18:11:47 <rosmaita> they'll have a presence at the PTG and we can get more details then
18:12:09 <rosmaita> but the short version is, the faster we get migrated to weblate, the sooner we can do other stuff
18:12:09 <JayF> #info i18n team has to prioritize their tool migrations; discussion about how governance translation fits into that will happen at PTG
18:12:12 <JayF> #undo
18:12:12 <opendevmeet> Removing item from minutes: #info i18n team has to prioritize their tool migrations; discussion about how governance translation fits into that will happen at PTG
18:12:18 <JayF> #info i18n team has to prioritize their tool migrations; discussion about how governance doc translation fits into that will happen at PTG
18:12:27 <JayF> thank you
18:12:32 <JayF> That's all for tracked action items.
18:12:39 <JayF> #topic Gate Health Check
18:12:46 <JayF> Any update on the general health of the gate?
18:12:58 <dansmith> there's something going on with the grenade job,
18:13:03 <rosmaita> oh noes
18:13:13 <JayF> skip-level, normal, or "yes"?
18:13:15 <dansmith> which isn't new (apparently) but the fail rate seems higher this week
18:13:24 <dansmith> this is a normal one
18:13:31 <dansmith> it's in the cinder pre-validation stuff,
18:13:51 <dansmith> but I haven't dug in deep yet
18:14:30 <gmann> we recently updated the setting of upgrade of stable/2023.2 to master and skip level job from stable/2023.1 to master
18:14:33 <gmann> which one failing?
18:14:54 <clarkb> There is some post failure thing when trying to get qemu/libvirt logs as well. Has that been addressed (I don't see as much orange on hte zuul status today)
18:14:57 <dansmith> [ERROR] /opt/stack/new/grenade/inc/plugin:123 Failed to run /opt/stack/new/grenade/projects/70_cinder/resources.sh verify pre-upgrade
18:14:57 <dansmith>
18:15:17 <dansmith> clarkb: I haven't seen that one.. are you talking about the lxml failure in post?
18:15:31 <dansmith> clarkb: we're trying to land a fix for that but the cinder grenade verify has nailed it three times in a row :(
18:15:47 <dansmith> clarkb: that's this patch: https://review.opendev.org/c/openstack/nova/+/898435
18:15:47 <clarkb> dansmith: I saw the lxml thing but on a random job I looked at it appeared to fail elsewhere when trying to find a file. But maybe I misparsed it
18:15:58 <dansmith> clarkb: okay I haven't seen that one
18:16:36 <dansmith> but the rash of post_failures yesterday were from the lxml thing, at least that I've seen
18:16:37 <clarkb> oh ya I think it may be side effects of the lxml thing?
18:16:52 <clarkb> https://zuul.opendev.org/t/openstack/build/920b297afc9a43c08c4599460a1b0ab2/console is the error I'm talking about and elsewhere it complains about lxml
18:17:41 <dansmith> the qemu dump message is always there unless qemu crashed during a run AFAIK
18:17:43 <dansmith> unrelated to any failure
18:18:14 <clarkb> its just annoying because it makes the jobs record post failure instead of failure
18:18:37 <clarkb> maybe it should be made to not error if it fails to make the actual errors more clear
18:18:55 <dansmith> the lxml thing is causing the post_failure
18:19:24 <dansmith> because in post-run we use ansible's virt module and that requires lxml but doesn't actually depend on it so it doesn't get installed
18:19:38 <dansmith> and somewhere around when we moved everything to a venv, we stopped getting lxml for free on the host
18:20:08 <clarkb> ah
18:21:13 <JayF> Is there any action we need to take or ask the cinder team to take for the grenade issue?
18:21:45 <dansmith> I haven't dug into the issue yet so I don't know if we can fully blame them yet or not
18:21:59 <dansmith> but it always happens in the cinder phase, so definitely happy to have any help from them :)
18:22:21 <JayF> heh, sounds good. Thank you for looking into that. Is there anything else of note for the gate health check/
18:24:02 <JayF> Moving on then.
18:24:07 <JayF> #topic Leaderless projects
18:24:23 <JayF> gmann: how are leaderless projects looking?
18:24:41 <JayF> #link https://etherpad.opendev.org/p/2024.1-leaderless
18:25:10 <JayF> We have multiple late candidacies listed in there, a couple that have already landed as well.
18:25:11 <gmann> we have 9 volunteer for leaderless projects
18:25:31 <gmann> and 3 a re already there but invalid candidacy which include Monasca also
18:25:48 <gmann> I asked them to propose patch in governance and a few of them did but not all
18:25:59 <gmann> I will ask remaining one and we can discuss/ask question in gerrit
18:26:23 <gmann> but it is good that we have volunteer for all 12 leaderless project
18:26:43 <gmann> and we can discuss each one by one in PTG
18:27:00 <JayF> I'd highly recommend TC members take time to review them async before the PTG as well :)
18:27:09 <gmann> I will try to get governance change before PTG
18:27:10 <gmann> ++
18:27:19 <JayF> Is there anything else we want to address around this in our meeting today?
18:27:29 <gmann> nothing else from my side.
18:28:54 <JayF> Moving on
18:28:58 <JayF> #topic PTG Reminder
18:29:01 <JayF> Reminder: PTG is next week
18:29:09 <JayF> #link https://etherpad.opendev.org/p/tc-ptg-october-2023
18:29:38 <JayF> I will be assigning topics to time windows later today/tomorrow, trying to ensure we won't go over as much as possible.
18:29:52 <JayF> If you have preferences or need me to put certain categories somewhere, please reach out.
18:29:58 <JayF> Also related and somewhat obvious:
18:30:08 <JayF> #info TC Weekly Meeting next week cancelled due to PTG
18:30:38 <JayF> Any other comments/questions/etc about PTG planning?
18:32:21 <JayF> Alright, moving on.
18:32:24 <spotz[m]> Monday morning and&I session will be the leadership shadowing topic
18:32:46 <JayF> I'm not sure what you mean?
18:35:09 <JayF> spotz[m]: did you have a scheduling request? I'm confused
18:38:12 <JayF> I'm going to move on and assume that was intended for another window? If there's something we need to circle back to, we can./
18:38:17 <JayF> #topic Open Discussion & Reviews
18:38:50 <JayF> #link https://review.opendev.org/q/projects:openstack/governance+is:open
18:39:17 <JayF> One thing here, seanmooney had the 2024.1 runtime requirements change up
18:39:29 <JayF> there is some contention on that, but a clear majority wants to keep 3.8, but there is a CR-1 for content issues on it
18:39:41 <clarkb> I wanted to note that it appears RH mail servers cannot send email to our new list server because they are using stale DNS records. Unsure of where the stale records are being found. POssibly the mail servers aren't respecting the TTLs or some DNS server is returning old records improperly.
18:40:05 <JayF> Does someone want to volunteer to update that patch, or post a follow-up patch, addressing the issues?
18:40:08 <dansmith> AFAIK our mail servers are google
18:40:11 <dansmith> clarkb: ^
18:40:52 <clarkb> dansmith: there is another third party service you use in between aiui and I think fungi suspected that
18:41:04 <clarkb> mimecast
18:41:15 <JayF> Can we table that until after the meeting, please?
18:41:16 <dansmith> isn't that google?
18:41:28 <JayF> We're very close to wrapping up.
18:41:32 <dansmith> sure
18:41:35 <clarkb> JayF: sure I just wanted the TC to be aware of it which is why I brought it up in the meeting
18:41:44 <JayF> I appreciate the notice; not sure there's any action we can take
18:42:22 <JayF> In lieu of another volunteer to update that patch, I guess I will? We need a PTI landed that is clear
18:42:43 <rosmaita> well, the PTI is already landed, this was just a clarification, i think
18:42:50 <JayF> I'll push a follow-up on top of that patch which will resolve the issues which garnered a CR-1, then get that vote lifted and land it all
18:42:54 <spotz[m]> @jayf just a heads up on our session
18:42:57 <JayF> spotz[m]: ack
18:43:45 <gmann> yes, this is adding more clarification and no change in PTI
18:43:48 <JayF> Anything additional for open discussion or open reviews? Going to wait a couple of minutes then close out the meeting (then we can all turn into the MX troubleshooting gang)
18:44:07 <gmann> I still need to land the job template change as per PTI. need to do one quick update
18:44:20 <rosmaita> JayF: is your plan to push a new patch set, that will clear the votes, and then everyone re-votes?
18:44:30 <JayF> rosmaita: no, I'm going to do a follow-up to avoid clearing votes
18:44:45 <gmann> ++
18:45:01 <JayF> rosmaita: and ask whoever did the CR-1 to flip it after I push a follow-up, then we can land the follow-up as a trivial/typo fix
18:45:28 <rosmaita> well, i wonder about that ... looking at the history of the patch, there was at least one person who voted +1 on the original proposal to remove py3.8 in PS 1, and then +1 also to keep py3.8
18:45:54 <rosmaita> i think it would be good to have a clean set of votes
18:46:50 <rosmaita> but that's not what i wanted to talk about in open discussion
18:47:12 <JayF> I am extremely hesitant to reset the clock on that change and ask folks to revote. I don't think it's justified and just creates more work for folks having to mash the buttons again
18:47:14 <rosmaita> what i wanted to ask is, what is the status of changes to the TC charter in light of the proposed foundation bylaws changes?
18:47:38 <JayF> I actually don't know the answer to that question; I think some of that is in the hands of the oif lawyer
18:47:41 <gmann> changes are in review by legal team
18:47:48 <JayF> I'll take an action to try and get a meaningful update for PTG
18:47:54 <gmann> and as next it will be voted in Board meeting
18:48:14 <rosmaita> right, but i thought the situation is that they won't remove stuff from the bylaws until it's already been moved to the TC charter?
18:48:22 <JayF> #action JayF to reach out to OIF for a meaningful update on potential TC charter updates
18:48:25 <gmann> and after that we can do the charter changes, I will push those charter changes but waiting for it to be formally ready and voted in board
18:48:26 <spotz[m]> Which.would be November
18:48:27 <rosmaita> otherwise, we are in a limbo situation were we can do almost anything we want
18:48:46 <JayF> I don't know the answer to those questions; I trust the OIF to; I'm going to take that action and ask and try and get some first-party information.
18:48:51 <gmann> JayF: I am on that. we discussed in strategic meeting to wait till legacl check and board vote
18:49:02 <rosmaita> ok, sounds good
18:49:14 <JayF> So there is zero action for us until after Nov board meeting?
18:49:17 <JayF> #undo
18:49:17 <opendevmeet> Removing item from minutes: #action JayF to reach out to OIF for a meaningful update on potential TC charter updates
18:49:19 <gmann> rosmaita: it will be done before bylaws change
18:49:46 <rosmaita> gmann: ok, that was my understanding ... do you need help on the charter change, or is it easier to just do it yourself?
18:49:49 <JayF> gmann: can we ensure timeline allows TC members significant time to review those charter changes before the board meeting? I don't want anyone feeling pressured to approve things based on the timeline.
18:49:56 <gmann> I mean after board vote but before individual members vote. after individuals members vote (during board election in jan) only Bylaws get officially change
18:50:05 <JayF> aha
18:50:26 <gmann> rosmaita: thanks, I will catchup with you on that as you were present in all those discussion so it will be good help
18:50:41 <JayF> Thank you for bringing it up, it's a good topic to stay on top of.
18:50:53 <rosmaita> sounds good ... i wonder about the timing though, because the bylaws changes will remove some restrictions on the TC
18:50:59 <spotz[m]> All bylaw changes are voted on same time as board elections
18:51:14 <rosmaita> but if we haven't already adopted those ourselves in the charter, then i think that is a problem
18:51:20 <spotz[m]> Use best judgement
18:51:22 <JayF> My (weak) understanding is: bylaws changes are staged by a vote of the board; in Jan when individual members vote them, they go into effect
18:51:23 <gmann> JayF: sure, I will monitor how far the legal checks are and when in baord meeting we have those proposal
18:51:30 <JayF> between those votes is our window to update the TC charter
18:51:56 <gmann> yes, Individual Members votes are final agreement to byLaws change and we will put things in TC charter before that
18:51:57 <JayF> so we'll have a clock running in any event, I guess
18:52:03 <JayF> just by nature of the coordinatino
18:52:18 <gmann> we cannot do it now because we want it to be legally check and board agreement as overall
18:52:26 <gmann> otherwise we might need to revert few things
18:53:16 <JayF> We have about 6 minutes left, anything else for open discussion?
18:54:12 <gmann> these are the steps: 1. strategic discussions - DONE 2. Legal checks - in progress 3. Board vote - future 4. TC charter change - future 5. Individual members vote - future 6. bylaws change - future and last step
18:54:40 <gmann> so TC charter will be changed before bylaws
18:55:22 <JayF> Alright, thank you :) I'm glad you're helping translate some of this. Let me know when the next gmann foundationing-101 class is and I'll attend ;)
18:55:36 <gmann> sure
18:56:32 <JayF> Going to give another minute for new topics before closing the meeting.
18:56:45 <dansmith> end it.
18:57:10 <JayF> #endmeeting