18:00:19 <JayF> #startmeeting tc
18:00:19 <opendevmeet> Meeting started Tue Oct 31 18:00:19 2023 UTC and is due to finish in 60 minutes. The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:19 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:19 <opendevmeet> The meeting name has been set to 'tc'
18:00:23 <JayF> #topic Roll Call
18:00:26 <dansmith> o/
18:00:30 <knikolla> o/
18:00:31 <JayF> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:35 <gmann> o/
18:00:35 <JayF> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee.
18:00:44 <JayF> #info Two noted absenses: spotz[m] and slaweq
18:01:07 <rosmaita> o/
18:01:09 <frickler> \o
18:01:32 <JayF> Alright, I think that's everyone accounted for then, moving on to the agenda.
18:01:40 <JayF> #topic Follow up on tracked action items
18:01:52 <JayF> there is one; it's mine; and I've not done it yet due to running out of hours in the day
18:02:01 <JayF> #action JayF Before next video meeting, write up a short document on pros/cons of moving TC video meetings to jitsi-meet.
18:02:21 <JayF> I wanted to have this done by this meeting, but between PTG and other responsibilities I did not have time. I'll try to have something written up in an etherpad by the end of the calendar-week.
18:02:32 <JayF> #topic Gate Health Check
18:02:36 <JayF> Anything on the gate?
18:02:54 <dansmith> so,
18:03:04 <dansmith> things are not terrible, but not great either, IMHO
18:03:31 <dansmith> this morning I debugged an issue which ended up being a *glance* OOM, where it swole up to >2G while uploading a tiny snapshot to swift
18:03:37 <dansmith> which of course took out a bunch of other tests
18:04:25 <dansmith> there have also been some unstable devstack or node setup type things I've seen, but haven't chased to any conclusions
18:04:39 <clarkb> we were temporarily running without rackspace due to an openstacksdk update that broke nodepool's ability to talk to that cloud. This should be temporarily resolved wtih a more proper fix on its way through merge processes
18:04:52 <dansmith> but basically I think we're in that same post-big-fix-push where stuff starts to rot out the minute we stop making a concerted effort :/
18:05:39 <gmann> a few of failure i also observed but other than that it was ok. got a few of the changes merged in tempest, devstack, and neutron quickly
18:05:50 <JayF> Is there any specific action we need to take or encourage other than constant vigilance?
18:06:14 <dansmith> I've been rechecking an upgrade fix series in nova for 24 hours already.. merged one piece, but 2/3 still waiting for rechecks
18:06:15 <gmann> dansmith: was oom in import job or other glance job?
18:06:22 <dansmith> gmann: non-import
18:06:25 <gmann> k
18:06:59 <dansmith> we also did merge the devstack change to use cached tokens, which is nice and reduced some of the keystone calls by a lot
18:07:08 <gmann> ++
18:07:15 <dansmith> still way too many of course, but it means we hit keystone less hard in the setup phase, which is good
18:07:26 <rosmaita> nice
18:07:47 <dansmith> basically client-side optimization which helps overall, but doesn't solve the actual problem
18:08:45 <dansmith> anyway, nothing else specific to call out
18:09:10 <JayF> Thanks for staying on top of that.
18:09:15 <JayF> #topic Leaderless Projects
18:09:24 <JayF> gmann: is there anythign worth chatting about here that is new since PTG?
18:09:40 <gmann> nothing else from what we discussed on Thursady/friday
18:09:57 <gmann> I will work on the action we discussed in PTG
18:09:58 <JayF> Ack; please tc-members review the related PRs from the etherpad
18:10:01 <JayF> #link https://etherpad.opendev.org/p/2024.1-leaderless
18:10:07 <gmann> yeah
18:10:09 <JayF> #topic PTG Follow-ups
18:10:16 <JayF> #link https://etherpad.opendev.org/p/tc-ptg-october-2023
18:10:21 <JayF> #link https://etherpad.opendev.org/p/tc-leaders-interaction-2024-1
18:10:27 <JayF> #link https://etherpad.opendev.org/p/oct2023-ptg-os-dbperf-crossproject
18:10:41 <JayF> I have not had time to significantly sort through TC PTG notes and break out any specific action items
18:11:00 <JayF> I wanted to have this agenda item in place for us to note the etherpads and mark any actions that may be seen as urgent
18:11:21 <JayF> otherwise my goal will be to have actions broken out into the TC tracker in the next 2 weeks, including an email summary of TC PTG to the list this week.
18:14:41 <JayF> Looks like no interest in more PTG talk, just days after the PTG. I'm stunned! :D
18:14:50 <JayF> #topic Open Discussion and Reviews
18:15:12 <JayF> Are there any topics for open discussion? Most of the reviews we discussed at the PTG, I will not re-enumerate them here -- please review things open in governance repo.
18:15:59 <frickler> one topic: should yoga go into EM instead of Unmaintained?
18:17:23 <JayF> I followed the discussion earlier, and I mainly wonder if it does any harm to delay action on yoga until documentation is completed? I know this has been pushed a couple times already in general (finalizing this documentation), so I'm not certain we should, but it's one possible option.
18:17:52 <dansmith> super unhelpful, but I don't have a strong opinion
18:17:59 <gmann> it should not matter if we delay yoga to EM or now. question stay same
18:18:16 <gmann> yoga and also for zed in future
18:18:20 <rosmaita> well, the current EM branches will have to be moved to Unmaintained/deleted at some point, so might as well have yoga join them until we have a clear strategy
18:18:27 <JayF> I don't have a strong opinion other than that it seems silly to ask the releases team to essentially do something 2x (automation -> EM, automation -> new UM process)
18:18:39 <JayF> rosmaita: that's an extremely good point that cancels out mine entirely
18:19:06 <rosmaita> :)
18:19:26 <gmann> there is resolution passed to have no EM and move to Unmaintained so I think we should follow that even implementation of it in doc/policy is dleayed
18:19:30 <JayF> I also think that from the perspective of what tonyb brought up at the PTG, about how/where decisions are made, that doing the thing in documentation until something else is in documentation seems to be the most consistent thing we can do.
18:19:56 <JayF> hmm again a good point, same thought but different outcome
18:20:42 <gmann> that does not stop us to discuss here right ? :)
18:20:58 <JayF> No it doesn't, but it's extra awkward because we're in a middle ground
18:21:12 <gmann> I think let's review p-t-g as soon as we can and if we can merge it before yoga EM time comes
18:21:21 <JayF> where our written stuff says two things; our governance docs which are official say one, and the release docs which users/operators look to say another
18:21:58 <JayF> Can someone ensure we get an ML thread started about this? frickler since you brought it up, would you be willing?
18:22:05 <frickler> moving to Unmaintained is an optional process that needs to be documented and implemented, according to the resolution the default action would be to move yoga to EOL
18:22:06 <gmann> yeah that we need to fix that is why I am saying let's do that as first step and as soon as we can
18:22:50 <JayF> gmann: can you put a link to that change in here and put it in the minutes if you have it at hand?
18:23:06 <gmann> #link https://review.opendev.org/c/openstack/project-team-guide/+/897505
18:23:10 <gmann> here ^^
18:23:23 <frickler> yoga EM time is in two days according to the tentative schedule
18:23:42 <frickler> so not much time for an ML thread
18:24:04 <JayF> Is there anyone who would object to punting that a minimum of one week, so we can have an ML thread and an agenda item for next week about how to adjudicate this, and hopefully also potentially merge the p-t-g doc in the meantime to make the entire situation less sticky?
18:24:12 <gmann> frickler: but we did not say about yoga or anything, resolution mentioned last 3 active EM to automatically move to Unmaintained and rest all to EOL https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html#transition
18:24:13 <frickler> also I don't like to send any mail to the list
18:24:40 <gmann> if yoga moving to EM before we implement the policy I think it make yoga to fall into those last three EM
18:24:52 <frickler> gmann: the resolution says: no more EM, to me that also says: no more projects transition to EM. right now.
18:25:30 <JayF> gmann's interpretation more closely matches mine; but I also care more about ensuring we do the sensible thing than I do about following the exact letter of the rule down to the minute of when yoga's next phase should be acted upon.
18:25:47 <fungi> keep in mind that the release team has taken em/eol dates on the schedule as "on or sometime as soon after this date as is convenient"
18:26:10 <gmann> yeah but policy are not implemented yet so... do not know I think it applies when we implied it?
18:26:46 <fungi> my point being, if there's a delay of a week or two in switching branches to em or eol, that's not unusual based on past transitions anyway
18:26:52 <JayF> I propose that the TC request the releases team delay action on the yoga stable branches at least one week, and that in that week we attempt to get the p-t-g docs landed and start asynchronous communications about the implementation of unmaintained branch policy
18:27:32 <rosmaita> that sounds reasonable to me
18:28:02 <gmann> +1. if we are doing that let's delay till we merge p-t-g change just to avoid postponing it again
18:28:34 <JayF> gmann: I do not want to say it that way because I think we've shown without a time pressure we may delay too much. I prefer feeling the pressure of needing to land that in a week, then dealing with it next week if it does not.
18:29:09 <gmann> sure, if we deadline that change to merge it is great. agree
18:29:17 <JayF> I'm trying to check to ensure we have consensus, frickler does not seem on board with this, and we are down 2 members for this meeting, that makes 3-1 essentially, with 7 people attending, I don't feel like this represents TC consensus yet.
18:29:24 <frickler> ack. there's another related question: if we tell people now or in a week "speak up if you want to prevent stable/yoga for project xyz from going eol", how much time do we give for responses
18:29:32 <gmann> I think knikolla fixed my comment there so will re-review today
18:29:43 <frickler> I'm +1 on the delay
18:29:54 <gmann> cool
18:29:55 <JayF> frickler: thank you for being explicit; didn't want to stomp on your concern from earlier :)
18:29:58 <dansmith> delay is fine with me if it means we can move on
18:30:31 <JayF> frickler: I was thinking about this that a 1 month period seems reasonable, we know from election nominations that 2 weeks can often miss people, and EOL'ing a branch is much more expensive to undo, technologically, than a late candidacy.
18:30:55 <JayF> This is a detail we likely need documented in the p-t-g. I'll ensure that gets in my PR feedback.
18:31:05 <JayF> (and IMO is best argued in that venue)
18:31:49 <frickler> I already mentioned that there, just wanted to give it more visibility
18:31:52 <JayF> Are there other comments on the topic in open discussion of stable/yoga branch adjudication, or generally on unmaintained branch support?
18:32:38 <JayF> #info TC will request releases team delay at least 1 week in adjudication of stable/yoga branch to allow TC to complete documentation of unmaintained branch implementation.
18:32:49 <JayF> Anything else, generally, for open discussion?
18:33:46 <frickler> there is a reqs patch that may profit from tc feedback
18:34:22 <JayF> Can you link it into the minutes?
18:34:22 <frickler> https://review.opendev.org/c/openstack/requirements/+/898699
18:34:33 <frickler> #link https://review.opendev.org/c/openstack/requirements/+/898699
18:35:19 <JayF> Alright, that looks interesting for sure and has been added to my review queue.
18:35:41 <JayF> Is there anything further to comment about that, or other topics for open discussion?
18:36:50 <JayF> Last call for TC meeting?
18:37:32 <JayF> #endmeeting