18:00:57 <JayF> #startmeeting tc
18:00:57 <opendevmeet> Meeting started Tue Nov 7 18:00:57 2023 UTC and is due to finish in 60 minutes. The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:57 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:57 <opendevmeet> The meeting name has been set to 'tc'
18:01:01 <JayF> #topic Roll Call
18:01:03 <JayF> o/
18:01:08 <gmann> o/
18:01:21 <JayF> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:01:23 <JayF> #link https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ
18:01:26 <knikolla> o/
18:01:26 <JayF> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:01:27 * bauzas shamelessly lurks
18:01:28 <JayF> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee.
18:01:29 <rosmaita> o/
18:04:33 <JayF> #topic Follow up on tracked action items
18:04:50 <JayF> #link https://etherpad.opendev.org/p/JayF-Nov-2023-MeetPad-v-Zoom
18:07:53 <fungi> you had to opt into meetpad in the last ptg
18:08:49 <fungi> another concern on the foundation side is zoom licenses (zoom really doesn't like you scaling licenses up and down)
18:09:01 <rosmaita> The "Share your PTG feedback with us!" email (31 Oct 2023) says "One important thing to note is that for our next PTG event (the first PTG in 2024, dates TBD) we will be making the default meeting tool Meetpad instead of Zoom becauseĀ open source needs open tools"
18:09:22 <JayF> Discussion ongoing in video around action item to document meetpad/zoom pros and cons for hosting TC meetings. Discussion currently informational in nature; any change in meeting location would require an update to our written documentation.
18:18:20 <JayF> #info Jay is not taking further action on moving TC meetings from Zoom. Encourages other tc-members who may have strong feelings about Zoom-located meetings to write up a proposal to change if they wish a change to happen.
18:18:28 <JayF> #topic Gate Health Check
18:19:22 <gmann> frickler: on the topic you not joining TC video call. is the reason zoom or video call or time thing? In TC meeting today it is not clear what is reason so that we can try to solve and include you in meeting.
18:20:00 <JayF> #info Dan reports nothing serious; a single flakey test with Nova that is likely nova's fault. Token's caching client patch merged; numbers have improved but some reports that other behaviors may be worse. Overall health is OK but slowly regressing.
18:20:12 <JayF> dansmith: ^ that an accurate reflection for the minutes?
18:20:22 <JayF> #undo
18:20:22 <opendevmeet> Removing item from minutes: #info Dan reports nothing serious; a single flakey test with Nova that is likely nova's fault. Token's caching client patch merged; numbers have improved but some reports that other behaviors may be worse. Overall health is OK but slowly regressing.
18:20:31 <JayF> #info Dan reports nothing serious; a single flakey test with Nova that is likely nova's fault. Tokens caching client patch merged; numbers have improved but some reports that other behaviors may be worse. Overall health is OK but slowly regressing.
18:21:14 <dansmith> sure
18:21:45 <fungi> #link https://bugs.launchpad.net/oslo.utils/+bug/2042886 versionutils convert_version_to_tuple fails with beta versions (linked in zoom chat by slaweq)
18:24:10 <fungi> #link PBR 6.0.0 released just now (adding PEP 660 support, dropping Sphinx integration), keep an eye out for problems: https://review.opendev.org/c/openstack/releases/+/900041
18:24:31 <JayF> thank you for adding those links to the minutes
18:27:41 <JayF> #topic Leaderless Projects
18:29:01 <JayF> #link https://etherpad.opendev.org/p/2024.1-leaderless
18:30:22 <JayF> #info tc-members are encouraged to review the etherpad and review PTL appointments
18:30:39 <JayF> #topic Implementation of Unmaintained Branch Statuses
18:30:44 <clarkb> fwiw Kolla, Glance, SDK, PTGbot, and OpenStack Security teams used meetpad during the PTG. There may have been others and I missed tehm.
18:30:50 <JayF> #link https://etherpad.opendev.org/p/early-caracal-unmaintained-transition
18:31:20 <JayF> #link https://review.opendev.org/c/openstack/project-team-guide/+/897505
18:48:32 <JayF> #info TC discussed logistics of implementing unmaintained status; main item we need is to ensure we engage releases team to make sure whatever path we pick for implementation works well for them. We need to ensure those communications explicitly include the fact that UM->EOL transitions may become the only release transition that does not require a PTL approval.
18:53:57 <bauzas> and what if a PTL wants a UM branch to be EOL ?
18:54:09 <fungi> #link Resolution on unmaintained branches: https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html
18:54:35 <gmann> bauzas: they can propose and it stays for a month if anyone volunteer to maintain in unmaintained state. if no volunteer then it goes to EOL
18:54:47 <JayF> #topic PTG Follow Ups
18:55:02 <gmann> but current proposal in p-t-g change is moving unmaintained to EOL stays for 1 month at least
18:55:21 <JayF> #info Jay will send email to the ML in the next week summarizing TC PTG activities and transition tracked items to 2024.1 TC Tracker
18:55:27 <JayF> #topic Open Discussion and Review
18:55:27 <fungi> #link This month's OpenInfra Foundation newsletter is being finalized tomorrow, if you have any content you want included for OpenStack please add it to https://etherpad.opendev.org/p/newsletter-openstack-news today and I'll try to include it.
18:55:41 <gmann> bauzas: feel free to review it #link https://review.opendev.org/c/openstack/project-team-guide/+/897505?usp=email
18:55:52 <JayF> #link https://review.opendev.org/q/status:open+repo:openstack/governance
18:56:01 <bauzas> gmann: thanks, I see written in the TC resolution "The PTL or Unmaintained branch liaison are allowed to delete an Unmaintained branch early, before its scheduled branch deletion."
18:56:02 <fungi> #link OpenInfra Live is hosting a PTG recap episode for anyone wishing to participate: https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/P4Y66SJNBG4DGW7URYAAJGKAI7NA33F5/
18:56:54 <gmann> bauzas: yeah, they can propose but it stays for 1 month at least so that we give enough time for any volunteer to show up
18:57:03 <bauzas> ack
18:58:20 <JayF> #action Jay to sign up to rep TC at the PTG OpenInfra Live recap
19:00:34 <JayF> #info Recording to be uploaded to youtube later today.
19:00:36 <JayF> #endmeeting tc