18:00:07 <JayF> #startmeeting tc
18:00:07 <opendevmeet> Meeting started Tue Dec 12 18:00:07 2023 UTC and is due to finish in 60 minutes. The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:07 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:07 <opendevmeet> The meeting name has been set to 'tc'
18:00:17 <knikolla> o/
18:00:19 <JayF> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:22 <JayF> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee.
18:00:24 <JayF> #topic Roll Call
18:00:25 <gmann> o/
18:00:26 <JayF> o/
18:00:33 <frickler> \o
18:00:34 <spotz[m]> o/
18:00:34 <rosmaita> o/
18:00:37 <JayF> #info dansmith the only noted absense in the agenda
18:00:48 <jamespage> o/
18:00:58 <spotz[m]> I'll be out after this week I'll update the agenda
18:01:05 <jamespage> ditto
18:01:14 <JayF> Thanks spotz[m] and jamespage! Enjoy the holiday!
18:02:00 <JayF> We have quorum, will give a couple more minutes for late arrivals.
18:03:15 <slaweq> o/
18:03:20 <slaweq> sorry for being late
18:03:39 <JayF> No problem :) everyone gets overlapping meetings/TZ issues/etc
18:03:45 <JayF> #topic Follow up on tracked action items
18:03:51 <JayF> All of these are about the OIF Bylaws change.
18:04:25 <JayF> #info There is no strict deadline for approval of OIF bylaws related governance changes.
18:04:28 <JayF> That takes care of mine.
18:04:34 <gmann> yeah, I pushed the changes for TC tracker #link https://review.opendev.org/c/openstack/governance/+/903236
18:04:38 <JayF> gmann you signed up to create teh two changes, I believe you did
18:04:48 <gmann> and this is resolution to vote on the bylaw changes #link https://review.opendev.org/c/openstack/governance/+/903239
18:04:52 <JayF> #link https://review.opendev.org/c/openstack/governance/+/903236
18:04:56 <JayF> #link https://review.opendev.org/c/openstack/governance/+/903239
18:05:11 <JayF> Thank you for that, I'll dedicate time to review them immediately after the meeting and I suggest all tc-members do the same.
18:05:26 <JayF> Any questions about the TC charter/OIF bylaws change since we don't have a dedicated agenda item?
18:05:46 <gmann> I would request all tc-members to check those, as JayF mentioned there is no hard deadline but we should finish this work as soon as we can so that foundation will finish the bylaw change process
18:05:57 <gmann> yeah, we can discuss here if any question
18:06:03 <gmann> *here also
18:06:06 <JayF> Please add to the pre-holiday list at a minimum :D
18:06:11 <JayF> #topic Gate Health Check
18:06:14 <gmann> ++
18:06:14 <JayF> How is the gate looking?
18:06:21 <knikolla> thanks gmann, will review today :)
18:06:25 <gmann> thanks
18:06:49 <JayF> Ironic had a couple days breakage this week, landing a big chain of patches to the ironic<>nova driver, and the middle state is apparently broken. We've temporarily disabled the broken job and have had the fix in the nova gate since yesterday morning.
18:07:02 <slaweq> I think gate looks pretty good, at least from what I can say
18:07:09 <gmann> on gate side, there have been some failure on nova side and melwitt continuously proposing some ideas/fixes which are helpful .
18:07:42 <gmann> other than that I have not observed any frequent failure in general tempest jobs
18:07:56 <JayF> Thanks for the efforts folks are putting forward to keep the gate running. Moving on.
18:08:01 <JayF> #topic Leaderless projects
18:08:11 <JayF> #link https://etherpad.opendev.org/p/2024.1-leaderless
18:08:29 <gmann> one update here: there is PTL proposal for ec2api also #link https://review.opendev.org/c/openstack/governance/+/903163
18:08:44 <gmann> i think we have 3 open proposal now, please review those
18:08:51 <JayF> #link https://review.opendev.org/c/openstack/governance/+/903163 New proposal for ec2api ptl
18:09:02 <fungi> the foundation staff have been informed that the opensearch donation from amazon is being restructured to a monthly allocation instead of yearly. some costs have spiked over the past two months and we're in danger of getting charged an overage
18:09:24 <fungi> i've started talking to dpawlik to see if we can figure out what's triggered that and how we can scale it back
18:09:43 <JayF> I'll note that melwitt's work on Nova's gate, recently mentioned, is using opensearch extensively
18:09:51 <JayF> and has been evangelized around the list/nova devs/etc
18:09:55 <JayF> and may be the entire explanation...
18:10:09 <fungi> sorry, meant to type that before the topic changed
18:10:23 <JayF> Not a problem :)
18:10:51 <gmann> yeah opensearch was replacement of ELK thing which are needed for our day to day activities
18:11:32 <fungi> an alternative might be to seek a donor to help cover the additional cost (amazon is only willing to chip in us$50k/yr)
18:12:07 <gmann> I think fungi has good point of being in danger and we should discuss it on priority
18:12:25 <JayF> fungi: would it be possible to have you raise this concern to the openstack-discuss mailing list?
18:12:25 <gmann> it was 45K last year rufht?
18:12:26 <gmann> right
18:12:36 <fungi> JayF: i definitely can
18:12:54 <gmann> more than openstack-discuss I think this is board or foundation staff level discussion we should have
18:12:56 <fungi> i'm getting most of this info second-hand and am sort of playing middle-man between parties
18:13:07 <JayF> gmann: awareness at every level provides value imo :)
18:13:14 <gmann> no harm in asking other volunteer in openstack-discuss though but that should not be enough i think
18:13:18 <gmann> JayF: sure
18:14:05 <gmann> I can re-start the thread between board and TC we had last time on this so that we know the background and can restart the discussion
18:14:23 <JayF> Thanks for that.
18:14:34 <gmann> I mean board informal strategic discussion we had last time on this
18:15:12 <gmann> I can include the interested tc-members in that ML, ping me. will include JayF for sure
18:15:22 * frickler wonders what interest aws has in sponsoring this. they don't seem interested in openstack otherwise, are they?
18:15:25 <spotz[m]> me please
18:15:31 <gmann> ack
18:15:37 * frickler too
18:16:18 <rosmaita> frickler: you can use s3 as a backend for cinder/glance
18:16:56 <gmann> frickler: Allison Randal helped to get this sponsoring so she might have more background/aws relational
18:17:50 <gmann> but as it was yearly help, we kind of expected this could have next year or later.
18:18:24 <frickler> so people actually use AWS S3 instead of radosgw? (but I agree that this is getting offtopic now)
18:19:03 <JayF> Yeah, I'm going to move on to the next topic :)
18:19:14 <JayF> #topic Implementation of Unmaintained Branch Statuses
18:19:35 <JayF> It looks like this is starting to make some motion, which is exciting! Is there any specific update for this week, rosmaita?
18:20:08 <rosmaita> nothing from me, i will take an action item to check in with the release team on Friday and report back next week
18:20:25 <rosmaita> (we left it that they will ping the TC if they need help)
18:20:25 <JayF> Do you want that in the minutes or just, you'll have an update at this topic next week?
18:20:59 * JayF assumes you'll just update us on the topic next week and avoids double-booking the topic
18:21:03 <JayF> #topic 2024.1 TC Tracker
18:21:06 <rosmaita> ok
18:21:08 <JayF> #link https://etherpad.opendev.org/p/tc-2024.1-tracker
18:21:17 <JayF> Any updates on TC tracker-tracked items?
18:22:37 <JayF> Moving on to next topic.
18:22:45 <JayF> #topic Open Discussion and Reviews
18:22:58 <JayF> #link https://review.opendev.org/q/status:open+repo:openstack/governance
18:23:11 <JayF> Please have a look at open governance reviews; I'll make a pass this afternoon as usual to merge eligible changes.
18:23:20 <JayF> Any topics for open discussion this week?
18:23:22 <frickler> I was hoping we'd also handle inactive projects under the leaderless topic, but so I'll mention these here for visibility
18:23:43 <JayF> ++ please do, lets link those changes into the agenda
18:23:44 <gmann> ++
18:23:56 <gmann> I will review those today
18:23:59 <JayF> #link https://review.opendev.org/c/openstack/governance/+/902623
18:24:02 <JayF> #link https://review.opendev.org/c/openstack/governance/+/902624
18:24:02 <frickler> those patches are stacked on top of each other because otherwise they'd conflict, let me know if I should change the ordering
18:24:04 <JayF> #link https://review.opendev.org/c/openstack/governance/+/902625
18:24:06 <JayF> #link https://review.opendev.org/c/openstack/governance/+/902626
18:25:27 <JayF> Is there anything further to discuss on that or other topics for open discussion?
18:25:50 <fungi> sorry, juggling multiple meetings in this timeslot, but the indication from amazon was that their interest in donating opensearch resources was to raise the profile of opensearch recognizing it as a legitimate open source project and also of their managed opensearch service offering
18:26:06 <frickler> so marketing, ok ;)
18:26:14 <frickler> repeating my comment from last week: testing fungi's affiliation patch 876738 I see that 4 members do no specify an affiliation in their profile, maybe everyone can check and fix that?
18:26:28 <fungi> (remember that amazon forked opensearch when elastic changed the license on elasticsearch, so have been trying to get out from under that shadow)
18:26:28 <gmann> ++
18:26:54 <JayF> frickler: can we be specific about where that affiliation is set?
18:27:08 <JayF> frickler: wondering if we need to #action the tc-members who need to set affiliations to do a change to do so
18:27:13 <frickler> JayF: in your profile on the oif page
18:27:26 <gmann> #link https://openinfra.dev/a/profile
18:27:48 <gmann> I think openstack.org is synced up automatically or it is otherway around ?
18:27:53 <gmann> or we need to update both
18:28:09 <frickler> iiuc oif is the source of truth nowadays
18:28:53 <jamespage> fixing mine now
18:28:57 <gmann> most of time (not recently) updated openstack.org and it got synced up in openinfra.dev also but doing directly on openinfra is good
18:29:01 <JayF> Ack; thanks for that callout frickler. We should resolve that issue before we, say, pass resolutions that change our charter to depend on that information :D
18:29:08 <frickler> there's also the question whether e.g. "Red Hat Inc." is different from "Red Hat" or "Red Hat $country" and how to handle that
18:29:21 <knikolla> ugh, i thought i had one. will update mine.
18:29:31 <frickler> or "Canonical $somewhere" for that matter
18:30:09 <gmann> I think 'Affiliation' definition in bylaws consider them all single org right? but its tooling we need to take care of that
18:30:31 <frickler> finally there's also the question whether we should also ask PTLs and other leader positions to provide this information
18:30:43 <gmann> not sure if IBM and Red Hat is considered same?
18:30:49 * slaweq just fixed own profile
18:31:06 <slaweq> gmann: I don't think it should
18:31:09 <knikolla> i fixed mine too.
18:31:10 <JayF> I think it's valuable to have the information; but unless we have specific requirements in bylaws for affiliation diversity around PTLs, I don't think we should require them.
18:31:26 <spotz[m]> Red Hat and IBM not the same
18:31:28 <JayF> But that being said -- the info is useful for non-leaders too. It's useful generally.
18:31:54 <spotz[m]> Red Hat, Red Hat Inc. are the same, we have to clean them up in the speakers list every Summit:)
18:32:04 <gmann> yeah, info is good. agree with frickler to ask PTL also but just a nice to have info in profile
18:32:33 <gmann> and mandatory for election things
18:33:20 <fungi> i was doing affiliation analysis recently and found contributors spelling "red hat" 28 (no joke) different ways
18:33:21 <frickler> PTLs are also elected, so we could decide to make this mandatory information to provide? but asking nicely is fine for me for now
18:33:58 <knikolla> fungi: that's impressive
18:34:20 <gmann> :)
18:34:45 <knikolla> my partner has two first names and two last names and it's fun to see all the different ways software systems fail to cope with that.
18:34:52 <spotz[m]> And don't forget RedHat
18:35:05 <slaweq> LOL
18:35:08 <fungi> technically we do at least need accurate affiliation data for tc candidates in order to avoid violating the current charter limits on affiliation
18:35:21 <JayF> ++
18:35:44 <gmann> yeah
18:35:50 <spotz[m]> I agree though I think we're good at noting Red Hat and Red Hat Inc are the same on a manual level:)
18:36:06 <gmann> should we have that info in this page too? #link https://governance.openstack.org/tc/
18:36:13 <spotz[m]> It's when we try to do things programmatically it takes more effort
18:36:17 <gmann> this table #link https://governance.openstack.org/tc/#current-members
18:36:48 <JayF> It'd be nice from a documentation standpoint; but not at the cost of having that affiliation have two sources of truth
18:36:54 <spotz[m]> Maybe as most of us seem to use personal emails for Open Source work
18:37:05 <JayF> if we could pull it from opendev profile into that page; awesome; if not, I'd worry about drift
18:37:13 <spotz[m]> I guess we can't just pull it in?
18:37:23 <frickler> some variant of fungi's script could do that
18:37:40 <frickler> maybe not live, but via some check job?
18:37:58 <fungi> that script is still mostly a poc but happy to make improvements and polish it
18:38:04 <gmann> i think check during election time or any change in TC members is enough
18:38:14 <JayF> ++
18:38:31 <frickler> ok I have another thing I mentioned earlier, but failed to link to the actual page :-/ https://docs.openstack.org/install-guide/openstack-services.html
18:38:32 <JayF> We trust CI for more important things than this, such as if the software we govern actually does anything :D
18:38:47 <spotz[m]> I would say the stackalytics file but you don't need to add yourself there unless you change companies for some reason
18:38:48 <gmann> +1
18:38:55 <frickler> this mentions yoga and earlier, no wonder ppl keep installing old releases
18:39:10 <JayF> spotz[m]: that file is not updated anymore, stackalytics is not maintained, patches to that file have been open months and months
18:39:20 <JayF> spotz[m]: we really need to not direct people there/treat the website as gone :(
18:39:50 <gmann> frickler: nice catch
18:40:07 <spotz[m]> If I get time over the holidays I'll work on the install guides, no promises
18:40:16 <frickler> so do we want to drop EOL releases there? and how can we keep this up to date?
18:40:35 <fungi> openstack.biterg.io is trying to pull affiliation data from openinfraid (foundation) profiles, but we have very spotty coverage owing to people not having much incentive to keep their affiliations/date ranges accurate there
18:40:38 <JayF> Does someone want to take an action to dig into this? There is no docs team.
18:40:43 <gmann> good point, and with unmaintained status, do we want to keep those also there?
18:41:08 <JayF> I don't think the TC meeting is the best place to go point by point, but we can get a few interested folks together who want to fix things up
18:41:19 <gmann> or maybe have those all there even people install EOL release also
18:41:25 <gmann> at least they find doc somewhere
18:41:50 <gmann> good to add this i tracker and ask for volunteer
18:41:55 <gmann> *in
18:42:08 <gmann> there are many doc issues still
18:42:40 <frickler> +1
18:43:02 <spotz[m]> Ok I think I can up date the links on that page, it gets a little wonky where we go from name to numbers....
18:43:31 <JayF> spotz[m]: can I put you down for an action to follow up post-holidays, even if it's not done, just like, status update/let folks know where it lies?
18:43:45 <spotz[m]> I'll take the action item to update that page as much as possible
18:44:00 <JayF> #action spotz[m] to look into updating https://docs.openstack.org/install-guide/openstack-services.html and report back to TC post-holidays
18:44:12 <JayF> Any other topics for Open Discussion?
18:44:30 <gmann> remember we still have releasenotes link error for release name vs number. added in tracker too
18:44:43 <gmann> and frickler has pushed some changes for that.
18:44:52 <gmann> mentioning here as that is also known broken doc link
18:44:57 <spotz[m]> Someone just remind me how far back we need to keep there:)
18:45:12 <JayF> https://releases.openstack.org is the canonical source
18:45:34 <JayF> which says back to stein right now, until a month goes by, when hopefully it'll say "Victoria -> unmaintained"
18:45:36 <JayF> as the last one :)
18:45:37 <spotz[m]> Stein thanks:)
18:45:44 <frickler> spotz[m]: train and ussuri are just up for being EOLed globally
18:45:53 <JayF> just noting that it'll be victoria perhaps by the time you get done :D
18:46:21 <gmann> spotz[m]: maybe we can add all EOL under new section 'EOL releases' insead of removing them
18:46:42 <frickler> hmm, I thought stein was eol already, will check with release team
18:46:51 <gmann> or just keep them all and adda notes to check the release page about each release lifecycle
18:47:11 <spotz[m]> The Minimal deployment sections would over run the page but we could divide the install guide part
18:47:34 <rosmaita> btw, i just noticed that i missed an item for the Unmaintained branch implementation status
18:47:45 <rosmaita> https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/UJ7Y76LRWTZQSSDAGMPWCCVVGGIX3TOG/
18:48:02 <rosmaita> ussuri and train EOL
18:48:21 <rosmaita> (to clear them out before moving v through y to umaintained/
18:49:25 <JayF> Thanks!
18:49:33 <knikolla> i have to drop off early today. If I don't see you next week in the TC meeting, happy holidays! o/
18:49:37 <JayF> \o
18:49:54 <JayF> Anything else for Open Discussion, or can we all join knikolla in dropping the meeting? :D
18:50:04 <slaweq> happy holidays knikolla
18:50:08 <jamespage> me too - need to ship a child somewhere for 10 minutes time - have a nice break folks!
18:50:08 <spotz[m]> Happy Holidays Kristi
18:50:18 <JayF> that sounds like consensus :)
18:50:22 <JayF> have a good holiday o/
18:50:24 <JayF> #endmeeting tc