18:00:51 <gouthamr> #startmeeting tc
18:00:51 <opendevmeet> Meeting started Tue Apr 30 18:00:51 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:51 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:51 <opendevmeet> The meeting name has been set to 'tc'
18:01:04 <spotz[m]> o/
18:01:07 <gouthamr> #topic Rollcall
18:01:08 <gmann> o/
18:01:09 <JayF> o/
18:01:13 <dansmith> o/
18:01:14 <slaweq> o/
18:01:18 <frickler> \o
18:01:31 <noonedeadpunk> o/
18:01:44 <gtema> o/
18:02:07 * gouthamr wow that's a full house :)
18:02:10 <frickler> wow, full house ;)
18:02:18 <gouthamr> hey there everyone; Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:02:26 <gouthamr> #chair frickler
18:02:26 <opendevmeet> Current chairs: frickler gouthamr
18:02:38 <gouthamr> ^ i will do this with each meeting; in case i get disconnected :)
18:02:58 <frickler> ack
18:03:21 <gouthamr> Today's meeting agenda can be found at
18:03:29 <gouthamr> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee (TC meeting agenda for 30th Apr 2024)
18:04:20 <gouthamr> lets get started
18:04:30 <gouthamr> a procedural topic
18:04:33 <gouthamr> #topic Monthly video meeting updates
18:05:08 <gouthamr> i was chatting with JayF about this; and i thought lets get a wider consensus on the platform we use for our monthly video meetings
18:05:47 <gouthamr> i'd like to thank the Open Infra Foundation for letting us use a pro Zoom account so we can keep longer meetings and do other fancy things
18:06:24 <gouthamr> but i know a lot of you were never happy with doing this; and i think the problem was with the feature gap we had in the past with Jitsi
18:06:53 <dansmith> a lot?
18:06:56 <gouthamr> but, having successfully used meetpad.opendev.org in the last PTG, i think its time to consider it again for our monthly meeting
18:07:00 <gmann> also, has anyone tested the recording? because we need recording for TC meeting to be published on public youtube channel
18:07:19 <gouthamr> dansmith: /me made an assumption based on how the community feels about non-opensource tools
18:07:21 <JayF> ==gmann that's my only concern; that we're able to get a high quality recording
18:07:30 <noonedeadpunk> I think we did last time we evaluated meetpad
18:07:36 <noonedeadpunk> and it was far from being usable
18:07:52 <gmann> yeah, we should test that before trying in meeting directly
18:07:56 <spotz[m]> Does meetpad now record?
18:08:08 <noonedeadpunk> It did, but smth was completely off there
18:08:09 <dansmith> desktop integration is a big one for me, i.e. mute and other button sync, which meetpad doesn't do properly (or at all)
18:08:23 <JayF> spotz[m]: recording on meetpad is done locally aiui
18:08:32 <dansmith> yeah, still no recording support, you have to do it locally, AFAIK
18:08:40 <gouthamr> gmann JayF: ++ i agree on recording; and we (in the manila team) have tested meetpad well enough this past PTG and have recorded things and things have gone swimmingly well
18:09:05 <JayF> you're the person who is going to be responsible for recording it, so if you're onboard I am
18:09:15 <dansmith> gouthamr: I thought cinder and glance used something else for ptg specifically for that reason?
18:09:26 <JayF> but I'll note I don't have a strong opinion one way or the other -- in terms of issues before the TC, what platform we use for video meeting is not a large priority imo
18:09:45 * frickler just takes the opportunity to note again that I'm not happy with video meetings at all and would support a motion to stop them completely. and while I am +1 with the change to meetpad, I likely won't join those either
18:09:50 <gouthamr> ah i didn't know; but https://www.youtube.com/watch?v=Bhg4aT1B_vE&list=PLnpzT0InFrqCHg9lfMcPe136BU-27jt-x is a testament
18:10:13 <gouthamr> dansmith ^
18:10:22 <dansmith> ack, just saying
18:10:40 <dansmith> if frickler isn't going to join the video meetings anyway, is there anyone else feeling strongly about moving away from zoom?
18:10:57 <JayF> frickler: I too would prefer no video meetings whatsoever out of the three options of "jitsi", "zoom", or "no video" :)
18:11:02 <gmann> I am ok with zoom as it has been very smooth
18:11:10 <JayF> frickler: I appreciate the built-in logging of text-based collaboration
18:11:20 <slaweq> zoom is fine for me
18:11:22 <clarkb> the recording support is built into meetpad but it records a file to your local machine
18:11:30 <clarkb> just to clarify that it is supported but it doesn't auto upload to say youtube
18:11:36 <clarkb> (or anywhere else)
18:11:47 <dansmith> clarkb: or handle the recorder dropping from the call, presumably'
18:12:03 <clarkb> yes that is the case I think
18:12:11 <clarkb> the client has to be connected to record
18:12:14 <gouthamr> dansmith: if there's a disconnection, the recording still gets downloaded.. but yes, it gets fragmented
18:12:35 <dansmith> anyway, +1 for staying with zoom from me
18:12:45 <slaweq> can it be recorded by more than one person in the same time maybe?
18:13:09 <clarkb> yes
18:13:11 <gouthamr> slaweq: yes
18:13:41 <slaweq> so that could be eventually workaround if we would have e.g 2 people recording it just in case one would be disconnected
18:13:44 <slaweq> just saying
18:14:15 <spotz[m]> I like the idea of moving to meetpad
18:14:22 <slaweq> it is not perfect of course but can be more likely to be fine then
18:14:49 <gouthamr> my proposal is that we try it; if it becomes too painful, lets go back
18:15:18 <noonedeadpunk> so basically that boils down to you and frickler
18:15:21 <gouthamr> but, if you're against trying it, i'd like to know :) no need to stir the pot..
18:15:31 <dansmith> I've tried it plenty and prefer zoom, FWIW
18:15:33 <noonedeadpunk> as in case of your absence there should be someone who can do recording as well
18:15:47 <gouthamr> noonedeadpunk: +1
18:15:51 <dansmith> I'm not sure what trying we need to do, unless you mean "see how often we fail to get a usable recording" or something :)
18:16:01 <gouthamr> ^ that
18:16:10 <dansmith> seriously? :)
18:16:31 <JayF> I will comment that: 1) our TC videos on yt get minimal views and 2) I got zero complaints the one time I failed to start recording directly
18:16:33 <slaweq> sounds good for me, we are using meetpad in e.g. neutron for the ci meetins every other week and it works fine for us
18:16:37 <JayF> so I don't think it's a large risk to try something
18:16:53 <gmann> I am very concern on 'no/fail recording' which can be a issue with TC video call being public
18:17:15 <dansmith> I totally don't get the mix of "we must have text-based archives of everything" and also "meh, if we fail to record no big deal"
18:18:02 <JayF> dansmith: IME the utility of recordings is minimal compared to the utility of searchable text-based archives/notes
18:18:09 <gmann> JayF: I have seen many people in past complaining about TC meeting transparency of video call. if it was not recorded by mistake it is fine but if do it bcz of tool we use then  its issue
18:18:23 <noonedeadpunk> yeah, despite limited interest, I believe that all recording must be safe
18:18:37 <noonedeadpunk> otherwise we should pretty much neglect all non-recorded part...
18:19:40 <noonedeadpunk> and yes, I also have heard some complaints about non-transparency of video calls - potentially in the same discussion as gmann did :D
18:19:46 <fungi> fwiw, most complaints about lack of transparency of meetings was about in-person meetings, vs irc where there's a skimmable log of the discussion (skimming a video recording is nontrivial)
18:20:09 <fungi> not about lack of recordings
18:20:10 <JayF> fungi: ++ that's basically what I meant re: video recordings having minimal utility
18:20:31 <noonedeadpunk> well, frankly, with todays LLMS getting audio to text (with like whisper) makes things way more trivial...
18:20:33 <dansmith> yeah, not everyone watches every meeting, but people do need to fill-in in case they miss one, so one data point about a missing recording is not really very representative, IMHO
18:20:57 <gmann> same with logs. not everyone ready all logs and they can complain thesame
18:20:59 <gmann> the same
18:21:18 <dansmith> well, it's easy to not complain if you usually don't need them, but when you do and they're not there, it's a problem
18:21:30 <gmann> yeah
18:21:35 <gouthamr> +1 ; so while the youtube video recording viewership may be low.. there's an archive to go back to for _something_ in case we need to
18:21:38 <dansmith> anyway, this seems like a solution in search of a problem, because nobody that is currently not attending would if we move, and we've spent 21 minutes on this so far
18:22:07 <gouthamr> hmmm; true
18:22:33 <gouthamr> alright; we were split between people wanting to try it, and sticking with the solution
18:22:35 <gouthamr> we have..
18:23:44 <gouthamr> so lets table this for now; honestly i did hope that we'd be more accepting of a non-commercial/open source tool and yes, it'd increase participation amongst the TC... if that's not going to happen with this tool change, i don't mind sticking to what we have
18:24:09 <gouthamr> thank you for sharing your views on this!
18:24:17 <gouthamr> lets jump right into the meat of this meeting
18:24:20 <gouthamr> #topic 2024.2 TC Tracker
18:24:25 <gouthamr> oh
18:24:27 <gouthamr> #undo
18:24:27 <opendevmeet> Removing item from minutes: #topic 2024.2 TC Tracker
18:25:16 <gouthamr> #agreed The next video meeting will be on Zoom; gouthamr will share details on the ML.. we can continue to dissect the meeting tool/platform outside of the TC meeting
18:25:20 <gouthamr> #topic 2024.2 TC Tracker
18:25:22 <gouthamr> #link https://etherpad.opendev.org/p/tc-2024.2-tracker (Technical Committee activity tracker)
18:26:22 <gouthamr> ^ there's been some movement on many open governance items
18:26:43 <gouthamr> beyond proposals to the governance repo, there is ML activity captured in that tracker as well
18:27:15 <gmann> gouthamr:  ++ for adding date wise status tracking.  I added the status on my item in etherpad.
18:28:14 <gouthamr> +1 it would help me keep the ticker on things; and allow things to merge in a timely manner
18:29:53 <gouthamr> there may be missing activities on this etherpad
18:30:14 <gouthamr> please add them if you were keeping tab of them :)
18:31:12 <gouthamr> i think one thing i had a question about was gate stability that a lot of work went into.. i don't know if we meant to keep checking in during this release
18:31:56 <dansmith> honestly the work we put in was mostly in the checking, and I think the highlighting is what actually made things progress
18:32:11 <dansmith> I mean, I think it's been that way for a couple years now
18:32:17 <dansmith> "gate health dies in darkness" or some such
18:32:19 <gmann> I think that is worth to continue and has helped us on progressing on gate stability even it is not stable yet
18:32:39 <gmann> at least having TC eyes on big breaking things help
18:33:05 <slaweq> +1
18:33:44 <gouthamr> +1 agreed! i'll take a stab at filling the details thus far and ask questions; is there an update anyone would like to share now?
18:34:35 <gouthamr> taking silence as no..
18:34:41 <dansmith> I've been stuck on something not very upstream the last few weeks,
18:34:58 <dansmith> so I don't have the same "butt dyno" feeling I would normally
18:35:19 <dansmith> but I think it's been relatively decent of late, but things are starting to pick up for the cycle and that's when things will happen
18:36:27 <slaweq> I was also off for quite some time recently but after I came back I didn't saw any major issues there
18:36:37 <gmann> i have not seen blocking failure in this week but there are less activities so far
18:37:17 <gmann> fixed one issue in tempest jobs but that is for victoria/wallaby branches
18:37:19 <gouthamr> +1 i think this thingy may drive up some activity
18:37:30 <gouthamr> #link https://canonical.com/blog/canonical-releases-ubuntu-24-04-noble-numbat (Ubuntu 24.04)
18:38:04 <frickler> well, I was going to mention this later, but the QA team has no volunteer yet to make devstack run on that
18:38:05 <dansmith> yeah, when do we get 24.04 jobs?
18:38:10 <dansmith> ah
18:38:19 <gmann> not yet
18:38:38 <gmann> I mean no volunteer yet as frickler mentioned so not sure when we will have
18:38:44 <frickler> also the opendev team may be thankful for help for getting mirrors set up and images built
18:39:05 <dansmith> has someone tried and it fails, or just no known attempts yet?
18:39:20 <frickler> no attempts afaik
18:39:26 <dansmith> ack
18:39:33 <fungi> some things needed updating in underlying components first (glean, dib...)
18:39:36 <noonedeadpunk> well, in osa we tried, but it failed way before, so not representative yet.
18:39:53 <noonedeadpunk> But I was wondering about 1 thing - I guess 24.04 is shipped with py3.12?
18:40:02 <fungi> big thanks to frickler for helping work out a lot of that
18:40:04 <dansmith> yeah, as I understand
18:40:05 <noonedeadpunk> and there was some struggle with it?
18:40:15 <noonedeadpunk> At least according to what is written in PTI
18:40:24 <noonedeadpunk> (and plenty of ML discussions)
18:40:41 <JayF> I think most outstanding items preventing py3.12 from running  at all have been resolved
18:40:52 <frickler> noonedeadpunk: what's written in the PTI iiuc is mainly due to 24.04 not being available when the reqs for 2024.2 were to be finalized
18:40:53 <JayF> if that's not true I'd be interested to know what specific items still exist
18:41:04 <fungi> note that we do already have python3.12 jobs available, they just don't run on ubuntu noble yet
18:41:13 <dansmith> I know taskflow has some stuff that is going to explode, but I don't know if that is in 3.12 or later
18:41:31 <gtema> Jayf: sure? Sometime ago even docs build jobs were failing for some projects
18:41:48 <noonedeadpunk> aha, ok, gotcha
18:42:22 <fungi> 3.13 is going to be a more painful version, due to the "removing dead batteries" effort
18:42:33 <dansmith> fungi: yeah
18:42:38 <JayF> gtema: I have not tested docs builds; mainly focusing on unit tests and known-broken-issues (e.g. eventlet-related stuff, sslcontext changes)
18:42:57 <gmann> this is result for unite testing on py3.12 #link https://zuul.openstack.org/builds?job_name=openstack-tox-py312&skip=0
18:43:20 <gmann> I think more failing than passing
18:43:32 <JayF> To be clear; my comment was meaning
18:43:41 <JayF> nothing should be blcoking those projects from being 3.12 compatible now
18:43:48 <dansmith> ah yep, taskflow is broken: https://zuul.openstack.org/build/915772d7ce8e4af191f0abf30ec22acd
18:43:50 <dansmith> which means glance
18:43:56 <dansmith> and probably others, cinder maybe
18:44:20 <dansmith> can't even import it, so that'll be a problem
18:44:26 <dansmith> (in 3.12)
18:45:13 <noonedeadpunk> octavia?
18:45:49 <dansmith> ah here we go, problem solved :) https://github.com/simonrob/pyasyncore
18:46:27 <johnsom> We are just going to remove that code from taskflow
18:46:39 <johnsom> No one is using it
18:46:57 <dansmith> I thought it ran deeper than trivial removal
18:47:07 <johnsom> Nope
18:47:08 <dansmith> if not, then cool,
18:47:22 <johnsom> There is a patch up already
18:47:28 <dansmith> excellent
18:47:30 <gouthamr> #link https://bugs.launchpad.net/taskflow/+bug/2026183 (taskflow shouldn't be using asyncore / asynchat anymore)
18:47:49 <noonedeadpunk> that sounds too trivial :D
18:47:55 <gouthamr> #link https://review.opendev.org/c/openstack/taskflow/+/916147 (Python3.12: disable process_executor, which depends on asyncore)
18:48:51 <gouthamr> alright; do we have a recommendation on how to approach this? we have a two part problem - python3.12 and the using the latest LTS
18:49:55 <gouthamr> maybe we tell project teams to look at their failing 3.12 jobs because we intend to switch the default to voting?
18:50:09 <dansmith> not in this release right?
18:50:30 <gouthamr> yeah, E would be the focus; but start now?
18:50:30 <frickler> well one option would be to resort to only using Debian as LTS platform
18:50:31 <dansmith> PTI says it's advisory only, so we can't do that until next release at the earliest, AFAIK
18:50:33 <JayF> I think it's to the point of project team responsibility now, we've enabled py3.12 support in libraries we use and in oslo stuff
18:50:37 <gmann> this release, it will be non voting only and voting in next one
18:50:51 <JayF> it never hurts to encourage people to pay attention now though :)
18:50:57 <gmann> but we expect project to work on issues in this release so that no issue in making it voting in next cycle
18:51:04 <gmann> yeah
18:52:18 <frickler> maybe jamespage has some colleagues that could be motivated ... cf. the earlier discussion about Charms
18:52:29 <gouthamr> ^ ++
18:53:05 <gmann> that's even on python 3.11 which is voting job
18:53:51 <gmann> not sure if anything py 3.12 has solution for and they want to avoid py3.11 testing
18:54:40 <frickler> from what I read in that review the real issue was broken constraints pinning
18:54:41 <gouthamr> we'll gather that info over the ML
18:55:13 <gouthamr> alright; we're 5 mins to close
18:55:23 <gouthamr> and i wanted to leave some space for open discussion
18:55:31 <gouthamr> #topic Open Discussion
18:56:04 <frickler> I wanted to also shortly mention the topic of global-requirements.txt cleanup that came up earlier today
18:56:55 <frickler> stephenfin made some work in the reqs repo to clean things up, one patch removed old constraints (excludes), which now causes reqs check in other projects to fail
18:57:22 <frickler> see e.g. the lively discussion in the nova meeting earlier
18:57:50 <frickler> not sure yet whether some actual action on the TC side is needed, but likely worth watching at least
18:58:22 <JayF> I took the action of approving like 10 patches in Ironic projects fixing them :D
18:58:23 <gouthamr> #link https://meetings.opendev.org/irclogs/%23openstack-requirements/%23openstack-requirements.2024-04-30.log.html (discussion on openstack-requirements regarding dropping exclusions)
18:58:53 <gouthamr> #link https://meetings.opendev.org/irclogs/%23openstack-nova/%23openstack-nova.2024-04-30.log.html (discussion on openstack-nova regarding dropping exclusions)
18:59:12 <frickler> #link https://review.opendev.org/c/openstack/requirements/+/916006 the relevant patch
18:59:24 <spotz[m]> Thanks Goutham!
18:59:37 <frickler> as, I think the fallout was a bit unexpected
18:59:45 <frickler> s/as/yes/
19:00:14 <gmann> one more thing.  we have now 23 open reviews. I would request to get more vote and merge the one already eligible https://review.opendev.org/q/project:openstack/governance+status:open
19:00:28 <gouthamr> ^ gmann yes; i've a post meeting AI on this
19:00:36 <gmann> thanks
19:00:59 <gouthamr> perfect; we're at the hour.. the chariot turns into a pumpkin, or something
19:01:04 <gouthamr> thank you all for attending!
19:01:10 <gouthamr> #endmeeting