18:00:39 <gouthamr> #startmeeting tc
18:00:39 <opendevmeet> Meeting started Tue May  7 18:00:39 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:39 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:39 <opendevmeet> The meeting name has been set to 'tc'
18:00:52 <noonedeadpunk> o\
18:01:13 <gouthamr> #topic Rollcall
18:01:29 <gmann> o/
18:01:31 <dansmith> o/
18:01:41 <noonedeadpunk> I forgot to mark myself as out today, but on openinfra Sweden event, so really more out then it
18:02:05 <gouthamr> ack noonedeadpunk
18:02:12 <gouthamr> this meeting is happening simultaneously on Zoom
18:02:14 <gouthamr> #link https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
18:02:18 <slaweq> o/
18:03:28 <JayF> o/
18:04:32 <gouthamr> courtesy ping: spotz[m] frickler
18:04:37 <gouthamr> gtema
18:05:10 <gtema> O/
18:05:24 <gouthamr> #topic DPL model improvement proposals and TC Liaisons
18:05:35 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/916822 (Move DPL model into doc)
18:05:35 <gmann> gtema: today is video call #link  https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
18:05:35 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/916833 (Add DPL model & liaison reset policy)
18:05:35 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/917516 (TC liaisons for requirements, release management and ; freezer is the fourth)
18:06:12 <gtema> Right, forgot about video, will join in a min
18:06:47 <gouthamr> gmann is presenting the idea behind https://review.opendev.org/c/openstack/governance/+/916833  and https://review.opendev.org/c/openstack/governance/+/917516
18:08:00 <gouthamr> we're not in a hurry to merge this
18:08:08 <gouthamr> but we're interested to know if there are any major disagreements
18:08:22 <gouthamr> please add your comments to these gerrit changes
18:09:51 <gouthamr> tkajinam brought up the concern that the initial DPL model proposal suggests that the model is suggested for low activity projects
18:10:01 <gouthamr> JayF suggested we change the language to clarify this
18:11:27 <gouthamr> we're suggesting spreading the load for the TC liaisons for the DPL projects
18:11:47 <gouthamr> tc-members please feel free to claim any projects you'd wish
18:12:32 <gouthamr> gtema is seeking if we have a written procedure to know when a project is active/not
18:12:42 <JayF> #link https://governance.openstack.org/tc/reference/emerging-technology-and-inactive-projects.html
18:12:45 <JayF> I think this is it? gtema
18:12:53 <gouthamr> JayF++
18:13:53 <gouthamr> project meetings aren't a strict requirement to judge an active project...
18:14:35 <gouthamr> but a holistic/subjective approach that works instead to judge a project's activity/inactivity seems to warrant a TC liaison's judgement
18:14:56 <gouthamr> (or the TC's judgement in case of PTL model projects)
18:15:12 <slaweq> helper script which may give some data about project's health: https://github.com/openstack/governance/blob/master/tools/project_stats_check.py
18:15:20 <gouthamr> its really hard to automate this sort of thing
18:16:46 <JayF> given how projects in openstack are mature enough to be mostly "done", it's hard to use statistics alone to measure project activity
18:17:18 <gouthamr> gtema says project users/operators need to know which projects are active
18:18:12 <gouthamr> JayF brought this up at the TC PTG
18:18:28 <gouthamr> #link https://etherpad.opendev.org/p/apr2024-ptg-os-tc (TC PTG etherpad)
18:19:44 <gouthamr> there was no conclusion to make a proposal
18:21:09 <gouthamr> can we break up the problem to make a proposal - for example, if the security concerns are at the top of our mind, can we have a proposal just isolating the security requirements for projects
18:21:55 <gouthamr> we'd need to change the project requirements to accommodate this
18:22:13 <gouthamr> the security-sig and VMT has less volunteers though; so we'd need to do this simultaneously by growing the security-sig/VMT
18:22:55 <gouthamr> will a yellow/green/red marking on our existing project list help? in addition to having https://governance.openstack.org/tc/reference/emerging-technology-and-inactive-projects.html and
18:23:07 <JayF> (I said) We have a limited amount of resources, any approach would have to acknowledge that and use prioritization rather than just adding additional requirements
18:23:10 <gouthamr> slaweq suggests adding a badge in repo
18:24:01 <gouthamr> people are discovering projects using multiple sources: project documentation, project navigator, git repositories
18:24:40 <opendevreview> Merged openstack/governance master: Move openstack/kuryr and openstack/kuryr-libnetwork to Zun  https://review.opendev.org/c/openstack/governance/+/917517
18:24:41 <opendevreview> Merged openstack/governance master: Add timeline to remove enforce_scope in RBAC goal  https://review.opendev.org/c/openstack/governance/+/915179
18:24:41 <gouthamr> gmann brought up the "openstack map" would also need to accommodate this
18:25:09 <gouthamr> #link https://object-storage-ca-ymq-1.vexxhost.net/swift/v1/6e4619c416ff4bd19e1c087f27a43eea/www-assets-prod/openstack-map/openstack-map-v20240401.pdf (current "openstack landscape" or map
18:26:56 <gouthamr> #action gtema will make a proposal to the governance repo regarding tagging inactive projects more prominently
18:27:08 <gouthamr> #topic Next steps on PyPi Maintainers cleanup (gmann)
18:27:26 <gouthamr> the existing state is recorded in this etherpad
18:27:27 <gouthamr> #link https://etherpad.opendev.org/p/openstack-pypi-maintainers-cleanup (Notes on PyPi maintainership of OpenStack packages)
18:28:43 <gouthamr> we've to break the package list into two: one where openstack-ci is a co-maintainer/owner; and other where openstack-ci doesn't figure in the maintainers list
18:29:04 <gouthamr> #action gouthamr will work on this list
18:31:35 <gouthamr> #topic 2024.2 TC Tracker
18:31:41 <gouthamr> #link https://etherpad.opendev.org/p/tc-2024.2-tracker (Technical Committee activity tracker)
18:34:24 <gouthamr> we discussed items that needed more TC review atm
18:34:47 <gouthamr> re: dropping eventlet vs replacing eventlet with asyncio
18:35:07 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/902585 (Migrate eventlet usages to asyncio)
18:35:26 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/916546 (Goal: Remove eventlet requirements from shared libraries)
18:35:57 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/PY6NUNYFU63XOIZHDDBONJDHRXJMZF5J/ ([all][oslo][neutron][glance][ironic] Deprecating eventlet based WSGI server)
18:37:42 <gouthamr> projects seem to be concerned that the big leap from eventlet to asyncio needs to be figured out via https://review.opendev.org/c/openstack/governance/+/902585
18:37:52 <gouthamr> and we may be impeding individual project progress
18:38:22 <gouthamr> JayF suggests that we should clarify that the TC doesn't stand in the way of projects exploring options to replace eventlet
18:38:53 <gouthamr> we're not going to have a one-size-fits-all solution
18:39:18 <gouthamr> JayF suggests communicating this to the ML is required now
18:43:10 <gouthamr> ^ this seems like a general consensus in the TC
18:44:31 <gouthamr> hberaud ^
18:44:50 <gouthamr> we'd continue chatting on the gerrit change..
18:47:46 <JayF> I will take an action to chat with hberaud and try to find a soft landing for that proposal and communicate that to the larger community (via gerrit/ML)
18:49:07 <gouthamr> #topic Open Discussion
18:49:56 <gouthamr> JayF++
18:50:54 <gouthamr> why does devstack take a longer time on zuul jobs vs github actions
18:51:07 <gouthamr> clarkb brought this up multiple times in the past
18:53:18 <gouthamr> #link https://review.opendev.org/c/openstack/devstack/+/676016 (OSC as a service on devstack)
18:53:31 <gouthamr> ^ this proposal is ancient in our release timeline
18:54:49 <gouthamr> the underlying issue seems to be the token caching
18:54:52 <gouthamr> in OSC
18:59:43 <gouthamr> thank you all for joining!
18:59:50 <gouthamr> lets catch up here in a week!
18:59:57 <gouthamr> #endmeeting