18:00:12 <gouthamr> #startmeeting tc
18:00:12 <opendevmeet> Meeting started Tue Jun  4 18:00:12 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:12 <opendevmeet> The meeting name has been set to 'tc'
18:00:40 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:00:46 <gouthamr> #link https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ
18:01:07 <gouthamr> zoom link:
18:01:19 <gouthamr> #link https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09 (Zoom Video Call for the TC weekly meeting)
18:01:26 <gouthamr> #topic Roll Call
18:02:06 <gmann> o/
18:02:41 * gouthamr notes dansmith noonedeadpunk gtema slaweq are on the video call
18:03:02 <gouthamr> noted absences: JayF spotz
18:03:23 <gouthamr> #chair frickler
18:03:23 <opendevmeet> Current chairs: frickler gouthamr
18:04:08 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:04:30 <gouthamr> the meeting agenda is here:
18:04:32 <gouthamr> #link https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:06:13 <gouthamr> #AIs from last meeting
18:06:23 <gouthamr> PyPi maintainers cleanuo
18:06:26 <gouthamr> PyPi maintainers cleanup*
18:07:06 <gouthamr> frickler has been cleaning up the list that we've had of human maintainers; ty frickler
18:07:53 <gouthamr> #link https://etherpad.opendev.org/p/openstack-pypi-maintainers-cleanup#L52 (Maintainers that need to be dropped across packages)
18:08:42 <gouthamr> clarkb mentioned that the opendev infra managers would like a second package maintainer account besides "openstackci" that would allow tc members do some of the maintenance work for openstack packages on PyPi
18:09:59 <gouthamr> context: the TaCT SIG (which frickler is part of) has been doing this cleanup so far - because its clunky to pass the "openstackci" creds around to TC folks given PyPi's 2FA
18:10:47 <gouthamr> the second package maintainer account will help other folks participate with maintenance operations like these: adding/removing maintainers, metadata changes
18:11:11 <gouthamr> we could be using this second account to help with the package/project retirement process too..
18:15:30 <gouthamr> #action start working on packages where openstackci isn't the owner in parallel  (gouthamr)
18:15:39 <gouthamr> next AI:
18:15:46 <gouthamr> Following up on Monasca and Freezer zuul config errors
18:16:02 <gouthamr> noonedeadpunk will follow up with the zuul config errors in freezer
18:16:36 <gouthamr> we'll follow up on this, and on monasca in the next week's meeting
18:17:00 <gouthamr> a reminder that milestone-2 is the deadline
18:17:30 <gouthamr> to assess project activity to update the inactive projects list
18:19:16 <gouthamr> we have no response from freyes (and jamespage) on https://review.opendev.org/c/openstack/governance/+/914254
18:19:41 <gouthamr> gmann has posted on the ML and on IRC regarding this; tabling this item for another week
18:21:59 <gouthamr> re: Watcher revival (dansmith) - things to unblock CI have merged
18:22:26 <gouthamr> dansmith is playing around with the repo some more; the repo/codebase is in a good shape so far
18:23:05 <gouthamr> #topic Skyline's graduation
18:23:24 <gouthamr> #link https://governance.openstack.org/tc/reference/emerging-technology-and-inactive-projects.html
18:25:14 <gouthamr> the team doesn't have public meetings that we know of; weekly/at the PTG
18:25:25 <gouthamr> there were concerns regarding how the project was packaged
18:26:18 <gouthamr> project's actively developed looking at the gerrit activity; good features/bugfixes landing release-to-release
18:27:08 <gouthamr> pinging folks on IRC is hard too, for external folks..
18:30:27 <gouthamr> there's evidence (via the OpenStack User Survey) of Skyline's usage in production deployments and there are requests to deployment projects like openstack-ansible to include skyline
18:31:52 <gouthamr> gmann says we shouldn't hold the project team guide guidelines regarding public meetings as the bar
18:32:11 <gouthamr> there're quite a few projects whose meetings have reduced or fallen off entirely
18:32:52 <gouthamr> #action we're voluntelling frickler to coordinate the graduation of skyline from the "emerging" prjects list
18:33:17 <gouthamr> moving on...
18:33:21 <gouthamr> #topic 2024.2 TC Tracker
18:34:56 <gouthamr> gmann was fixing the 'validate-legacy.py' projects that helps with project retirements
18:35:26 <gouthamr> we had a bug that allowed project retirements to happen with files (or without required files) in some cases
18:36:32 <gouthamr> context: retired projects just have a ".gitreview" and a README file
18:36:40 <gouthamr> #agreed we're going to add older project repositories that have inconsistent files to an ignore list and let them be
18:37:32 <gouthamr> #topic Open Discussion and Reviews
18:38:56 <gouthamr> anything to discuss?
18:39:35 <gouthamr> there was nothing on the video call participants and we dropped off
18:40:16 <gouthamr> thanks again everyone; especially frickler who's probably nursing his fingers with all the PyPi cleanup work..
18:40:23 <gouthamr> see you here next week!
18:40:27 <gouthamr> #endmeeting