18:00:27 <gouthamr> #startmeeting tc
18:00:27 <opendevmeet> Meeting started Tue Jul  2 18:00:27 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:27 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:27 <opendevmeet> The meeting name has been set to 'tc'
18:01:20 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:01:33 <gouthamr> #link https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ
18:01:39 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:01:45 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:51 <gouthamr> #topic Roll Call
18:01:53 <gmann> o/
18:02:01 <JayF> o/
18:03:15 * gouthamr notes that slaweq gtema spotz[m] are on the Zoom call
18:03:30 <gouthamr> #link https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
18:03:38 <gouthamr> ^ link to the Zoom call in case you need it
18:03:50 <gouthamr> noted absence: dansmith
18:03:57 <clarkb> note you may want to undo that if zoom bombing is still an issue (though I guess regular meeting logs are also posted so meh)
18:04:15 <gouthamr> :P
18:04:17 <gouthamr> yes
18:04:25 <gouthamr> #undo
18:04:25 <opendevmeet> Removing item from minutes: #link https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
18:04:30 <JayF> I put that on the ML once not realizing and it didn't become an issue.
18:04:38 <gouthamr> ++
18:04:44 <JayF> Probably wise to have opsec but no little actual benefit at this point in time [knock on wood]
18:04:57 <gouthamr> courtesy ping noonedeadpunk
18:05:19 <clarkb> now that everyone isn't stuck at home the novelty/fun/entertainment in disrupting online communications has gone away
18:05:53 <JayF> Dan noted prior to the meeting start that he is out, working on today's recent OSSA (just putting this into the minutes)
18:06:30 <gouthamr> #topic Action Items from past weej
18:06:32 <gouthamr> #topic Action Items from past weej#undo
18:06:35 <gouthamr> #undo
18:06:35 <opendevmeet> Removing item from minutes: #topic Action Items from past weej#undo
18:06:40 <gouthamr> #topic Action Items from past week
18:07:10 <gouthamr> Following up on projects in the "inactive" state
18:07:40 <gouthamr> freezer is looking to remain in the "inactive" project list through this cycle
18:07:54 <gouthamr> gmann: we're looking for a formal vote, but doesn't have to happen on gerrit
18:08:28 <gouthamr> JayF mentioned that decisions made in meetings upset community members
18:09:02 <JayF> We had a specific complaint a couple of PTGs ago about people worried we made decisions in meetings. Our response was all official decisions are made async, in gerrit.
18:09:06 <JayF> I'd like us to keep that pattern.
18:09:19 <gouthamr> +1
18:10:10 <gouthamr> gmann suggests that noonedeadpunk can create a gerrit change to annotate the inactive project list with the 2024.1 release
18:11:18 <gouthamr> JayF gtema and gmann would like to reflect the data in a more formal way: projects.yaml and project documentation
18:11:35 <JayF> I suggest putting project inactivity in reference/projects.yaml, noting each release it was inactive similar to how we note each release we nominate a ptl.
18:12:38 <gouthamr> spotz[m] asked if the objection from the community around voting was because we weren't recording the vote formally via Meetbot's voting process
18:13:11 <gouthamr> JayF mentioned that wasn't the case; the problem was with folks in different timezones wouldn't be able to meaningfully participate
18:13:38 <gouthamr> wrt monasca, gmann will respond to thuvh's IRC question on the ML
18:13:43 <JayF> This was an issue brought up by the community a couple of PTGs ago, I believe it was the one at the beginning of my time as Chair, or maybe my first as vice-Chair
18:13:52 <JayF> re: meeting votes v gerrit votes
18:17:08 <gouthamr> regarding Skyline leaving the "emerging" projects list, we'd like the PTL/core team  propose a gerrit change to remove the project from that list
18:17:27 <gouthamr> we are asking if anyone in the TC disagrees with giving skyline folks more time to propose this change
18:18:42 <gouthamr> #agreed we'll give the Skyline team more time to work with us to remove the project from the emerging projects list
18:18:59 <gouthamr> #topic Remove eventlet from OpenStack (hberaud / zzzeek)
18:19:36 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/902585/ (Goal Proposal: Remove eventlet from OpenStack)
18:20:07 <gouthamr> this goal defines the problem - the patterns of eventlet's use in OpenStack for folks interested to learn why this is a problem
18:21:49 <gouthamr> the goal also proposes a plan for project teams to follow to replace the use of eventlet
18:23:32 <gouthamr> zzzeek has been the maintainer of sqlalchemy, and most OpenStack projects use it..
18:24:17 <JayF> also is a fairly prolific openstack contributor in his own right, fwiw
18:25:07 <gouthamr> he's looking to show how sqlalchemy uses asyncio today so we can see examples/pattern to follow
18:25:22 <gouthamr> he's currently sharing a presentation, we'll grab you a link
18:25:49 <JayF> it'll start in the video about 20-25 minutes in, too, which is helpful
18:25:58 <JayF> not sure these slides are that useful without Mike's context
18:26:04 <gouthamr> true
18:28:12 <gouthamr> we're currently going through how eventlet's monkeypatching achieves nonblocking I/O
18:31:54 <gouthamr> sqlalchemy was tasked to adding a asyncio frontend, but zzzeek wasn't keen on rewriting the whole front end to be asyncio specific.. so sqlalchemy's approach is to use an abstraction that allows both sync and async sections
18:32:38 <gouthamr> #link https://awaitlet.sqlalchemy.org/en/latest/ (a library that allows non-async defs that invoke awaitables inside of asyncio application)
18:33:14 <gouthamr> this approach is also present in a library called "greenback", but zzzeek found it was complicated
18:34:07 <JayF> #link https://review.opendev.org/c/openstack/oslo.db/+/922976 asyncio enginefacade for oslo.db, also on the slides in the meeting
18:34:13 <gouthamr> ty JayF
18:34:22 <JayF> Will that work if I'm not chair?
18:34:26 <gouthamr> yes
18:34:28 <JayF> nice
18:39:16 <gouthamr> JayF is asking if zzzeek is experimenting with using the oslo.db Asyncio Facade with any OpenStack service
18:41:16 <gouthamr> zzzeek has looked at a few services; some services may want to use this asyncio db facade  - there are examples in the docs.. there are some other services, like Swift that seem to use eventlet in a different way
18:43:29 <JayF> I also asked if it's useful as a migration tool, and it sounded like the answer is yes, it mainly exists to let asyncio-native and non-asyncio-native code to live together in the same python module
18:43:53 <zzzeek> #link https://awaitlet.sqlalchemy.org/
18:44:09 <zzzeek> #link https://github.com/zzzeek/async_demo/
18:44:15 <zzzeek> zeek's async demo ^^^^
18:46:21 <gouthamr> +1 ty zzzeek
18:46:23 <JayF> zzzeek+++ I appreciate having technical presentations in the TC video meeting. IDK if this used to be a common thing, but this has been great. Thank you!
18:46:33 <gouthamr> ++
18:46:37 <zzzeek> great
18:49:01 <gouthamr> we're discussing timelines and suggestions on how to get people involved across the community
18:49:28 <gouthamr> should the specification include a timeline?
18:49:38 <zzzeek> #link https://docs.google.com/presentation/d/169Bc_Uhv-L-0HzM6WuE6uBsC-1hIlgCOQ4lRAAapv1M/edit?usp=sharing
18:49:58 <gouthamr> ^^ ++ perfect; thanks zzzeek
18:50:55 <gouthamr> JayF recommends us to timebox the spec reviews
18:54:01 <JayF> I'd note the spec in question
18:54:03 <JayF> #link https://review.opendev.org/c/openstack/governance/+/902585
18:54:14 <JayF> Was filed Dec 4, 2023. It's been in review for seven months.
18:56:25 <gouthamr> gmann was concerned that the goal wasn't exactly clear - it reflects our need for options as opposed to a specific technology.. so people may be left confused on wht to do, how and when
18:56:45 <gouthamr> JayF is concerned about getting any nergative feedback in there in a time boxed manner
18:56:48 <JayF> I clarified that my intention in suggesting a deadline was more around ensuring all TC members had refelected their opinions with review comments and votes
18:57:00 <JayF> so that we don't have those folks continuing to be in limbo for more months
18:57:21 * gouthamr how are you typing without putting your hands on your keyboard
18:58:22 <gouthamr> we are nearly at the hour
18:58:40 <hberaud> thanks everyone!
18:58:42 <gouthamr> and so we decided to keep on the topic; and kept the room open for any other questions/concerns regarding $topic
18:58:44 <JayF> thanks o/
18:59:10 <gouthamr> we just hopped off the video call; thank you all for joining.. and for the productive discussion
18:59:44 <gouthamr> we'll summarize this; and we can brainstorm the timeline.. and tc-members will get my nag on the reviews :)
18:59:56 <gouthamr> until next week for this meeting!
19:00:04 <gouthamr> hberaud++ zzzeek++
19:00:07 <gouthamr> #endmeeting