18:00:17 <gouthamr> #startmeeting tc
18:00:17 <opendevmeet> Meeting started Tue Jul  9 18:00:17 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:17 <opendevmeet> The meeting name has been set to 'tc'
18:00:53 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:57 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee.
18:01:04 <gouthamr> #topic Roll Call
18:01:17 <JayF> o/
18:01:18 <gmann> o/
18:01:21 <slaweq> o/
18:01:32 <frickler> \o
18:01:47 <noonedeadpunk> o/
18:02:38 <gouthamr> noted absence: gtema dansmith
18:02:58 <gouthamr> courtesy-ping spotz[m]
18:03:01 <gouthamr> #chair frickler
18:03:01 <opendevmeet> Current chairs: frickler gouthamr
18:04:53 <gouthamr> alright welcome everyone! lets get started..
18:04:58 <gouthamr> #topic AIs from last week
18:05:37 <gouthamr> think we have progress on all three projects we were concerned about in the "inactive" and "emerging" projects lists:
18:05:38 * noonedeadpunk being triggered by "AI" badly these days xD
18:06:01 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/923466 (remove monasca from inactive list)
18:06:29 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/923441 (Inactive state extensions: Freezer)
18:07:00 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/VBH4YU7IBY4FXSAZYL4AIB57BTSPQ572/ ([skyline][tc] Graduating skyline out of the "Emerging Projects" list)
18:07:18 <gouthamr> ^ the last one still being an ML discussion
18:08:36 <gouthamr> we'll get to the eventlet discussion in a little bit
18:08:55 <gouthamr> were there any other action items that folks were tracking?
18:09:58 * gouthamr takes silence as a no..
18:10:32 <noonedeadpunk> I was absent last meeting and didn't managed to watch recording :(
18:10:38 <gouthamr> our next topic pertains to the changes above as well
18:10:42 <gouthamr> #topic Project Activity Tracking
18:11:07 <JayF> noonedeadpunk: I'll note that this one is VERY worth watching, especially the technical presentation starting at about the 20 minute mark.
18:11:32 <gouthamr> noonedeadpunk: ack; the eventlet goal proposal sheds more light on what was spoken
18:11:32 <noonedeadpunk> ++
18:12:19 <gouthamr> there were some discussions in teh TC channel in the past couple of weeks regarding inactive projects..
18:12:49 <gouthamr> frickler: sorry to put you on the spot here; but, would you like to share any open concerns here so we can brainstorm?
18:13:30 <gmann> current inactive projects or possible inactive projects which are not yet marked?
18:13:37 <frickler> well where do I start? seems quite some projects are in a state to be concerned about
18:13:56 <gouthamr> lets start with monasca
18:14:38 <frickler> well for monasca I listed my concerns in the review, I would have expected some feedback there
18:14:43 <gouthamr> i did take a look at your comments on the monasca patch.. i get that it appears to be a single person bootstrapping a team, and you're hesitant to get the deliverables back into the cycle-with-intermediary cadence
18:15:31 <frickler> not just a single person, but one with little track record of doing things in openstack
18:15:39 <gmann> yeah, current PTL seems active to fix gate and do releases. there are ML thread also
18:15:50 <JayF> I find it hard, personally, to consider a project active if it has a single-point-of-failure maintainer -- regardless of the trust level of that single person.
18:16:08 <gmann> it seems only one repo gate is yet to be fixed and other repo under monasca is good?
18:16:26 <noonedeadpunk> I've looked through couples - and I think we don't know
18:16:37 <noonedeadpunk> as some have last patch merged in april or so
18:16:57 <noonedeadpunk> (I didn't check grafana for periodic tests though)
18:17:07 <frickler> I didn't look today, but there were a lot of config errors still, no current PTI template, so I would not call that "gate fixed"
18:17:40 <frickler> also there is the concern about stable branches support if we do not retire the project
18:17:48 <fungi> monasca has *17* deliverables, just fyi
18:17:49 <gmann> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/ZU22KSVDOC46WS6AIS3UHVFVDHOV4KFA/
18:18:01 <gmann> this is the discussion on release and stable branches
18:18:15 <slaweq> to be strict criteria which should be met by project to be active are  https://governance.openstack.org/tc/reference/new-projects-requirements.html
18:18:29 <gmann> but as we know that PTL is responding and trying to fix gate/release, we should discuss with them
18:18:33 <slaweq> and one of rules there says clearly  "The project has an active team of one or more contributors."
18:18:47 <slaweq> so I don't think we should block it just because of that one maintainer only
18:18:53 <gmann> we should continue it in gerrit or in ML or invite them in meeting.
18:18:59 <noonedeadpunk> well, at least periodic publish of doker images succeeds...
18:19:01 <gmann> slaweq: ++
18:19:07 <JayF> slaweq: acknowledged, fair point, I will propose a change to that but obviously we operate under rules as written today
18:19:22 <noonedeadpunk> ++
18:19:34 <gmann> JayF: then it need change in OpenStack new project application and its a huge change
18:20:16 <gouthamr> on zuul-config-errors, i see that only a few monasca repos have config errors remaining
18:20:21 <JayF> Well, maybe huge change is needed if we don't want to  (again) leave openstack users high and dry when a barely-active project can't fix a CVE.
18:20:30 <gmann> which is what I think we discussed it in PTG right? and we can go with that or start re-discussion
18:20:43 <slaweq> JayF yeah, maybe those rules should be updated somehow, but that's what is there today
18:20:46 * gouthamr waves at thuvh
18:20:51 <gmann> sure, its a impact of many projects
18:21:06 <noonedeadpunk> (and if they should is completely different discussion)
18:21:10 <gmann> and its not only single maintainer but can be single organization or so
18:21:28 <slaweq> gmann++
18:21:33 <noonedeadpunk> then we should drop sunbeam :D
18:21:45 <gmann> noonedeadpunk: and many more
18:21:48 <noonedeadpunk> would prevent tripleo case though
18:21:56 <noonedeadpunk> but I'd say it's too radical, imo
18:21:59 <gmann> anyways it is a big discussion topic
18:22:05 <noonedeadpunk> ++
18:22:38 <gmann> for monasca, I will say let's wait for the thuvh to respond the frickler query which are valid one
18:23:07 <slaweq> ++
18:23:08 <gmann> and as we passed the m-2 I also agree with frickler on not to move it to Active in this cycle
18:23:20 <noonedeadpunk> frankly, I'd say we're kinda too late for this cycle... and given we don't have a strong opinion - is kinda sign that it might be worth to wait for the next one
18:23:27 <gmann> I will also record my feedback in gerrit
18:23:29 <gouthamr> ^ i agree; thanks for making the observations frickler.. some seem more serious to address than others
18:23:34 <gmann> noonedeadpunk: ++
18:23:46 <gouthamr> it'
18:24:04 <gouthamr> i had a question: doesn't thuvh have the option of requesting a release nevertheless?
18:24:30 <frickler> IMO not as long as the project is marked inactive
18:24:42 <JayF> I think if it's cycle-* it cannot
18:24:43 <gmann> they can do independent I think but not as per release/team process
18:25:02 <noonedeadpunk> but then they need to move it to independent cycle
18:25:14 <noonedeadpunk> which I'm not sure will be approved either...
18:25:16 <gmann> yes
18:26:01 <noonedeadpunk> but dunno
18:26:06 <gouthamr> i see - thanks; we'll wait for thuvh's responses on the patch.. please share any further concerns you may have as well.
18:26:12 <gmann> '...In such a case, it is up to the project itself to get CI working and propose a release if that is needed.' #link https://governance.openstack.org/tc/reference/emerging-technology-and-inactive-projects.html#timeline
18:26:38 <gmann> they can ask for more time like freezer as this is 2nd cycle they are Inactive
18:27:42 <gouthamr> ^ yes; i think if they badly wanted - i.e., there's some business need for released code, they could request a release and continue working on getting back to a healthy state
18:27:45 <noonedeadpunk> yeah, I haven't worked on patch to allow projects to seamlessly remain inactive while they're working on it, but it would make total sense to allow that
18:28:12 <noonedeadpunk> well, I'm not sure that RDO/UCA will package inactive anyway
18:28:20 <noonedeadpunk> and otherwise - they can install from SHA...
18:28:24 <noonedeadpunk> but anyway
18:28:29 <JayF> It might be interesting to consider automatically flipping things out of a cycle-
18:28:39 <JayF> **based release model if/when they go inactive.
18:29:32 <gouthamr> okay; lets move to any other projects in this state
18:29:56 <fungi> probably worth checking how that might impact the possibility for stable point releases
18:30:06 <frickler> tacker, masakari and zaqar seem to have issues with current sqlalchemy/oslo.db
18:31:05 <noonedeadpunk> well, last time I checked masakari - it had issues with db upgrade for 2024.1, but my patch for master was passing nicely.
18:31:40 <noonedeadpunk> tacker used to be quite active and working on own blueprint for keystone to solve some usecase they had
18:31:51 <noonedeadpunk> have no idea about zaqar
18:31:55 <gmann> for tacker, this is wip fix from PTL but still not green #link https://review.opendev.org/c/openstack/tacker/+/919969
18:31:59 <frickler> https://zuul.opendev.org/t/openstack/builds?job_name=cross-masakari-py311&project=openstack/requirements
18:32:18 <noonedeadpunk> It was in my todo list to reach masakari PTL, but I failed so far (was on a sick leave last week, so todo moved slightly)
18:32:24 <gmann> Yes, tacker is active and they and meeting last night and discussed these
18:32:47 <gouthamr> #link https://review.opendev.org/c/openstack/zaqar/+/916734 (Zaqar's sqlalchemy2.0 fix)
18:33:00 <gouthamr> #link https://review.opendev.org/c/openstack/tacker/+/919969 (tacker's sqlalchemy2.0 fix)
18:33:05 <noonedeadpunk> I will take masakari as AP for this week
18:33:31 <gmann> tacker meeting discussion #link https://meetings.opendev.org/meetings/tacker/2024/tacker.2024-07-09-08.02.log.html#l-8
18:33:57 <noonedeadpunk> last masakari patch is https://review.opendev.org/c/openstack/masakari/+/920034 - just issued re-check for it
18:34:06 <gmann> gouthamr: I think link should work if mentioned in between text right? or I am missing and doing it wrongly ?
18:34:31 <gouthamr> gmann: nope; the highlight just works if its at the beginning of the message
18:34:42 <gmann> is it?
18:34:44 <gouthamr> but, don't mind me/you/anyone fixing these..
18:35:22 <gouthamr> heres an example: https://meetings.opendev.org/meetings/tc/2024/tc.2024-07-02-18.00.log.html#l-20
18:36:30 <gmann> k, will check later
18:36:45 <gouthamr> gmann noonedeadpunk ty for the updates here.. think we can check on these three again next week
18:36:49 <frickler> ok, I think those can be having a good chance of making progress soon, then
18:37:15 <frickler> next would be the growing list of issues the release-team recorded https://etherpad.opendev.org/p/dalmatian-relmgt-tracking#L358
18:37:46 <frickler> I'm not sure how to deal with those, I mean, not responding to a single release patch surely isn't critical
18:37:50 <noonedeadpunk> can confirm adjutant is in quite poor shape
18:38:10 <gouthamr> "no response to dalmatian-1 patch" - i'm guilty of doing some of these - summer holidays yada yada
18:38:20 <noonedeadpunk> I don't think they even close to comply with django version defined in U-C
18:38:32 <frickler> but when it repeats it maybe means one should take a closer look
18:39:29 <noonedeadpunk> and I'm guilty as well on one of these...
18:39:49 <gouthamr> dalees: ^ fyi; on adjutant
18:40:05 <frickler> no patches merged for adjutant this whole year
18:41:13 <noonedeadpunk> I actually tried to deploy adfjutant this year and needed to make quite some changes and then gave up... But proposed _some_ patches at least...
18:41:23 <noonedeadpunk> Didn't follow up on them though, as gave up...
18:41:34 <gmann> #link https://review.opendev.org/q/project:openstack/adjutant
18:41:56 <gmann> #link https://review.opendev.org/c/openstack/adjutant/+/912534
18:42:18 <gmann> it seems these reno fixes for unmaintained branches also not yet merged
18:42:25 <gmann> seems in bad state
18:42:38 <gouthamr> maybe this is one of those cases where an unmaintained branch wasn't in the team's interest
18:42:53 <gmann> its on master branch
18:43:15 <gmann> otherwise master releasenotes job fails
18:43:17 <gouthamr> oh; i was looking at the gerrit list
18:43:23 <noonedeadpunk> no logs left though...
18:43:38 <gmann> yeah unmaintained is all next things :) even master is in bad state
18:44:32 <gouthamr> frickler: does the release team feel comfortable pushing through bot changes like this one? i.e., if you had +2 powers, would you use it?
18:44:34 <noonedeadpunk> as I said - it 100% wont fly in current shape with Django 4
18:45:14 <frickler> gouthamr: no, IMHO that should not be done by the release team
18:45:43 <noonedeadpunk> I don't think it's even good idea to give releases team core to all projects...
18:45:45 <gmann> noonedeadpunk: yeah
18:47:00 <gmann> it seems this is case of inactive project detected after m-2
18:47:15 <gouthamr> yeah; its definitely in project maintainers' interest to react to these..
18:48:01 <noonedeadpunk> I'd cross fingers that dalees would fix that... as it's not _that_ much work, if there's interest ofc...
18:48:08 <noonedeadpunk> otherwise - yeah
18:48:57 <gouthamr> i
18:49:07 <gouthamr> i'll take an AI to start a mail thread on this
18:49:59 <gouthamr> frickler: ty for sharing the etherpad
18:50:18 <gouthamr> #link https://etherpad.opendev.org/p/dalmatian-relmgt-tracking#L358 (Release management project health tracking for Dalmatian)
18:50:27 <gouthamr> lets move on to other concerns
18:51:26 <gouthamr> #action gouthamr will start an ML discussion on adjutant's health
18:51:51 <gouthamr> i'd like to skip the gate-health topic and jump to the TC tracker
18:51:56 <gouthamr> #topic 2024.2 TC Tracker
18:52:19 <gouthamr> i apologize but we can chat about gate health right after this if we have time, or after the meeting
18:52:22 <spotz[m]> Sorry I’m late!
18:52:32 * gouthamr hey there spotz[m]
18:52:48 <gouthamr> #link https://etherpad.opendev.org/p/tc-2024.2-tracker (TC Tracker)
18:52:58 <gmann> one update on kuryr-kubernetes
18:53:16 <gmann> kuryr-kubernetes retirement is on hold as tacker has a dependency on it, and tacker team is working on that
18:53:20 <gmann> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/OZSOHDHD3HYGHSHYBDMEX4L2VY6EWPLO/
18:53:34 <gouthamr> ack; thanks gmann
18:53:44 <gouthamr> #link https://review.opendev.org/q/topic:%22retire-kuryr-kubernetes%22
18:53:44 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/922507
18:54:43 <gouthamr> i wanted to timebox a couple of changes because of two reasons
18:55:28 <gouthamr> please feel free to be critical of that decision; i'm hoping to make some progress while still accommodating your valuable viewpoints!
18:55:40 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/922512 (Affiliation Diversity Handling in OpenStack TC)
18:55:54 <gouthamr> ^ this is a charter change that affects the upcoming election
18:56:23 <gmann> slaweq: ^^ I replied to your comment, can you please check
18:56:47 <gouthamr> if you haven't looked at it, please do! i'm hoping we can either merge this or an alternative
18:57:21 <gouthamr> prior to the nomination period; and allow candidates and the electorate a chance to understand its implications
18:57:24 <slaweq> gmann sure, sorry that I missed it
18:57:28 <gmann> thanks
18:58:23 <gouthamr> so, here comes the controversial part - i'll nag you to place a +1 or -1 or abstain by July 15th
18:58:48 <gouthamr> don't need this to merge by then; but, if you have a different opinion, i'd like for you to share it by then
18:59:37 <gouthamr> any concerns?
18:59:43 <gmann> I think it has +ve feedback so far
19:00:10 <gouthamr> yes; and we're at the hour
19:00:23 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/902585  (Remove eventlet from OpenStack)
19:00:42 <slaweq> I wiil read all the comments there tomorrow morning for sure
19:00:45 <gouthamr> ^ we can chat about this outside of this meeting; but, this has a similar timebox to air out any views
19:01:08 <gouthamr> if you'd like to -1, please do so by 15th July 2024
19:01:46 <gouthamr> i'll note that it has sufficient votes and soak time to merge already; but seeing its far reaching implications, i think i'd like to let you folks weigh in
19:02:02 <gouthamr> that said; apologies for going over time here..
19:02:11 <gouthamr> let's call it a meeting
19:02:16 <gouthamr> thank you all for attending!
19:02:19 <gouthamr> #endmeeting