18:00:29 <gouthamr> #startmeeting tc
18:00:29 <opendevmeet> Meeting started Tue Jul 30 18:00:29 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:29 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:29 <opendevmeet> The meeting name has been set to 'tc'
18:00:49 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct
18:00:55 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:01 <gouthamr> #topic Roll Call
18:01:02 <noonedeadpunk> o/
18:01:04 <gmann> o/
18:01:06 <slaweq> o/
18:01:18 <gtema> o/
18:01:18 <spotz[m]> o/
18:01:34 <dansmith> o/
18:02:00 <gouthamr> noted absence: JayF
18:03:02 <frickler> \o
18:03:23 <gouthamr> #chair frickler
18:03:23 <opendevmeet> Current chairs: frickler gouthamr
18:03:35 <gouthamr> everyone else is here; so lets get started
18:03:53 <gouthamr> #topic Action Items from the past week
18:04:28 <gouthamr> 1. Follow Up on Eventlet Removal
18:05:07 <gouthamr> hberaud had a typo-fix patch up; and he told me he's working on the rest of the comments he received on the goal proposal
18:05:36 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/924944 ([follow up] Fix typos - eventlet removal)
18:05:56 <gouthamr> 2. Skyline Project: Await response from wu_wenixang on frickler's concerns
18:06:25 <gouthamr> i don't see anything on https://review.opendev.org/c/openstack/governance/+/924109
18:07:23 <gouthamr> wu_wenixang: if you see this; a gentle nudge
18:09:00 <gouthamr> frickler: are you in touch with skyline folks in any other way? perhaps any pending release team patches?
18:09:40 <frickler> nope
18:10:09 <gouthamr> okay; i cross posted your comment on ythe original change: https://review.opendev.org/c/openstack/skyline-console/+/924130
18:11:03 <gouthamr> in similar news; setuptools forced us to bump the upper constraint on packaging in stable/2023.1
18:11:48 <noonedeadpunk> Um
18:12:03 <gouthamr> we had an AI to take a look and get clarkb's patch merged
18:12:08 <noonedeadpunk> Aha, ok, that's probably fine:)
18:12:33 <gouthamr> which i see mnaser is taking back to unmaintained/zed: https://review.opendev.org/c/openstack/requirements/+/925271
18:13:08 <clarkb> as mentioned in the nova channel earlier today. The issue is somewhat forced on us. Bit rot happens. We can choose to "break" policy and make things work again or we can choose to leave things boken in which case the policy isn't helping anyone
18:13:14 <gouthamr> (╯°□°)╯︵ ┻━┻
18:13:17 <mnaser> yes, without that, we cannot land the CVE fixes into zed still.
18:13:32 <mnaser> its poopy, but it is following pattern
18:13:38 <clarkb> it is my personal opinion that the policy is too rigid if it can't be bent to allow for fixing things
18:13:38 <gouthamr> yeah :(
18:13:51 <clarkb> and its unlikely we're going to break anything harder than it already is in this particular circumstance
18:14:05 <fungi> also packaging is fairly disconnected from anything we do directly, so increasing the version when setuptools needs it should be fairly safe
18:14:16 <spotz[m]> If there's a fix for a CVE and we can fix the issue by going around policy I think it's a no brainer
18:14:46 <gouthamr> agreed; distros for one are obviously keen on the CVE fixes, so they should be paying attention to the UC bumps we're making
18:15:16 <noonedeadpunk> I feel actually that we must land that backport in this case
18:15:29 <spotz[m]> I'll point RDO folks to this
18:15:50 <gmann> noonedeadpunk: ++
18:16:23 <gouthamr> ty folks; perhaps prometheanfire can help with landing the change into unmaintained/zed
18:16:29 <fungi> well, the distros also don't continually update setuptools, so may not need the packaging update
18:17:00 <fungi> updates to setuptools are somewhat forced on us due to our non-use of distro-packaged dependencies
18:17:10 <gouthamr> i see
18:17:15 <mnaser> fwiw this primarily breaks the installation of a specific package/tool which we use to monitor ci job health (I think something about load monitor or something)
18:18:05 <frickler> it also breaks other things, dbcounter is just the first failure of that type in devstack
18:19:13 <gouthamr> alright, lets move on..
18:19:15 <fungi> thankfully all testing-related impact, seems like (not that it makes it any less painful for us)
18:19:25 <gouthamr> +1
18:19:52 <gouthamr> dansmith gmann spotz[m]: can i have your attention on a couple of openstack-manuals updates?
18:20:03 <spotz[m]> Yep
18:20:11 <gmann> sure, will check
18:20:18 <gouthamr> #link https://review.opendev.org/q/owner:d1nuc0m@protonmail.com+project:openstack/openstack-manuals+status:open
18:20:26 <gouthamr> thank you!
18:21:15 <gouthamr> the last AI we had was around assessing the relevance and maintenance status of TC-managed repositories like constellations and goal-tools.. i was working on governance-sigs last week; will add this item to the tracker and make incremental progress here
18:21:48 <gouthamr> that's all the AIs i was tracking
18:22:06 <gmann> I think we can retire constellations  but keep  goal-tools as it can be useful in future goals or so
18:22:29 <gouthamr> gmann: ack
18:22:55 <gouthamr> any other AIs that we want to chat about?
18:23:22 <gouthamr> #topic A check on gate health
18:24:19 <gouthamr> do we have any broken/unstable gate issues in the past week to bring up?
18:24:52 <dansmith> no changes that I've noticed in the last couple weeks, aside from the setuptools problems
18:24:59 <gmann> pretty much good shape. I did not notice any blocker last week
18:25:30 <slaweq> me neighter
18:25:54 <fungi> centos-8-stream nodesets were finally removed from our job config late yesterday
18:26:21 <clarkb> and we have removed the linaro cloud as the hardware it was running on is going away on the 10th
18:26:30 <fungi> also we shut down the linaro arm64 region in nodepool, so right now all arm jobs are running in osuosl
18:26:33 <clarkb> oh and tempest added early failure detection to the zuul job
18:27:06 <fungi> that should squeeze a bit more resources out of gate runs at least
18:27:25 <gouthamr> #link https://review.opendev.org/c/openstack/tempest/+/924956/ (Add early failure detection for tempest base job)
18:27:30 <fungi> since resets can happen as soon as tempest knows it's going to fail rather than waiting for the job to complete and report
18:27:56 <fungi> so changes down-queue can get their new test runs started sooner
18:28:35 <gouthamr> great!
18:28:50 <gouthamr> ty for that update clarkb fungi frickler
18:29:05 <gouthamr> thanks for sharing dansmith slaweq gmann
18:29:35 <gouthamr> i was trying to find a mail a while ago regarding zuul config errors
18:29:55 <gouthamr> #link https://zuul.opendev.org/t/openstack/config-errors
18:30:27 <gouthamr> some of these could mean that these jobs are unusable, while some others are deprecation warnings and such
18:31:19 <gouthamr> 357 "errors", 364 warnings
18:31:29 <gouthamr> pretty evenly split
18:32:41 <gouthamr> maybe its time we reprise the task of having someone from each of the project teams look at this
18:33:09 <slaweq> There is a lot of neutron related warnings there, I will look into those this week
18:33:24 <gouthamr> slaweq++ ty
18:34:16 <gouthamr> #action: gouthamr will note this in the weekly email
18:34:17 <fungi> removing dead branches cleaned up a bunch. also there's a pending cleanup of non-openstack projects which should knock the total count down
18:35:08 <gouthamr> oh yeah, all these "x/" ones show up under the "openstack" tenant
18:35:43 <fungi> ah, the cleanup i was remembering for those merged yesterday though, so this is after that's been done
18:37:05 <gouthamr> acj
18:37:10 <gouthamr> ack*
18:37:22 <gouthamr> anything else about the gate?
18:37:43 <gouthamr> #topic 2024.2 TC Tracker
18:37:54 * gouthamr hit enter too soon
18:38:25 * gouthamr pauses 30 seconds, please feel free to chime in
18:39:23 <gouthamr> #link https://etherpad.opendev.org/p/tc-2024.2-tracker (Technical Committee activity tracker)
18:40:25 <gouthamr> gmann: on kuryr-kubernetes's retirement, i didn't see any changes in tacker
18:40:42 <gmann> yeah, no change in situation, it is still on hold
18:41:48 <gouthamr> okay; any impact on any deliverables for us?
18:42:18 <gmann> I do not think so any risk or impact, retirement can be done later or even in next cycle
18:42:26 <gmann> it does not really harm to wait
18:42:33 <gouthamr> i.e., we're approaching milestone-3, do any of these components (kuryr-kubernetes, kuryr-tempest-plugin) get an automatic release for them that we need to avoid
18:43:29 <gmann> if things are working and it is release-able then no harm otherwise it can stay without release and retire once tacker is ready
18:43:47 <gmann> we have already asked for the help to maintain it so no release should not surprise anyone
18:44:14 <gouthamr> yes; the release team can take a call here i guess?
18:44:20 <gmann> I will check with release team if anything they need from TC to take action/decision on this
18:44:24 <gmann> yeah
18:44:41 <gouthamr> ty gmann
18:45:06 <gouthamr> i see no further updates on the monasca inactivity extension change
18:45:28 <gouthamr> #link  https://review.opendev.org/c/openstack/governance/+/923919 (Inactive state extensions: Monasca)
18:46:26 <gouthamr> frickler's concern is valid; its silly to refer to what freezer did as being the same situation with monasca ¯\_(ツ)_/¯
18:47:01 <gouthamr> but, i had workflowed this change before
18:49:22 * gouthamr adds another comment
18:49:27 <gouthamr> let me see if thuvh can come back to the change
18:50:36 <gouthamr> anything else on the tracker that needs a discussion here today?
18:51:32 <gmann> need more reviews on this follow up https://review.opendev.org/c/openstack/governance/+/923876
18:53:28 <gouthamr> #topic Open Discussion
18:54:59 <gouthamr> gmann: can you add your +1 too
18:55:17 <gmann> sure
18:56:19 <gouthamr> T-4 minutes left to add something to the minutes here
18:58:28 * gouthamr just filled out the October PTG survey for the TC
18:59:20 <gouthamr> The PTG will be held October 21 through 25; and there's still a month to let diablo_rojo know you need a room
18:59:33 <gouthamr> #link https://openinfrafoundation.formstack.com/forms/oct2024_ptg_survey
19:00:16 <spotz[m]> And OpenInfra Days NA CFP is open https://forms.gle/V2qjCnEtitr3ALHPA
19:00:49 <gouthamr> its a virtual event, so room space is not at a premium :D just that it helps to have the foundation advertise participating groups and get more participation
19:00:57 <gouthamr> ah ty spotz[m]
19:01:03 <gouthamr> we're at the hour
19:01:08 <gouthamr> thank you all for attending
19:01:25 <gouthamr> our next meeting will be here and on Zoom simultaneously
19:01:37 <noonedeadpunk> ++
19:01:42 <gouthamr> see you there
19:01:47 <gouthamr> #endmeeting