18:00:10 <gouthamr> #startmeeting tc
18:00:10 <opendevmeet> Meeting started Tue Aug  6 18:00:10 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:10 <opendevmeet> The meeting name has been set to 'tc'
18:00:35 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:00:41 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:47 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:00:52 <gouthamr> #topic Roll Call
18:01:03 <noonedeadpunk> o/
18:01:13 <noonedeadpunk> can I ask for a meeting link in IRC ?:)
18:01:21 <gouthamr> dansmith: slaweq and JayF are on the Zoom call
18:01:28 <gouthamr> noonedeadpunk: https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:34 <gouthamr> sorry for the redirection
18:02:09 <gouthamr> noted absence: gtema
18:02:35 <gouthamr> courtesy ping: spotz[m] gmann frickler
18:03:32 <spotz[m]> I’m at the CentOS Board F2F so can’t join video but around if needed
18:03:39 <gouthamr> ack spotz[m]
18:07:07 <gouthamr> #topic Action Items
18:11:34 <gouthamr> 1) Check Zuul Configuration Errors: this was added to the TC summary email
18:12:12 <gouthamr> 2) Encourage Leadership Nominations: slaweq sent out the kick-off email; JayF and gouthamr have mentioned this in their emails to the mailing list; we'll discuss this some more if we have time today
18:12:54 <gouthamr> 3) Eventlet proposal follow up: typo fixes have merged
18:13:03 <gouthamr> #topic A check on gate health
18:13:03 <gouthamr> 
18:14:26 <gouthamr> dansmith: reports that  jobs running on CentOS Stream are unstable
18:14:33 <gouthamr> rocky nodes seem more stable
18:15:04 <gouthamr> noonedeadpunk confirms that rocky seems to be more stable to use as a replacement
18:15:17 <dansmith> #link https://review.opendev.org/c/openstack/devstack/+/925400
18:16:02 <gouthamr> noonedeadpunk: had issues with package mirrors with rocky a while ago
18:16:16 <gouthamr> question: do we have infra-mirrors for rocky?
18:16:57 <gouthamr> fungi: says tehre were some patches to add rocky mirrors to infra; we haven't finished up the work
18:17:05 <gouthamr> need some time/bandwidth to push this through
18:17:07 <fungi> i'll get a link for the minutes
18:17:27 <gouthamr> ty fungi
18:19:22 <gouthamr> correction: there was no prior work to add the mirrors
18:19:40 <gouthamr> there was a discussion; and the community was generally supportive
18:20:06 <gouthamr> infra cleanup has made room for newer ubuntu noble mirrors, and for stuff like rocky-linux
18:21:16 <gouthamr> openstack-ansible has noble jobs
18:21:37 <fungi> #link https://grafana.opendev.org/d/9871b26303/afs Utilization of AFS servers and volumes
18:21:41 <gouthamr> nice
18:22:10 <gouthamr> action item from the zoom call: gouthamr will poke #openstack-qa about noble testing efforts
18:22:21 <gouthamr> #topic 2024.2 TC Tracker
18:23:56 <gouthamr> many things on the tracker are complete now..
18:23:59 <gouthamr> #link https://etherpad.opendev.org/p/tc-2024.2-tracker
18:24:50 <gouthamr> "unmaintained-core" folks are actively merging critical/CVE fixes
18:25:20 <gouthamr> project maintainers are unburdened; proposers are working with the unmaintained-core to get patches in
18:26:12 <gouthamr> noonedeadpunk has interacted with users that were cloning repositories from stable branches whose automation broke because of the unmaintained branch transition
18:26:30 <gouthamr> unmaintained branches still need some CI maintenance work within the openstack-ansible team
18:29:52 <gouthamr> unmaintained branches have a lot of zuul configuration errors
18:29:57 <gouthamr> periodic jobs configured against unmaintained branches negatively affect zuul
18:30:55 <gouthamr> zuul config errors in one project also affect any related projects that are referencing these config/jobs
18:31:24 <gouthamr> maintainers will get an error on a patch if zuul detects config errors
18:31:43 <gouthamr> but, periodic jobs don't report errors on a patch
18:32:26 <gouthamr> #link https://zuul.opendev.org/t/openstack/config-errors
18:32:49 <gouthamr> infra did a sweep of  non-openstack project in the openstack zuul tenant
18:32:55 <gouthamr> s/project/projects
18:33:00 <gouthamr> and cleaned those up
18:33:21 <gouthamr> #link https://lists.opendev.org/archives/list/service-announce@lists.opendev.org/thread/X5TM537UZFPYXF23H6TJFSKO7M6GVM2W/
18:34:09 <gouthamr> elodilles: is there a plan on EOL for any current unmaintained branches?
18:34:24 <gouthamr> ^ a question for later
18:36:18 <gouthamr> EOL of distros also affects testing on these unmaintained branches..
18:36:59 <gouthamr> there's already an expectation that distros are testing these old branches by us calling these branches "unmaintained"
18:40:05 <gouthamr> we went down the list and recapped all the items, open or pending closure
18:40:16 <gouthamr> #topic Open Discussion and Reviews
18:42:04 <gouthamr> Elections! we are discussing the ending of the term for 4 tc members in October
18:43:28 <gouthamr> fungi: says we have affiliation querying functionality in the election tooling
18:44:09 <gouthamr> we could surface that in places prominently for election officials to react
18:45:47 <gouthamr> we don't currently _require_ foundation members nominating themselves to declare their affiliation on their foundation profiles
18:46:40 <gouthamr> should we make that a requirement with the zuul testing of a "valid candidate" ?
18:47:09 <gouthamr> tc can encode this requirement in the charter
18:47:20 <gouthamr> or a resolution
18:47:59 <gouthamr> #action gouthamr will follow up on this
18:49:15 <gouthamr> fungi offered help with the election tooling, and there are folks like tonyb that could potentially help as well with the election tooling, ask on #openstack-election
18:50:05 <gouthamr> #action check on contributions to TC repositories counting towards AC (gouthamr)
18:51:58 <gouthamr> slaweq suggested emailing existing PTLs about the nomination period directly to avoid the number of projects that won't have nominations by the end of the period
18:52:31 <gouthamr> is this sort of action warranted? frickler noted elsewhere that it would be providing an unfair advantage to existing candidates
18:52:44 <gouthamr> or showing a preference (sorry if i was misunderstanding that concern)
18:52:51 <gouthamr> fungi noted that this was done in the past
18:53:22 <gouthamr> election officials shouldn't be expected to do this..
18:53:39 <gouthamr> because it can indicate favoritism towards some candidates
18:55:57 <gouthamr> JayF notes that openstack leadership elections were contested more heavily in the past; there's a benefit to direct outreach now..
18:56:03 <gouthamr> because there's a lot of people forgetting to nominate themselves
18:56:31 <gouthamr> doing direct outreach may also discourage folks from paying attention to the mailing list
18:56:49 <gouthamr> or set a new expectation that may be infeasible to future election officials
18:58:07 <gouthamr> election nominations occur during vacations (summer vacations now, lunar new year during the next cycle)
18:58:52 <gouthamr> another thing to note is for well meaning community members, people apart from election officials, can be doing the direct outreach as well
19:01:29 <gouthamr> and that brings us to the end of the hour
19:01:47 <gouthamr> we'll continue discussing on the #openstack-tc channel and the #openstack-election channel
19:01:50 <gouthamr> thank you all for attending
19:01:53 <gouthamr> see you here next week!
19:01:56 <gouthamr> #endmeeting