18:00:40 <gouthamr> #startmeeting tc
18:00:40 <opendevmeet> Meeting started Tue Sep  3 18:00:40 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:40 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:40 <opendevmeet> The meeting name has been set to 'tc'
18:01:08 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:01:29 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:38 <gouthamr> ^ this also contains a link to the video meeting
18:02:30 <gouthamr> #topic Roll Call
18:02:34 <JayF> o/
18:02:35 <dansmith> o/
18:02:37 <cardoe> o/
18:02:42 <gtema> o/
18:03:00 <gmann> o/
18:03:24 <gouthamr> notes that slaweq and noonedeadpunk are on the video call
18:03:40 <gouthamr> noted absence: s p o t z and f r i c k l e r
18:03:43 <slaweq> o/
18:03:45 <slaweq> sorry
18:05:21 <noonedeadpunk> o/ sorry
18:05:37 <gouthamr> #topic Action Items from the past week
18:05:46 <gouthamr> TC Members: Continue discussing licensing topics at the Forum/PTG session and propose any potential resolutions on licensing issues.
18:06:01 <gouthamr> #action: gouthamr will share a PTG planning etherpad after the meeting
18:06:06 <gouthamr> TC Members Attending the Suwon Summit (spotz leading): Plan and prepare for the TC session at the OpenInfra Summit in Suwon and discuss logistics for potential remote sessions.
18:06:37 <gouthamr> ^ spotz[m] will recap this for us in a future meeting
18:06:43 <gouthamr> gmann: Target merging the requirement bump for oslo.policy 4.4.0 by the Feature Freeze (FF) deadline this week.
18:07:46 <gouthamr> ^ requirements change hasn't merged yet.. gmann is monitoring
18:08:02 <gouthamr> #link https://review.opendev.org/c/openstack/requirements/+/925464 (oslo.policy 4.4.0 UC bump)
18:08:30 <gouthamr> there's no impact on most services; the few that have issues are being addressed
18:08:46 <gouthamr> gmann: if you have any patch links to share, please do :)
18:09:52 <cardoe> gmann: is there a roadmap story for the overall effort?
18:10:49 <gmann> gouthamr: it think requirement change has link in depends-on but this is ML thread
18:10:50 <gmann> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/MPHSVG222OFHJL2AQD2A7CJGTH57SRCJ/
18:11:53 <gouthamr> thank you gmann
18:12:40 <gouthamr> #topic A status update on the elections (slaweq/gouthamr)
18:13:12 <gouthamr> Four projects need action from the TC: mistral, swift, watcher, kuryr
18:13:22 <gouthamr> Kuryr retirement currently blocked
18:13:26 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/922507
18:13:39 <gouthamr> the ballots went out early
18:13:48 <gouthamr> there was no need for a PTL election
18:14:16 <gouthamr> multiple members liked the idea of allowing more time for voting
18:14:31 <gouthamr> so the mistake wasn't really one in people's view
18:14:38 <gouthamr> slaweq mentions that the process can be improved
18:14:59 <gmann> cardoe: we have divided this effort into different phases
18:15:01 <gmann> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html
18:15:08 <dansmith> not sure how globally-applicable "Oops all crunchberries" really is
18:15:16 <gouthamr> :D
18:15:31 <dansmith> https://knowyourmeme.com/memes/oops-all-berries-box-parodies
18:15:34 <dansmith> for context
18:15:45 <JayF> I'm more concerned about you being insensitive to those with roof-of-mouth injuries /s :D
18:15:55 <gmann> cardoe: and this is latest status (I need to update it for this cycle) but ~12 projects completed the phase-1
18:15:55 <gtema> I am honestly worrying about swift. This is not the first time swift is without candidates
18:15:56 <gmann> #link https://etherpad.opendev.org/p/rbac-goal-tracking#L28
18:15:59 <cardoe> Thank you gmann.
18:16:06 <gouthamr> during the nomination period, slaweq sent out emails to the mailing list as well as to coordinators personally
18:16:07 <dansmith> that's the only thing that stops me from eating them.. when my mouth is totally shredded
18:16:41 <gouthamr> multiple folks on the TC have appreciated the move to send all project contributors email reminders to nominate themselves for the TC
18:17:30 <gouthamr> folks that contribute less often reached out to maintainers asking if they needed help - it was very good to invoke that response
18:17:55 <gouthamr> every cycle, we used to have 10+ projects that were "leaderless"; this cycle we're down to 4
18:18:00 <gouthamr> so that's great progress
18:18:39 <JayF> ++ Good job by elections officials, and good job by the community stepping up in both PTL and TC elections. \o/
18:18:55 <gouthamr> the tacker team needs to drop kuryr dependency before we retire "kuryr-kubernetes" and "kuryr-tempest-plugin"
18:19:13 <gouthamr> the kuryr team has already unofficially disbanded
18:19:28 <gouthamr> there was a question seeking kuryr-kubernetes's release during this cyclke
18:19:35 <gouthamr> s/cyclke/cycle
18:20:33 <gmann> #link https://review.opendev.org/c/openstack/releases/+/926761
18:20:51 <gouthamr> the release may not be useful/required for anyone; but it was done in case
18:20:54 <gouthamr> thanks gmann
18:21:55 <gouthamr> dansmith was trying to keep watcher from retirement so we can evaluate if there was any downstream interest
18:22:09 <gouthamr> but, there wasn't any interest yet..
18:22:44 <gouthamr> mnaser wanted to look if watcher was useful for them during the VMWare working group call
18:23:07 <gouthamr> its unfortunate there is no team to maintain the project within the OpenStack ecosystem
18:23:51 <gouthamr> JayF notes that its worth keeping the project by converting it into an independent project,outside of the "openstack" namespace
18:24:08 <gouthamr> that way we don't erase the repos, etc, and allow any future maintenance
18:24:36 <gouthamr> JayF suggests publicizing such situations during the Open Infra Live calls
18:25:17 <gouthamr> dansmith fears that we might attract maintainers that won't really "maintain" the project any further
18:25:24 <JayF> well, to be clear, I didn't mean indepednent from openstack
18:25:30 <gouthamr> ^ please correct me
18:25:31 <JayF> I mean indepedent release model as opposed to cycle-with-x
18:25:38 <gouthamr> ah
18:25:51 <JayF> which basically means any inactivity doesn't get in the way of the integrated release
18:26:02 <gouthamr> true, would still mean there's still a need for leadership
18:27:08 <gouthamr> it was noted on the video call that mistral was being used/maintained by OVH
18:28:32 <gouthamr> we'll need to reach out to OVH folks again and understand why there was no nominee
18:31:00 <gouthamr> continuing the discussion on watcher: maintainers that don't have as much experience, and community trust to take care of the project may not be able to help with any CVEs - something that happened with murano in the past cycle
18:32:03 <gouthamr> #action : revive a "leaderless" projects etherpad right away to deal with the four projects (slaweq)
18:32:52 <gouthamr> timburke responded to swift becoming leaderless on this channel
18:33:11 <gouthamr> gmann suggested going to DPL to reduce swift team's election overhead
18:34:12 <gouthamr> there's still an overhead - DPL liaisons are reset every cycle unless the team responds in time to prevent it
18:34:40 <gouthamr> for now, timburke is waiting on the elections to wrap up to propose his appointment patch
18:36:49 <gouthamr> #topic October PTG: Unmaintained branches - Transitioning "Antelope" to "unmaintained" - can we gather concerns?
18:37:06 <gouthamr> noonedeadpunk thinks this transition is kind of aggressive
18:38:07 <gouthamr> he thinks we should look at the user survey; and see if Antelope being SLURP needs any more time than we've previously decided
18:38:27 <gouthamr> JayF says that this is intentional and discussed - we shouldn't change the policy
18:39:00 <gouthamr> noonedeadpunk notes that the SLURP, and unmaintained process seems difficult to impose on the users
18:39:01 <fungi> 2023.1/antelope was released 2023-03-22 and is projected to end normal maintenance 2024-10-30 (19 months after release)
18:39:20 <gouthamr> ^ +1 thanks fungi
18:40:35 <gouthamr> "unmaintained" isn't that the code disappears.. it just means that we are clarifying the state that we were in
18:40:55 <gouthamr> "stable" ("extended-maintainance") was a misnomer ... we weren't maintaining these
18:42:48 <gouthamr> unmaintained allows project teams/contributors to worry less about CI jobs that break because of peripheral reasons
18:42:57 <JayF> I noted one of the big advantages of unmaintained is that we can ^^ remove jobs in that case
18:43:11 <JayF> and CI maintenance has historically been a large time sink on Ironic
18:43:40 <gmann> #link https://releases.openstack.org/
18:44:17 <noonedeadpunk> but with unmaintined process most just keep runing broken periodic jobs after branching not caring to remove them
18:44:35 <gouthamr> #topic A check on gate health
18:44:35 <gouthamr> 
18:44:49 * JayF suspects many projects -- probably Ironic-related included -- need to remove periodic jobs on almost all branches, because I don't think people generally track 'em
18:45:00 <gouthamr> gate's been quite busy because of Feature Freeze deadlines
18:45:32 <gouthamr> dansmith has a trivial patch to skip a tempest test, blocks work in glance.. he's on his 7th recheck
18:45:55 <gouthamr> failures seem to tend higher as the load Zuul with test jobs right now
18:46:33 <gouthamr> we've discussed a way to skip check jobs when a patch failed at the gate..
18:47:21 <gouthamr> but, this was avoided because people would be tempted to re-run the gate jobs mindlessly
18:47:37 <gouthamr> when something that merged in the interim caused a genuine failure
18:47:42 <fungi> note that the requirement to pass the check pipeline before being enqueued into the gate pipeline is a policy choice in the openstack tenant, other zuul tenants allow changes to be enqueued directly into the gate pipeline on approval
18:47:58 <gouthamr> but, dansmith notes that times have changed, and we could change the policy around this now ^
18:48:03 <JayF> I'll note (didn't say this in video) that I've seen that problem with newer contributors even in check pipeline. When it happens, cores redirect and teach, but you don't always catch is soon.
18:48:52 <gouthamr> doing this will reduce the pain; but, will not resolve all the intermittent failures
18:48:59 <gouthamr> we need to make progress on these in parallel
18:49:17 <gouthamr> we can't even mark tests as unstable all over and call it a day
18:49:48 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2026757
18:50:48 <JayF> This is the Ironic bug around dnsmasq crashes I referenced. Essentially when we HUP dnsmasq multiple times in short order with many config updates, it will sometimes crash or segfault (version dependant). In the real world, this is able to respawn via neutron-dhcp-agent before any actual computer would ever run -- in CI, it causes racy failures when it crashes.
18:50:49 <gouthamr> project teams need to make progress on addressing intermittent test failures
18:51:07 <JayF> Upstream dnsmasq has no interest, AIUI, in fixing this issue.
18:51:34 <JayF> Myself, and other GR-OSS contributors, are going to look at kea support in Neutron-DHCP-Agent and Ironic next cycle.
18:52:11 <JayF> (this is also why we have to have https://opendev.org/openstack/ironic/src/branch/master/devstack/lib/ironic#L3544 in our devstack library)
18:52:19 <gouthamr> regarding the policy around re-enqueuing check vs directly going to gate on approval - we can change this policy within the new TC
18:52:24 <JayF> we go from the newer, extremely broken version, to the older less broken version :(
18:52:45 <gouthamr> dansmith suggests we set a timeline around seeing how well this change is working
18:53:48 <gouthamr> we'll need to make sure we continue the audit on "recheck"s
18:54:00 <gouthamr> so we can correct behaviors across the contributor base
18:54:21 <JayF> aside: isc-dhcp-server is no longer a maintained software project :(
18:54:29 <dansmith> WAT
18:54:34 * dansmith googles
18:54:42 <JayF> kea is the replacement, and it's open core. Thanks ISC!
18:54:50 <JayF> Pretty sure the bits Ironic need are in the open parts.
18:55:06 <dansmith> oh man, I didn't know that. I've been using ISC for decades
18:55:13 <JayF> yeah, it's a bummer for sure
18:55:33 <JayF> I worked multiple places that had a downstream, low-quality isc-dhcp-server plugin for agent instead of dnsmasq :/
18:55:34 <gouthamr> really quickly through the next topic
18:55:36 <gouthamr> #topic 2024.2 TC Tracker
18:55:41 <gouthamr> #link https://etherpad.opendev.org/p/tc-2024.2-tracker (Technical Committee activity tracker)
18:56:11 <gouthamr> ^ we've been making great progress here, and the TC has been very responsive to reviews, thank you!
18:56:21 <gouthamr> lets move on to the next topic in the interest of time
18:56:24 <gouthamr> #topic Open Discussion and Reviews
18:58:41 <JayF> gouthamr: you were channelling truman there, I had to finish the quote :D
18:59:00 <gouthamr> we dropped off the video call with a "If I don't see you, Good Afternoon, Good Evening and Good Night"
18:59:03 <gouthamr> thank you JayF
18:59:23 <gouthamr> we did take a moment to thank JayF and dansmith for their exemplary leadership over their time within the TC
18:59:52 <gouthamr> JayF expressed that he'd continue to be a leader within the community, and still participate in this forum..
19:00:15 <gouthamr> that said, we've wrapped up the last video meeting with the current TC. phew time flies
19:00:38 <JayF> I'll note
19:00:39 <JayF> before you close it
19:00:44 <gouthamr> our next one is on Oct 1st
19:00:50 <JayF> also thanks to gouthamr for a successful almost-fully-first term as Chair
19:01:12 <gouthamr> ! thank you JayF.. wouldn't be possible without you
19:01:12 <opendevmeet> gouthamr: Error: "thank" is not a valid command.
19:01:19 <gouthamr> haha :D
19:01:30 <gouthamr> its got to be
19:01:47 <JayF> !success gouthamr was a good chair of the TC this term
19:01:47 <opendevmeet> JayF: The operation succeeded.  gouthamr was a good chair of the TC this term
19:01:53 <gouthamr> alright, see you here next week!
19:01:54 <JayF> That one exists :)
19:01:57 <gouthamr> woot!
19:02:10 <gouthamr> thanks everyone for participating!
19:02:11 <gouthamr> #endmeeting