18:00:26 <gouthamr> #startmeeting tc
18:00:26 <opendevmeet> Meeting started Tue Sep 17 18:00:26 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:26 <opendevmeet> The meeting name has been set to 'tc'
18:00:35 <bauzas> \o
18:00:47 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:51 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:00:54 <gouthamr> #topic Roll Call
18:01:07 <gmann> o/
18:01:07 <frickler> \o
18:01:24 <gouthamr> noted absence: s l a w e q
18:01:29 <noonedeadpunk> o/
18:01:39 <dansmith> o/
18:01:43 <JayF> o/
18:01:43 <gtema> o/
18:01:44 <cardoe> o/
18:02:01 <bauzas> \o (again for formal reasons)
18:02:53 <spotz[m]> \o/
18:03:49 <gouthamr> hello everyone! let's get started
18:04:02 <gouthamr> #topic Action Items from the past week
18:04:31 <gouthamr> we took an AI on continuing to add content onto our PTG etherpad
18:04:54 <spotz[m]> And the list of projects came out after the meeting
18:04:54 <gouthamr> #link https://etherpad.opendev.org/p/oct2024-ptg-os-tc (OpenStack Technical Committee vPTG planning)
18:05:34 <gouthamr> yes
18:05:42 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/APAC5ANX4TQLP5R257D6OIADTN6Y5GMS/ (PTG October 2024 Teams List)
18:06:15 <gouthamr> a quick glance (heh) through the service teams there, it does look like a decent list of teams that chose to gather
18:06:44 <gouthamr> you could compare it to the official list of projects we have here:
18:06:50 <gouthamr> #link https://governance.openstack.org/tc/reference/projects/ (OpenStack Project Teams)
18:07:44 <gouthamr> there may be some small teams that be dispersed into these existing projects to have their own PTG sessions simultaneously..
18:08:52 <gouthamr> and there are teams that don't have sufficient affiliation diversity (boo) that may not think its useful to schedule meetings at this event
18:09:48 <gouthamr> and then there's timezone challenges
18:09:55 <gouthamr> but, would expect this to be a productive gathering as the past ones have been!
18:09:57 <bauzas> which won't help their affiliation issues
18:10:25 <frickler> does anyone know about oceanbase? is this becoming an oif project?
18:10:29 <spotz[m]> One takeaway from Asia Summit is maybe to encourag everyone wo have one APAC slot if possible
18:10:46 <spotz[m]> For like D&I we onlt even take one slot but we do try for morning
18:11:18 <fungi> frickler: oceanbase is, i think, a community project spearheaded by huawei and they're interested in doing things the way openstack does them and learning from our community, so more of an adjacent community participation for now
18:11:20 <bauzas> when will the reservation slots available ?
18:11:28 <bauzas> for the PTG rooms
18:11:33 <gmann> frickler: nothing I am aware of. At least no such formal proposal yet to board.
18:12:04 <fungi> or maybe it was ant group? someone in china anyway
18:12:30 <gouthamr> bauzas: not yet; diablo_rojo will chime back in
18:12:36 <bauzas> cool
18:12:54 <gouthamr> on to our next AI:
18:12:58 <gouthamr> Revive the leaderless projects Etherpad (Mistral, Swift, Watcher, Kuryr)
18:13:03 <fungi> ah, yeah my bad, oceanbase is indeed from ant group
18:13:14 <fungi> (according to their "about" page)
18:13:31 <gouthamr> #link https://etherpad.opendev.org/p/2025.1-leaderless (2025.1 leaderless etherpad)
18:13:41 <gouthamr> ^ we have some patches for review
18:13:59 <gouthamr> we're on a hold until end of day tomorrow
18:14:11 <spotz[m]> Yeah Oceanbase has not be presented to the board nor has it been brought up here to the TC
18:14:17 <gmann> they need to wait until election are closed. PTL appointment needs to be done once PTLs are reset after election
18:14:23 <gouthamr> gmann: +1
18:14:41 <gmann> but good to see volunteer ready to take responsibility
18:15:12 <gouthamr> that's not too far away; but it was good to line these up..
18:15:29 <gmann> about watcher, I think we should start broader notification on ML etc
18:15:52 <gouthamr> gmann: agreed; i can take that AI
18:16:17 <gouthamr> #action gouthamr will start the ML discussion regarding watcher's leaderless situation and futures
18:16:18 <gmann> thanks
18:17:33 <gouthamr> gmann: do we have any update from tacker in the past week regarding their use of kuryr-kubernetes
18:17:55 <gmann> work is still on going and not yet finished. Tacker PTL updated recently on gerrit
18:18:03 <JayF> Just observing that the work we've done over the last months/years to reduce this list is paying off :). It's not zero-leaderless but it's much, much fewer than in past years.
18:18:16 <gouthamr> true; happier situation
18:18:19 <gmann> I think we can wait for it until next cycle deadline to retire project
18:18:31 <gouthamr> gmann: Exoxy M-2?
18:18:37 <gmann> yes
18:18:37 <gouthamr> Epoxy*
18:18:54 <spotz[m]> Equine!
18:19:06 <gmann> #link https://review.opendev.org/c/openstack/tacker/+/926504
18:19:33 <gouthamr> hmmm; any objections to this? we haven't said "kuryr-kubernetes" (or the lesser used "kuryr-tempest-plugin") are inactive.. their CIs are failing, and hence releases are blocked
18:20:13 <gmann> we did not add them as inactive as we know retirement is happening but I can add them there if that make status clear
18:20:40 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/928531 (Release kuryr-kubernetes RC1 for 2024.2)
18:20:59 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/929530 ( 929530: Release kuryr-tempest-plugin for 2024.2)
18:22:00 <gouthamr> gmann: i think so
18:22:24 <gmann> commented on release change also
18:22:29 <gouthamr> sorry this sounds like process, but i think its an easy enough patch for us to share the status beyond this group/meeting
18:22:44 <gmann> I will propose that
18:22:48 <gouthamr> ty gmann
18:23:11 <gouthamr> since all leaderless projects are accounted for
18:23:17 <gouthamr> lets move to our next AI:
18:23:22 <gouthamr> Discuss project release tracking and release issues within the release team (frickler)
18:23:31 <gouthamr> ^ anything to share here, frickler?
18:23:45 <bauzas> this week was quiet, right?
18:23:58 <frickler> essentially only that we decided that we should discuss this at the PTG
18:24:12 <gouthamr> ack; makes sense
18:24:19 <frickler> since it is too late to do anything for the ongoing release anyway
18:25:06 <gouthamr> the next couple of AIs will show up in dedicated topics today:
18:25:08 <gouthamr> - Monitor gate health with the new RaxFlex cloud and check for issues related to internal network + FIPs
18:25:09 <gouthamr> - Provide Suwon recap in the next meeting
18:25:21 <gouthamr> lets move to those in a bit
18:25:33 <gouthamr> were there any other action items that you were tracking?
18:26:57 <gouthamr> alright lets move on
18:27:06 <gouthamr> #topic Discussions from OpenInfra Summit Asia (spotz[m]/bauzas)
18:27:19 <spotz[m]> Ok typing:)
18:27:26 <bauzas> I let spotz shoot first :)
18:28:10 <gouthamr> thank you both for participating at the summit and agreeing to recap anything that you might find interesting/relevant here
18:28:58 <spotz[m]> The Asia event had a very old school feel to it in that the number of people to the size of the space was right on with most of the sessions filled almost to capacity. There were good questions asked in the sessions and outside in the halls as well.
18:29:22 <noonedeadpunk> nice
18:29:34 * noonedeadpunk start regretting missing it now
18:29:44 <bauzas> yeah, had a blast from the past
18:29:48 <spotz[m]> The organizers did a great job of scheduling and the mix of talks(not sure on the OCP side of things), the dinner activity again was a great space for thos who attended
18:30:11 <spotz[m]> It's putting a bit of pressure on us to do that well for NA:)
18:30:55 <opendevreview> Ghanshyam proposed openstack/governance master: Mark kuryr-kubernetes and kuryr-tempest-plugin Inactive  https://review.opendev.org/c/openstack/governance/+/929698
18:31:05 <noonedeadpunk> NA are OIF Days, so no pressure :D
18:31:35 <spotz[m]> We do have a great schedule, and we have a reception planned as well.
18:32:20 * fungi stares at his blank slide deck and wills it to spontaneously generate a talk for him
18:32:32 <spotz[m]> I did put in for an OpenInfra leadership session, I still need to reach out to Mohammed and Tytus, but I've already spoken to Julia and Goutham. Just another meet and greet opportunity. Which reminds me!
18:32:40 <gouthamr> haha.. was there any community related feedback that you received? the size of the gathering does feel encouraging..
18:32:57 <gmann> or TC related?
18:33:14 <spotz[m]> The TC meet and greet went well, it ended up being more of a Q&A for a potential new contributor interested in Nova who just happened to be sitting next to sbauza!
18:33:17 <bauzas> there were a few discussions happening both hallways and during Forum sessions
18:33:35 <bauzas> that could be worth pursuing from a TC level
18:34:24 <spotz[m]> The forum session went really well, I sat in one a few. Oh and for good or bad the Forum sessions were recorded. I don't think that inhibited any open discussion though I know in some settings it might have
18:35:39 <spotz[m]> Oh and important to note if you see folks in audiences looking at their phones they were in a live translation app
18:36:21 <gouthamr> bauzas: nice; what kind, do you want to share a gist here? or perhaps as separate topics?
18:36:26 <bauzas> the session I have in mind that'd require some cross-project effort whould be translating our docs
18:36:39 <bauzas> we had a good chat with ian
18:36:59 <noonedeadpunk> oh...
18:37:10 <noonedeadpunk> has migration to the new trooling completely stuck?
18:37:11 <bauzas> he raised to us the fact that most of the ops docs are hardly translated, which prevents people to use OpenStack
18:37:36 <bauzas> noonedeadpunk: good point, I thought that session was originally intended to discuss state of the migration
18:37:38 <noonedeadpunk> as I think it was blocker for couple of volunteers I met previous year who wanted to translate things
18:37:46 <gmann> bauzas: good point
18:37:59 <fungi> i haven't heard much recently from either ian or seongsoo about the switch to weblate
18:38:09 <noonedeadpunk> and there were also couple of MLs I can recall of ppl asking on how to translate
18:38:12 <bauzas> but eventually ian explained that's the problem is way larger than just a tooling migration
18:38:32 <gmann> maybe this is good item to discuss in PTG also or get status for weblate at least
18:38:43 <bauzas> I proposed to sungsoo and ian a couple of ideas that we could discuss at PTG
18:38:47 <noonedeadpunk> well, but now we're just stuck kinda. As new signups to zanata are blocked
18:38:48 <gmann> ++
18:38:56 <bauzas> ian was supportive about it
18:38:57 <noonedeadpunk> and only horizon iirc does accept transaltions
18:39:20 <bauzas> and I was volunteer to take nova as a test project for translating our in-tree docs
18:40:01 <bauzas> but I'd appreciate insights from other teams and people, for sure, hence some x-p session at the PTG I guess
18:40:24 <bauzas> I haven't checked whether i18n is part of the OpenStack teams at the PTG
18:40:32 <gouthamr> it isn't
18:40:35 <JayF> Honestly, this may be a place where, if we're open to it, LLMs could potentially help in this space. I do wonder if 90%-accurate translated docs would be a benefit over someone just using a translate app on their own.
18:40:39 <bauzas> but I can surely poke ian and ask him his availabilities
18:40:57 <bauzas> JayF: that was one of the non-great ideas I had
18:41:18 <bauzas> and we basically designed some workflow that could include some gating job for translating the diff
18:41:27 <bauzas> but anyway, let's not paper it now
18:41:37 <fungi> worth noting, i18n is a sig these days, not a project team
18:41:51 <gmann> bauzas: thanks, or if they can chime in TC slots if booking separately is more work for them
18:42:00 <gmann> I mean add a topic for TC sessions
18:42:05 <spotz[m]> jayf we actually discussed that
18:42:33 <bauzas> yeah, we need to find the right slot for that discussion
18:42:40 <gouthamr> we might be able to drum up more volunteers to edit a translated version, than to attempt a laborious translation project themselves
18:42:50 <bauzas> if that's TC, I'm cool, but I want ian and sungsoo to chime in
18:43:33 <gmann> sounds good
18:43:37 <bauzas> gouthamr: do you want to somehow write some AI on it ?
18:43:47 * gouthamr takes note to poke seongsoo on discord
18:44:22 <gouthamr> ack; thank you bauzas - i'll add the placeholder topic to our etherpad and chase down some people to own it
18:44:36 <gouthamr> with sufficient advertisement, we can have a cross project collaboration around it
18:44:42 <bauzas> I think I can propose some asia-friendly timeslot for nova and bribe some nova folks to join if they feel enough rejuvenated on early hours
18:45:12 <bauzas> gouthamr: cool, thanks
18:45:58 <bauzas> another hallway discussion happened from my talk on nova bureaucratic process for contributions
18:46:45 <bauzas> it occured to me that none of our tracking etherpad is publicized somewhere and we're not explaining what we expect from our contributors
18:46:55 <bauzas> so I have a personal AI to document that
18:47:09 <bauzas> but I think this can be applicable to any project
18:47:26 <bauzas> anyway, long story and we're late, I stop now
18:47:44 <fungi> it's an interesting historical note that the reviewday/bugday dashboards were for tracking and prioritizing exactly that sort of stuff, but ended up completely abandoned for years
18:48:52 <JayF> bauzas: I will mention that I've heard TheJulia surface feedback that generally our use of etherpads (in Ironic context) is tough for new contributors
18:49:04 <JayF> I don't fully understand it, but it does line up with what you're sayin
18:49:08 <bauzas> we tested different ways for tracking but none of them were documented, that's the problem I need to solve, per se :)
18:49:51 <gouthamr> i was religiously maintaining a list like this: https://wiki.openstack.org/wiki/Manila/Etherpads
18:50:39 <gouthamr> bauzas: another thing would be to tack any etherpad you're using to the channel topic on #openstack-nova
18:51:29 <TheJulia> The other issue is historical tracking
18:51:44 <bauzas> I'd say that the problem will be solved if the process can be easily foundable without needing anyone to first understand the process :)
18:51:46 <TheJulia> And the desire humans deep in the middle of things every day to reduce scope/what they need to keep in memory
18:51:52 <TheJulia> and the first thing which goes is old back references
18:52:08 <TheJulia> Which creates lost context
18:52:34 * TheJulia gets off soapbox and puts it into a closet so it cannot be used again today
18:52:40 <bauzas> that's very late for discussing the benefits and limits of Etherpad :)
18:52:48 <gouthamr> :P no no .. lets keep using etherpads
18:52:55 <gouthamr> but, lets make them easier to find
18:52:58 <TheJulia> Just don't say keep using the wiki
18:53:00 <bauzas> anyway, I'm done
18:53:20 * bauzas gives the mic back
18:53:29 <gouthamr> great, thank you bauzas spotz[m]
18:53:30 <spotz[m]> hehe
18:53:42 <gouthamr> its very useful to have this recap..
18:53:45 <bauzas> np
18:53:47 <TheJulia> :)
18:54:04 <gouthamr> #link https://www.openstack.org/videos/summits/asia-2024 (Videos from the OpenInfra Asia Summit)
18:54:10 <gouthamr> ^ its too early, don't look
18:54:46 <gouthamr> we're short on time today
18:55:01 <gouthamr> #topic A check on gate health
18:55:22 <gouthamr> ^ any burning issues that need to be noted and discussion beyond this meeting?
18:56:23 <fungi> people have probably already noticed the zuul dashboard has changed. if there are any questions, feel free to follow up in #openstack-infra or #opendev (or #zuul:opendev.org matrix)
18:56:23 * gouthamr makes executive decision to skip the good parts
18:56:38 <gouthamr> oooh fancy
18:57:04 <gouthamr> thanks for highlighting that fungi
18:57:06 <gouthamr> #topic Open Discussion and Reviews
18:57:45 <gouthamr> #link https://review.opendev.org/q/project:openstack/governance+status:open (Open Reviews on the governance repo)
18:58:07 <gouthamr> ^ the list looks pretty well cared for, thank you for working on the proposals, and for all the reviews
18:59:43 <gouthamr> this seems a bit non-controversial to get in, but famous last words: https://review.opendev.org/c/openstack/governance/+/928078
18:59:48 <gouthamr> so please take a look :)
19:00:03 <gouthamr> with that, i think lets call it a meeting..
19:00:08 <gouthamr> thank you all for attending
19:00:11 <fungi> please remember to submit your cycle highlights!
19:00:13 <JayF> ty o/
19:00:22 <spotz[m]> Thanks all!
19:00:23 <gouthamr> fungi: +1
19:00:29 <gouthamr> #endmeeting