18:00:32 <gouthamr> #startmeeting tc
18:00:32 <opendevmeet> Meeting started Tue Oct  1 18:00:32 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:32 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:32 <opendevmeet> The meeting name has been set to 'tc'
18:00:48 <spotz[m]> link link link!!!:)
18:01:22 <noonedeadpunk> #link https://us06web.zoom.us/j/87108541765?pwd=emlXVXg4QUxrUTlLNDZ2TTllWUM3Zz09
18:01:32 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:01:37 <gouthamr> #link https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ
18:01:42 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:01:45 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:47 <gouthamr> #topic Roll Call
18:01:55 <gmann> o/
18:01:58 <noonedeadpunk> o/
18:02:03 <bauzas> \o
18:02:25 <gtema> o/
18:02:34 <JayF> o/
18:04:19 <gouthamr> noted absence: f r i c k l e r, c a r d o e
18:04:19 <spotz[m]> o/
18:04:58 <gouthamr> courtesy ping: slaweq
18:05:36 <slaweq> gouthamr: sorry but I don't feel well today and will not be at the meeting
18:05:51 <slaweq> I added my absence in the wiki page
18:05:54 <spotz[m]> Feel better!
18:06:00 <slaweq> Thx
18:06:04 <gouthamr> ah sorry about that; i reloaded the page now slaweq
18:06:07 <gouthamr> hope you feel better soon
18:06:09 <gouthamr> #topic Last Week's AIs
18:06:17 <gouthamr> Start ML discussion about Watcher’s leaderless situation (gouthamr)
18:06:31 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/3DRYZFDPVCZ45TOULOZ4R7K6BUOIHLU2/ ([tc][watcher] No leaders for project team, heading to retirement)
18:08:01 <gouthamr> i was proposing waiting for a week before beginning the process to retire the project
18:09:31 <gouthamr> we need some more push this week
18:10:29 <gouthamr> bauzas: you could type out what you were trying to say
18:10:42 <bauzas> meh
18:11:12 <bauzas> I was saying that maybe we should use the DPL support for this cylce
18:11:25 <gmann> ++
18:11:32 <gouthamr> #action gouthamr will respond to the mail thread and ask for an update this week
18:11:38 <gouthamr> noted bauzas
18:11:53 <gouthamr> moving on to the next AI:
18:11:58 <gouthamr> Propose marking Kuryr-related projects inactive (gmann)
18:12:10 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/929698 (Mark kuryr-kubernetes and kuryr-tempest-plugin Inactive)
18:13:51 <gouthamr> ^ we had to stop the release for these projects in 2024.2
18:14:23 <gouthamr> gmann says we should have marked these projects inactive while we were figuring out retirement; we're backfilling this patch so our stance is clear
18:14:45 <gouthamr> please review this patch so we can merge this week ^
18:14:56 <gouthamr> next AI:
18:14:57 <gouthamr> Coordinate a cross-project session at PTG to discuss translating documentation and improving accessibility for non-English-speaking users (gouthamr)
18:15:18 <gouthamr> #link https://etherpad.opendev.org/p/oct2024-ptg-os-tc (OpenStack TC PTG Planning Etherpad)
18:16:31 <gouthamr> seongsoo will be leading a TC PTG discussion
18:16:42 <gouthamr> gouthamr will be sharing a finer schedule this week
18:17:36 <gouthamr> noonedeadpunk says there's confusion about the state of translations right now; there was someone that added horizon translations months ago; however, it wasn't proposed by the tooling
18:19:55 <gouthamr> next AI: Monitor Zun and Kuryr release issues
18:19:59 <gouthamr> kudos to noonedeadpunk to helping Zun fix their CI
18:20:03 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/930554 (Do not release Kuryr in Dalmatian)
18:21:43 <gouthamr> the release team seems to be geared to have a smooth release tomorrow:
18:21:51 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/930752 (2024.2 Dalmatian final releases for cycle-with-rc projects)
18:22:09 <gouthamr> #topic Meeting time
18:22:09 <gouthamr> 
18:23:18 <gouthamr> #link https://framadate.org/openstacktc-25-1 (OpenStack TC Weekly Meeting times poll)
18:23:32 <gouthamr> ^ there were three contenders for the meeting time
18:23:41 <gouthamr> but for any of those slots, only 6 of us could actually make it
18:23:56 <gouthamr> three others were "Maybe" for this slot: 1800 UTC on Tuesdays
18:24:15 <gouthamr> the two other slots had at least one of us respond with a hard No
18:24:19 <spotz[m]> Maybe we wait and ask again later when Slaweq is here?
18:24:43 <gouthamr> oh, why?
18:25:23 <gouthamr> he could be busy between 1700 and 1900 UTC on Thursdays
18:26:23 <gouthamr> we've had a week to look at these results; and they've been visible to everyone :)
18:26:37 <gouthamr> #agreed we keep the existing meeting time
18:27:34 <gouthamr> #topic TC Election Liaison
18:28:45 <spotz[m]> Needs to be someone from this cycle or not re-running
18:29:23 <gouthamr> yes
18:29:44 <gouthamr> we have four TC members who aren't up for election
18:29:57 <bauzas> I can help to be the TC liaison if needed
18:30:03 <gouthamr> thank you bauzas
18:31:09 <gouthamr> #topic A check on gate health
18:31:24 <gouthamr> #link https://bugs.launchpad.net/devstack/+bug/2082617
18:31:45 <gouthamr> devstack ceph jobs are affected by this bug a lot these days
18:31:52 <gouthamr> still don't know the root cause here ^
18:33:09 <fungi> ironic noticed keystone has started breaking on postgresql: https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/MVHR5WZFEDOZA4ESBN5764EVP67GKOS5/
18:33:23 <fungi> #link ironic noticed keystone has started breaking on postgresql: https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/MVHR5WZFEDOZA4ESBN5764EVP67GKOS5/
18:33:34 <fungi> sorry, forgot to link it the first time
18:33:37 <gouthamr> thanks fungi
18:34:04 <gmann> gouthamr: can you hear us?
18:34:38 <gouthamr> gmann: nope
18:34:39 <gmann> we can hear you
18:34:43 <gouthamr> i thought i was talking to myself
18:36:02 * gouthamr fixes the broken sound
18:36:13 <gmann> #link https://review.opendev.org/c/openstack/grenade/+/930507
18:37:44 <gmann> #link https://bugs.launchpad.net/python-openstackclient/+bug/2080600
18:38:26 <gouthamr> ^ this fix has merged in master; new OSC release is necessary along with an upper-constraint bump
18:39:06 <gouthamr> we're going to do this after the coordinated 2024.2 release tomorrow
18:39:52 <gouthamr> the UC update patch will execute -cross jobs to test if projects are okay with the OSC changes coming with the bump
18:40:46 <gouthamr> TheJulia's post to the ML regarding keystone's breakage on postgres isn't a LP bug yet (please correct me if one was reported)
18:41:29 <JayF> It's not a bug as nobody officially supports postgres anymore aiui
18:41:35 <JayF> at least, I wouldn't personally file it as a bug
18:41:46 <gouthamr> noonedeadpunk spotted nodepool's responsiveness has increased
18:41:48 <JayF> the job was intended (from an Ironic POV) to be a canary so we could tell operators when things broke
18:42:02 <spotz[m]> Maybe a won't fix and explanation?
18:42:03 <fungi> noonedeadpunk: yes, rackspace's new "flex" environment is more than twice as fast on half the number of vcpus
18:42:14 <fungi> for many of our jobs anyway
18:42:17 <gouthamr> fungi: very nice
18:42:19 <JayF> There seems to be no interest in the Ironic community in doing any effort on these jobs other than removing them, unless someone asks for it :)
18:42:34 <fungi> longer term we hope to slowly swap out classic rackspace nodes for flex, as they bring more regions online
18:42:43 <gouthamr> JayF: manila folks maintain postgres jobs too; because some large deployments use it
18:43:14 <gouthamr> they're non-voting for the reason you mentioned
18:43:15 <JayF> I invite them to help reintroduce official postgres support into openstack; until then it's not really a priority IMO
18:43:22 <gouthamr> +1
18:43:34 <gouthamr> anything else for $topic?
18:43:45 <gouthamr> #topic TC Tracker
18:43:47 <noonedeadpunk> fungi: frankly - I was o_O on tests time and was thinking for real that we broke smth to a point that smth is simply not executed
18:43:56 <gouthamr> #link https://etherpad.opendev.org/p/tc-2024.2-tracker (Technical Committee activity tracker - 2024.2)
18:44:41 <gouthamr> #link https://etherpad.opendev.org/p/tc-2025.1-tracker (Technical Committee activity tracker - 2025.1)
18:45:52 <gouthamr> ^ you'll notice goal tracking as well here; just something we can try for this release
18:46:54 <gouthamr> we've been pretty good with these trackers
18:47:09 <gouthamr> please pull in anything you were finishing up for 2024.2 into the 2025.1 etherpad
18:47:14 <gouthamr> lets switch to Open Discussion
18:47:15 <gouthamr> #topic Open Discussion
18:47:16 <gmann> ++ good tracking too gouthamr
18:47:45 <noonedeadpunk> #link https://review.opendev.org/c/openstack/governance/+/927962
18:49:27 <gouthamr> ^ we're asking some questions on this change; alongside the swift PTL appointment change
18:49:41 <bauzas> (sorry folks, trying to fix my pipewire issue on my F40 laptop)
18:49:45 <gouthamr> hoping we can get axel and timburke responding here
18:49:59 * bauzas gets hit by https://bugzilla.redhat.com/show_bug.cgi?id=2232584
18:50:01 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/928881 (Appoint Tim Burke as PTL for Swift)
18:51:18 <gouthamr> gmann notes that folks must be more responsive on these governance changes to prove to the TC that they're  responsible and willing to engage with the TC
18:53:26 <gouthamr> bauzas is asking about PTG planning
18:55:20 <gouthamr> he suggests asking for who's interested in these topics to help with the scheduling
18:55:32 <gouthamr> (and noting their timezones)
18:55:48 <fungi> the oceanbase topic is proposed by people in apac timezones, i think
18:59:02 <spotz[m]> And I think I grabbed first slot on Monday for D&I
18:59:51 <gouthamr> +1 on both points
19:00:13 <gouthamr> #action gouthamr will share this etherpad on the ML asking interested folks to vote (with their nicks) on the topics
19:00:23 <fungi> we could maybe move (some of?) the inclusive terminology discussion into the d&i wg slot
19:01:01 <gmann> or its good topic for TC+leader interaction sessions
19:01:17 <gouthamr> fungi: agreed
19:01:38 <gouthamr> gmann: yes; we can re-hash that discussion in a time boxed manner if it happens after the D&I discussion
19:04:19 <bauzas> I guess we need to end the meeting here ? :)
19:04:36 <gmann> yeah
19:05:22 <bauzas> #endmeeting