18:04:26 <gouthamr> #startmeeting tc
18:04:26 <opendevmeet> Meeting started Tue Nov  5 18:04:26 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:04:26 <opendevmeet> The meeting name has been set to 'tc'
18:04:49 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:05:00 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:07:12 <gouthamr> The agenda is here: https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee#Next_Meeting
18:07:19 <gouthamr> #topic Roll Call
18:07:22 <gmann> o/
18:07:24 <gtema> o/
18:07:28 <bauzas> \o
18:07:28 <noonedeadpunk> o/
18:07:29 <slaweq> o/
18:07:32 <aprice[m]> o/
18:07:36 <spotz[m]> \o/
18:07:40 <clarkb> o/
18:07:53 <bauzas> spotz[m]: both left and right-handed ? whoa
18:08:14 <spotz[m]> I'm so exciting it's meeting time I'm doing the wave:)
18:08:53 <gouthamr> #topic Last Week's AIs
18:09:17 <gouthamr> Debug Quota Test Failures in SDK Job (gmann)
18:10:01 <gouthamr> this is tracking increasing cross project tests in the openstacksdk
18:10:10 <gouthamr> gmann will follow up next week
18:10:24 <gouthamr> next AI: Monitor Translation Automation and Facilitate Weblate Transition
18:10:24 <gouthamr> 
18:10:52 <gouthamr> the action was to coordinate with i18n team for necessary infra support and start a mailing list (ML) discussion if further issues arise
18:11:15 <gouthamr> ianychoi and SeongsooCho[m] are working on these, and we should hear from them regarding next steps
18:11:29 <gouthamr> bauzas has been in touch; we'll track this with the 2025.1 tracker
18:11:42 <gouthamr> Review and Merge Leaderless Project Changes
18:12:01 <gouthamr> ^ this was completed, thank you for the reviews
18:12:05 <gouthamr> no more pending items here
18:12:45 <gouthamr> are there any other AIs that we were tracking?
18:13:47 <gouthamr> bauzas highlights that we need to review the eventlet removal goal patch
18:14:15 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/931254 (Propose to select the eventlet-removal community goal)
18:14:47 <gouthamr> #topic OpenStack VMWare Working Group (aprice/jimmymcarthur)
18:15:33 <gouthamr> aprice[m]: is talking about feature gaps and migration challenges that were identified by the working group
18:15:51 <cardoe> I didn't speak up here but I'm on via Zoom.
18:15:57 <gouthamr> #link https://www.openstack.org/vmware-migration-to-openstack/ (VMware Migration to OpenStack)
18:16:05 <gouthamr> cardoe: noted
18:16:35 <JayF> It's slightly confusing we have a "VMWare working group" when we /also/ have a group working in nova to keep the vmware driver alive (or did that go away?)
18:18:36 <spotz[m]> Not 100% sure Jay but I can see both existing, driver so as not to lose functionality but the WG helping for folks wanting to migrate off
18:19:31 <JayF> Oh, I think both existing makes sense, just the naming on the face of it is a little confusing.
18:20:32 <gouthamr> jimmymcarthur asks how the working group can help the community
18:20:49 <gouthamr> is there anything on the website linked above that can be expanded or corrected
18:22:07 <gouthamr> we're discussing if the working group cares about existing integrations (the VMWare driver in nova) or is the group concerned about migrating off of VMWare to open source (or other alternatives) supported within OpenStack
18:23:03 <gouthamr> bauzas states that the Nova VMWare driver's maintenance fell off over time, however a contributor company helped revive it
18:23:25 <gouthamr> third party CI has been revived for the driver, and its currently in a better shape
18:23:43 <gouthamr> does the working group think this effort is useful/needed for its goals?
18:24:23 <gouthamr> aprice[m]: what company contributed to the revival?
18:24:47 <clarkb> SAP
18:24:49 <clarkb> I think
18:25:01 <gouthamr> she'd like to provide a shout out to that company/contributors.. and help bridge other contributors that are interested in this effort
18:25:29 <gouthamr> attendees on the zoom call agree that maintaining the VMWare driver is useful in the migration path..
18:26:00 <gouthamr> #link https://etherpad.opendev.org/p/vmware-migration-strategy (VMWare Migration Strategy/notes)
18:26:22 <gouthamr> ^ and meeting notes from this meeting are being added there as well
18:28:19 <gouthamr> Fabien Wiesel (fwiesel) has been taking the lead from SAP SE to revive VMWare driver support within OpenStack Nova
18:29:10 <gouthamr> aprice[m] said that this will be brought up in the next working group meeting (Monday)
18:30:45 <gouthamr> bauzas noted that the Nova meetings would be a good place to find and discuss with the VMWare driver maintainers
18:30:52 <gouthamr> #link https://wiki.openstack.org/wiki/Meetings/Nova (Nova meeting)
18:31:18 <gouthamr> jimmymcarthur recaps what the group has been focusing on
18:31:50 <gouthamr> they produced the whitepaper highlighting parallels and alternatives
18:32:00 <gouthamr> #link https://www.openstack.org/vmware-migration-to-openstack-white-paper (Migrating from VMware to OpenStack: Optimizing your Infrastructure to Save Money and Avoid Vendor-Lock-in)
18:32:35 <gouthamr> many of the items mentioned in the whitepaper pertain to projects that need contributors
18:33:05 <gouthamr> so the working group's efforts may help support the community to build/maintain these projects
18:33:16 <gouthamr> bauzas provided an example of Masakari (Instance HA)
18:33:35 <gouthamr> gmann asked if this is a Working Group under the OpenInfra Foundation
18:34:05 <gouthamr> aprice[m] said it is, and that's because other top-level projects under the foundation are participating as well
18:34:23 <gouthamr> aprice[m] gives a shout out to dansmith that participated in some of the meetings
18:35:04 <gouthamr> jimmymcarthur wants to note that this isn't a forum for operators to come ask for features - its for folks to step up and help
18:35:26 <aprice[m]> thank you all! very productive meeting
18:35:52 <gouthamr> thank you aprice[m] and jimmy!
18:36:09 <gmann> thanks for joining aprice[m] Jimmy, it was very helpful
18:36:24 <gouthamr> #topic Reviving the os-api-ref project's core team
18:36:55 <cardoe> What's the link to the broken items?
18:37:21 <gouthamr> aprice[m]: is there a link/invite that you'd like to share for the Working Group?
18:37:31 <gouthamr> gtema is noting that the api-ref needs updates, its currently using twitter-bootstrap that's deprecated years ago
18:37:45 <gouthamr> stephenfin is currently the only core reviewer/maintainer
18:38:27 <gouthamr> https://opendev.org/openstack/openstackdocstheme isn't maintained by the TC
18:38:37 <gouthamr> but https://opendev.org/openstack/os-api-ref is maintained by the TC
18:39:03 <gouthamr> the historic context here is that the os-api-ref was under the erstwhile docs team
18:39:18 <gouthamr> we moved this under the TC because we didn't have anyone else that maintained it
18:40:22 <gouthamr> openstackdocstheme is currently under the OSLO team
18:40:39 <gouthamr> #link https://governance.openstack.org/tc/reference/projects/oslo.html#openstackdocstheme (Oslo libraries)
18:40:39 <cardoe> So why do we have apathy?
18:41:21 <gouthamr> bauzas mentions that the TC wouldn't be the right set of people to be tagged as maintainers here
18:41:39 <gouthamr> you'd likely want sphinx experts (or atleast people familiar with this)
18:41:53 <gouthamr> noonedeadpunk agrees
18:43:09 <gouthamr> we're nervous bringing the maintenance to this group where there's little/no expertise
18:43:26 <gouthamr> a correction in the notes (thanks gmann)
18:43:36 <gouthamr> the TC can vote +2/+W on os-api-ref
18:43:52 <gouthamr> but the repo is under oslo's governance
18:44:10 <cardoe> clarkb: I'd follow up with "why are we forking our own OpenAPI spec?"
18:44:21 <gouthamr> clarkb asked if we could just use swagger instead rather than os-api-ref
18:44:32 <gouthamr> gtema says that its not feasible
18:44:58 <JayF> I mentioned this is part of a larger pattern of the TC expecting to pick up anything falling through the cracks
18:45:01 <gtema> openstack apis are pretty specific and cannot be rendered with "vanilla" swagger
18:45:02 <gouthamr> JayF agrees with bauzas - this problem has come up in the past
18:45:15 <gouthamr> cardoe is speaking in agreement as well
18:45:28 <JayF> which is not maintainable and will not cause the best technical result, and that perhaps letting something rot can be used as a method for getting people motivated
18:45:42 <gouthamr> the TC only has so much energy and effort (in addition to expertise)
18:46:45 <fungi> sounds like an argument for dropping openstackdocstheme (it's insanely complicated, there are simpler canned sphinx themes we could switch to instead)
18:47:03 <clarkb> that would also improve mobile reading of the docs
18:47:18 <gouthamr> gmann notes that a lot of oslo libraries can look like this
18:47:33 <JayF> fungi++++
18:47:45 <gouthamr> i.e., a bunch of cross project libraries are under oslo's governance..
18:47:55 <cardoe> fungi: that's what I was going at with my comments
18:48:02 <gouthamr> gmann offers help with os-api-ref
18:48:08 <JayF> that's the sorta creative solution that's better than throwing more effort at a project that has low interest (I don't think there's much crossover between 'theme designers' and 'backend cloud developers')
18:48:28 <gouthamr> os-api-ref and openstackdocstheme seem tightly coupled
18:48:46 <gouthamr> gtema says separating the two isn't straightforward
18:49:49 <fungi> bauzas is making the case for https://governance.openstack.org/tc/reference/upstream-investment-opportunities/
18:50:11 <gouthamr> bauzas wants to craft an encouraging message to potential project contributors to pay attention here noting what's involved in the project's maintenance
18:50:31 <gouthamr> the TC's push would be helpful in this regard
18:51:01 <JayF> fungi: I'll note, I've still had zero takers even inquiring about the one I did for Ironic :/ I'm not sure how effective that is
18:51:49 <gmann> not just ironic but for any opportunity listed there but we kept it there for more wider communication of where we need help
18:52:13 <gmann> and it seems we need to refresh it for 2024, we forgot to that during Jan
18:52:33 <fungi> yeah, i'm not saying the uio effort pays off, just that the idea of "tc lets people know where help would be appreciated" is what led to the creation of uio
18:52:44 <gmann> yeah
18:52:49 <gouthamr> JayF notes that G-Research funded a docs expert to review ironic docs in response to the Investment Opportunities addition
18:52:54 <gouthamr> it took months of working with the resource however
18:53:07 <gouthamr> so, he suggests adding an investment opportunity may not be enough alone
18:53:08 <gmann> gouthamr: we should create the refresh list for 2024. we usually do it every calendar year
18:53:16 <gouthamr> yes gmann
18:53:19 <gouthamr> il
18:53:33 <JayF> I will also say: super rewarding to do that work; even if it's not easy and is time consuming
18:53:37 <gouthamr> i'll kick off discussions to catch up on what was done about the 2023 list
18:53:53 <gouthamr> #action: review 2023 investment opportunities list
18:54:56 <gouthamr> gmann asks gtema to check with the oslo team regarding the current state... stephenfin represents the oslo group, and his input brought the topic here
18:55:44 <gouthamr> looks like we need to work on "how can we revive oslo and add more contributors to this team"
18:56:29 <gouthamr> cardoe thinks (in support of fungi's thought) we need to move away from complicated libraries that we're losing maintainers on
18:57:12 <gouthamr> if keeping up the effort is hard, maybe we take the pain to move to more sustainable alternatives..
18:58:25 <gouthamr> gtema says we could deprecate openstackdocstheme all over, but the styling goes away
18:58:31 <gouthamr> is the TC concerned about this at all?
18:58:59 <gouthamr> gtema clarified his work on the openapi specifications..
18:59:15 <gouthamr> we can't directly use swagger without also mixing in os-api-ref at the moment
18:59:23 <fungi> note that it wouldn't be a *loss* of styling to switch to a canned sphinx theme, https://zuul-ci.org/docs/zuul for example uses sphinx_rtd_theme
18:59:40 <gouthamr> i like that theme
18:59:59 <gouthamr> bauzas notes that swagger isn't a drop in solution ..
19:00:11 <gouthamr> gmann notes that the migration was attempted
19:00:21 <gouthamr> gtema's current efforts seem more encouraging
19:01:08 <gouthamr> alright we're at the hour
19:01:14 <gouthamr> thank youl all for attending
19:01:20 <gouthamr> we couldn't get through the agenda today
19:01:30 <gouthamr> but, there wasn't anything new this week
19:01:56 <gouthamr> we were left with regular items that we do catch up on - status of the gate, tracker etc
19:02:04 <gouthamr> we'll catch up on those next week, or outside of this meeting
19:02:06 <bauzas> yeah the problem with os-api-ref is way more difficult to solve than using a vanilla sphinx them
19:02:08 <bauzas> them*
19:02:14 <bauzas> doh, theme *
19:02:22 <gouthamr> sorry about the delay in starting the meeting
19:02:25 <gouthamr> #endmeeting