18:00:08 <gouthamr> #startmeeting tc
18:00:08 <opendevmeet> Meeting started Tue Dec  3 18:00:08 2024 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:08 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:08 <opendevmeet> The meeting name has been set to 'tc'
18:00:15 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:01:03 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:01:11 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:14 <gouthamr> #topic Roll Call
18:01:19 <noonedeadpunk> o/
18:01:29 <bauzas> \o
18:01:31 <gtema> o/
18:01:38 <spotz[m]> coming!
18:02:22 <gouthamr> we've slaweq on the zoom call
18:02:40 <gouthamr> noted absence: g m a n n, f r i c k l e r
18:03:06 <gouthamr> courtesy ping: cardoe
18:03:16 <slaweq> o/
18:05:22 <gouthamr> thanks for joining, lets get started
18:05:27 <gouthamr> #topic Last Week's AIs
18:06:20 <gouthamr> Gate Health and Docker Hub Rate Limits:
18:06:20 <gouthamr> we sent out a note to projects to consider alternatives to DockerHub as part of the TC Weekly Summary
18:07:11 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/7WNB6WGAXO5I3RPCM76JNZVQSHDH2VGC/ (OpenStack TC meeting Summary 26th Nov 2024)
18:07:26 <gouthamr> Ubuntu Noble Migration
18:07:44 <gouthamr> Reach out to remaining projects with failing jobs to guide migration or pinning nodesets
18:08:12 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/UFV3YPHI7ZECBS2HS35CFJOFNRAAGURH/ ([all][tc][ptl][qa] Migrating upstream CI/CD jobs to Ubuntu Noble (24.04))
18:09:55 <gouthamr> PostgreSQL Support Documentation:
18:09:55 <gouthamr> The TC summary included a note to confirm whether any projects still run PostgreSQL jobs and coordinate updates to governance or documentation as needed.
18:10:07 <gouthamr> ^ i've moved this item to the TC tracker
18:10:48 <gouthamr> these were the AIs that I was tracking; were there any other AIs you were pursuing?
18:11:55 <gouthamr> lets move on to the next topic
18:12:08 * gouthamr is changing up the order today to accommodate the new topic over the existing regular items
18:12:15 <gouthamr> #topic Unmaintained branch cleanup
18:12:28 <gouthamr> #link https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html (Resolution)
18:14:41 <gouthamr> By default, only the latest eligible Unmaintained branch is kept. When a new branch is eligible, the Unmaintained branch liaison must opt-in to keep all previous branches active.
18:15:16 <gouthamr> ^ this seems to be the first problem jens raised
18:15:40 <gouthamr> fungi says there was no process defined to have people sign up to be unmaintained branch liaisons
18:16:05 <gouthamr> so, project teams don't have one - it's unclear
18:16:51 <gouthamr> we need a process to perform this sort of cleanup of older unmaintained branches - maybe a post to the ML asking for liaisons for unmaintained branches
18:17:50 <gouthamr> what do we do now;
18:18:03 <gouthamr> jens proposed and wanted to EOM the Victoria branch
18:18:10 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/935373 (Transition victoria-eom branches to EOL)
18:18:19 <gouthamr> this keeps getting delayed by discussions around the patch
18:19:12 <gouthamr> noonedeadpunk is asking where we draw a line around unmaintained branches.. he highlighted that the latest user survey indicated that the yoga branch was deployed quite a bit
18:19:20 <gouthamr> and its currently unmaintained, do we cull it?
18:19:38 <gouthamr> we need to refine the process so we can understand what unmaintained branches we can cull
18:20:15 <gouthamr> slaweq and bauzas said that the user survey may indicate usage, but, doesn't mean operators are relying on the upstream community to keep the branches open
18:21:46 <gouthamr> fungi suggests that the user survey can't indicate who may be interested to volunteer to care for a specific branch
18:21:51 <gouthamr> it's anonymous
18:22:12 <gouthamr> noonedeadpunk says project teams may be more tied in to users/operators that rely on older branches
18:22:21 <gouthamr> the TC doesn't have all the visibility here..
18:24:03 <gouthamr> so we can't make a blanket decision..
18:24:39 <gouthamr> i think we can use the past strategy that we had with extended maintenance branches - i.e., when a new branch went to extended maintenance, the oldest extended maintenance branch was EOL'ed
18:26:36 <gouthamr> in terms of policy, we have said that only SLURP releases can go to "unmaintained"
18:26:46 <gouthamr> bobcat, dalmatian would go straight to EOL
18:27:41 <gouthamr> fungi says if projects are concerned maintaining Yoga (because we used it as a base branch to test out SLURP upgrades), the TC can designate this as a special branch
18:30:40 <gouthamr> we're now discussing how to find volunteers, how to find liaisons for specific branches
18:30:56 <gouthamr> we have an "unmaintained-core" team that we handed these questions off to..
18:31:03 <gouthamr> but, how much of this team is active?
18:31:41 <gouthamr> the release team is stretched too thin and cannot be burdened with this.. but, unfortunately is having to bring this up..
18:34:07 <fungi> just a data point: https://review.opendev.org/c/openstack/cinder/+/925097 is a security fix which merged to unmaintained/xena earlier today
18:34:35 <noonedeadpunk> ++
18:34:45 <noonedeadpunk> just in time
18:35:13 <gouthamr> thanks, good point..
18:35:41 <gouthamr> we're asking if there are any objections to V, X, W branches being EOLed
18:36:07 <fungi> (took over 4 months from when it was proposed, 6 months from when the advisory was published, but it did merge)
18:36:10 <gouthamr> there was no objection on the Zoom call
18:36:57 <noonedeadpunk> I think that Cinder was the last/only project who didn't backport the fix for this CVE to Xena in time?
18:37:16 <gouthamr> #agreed a ML post will be sent to EOL V, W, X branches
18:38:30 <gouthamr> what's left is to address this note from the original resolution:
18:38:32 <gouthamr> "The TC will maintain and document the full steps and guidelines for transitioning from maintained to unmaintained, and for the eventual branch deletion."
18:39:46 <gouthamr> noonedeadpunk suggests tabling this to a future IRC meeting when we have a few more hands on deck
18:40:01 <gouthamr> i agree, and prefer making incremental progress here
18:40:34 <gouthamr> lets move on to the next topic
18:40:37 <gouthamr> #topic A check on gate health
18:40:58 <gouthamr> is anyone noticing any new flakiness in the CI?
18:41:19 <gouthamr> noonedeadpunk brought up that all horizon plugins are broken due to the noble migration
18:42:20 <gouthamr> bauzas says nova tempest jobs are flakey since the past month; he's not looked in-depth at this.. patches are needing more rechecks to merge
18:42:52 <gouthamr> the nova team is triaging some new guest kernel issues noted in the job logs
18:44:01 <gouthamr> clarkb noted that project teams have started migrating to alternatives to DockerHub
18:44:20 <gouthamr> and the rework of proxies seems to hve helped avoiding DockerHub rate limits
18:44:25 <gouthamr> so the problem is cooling off now
18:44:46 <gouthamr> clarkb also noted a problem with booting CS10 nodes because of new CPU requirements
18:45:24 <gouthamr> ^ fungi and clarkb note that this may affect how we do Supported Runtimes for future releases
18:45:47 <gouthamr> if we can't boot the OS on our cloud providers, they can't be in our runtimes
18:46:40 <gouthamr> OpenMetal and RAXFlex seem like the only CI providers that could handle these CPU requirements
18:47:39 <gouthamr> "CentOS Stream 10 requires x86_64-v3 at minimum"
18:49:22 <clarkb> https://review.opendev.org/c/openstack/diskimage-builder/+/936024 is one of the diskimage builder changes where they have been trying to sort out testing with these images
18:49:43 <spotz[m]> And if anyone is coming to FOSDEM CentOS Connect will be he Thursday and Friday before so a good opportunity to talk to folks🙂
18:50:08 <gouthamr> thanks clarkb fungi and spotz[m]..
18:50:14 <gouthamr> any other gate issues to bring up
18:50:32 <gouthamr> #topic PTG AIs and the TC Tracker
18:50:36 <gouthamr> #link https://etherpad.opendev.org/p/tc-2025.1-tracker (Technical Committee activity tracker - 2025.1)
18:50:42 <clarkb> and I guess the bit that is implied is that opendev won't be able to support centos 10 stream test nodes unless something changes
18:50:50 <clarkb> we're just caught in the middle and can't really make those changes ourselves
18:50:56 <gouthamr> ++
18:52:59 <gouthamr> need some eyes on the eventlet goal proposal reworked here:
18:53:02 <clarkb> https://developers.redhat.com/articles/2024/01/02/exploring-x86-64-v3-red-hat-enterprise-linux-10# this is from january so a bit old but apparently it was just an exploration at one point. Not sure if any concrete decisions have been made
18:53:27 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/931254 (rework the initial eventlet goal proposal)
18:54:21 <gouthamr> #topic Open Discussion
18:55:04 <gouthamr> <fungi>
18:55:04 <gouthamr> in case anyone is interested in taking on additional leadership responsibilities: a reminder that nominations for the 2025 open infrastructure foundation board of director individual member elections are currently open, closing at 23:59 utc on december 13: https://lists.openinfra.dev/archives/list/foundation@lists.openinfra.dev/thread/5R57DDIS7TARSUQGHL2Y5XBCEPNLGHVC/
18:55:09 <gouthamr> ^ reposting this from last week
18:56:07 <gouthamr> there are some candidates that need more nominations from the community
18:56:16 <gouthamr> #link https://openinfra.dev/election/2025-individual-director-election/candidates (see Candidates Not Yet On The Ballot)
18:57:06 <gouthamr> anything else for today?
18:57:40 <gouthamr> we wrapped up the Zoom call
18:57:44 <gouthamr> thank you all for joining
18:57:56 <gouthamr> will see you here next week for our regular weekly IRC meeting
18:58:00 <gouthamr> #endmeeting