18:00:28 <gouthamr> #startmeeting tc
18:00:28 <opendevmeet> Meeting started Tue Jan  7 18:00:28 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:28 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:28 <opendevmeet> The meeting name has been set to 'tc'
18:00:40 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:00:44 <gouthamr> #link https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ
18:00:48 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:51 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:00:53 <gouthamr> #topic Roll Call
18:01:41 <noonedeadpunk> o/
18:01:41 <gouthamr> on the video bridge: slaweq cardoe noonedeadpunk gtema gmann spotz[m]
18:01:57 <gouthamr> fungi and clarkb too, ty for joining everyone..
18:02:01 <spotz[m]> o/
18:02:14 <gouthamr> courtesy ping: bauzas
18:02:21 <gouthamr> not in today: f r i c k l e r
18:02:26 <bauzas> arriving
18:04:13 <gouthamr> #topic Last Week's Action Items
18:05:43 <gouthamr> we had some AIs on Unmaintained Branches.. we'll follow up on a separate topic for this one
18:06:09 <gouthamr> election dates have been proposed; we'll chat about that in a bit too
18:08:35 <gouthamr> noonedeadpunk took an AI to figure out addressing blocked documentation changes
18:08:45 <noonedeadpunk> ++
18:08:52 <gouthamr> he'll summarize here since we're having technical difficulties on the Zoom call
18:09:13 <gouthamr> we did have other AIs pertaining to Ubuntu Noble jobs
18:09:20 <gouthamr> we'll address those in a separate topic too
18:09:52 <gouthamr> #topic Update on unmaintained branches (frickler)
18:10:29 <gouthamr> as of the last meeting, we know elodilles's company would like to maintain Victoria
18:10:36 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/937515 (Transition unmaintained/victoria to EOL)
18:11:02 <gouthamr> The deadline for the opt-in process was 30 Jan 2025
18:11:26 <noonedeadpunk> yup, last meeting a poor state of openstackdocstheme has been raised along with nobody being around on voting on changes there. while we can drop own theming, alternative would be to find way of landing proposed changes to such generic repos by tc, without having maintenance obligation due to rolling nature of tc members
18:11:54 <gouthamr> next step, elodilles can update the patch directly to exclude the projects being left in unmaintained state
18:12:05 <gouthamr> lets continue the discussion on the gerrit patch
18:14:04 <gouthamr> we are unsure if elodilles intends to volunteer to maintain W, X, Y, Z branches of the same repos
18:14:36 <gouthamr> gmann followed up on the gerrit change
18:15:05 <gouthamr> we'll keep this topic through the next meeting so we can chat with   f r i c k l e r   as well
18:15:34 <gouthamr> lets move on to the next topic
18:15:39 <gouthamr> #topic Update on election and changes
18:15:39 <gouthamr> 
18:16:00 <gouthamr> #link https://review.opendev.org/c/openstack/election/+/937408
18:16:29 <gouthamr> ^ election officials have kick-started the next election
18:16:34 <gmann> #link https://governance.openstack.org/election/
18:17:07 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/937741 (Allow more than 2 weeks for elections)
18:17:21 <gouthamr> ^ we are yet to merge this
18:18:38 <gouthamr> we have published the election dates already, we are unsure if we can make this charter change for this election without causing any confusion
18:18:57 <gouthamr> spotz[m] points out if we checked for holidays during the election period
18:20:20 <gouthamr> we may have an overlap with the Chinese New Year holidays
18:21:48 <gouthamr> maybe we can allow early nominations in lieu of this
18:21:49 <fungi> note that nomination check jobs will fail (or at least used to) if pushed prior to the open date for the nomination period, and so may need rechecking
18:22:20 <gouthamr> ++
18:22:46 <gmann> ++
18:22:49 <fungi> the main blocker is when the configuration with the precreated directories for teams hasn't been added to the repo yet
18:22:54 <gouthamr> we have a couple of things to set up elections:
18:22:54 <gouthamr> - kickoff email to the mailing list
18:22:54 <gouthamr> - schedule updates to https://releases.openstack.org/epoxy/schedule.html
18:23:29 <gmann> fungi: yeah, we need to create that in advance.
18:23:56 <gouthamr> sorry the third item, election officials creating the nomination directories
18:24:11 <fungi> yes, the candidates/2025.2 directory and team subdirectories are missing at the moment, so need creating first
18:24:29 <gouthamr> #action follow up on these three election todos in next week's meeting
18:24:30 <fungi> after that, nominations are technically possible
18:25:29 <clarkb> maybe go ahead and create a couple years worth of directories?
18:25:34 <fungi> there is an openinfra newsletter going out in a week or two, if the schedule can be confirmed before then i can include a mention of the dates there
18:25:48 <gouthamr> thanks fungi
18:26:05 <gouthamr> clarkb: true, we don't really need the names anyway do we
18:26:10 <gouthamr> release names
18:26:19 <gouthamr> #topic Status on migrate CI to Ubuntu Noble
18:26:36 <gouthamr> #link https://etherpad.opendev.org/p/migrate-to-noble (Etherpad tracking the goal)
18:26:49 <fungi> we still need to tag a pbr release
18:27:33 <fungi> but it's not altering how pbr does pyproject.toml support, it was more us proving it works
18:27:58 <fungi> i have a change proposed to update the docs too
18:27:59 <gouthamr> a set of changes to pbr occurred in the past couple of weeks:
18:28:04 <gouthamr> #link https://review.opendev.org/q/project:openstack/pbr+status:merged
18:28:05 <fungi> #link https://review.opendev.org/938585 Clarify PEP 517 implementation for users
18:28:29 <gouthamr> plan is to tag a beta release, and have projects test this
18:28:51 <fungi> we've been proving it all out with a series of changes to bindep, in case anyone wants to see a real world example
18:29:31 <gouthamr> there are three projects with failing noble jobs still:
18:29:35 <gouthamr> #link https://etherpad.opendev.org/p/migrate-to-noble#L172
18:30:27 <gouthamr> we may be blocked by inactive project teams, or its unclear if project maintainers have stepped away for the holidays
18:30:45 <gouthamr> gmann has raised the issue on irc channels, the openstack-discuss mailing list
18:31:28 <gouthamr> the concern is how the release would go for these project teams that won't follow the runtime testing guideline in time
18:31:40 <gouthamr> we
18:31:49 <gouthamr> will follow up next week with updates
18:32:23 <gouthamr> anything else for $topic?
18:32:52 <gouthamr> #topic A check on gate health
18:33:42 <gouthamr> we haven't identified anything new/specific show up in the new year
18:34:26 <gouthamr> bauzas notes that nova jobs in december were flaky with VM networking issues
18:34:53 <gouthamr> clarkb notes that dockerhub rate limits affect openstack-helm CI jobs
18:35:08 <gouthamr> the project teams chatted with opendev-infra over the holidays
18:35:29 <gouthamr> they've been told that opendev-infra can't control these rate limits, and a migration is teh best course of actioon
18:36:29 <fungi> we kept the lights on
18:36:37 <gouthamr> ++
18:37:21 <gouthamr> gerrit stores cache files on disk that inflated over the holidays
18:38:41 <gouthamr> this led to a bunch of timeouts and mess; manual intervention was required
18:38:58 <gouthamr> #topic PTG AIs and the TC Tracker
18:38:58 <gouthamr> 
18:39:02 <gouthamr> #link https://etherpad.opendev.org/p/tc-2025.1-tracker (Technical Committee activity tracker - 2025.1)
18:39:39 <gouthamr> ^ any thing that we'd like to share an update about today?
18:40:18 <gouthamr> we'll are getting back into full momentum now, so we can go over each item next week
18:40:33 <gouthamr> #topic Open Discussion and Reviews
18:41:17 <gouthamr> spotz[m] announced that there'd be a celebration of OpenStack 15th Birthday at FOSDEM 2025
18:41:40 <gouthamr> there'll also be a BOF session on OpenStack, spotz[m] will update us soon
18:41:57 <gouthamr> slaweq will be at FOSDEM 2025, and eat some cake on our behalf
18:43:47 <gouthamr> fungi mentions that there were some ML regarding lack of review attention in octavia
18:46:06 <gouthamr> cardoe pointed out that octavia might not be the only case where core reviewers aren't paying attention to reviews from new folks or individuals that don't contribute often
18:46:35 <gouthamr> slaweq mentions that he can check with the core team, he says the team is pretty small and might be stretched thin
18:46:56 <gouthamr> gmann says he's had to ping them a few times to get SRBAC patches merged
18:47:58 <gouthamr> #link https://meetings.opendev.org/irclogs/%23openstack-lbaas/%23openstack-lbaas.2024-12-25.log.html
18:48:52 <gouthamr> ^ a message on Dec 25 that wasn't ack'ed on IRC, but, the patch got some reviews when folks came back by the looks of it
18:49:45 <gouthamr> bauzas notes that new contributors may be expecting sync conversations over IRC
18:52:20 <gouthamr> we may have folks getting confused between IRC channels for #openstack-lbaas (official channel for octavia discussions) and #openstack-octavia (unregistered)
18:52:57 <gouthamr> someone from the octavia team may need to park in the channel and actively drive discussion away, or register the channel and set a topic/redirect message
18:56:04 <gouthamr> we're at M-2, the check point for any released projects to be tagged inactive if the project's momentum has stalled
18:56:40 <gouthamr> Monasca's CI jobs have been failing for months, and there is no activity on the various repos
18:57:21 <gouthamr> monasca is tagged "inactive" though.. no coordinated releases have occurred since 2023.2
18:58:07 <gouthamr> #action start an ML thread copying the PTL and ask to retire the project
19:01:33 <gouthamr> during this cycle, the ubuntu-noble migration effort was a good check on the health of project teams
19:02:04 <gouthamr> most teams were responsive, monasca and skyline remain the concern..
19:02:37 <gouthamr> hberaud brought up an issue with masakari and eventlet on the ML:
19:02:48 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/4RWJH7L7QWVO3SJ64MIGPUQ6Z4Q7HMYD/ ([masakari] failures with new version of Eventlet)
19:03:02 <fungi> i do wonder what can be done to attract a more global maintainer base to skyline, with it posed as the successor to horizon
19:03:16 <gouthamr> we'll follow up next week regarding this concern, its possible the issue was fixed
19:04:12 <gouthamr> fungi: it'd be the case if that plan was official.. i.e., if horizon was on a retirement path
19:04:26 <gouthamr> we wrapped up the meeting on Zoom
19:04:41 <gouthamr> sorry for running on here, wanted to make sure we had minutes :D
19:05:03 <gouthamr> thank you all for attending today, next week's meeting is back on IRC
19:05:07 <gouthamr> #endmeeting