18:00:08 <noonedeadpunk> #startmeeting tc
18:00:08 <opendevmeet> Meeting started Tue Jan 14 18:00:08 2025 UTC and is due to finish in 60 minutes.  The chair is noonedeadpunk. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:08 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:08 <opendevmeet> The meeting name has been set to 'tc'
18:00:17 <noonedeadpunk> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:00:22 <noonedeadpunk> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:00:26 <noonedeadpunk> #topic Roll Call
18:00:27 <noonedeadpunk> o/
18:00:35 <slaweq> o/
18:00:35 <gtema> O/
18:00:44 <spotz[m]> \o/
18:00:56 <bauzas> o/
18:00:58 <gmann> o/
18:01:28 <cardoe> o/
18:02:59 <noonedeadpunk> courtesy ping frickler
18:04:43 <noonedeadpunk> ok, let's move on then
18:04:52 <noonedeadpunk> we obviously do have a quorum
18:05:04 <noonedeadpunk> #topic Last Week's AIs
18:05:05 <frickler> o/
18:06:11 <noonedeadpunk> From the last week I do recall the only action point, which was on me, regarding proposing a solution to not well maintained projects, which have significant impact on representation openstack as a project
18:06:17 <noonedeadpunk> like openstackdocstheme
18:06:31 <noonedeadpunk> though I failed again to come up with a suggestion
18:07:37 <noonedeadpunk> I will try to take some time and write some things down for discussion during this week
18:07:46 <bauzas> cool
18:08:06 <cardoe> gtema was going to fix up the docs theme enough to move us forward.
18:08:17 <noonedeadpunk> #action noonedeadpunk to write a proposal on dealing with poorly maintained repos that can't be deprecated/retired
18:08:19 <cardoe> Then we were gonna talk about trying out a stock theme but the issue was who had the time?
18:08:41 <noonedeadpunk> yes, and also who can vote on changes
18:08:51 <noonedeadpunk> as currently there's nobody to review them
18:09:03 <gmann> during holidays it was not discussed much, but I added a topic to add gtema in openstackdocstheme core list so that he can maintain it
18:09:08 <gtema> Just a tiny bit. Update of bootstrap is there, but switch to Semi-Stock theme requires still work
18:09:27 <gmann> there was no objection but it needs to be finalized by oslo team
18:09:48 <noonedeadpunk> frankly - I'd try come up with a list of projects who don't comply with latest theme and tried to address them
18:10:05 <noonedeadpunk> as if our main issue is that everyone look different...
18:10:09 <noonedeadpunk> but yeah, dunno
18:10:11 <gtema> We have few customizations in the theme which are lost if we switch to the stock theme
18:10:37 <gtema> PDF link, pagination, bug reporting at the very least
18:11:23 <noonedeadpunk> not so far ago I was questioned why there're no pdf links for deployment guides and some other place...
18:11:33 <noonedeadpunk> so ppl do use pdfs
18:12:04 <noonedeadpunk> I think other place was release notes or specs...
18:12:09 <gtema> I wanted to come back to the theme today but failed
18:12:35 <spotz[m]> Don't forget translations and any impacts for that
18:13:01 <cardoe> So I've used a PDF linking extension before without a custom theme.
18:13:03 <gtema> Yeah
18:13:07 <noonedeadpunk> so maintaing theme for now sounds like cheaper solution
18:13:22 <cardoe> Generated the PDF and uploaded it to a place and just an extension added the link in my TOC
18:13:36 <gtema> Yes, but the content of the theme is something where we have influence
18:13:38 <fungi> right, i don't think the suggestion was to replace openstackdocstheme with just a stock theme, but to replace it with a stock theme plus appropriate plugins that we don't have to maintain ourselves
18:13:54 <cardoe> ^this
18:14:06 <gtema> Right fungi, this is my understanding as well
18:14:08 <cardoe> It might be much easier to maintain plugins vs a full theme.
18:14:16 <fungi> and many of the stock themes still allow simple configuration to pick your preferred color scheme, add logo graphics, etc
18:15:55 <bauzas> oh sorry my bouncer was AWOL
18:17:46 <noonedeadpunk> since we don't have an obvious volunteer for replacing the theme right now, I'd suggest trying to fix what we have as patches are around for a while
18:18:00 <gmann> ++
18:18:13 <noonedeadpunk> #topic Update on unmaintained branches
18:18:35 <noonedeadpunk> frickler: any updates on the topic?
18:18:58 <frickler> no from me, still waiting for elodilles to unveil the mystery of what projects they actually want to keep alive
18:19:42 <frickler> I did see a small number of patches to fix CI errors, but not much.
18:20:06 <noonedeadpunk> gotcha.
18:20:17 <noonedeadpunk> ok, let's move on then
18:20:22 <noonedeadpunk> #topic Update on election and changes
18:20:36 <noonedeadpunk> A resolution to allow longer then 2 weeks election has been merged
18:20:45 <noonedeadpunk> #link https://review.opendev.org/c/openstack/governance/+/937741
18:21:13 <noonedeadpunk> with that slaweq sent a ML with election dates
18:21:15 <noonedeadpunk> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/J7E345RKNQW45NMHZLU2V5GYGG3GTPQG/
18:21:21 <slaweq> changes in the election repo are also merged
18:21:29 <gmann> ++
18:21:38 <noonedeadpunk> #link https://review.opendev.org/c/openstack/election/+/938782
18:21:40 <slaweq> so we will have election nomination started 1 week earlier then it was planned before
18:21:49 <slaweq> and then voting will take 3 weeks instead of 2
18:21:50 <bauzas> cool
18:22:10 <noonedeadpunk> great news and thanks for your work!
18:22:41 <noonedeadpunk> #topic Status on migrate CI to Ubuntu Noble
18:22:54 <bauzas> maybe we need some weekly reminder for making sure people don't forget about the election deadlines ?
18:23:23 <spotz[m]> Yeah that's really the major issue on the election
18:23:49 <gmann> no major updates on noble migration this week except I am working a few of the doc jobs failure
18:24:11 <slaweq> last time I was sending reminder emails before nomination period ended - I will do the same this time too
18:24:26 <slaweq> we are also sending emails with some reminders to the ML
18:24:38 <gmann> slaweq: ++
18:24:48 <bauzas> ++
18:24:53 <slaweq> I don't remember exactly how often we do so but we can send probably few more if needed, like every week or so
18:27:29 <fungi> also including a reminder in the next openinfra newsletter. it was originally going out tomorrow but has been pushed back to monday now
18:28:07 <fungi> not sure that will help, but maybe it will reach a few people that ml posts don't
18:28:48 <noonedeadpunk> I kinda wonder what part of newsletter audience can vote on elections
18:28:58 <noonedeadpunk> thus how much target audience that is
18:29:50 <noonedeadpunk> anyway, migration to noble topic in gerrit:
18:29:53 <noonedeadpunk> #link https://review.opendev.org/q/topic:migrate-to-noble+status:open
18:30:16 <gmann> yeah, i will continue on the remaining things especially doc job.
18:30:19 <noonedeadpunk> looks like couple of patches were merged since last time
18:31:10 <noonedeadpunk> like nova, which could be fixing doctheme I guess
18:32:16 <gmann> nova one was merged in Nov, it was just some comment on that and it came up in the list
18:32:31 <gmann> octavia merged a few of them last week
18:33:09 <noonedeadpunk> ah, it was having a jammy test for nova that landed, ok
18:33:15 <gmann> its 'Lightbits CI' running after changes are merged. not sure why
18:33:35 <noonedeadpunk> yeah
18:34:10 <noonedeadpunk> ok, moving on then
18:34:17 <noonedeadpunk> #topic A check on gate health
18:34:51 <noonedeadpunk> any input on the topic? I haven't witnessed anything too bad lately
18:34:57 <gmann> seems good. I did not notice any blocker or frequent failure last week.
18:35:00 <gmann> yeah
18:35:22 <bauzas> ++
18:35:26 <bauzas> ditto here
18:36:01 <fungi> dockerhub rate limits are still hitting some projects hard
18:36:44 <fungi> zuul and opendev have been working on mirroring some general images we use for testing our infrastructure into quay to help improve the stability of our own jobs, so it's becoming an established pattern other teams could choose to replicate
18:37:28 <noonedeadpunk> it's good to know actually
18:37:43 <fungi> we'll be talking more about it in the opendev weekly meeting just after this, in the #opendev-meeting channel or you can hit us up for details in #opendev later
18:37:58 <noonedeadpunk> is there any established namespace there or projects are expected to create their own ones?
18:38:15 <noonedeadpunk> ok, fair, let's discuss outside of the meeting
18:38:19 <fungi> a little of both i think, that's some of what's still being discussed
18:38:40 <noonedeadpunk> #topic PTG AIs and the TC Tracker
18:38:46 <noonedeadpunk> #link https://etherpad.opendev.org/p/tc-2025.1-tracker
18:39:35 <noonedeadpunk> there were couple of updates to eventlet goal lately which apparently need a review
18:40:11 <noonedeadpunk> #link https://review.opendev.org/c/openstack/governance/+/931254
18:43:02 <noonedeadpunk> are there any other updates with the tracker?
18:43:09 <gmann> nothing from my side
18:44:13 <noonedeadpunk> #topic Open Discussion and Reviews
18:44:29 <noonedeadpunk> I wanted to raise question of Freezer and it's unmaintained state
18:44:58 <noonedeadpunk> As milestone-2 passed, project had to release client library
18:45:10 <fungi> it came up during friday's release meeting too
18:45:15 <noonedeadpunk> though a proposed patch to releases was obviously commented as project is inactive
18:45:31 <noonedeadpunk> which results in a chicken-egg situation kinda
18:45:58 <fungi> if there's an intent for freezer's deliverables to officially be part of the 2025.1/epoxy coordinated release then the deadline for letting the release team know that was last week
18:46:22 <noonedeadpunk> with my freezer dpl hat on, I can tell that process of getting from inactive state is a bit unclear for me right now
18:46:38 <gmann> I think state can be change to Active as we are seeing progress and it is release-ready. and there are positive votes in the proposal also.
18:46:51 <fungi> but that doesn't mean that the freezer maintainers can't add an acl to do their own independent releases until the tc decides they're no longer officially inactive and should be considered for inclusion in a future coordinated release
18:46:55 <slaweq> gmann++
18:46:59 <noonedeadpunk> #link https://review.opendev.org/c/openstack/governance/+/938938
18:47:05 <noonedeadpunk> proposal for active state ^
18:47:06 <gmann> noonedeadpunk: there is no hard written criteria but seeing good progress, CI green and having active maintainer are key thing to move project to Active
18:47:35 <gmann> we could do it before m-2 also so that you would not be stuck in release things
18:47:44 <noonedeadpunk> there was proposed a new spec yesterday to the project as well:
18:47:47 <noonedeadpunk> #link https://review.opendev.org/c/openstack/freezer-specs/+/939120
18:47:59 <fungi> since it's past the release "membership" deadline, i think the tc also needs to decide whether they're asking the release managers to make a late exception or preparing for 2025.2/flamingo inclusion
18:48:16 <noonedeadpunk> I was actually waiting for this to come before raising to show another interested party first
18:48:22 <gmann> ok
18:48:58 <gmann> I am all ok to make a late exception to include it in Epoxy release as it is not too late and if release team is ok for that?
18:49:06 <noonedeadpunk> well. to have that said, request for client release was sent in time :)
18:49:29 <noonedeadpunk> #link https://review.opendev.org/c/openstack/releases/+/938780
18:50:02 <spotz[m]> Then it might make sense to ask release
18:50:04 <gmann> but project was not moved to Active state yet right, that is valid concern from release team
18:50:10 <noonedeadpunk> yeah
18:50:13 <noonedeadpunk> true
18:50:23 <fungi> basically, while the project is still listed on the governance site as being "inactive" the release team assumes it won't be included
18:50:45 <spotz[m]> Was the client listed as inactive?
18:50:59 <fungi> individual deliverables aren't active or inactive, teams are
18:51:00 <gmann> for exception from TC, do release team need voting in meeting or a resolution to grant release for freezer projects even it is not active before m-2?
18:51:09 <noonedeadpunk> so the thing is, that there's no "flag" in projects as of today
18:51:14 <gmann> spotz[m]: it is whole project status but by deliverables
18:51:19 <noonedeadpunk> the only indicator of inactive is a doc page
18:51:21 <gmann> *not by
18:52:33 <gmann> I think resolution will be better for record and history. something like this but this time to allow release
18:52:34 <gmann> #link https://governance.openstack.org/tc/resolutions/20240227-remove-murano-from-2024-1-release.html
18:52:36 <noonedeadpunk> also to have that said - not all clients are still released
18:53:00 <noonedeadpunk> #link https://review.opendev.org/c/openstack/releases/+/938597
18:53:02 <noonedeadpunk> as example
18:54:33 <fungi> yes, the release managers don't handle releases for deliverables of inactive teams, active teams can have the release managers handle releases for a subset (all, some, or none) of their deliverables
18:54:35 <noonedeadpunk> but either way, I'd love to get some heading on what to do. Prolonging an inactive state for another release is also an option, though given Epoxy is SLURP - would be good to get into it
18:56:06 <gmann> I think proposing the exception as resolution can be step forward
18:56:08 <fungi> what's the upgrade story for freezer? can it be upgraded from the last versions that were included in a coordinated release, or no?
18:56:11 <noonedeadpunk> ps: also freezer-dr retirement is dependency for getting from inactive state
18:56:14 <noonedeadpunk> #link https://review.opendev.org/c/openstack/governance/+/938183/3
18:56:36 <noonedeadpunk> fungi: it should be upgradable, yes. No breaking changes were made so far
18:56:45 <fungi> cool, that helps
18:57:12 <noonedeadpunk> and feature development plans include some respect of existing deployments
18:58:13 <fungi> unrelated, i sent a reminder to openstack-discuss about voting in the foundation individual director election:
18:58:17 <fungi> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/SRW6I7UZSSIJGOPQJEWSPP2HOGMZEL2Z/ Foundation Individual Director election voting underway
18:58:20 <noonedeadpunk> but also the project was kind of client-oriented, where main heavy lifting was not on api/server side but on scheduler/client (basicaly run by a tenant on vms)
19:00:07 <noonedeadpunk> #endmeeting