18:00:09 <gouthamr> #startmeeting tc
18:00:09 <opendevmeet> Meeting started Tue Feb  4 18:00:09 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:10 <opendevmeet> The meeting name has been set to 'tc'
18:00:44 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:00:50 <gouthamr> #link https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ
18:00:52 * slaweq will be late 2 minutes
18:00:56 <gouthamr> ack slaweq
18:01:00 <noonedeadpunk> sorry, won't be able to participate today - clean forgot about the conflict:(
18:01:07 <gouthamr> no prob noonedeadpunk
18:01:14 * bauzas joins in a sec
18:01:16 <gouthamr> #topic Roll Call
18:01:20 <gouthamr> ack bauzas
18:01:22 <gmann> o/
18:01:28 <gmann> joining video call in 2min
18:01:30 <cardoe> o/
18:01:37 <gouthamr> gtema is on the Zoom call
18:02:02 <gouthamr> noted absence: f r i c k l e r
18:02:36 <gouthamr> courtesy ping: spotz[m]
18:02:48 <gouthamr> ^ may be traveling
18:02:55 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:02:58 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:05:13 <gouthamr> #topic Last Week's AIs
18:05:14 <bauzas> if I disappear, don't be afraid, I'm trying to fix a ubiquiti device :)
18:05:39 <gouthamr> Follow up on openstackdocstheme review permissions (gtema / gouthamr)
18:05:57 <gouthamr> ^ not yet addressed, we're missing oslo folks atm
18:07:01 <gouthamr> oslo meetings haven't restarted yet
18:07:25 <gouthamr> slaweq notes that the PTL/TC nomination kick-off email will be going out tomorrow
18:07:39 <gouthamr> if we have a leadership issue with oslo, we'll need to resolve that soon
18:07:45 <gouthamr> we'll get to this in a little bit
18:08:05 <gouthamr> next AI: Review and approve late Freezer release resolution
18:08:15 <gouthamr> ^ this was done
18:08:22 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/939792 (Add resolution for late Freezer release)
18:08:43 <gouthamr> we need to let the release team know to include freezer and other related repos in this coordinated release
18:09:00 <gouthamr> #action: gouthamr will ping the release team and see if there's any code changes required to do this
18:09:13 <fungi> i let them know yesterday when it merged
18:09:22 <gouthamr> thank you fungi
18:09:26 <gouthamr> #undo
18:09:26 <opendevmeet> Removing item from minutes: #action : gouthamr will ping the release team and see if there's any code changes required to do this
18:09:33 <fungi> happy to bring it up again in their meeting on friday too
18:09:52 <gouthamr> thanks, that would be helpful
18:10:10 <gouthamr> next AI: Oslo project’s governance model
18:10:35 <gmann> #link https://review.opendev.org/c/openstack/governance/+/939485
18:10:58 <gouthamr> the situation here is that some liaisons are more active than others
18:11:15 <gouthamr> the team needs to confirm if they'd like to continue with their DPL model
18:11:40 <gouthamr> some liaisons are volunteering part-time, so perhaps PTL model will work better
18:11:53 <gouthamr> gmann is the TaCT liaison and he's not got a preference
18:12:24 <gouthamr> but our process to reset the DPL model should be followed through because we don't have acks/nacks from existing liaisons
18:12:39 <gouthamr> per the process, we'll merge the patch to reset the leadership model
18:13:06 <gouthamr> and slaweq/ianychoi will need to vet any candidates for the PTL nominations
18:13:25 <gouthamr> #link https://review.opendev.org/c/openstack/election/+/940415 (Add 2025.2 election nomination dir for oslo)
18:13:36 <gouthamr> any disagreements here?
18:14:11 <gouthamr> sounds like none
18:14:21 <gouthamr> i'm looking for one or more TC members to RC+1
18:14:50 <gouthamr> bauzas mentioned he'll be happy to see a new PTL candidate for OSLO
18:15:05 <gouthamr> gmann has spoken to damani in the past about this, and he sounded interested to step up
18:15:26 <gouthamr> the TC doesn't really have a preference between the leadership models
18:15:43 <fungi> "Once a project team has moved to the distributed leadership model, they can revert to the PTL model by creating a change to projects.yaml to remove the “leadership_type: distributed” line in the team’s configuration. This change should have at least a +1 from all the people currently serving as liaisons, including the
18:15:45 <fungi> https://opendev.org/openstack/releases/src/branch/master/data/release_liaisons.yaml for the project team, which might not be in the governance repo. It must also get a +1 from the future PTL, listed in the same change." https://governance.openstack.org/tc/reference/distributed-project-leadership.html#process-for-opting-in-to-distributed-leadership
18:16:01 <gouthamr> but, its possible the DPL model isn't helping resolve contentious issues that show up
18:16:39 <fungi> (just making sure the documented process the tc has is followed or gets corrected if not)
18:17:11 <gouthamr> fungi: +1
18:17:49 * gouthamr workflowed https://review.opendev.org/c/openstack/governance/+/939485
18:18:06 <gouthamr> next up on our AIs
18:18:25 <gouthamr> Monitor Victoria EOL Transition Progress:
18:18:33 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/937515 (Transition unmaintained/victoria to EOL)
18:19:05 <gouthamr> thanks to elodilles for having updated the change removing around 70 repos from this EOL transition change
18:19:12 <gouthamr> and to frickler for initiating this
18:19:49 <gouthamr> so excluding these repos, we can now kick off the EOL for Wallaby, Xena, Yoga branches
18:20:26 <gouthamr> #action check with the release team on the next steps here, likely wallaby
18:22:08 <gouthamr> the maintenance burden of the unmaintained/victoria branch will remain with the unmainted-core gerrit group
18:22:50 <gouthamr> #link https://review.opendev.org/admin/groups/4d728691952c04b8b2ec828eabc96b98dc124d69,members (Unmaintained Core Group)
18:23:18 <gouthamr> gmann says that we should check the pulse of this group during the upcoming PTG
18:23:33 <gouthamr> #action gouthamr will add this to the PTG etherpad that he'll set up
18:23:38 <fungi> you can also replace the hex value with the group name in urls for clarity
18:24:03 <gouthamr> #link https://review.opendev.org/admin/groups/openstack-unmaintained-core,members (Unmaintained Core Group)
18:24:46 <gouthamr> that's all for the AIs
18:24:49 <gouthamr> #topic DPL model reset (gmann)
18:24:49 <gouthamr> 
18:25:45 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/939484 (Freezer)
18:25:45 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/939488 (Watcher)
18:25:45 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/939486 (Release)
18:25:45 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/939487 (Requirement)
18:25:45 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/939485 (Oslo)
18:26:11 <gouthamr> tc-liaisons to each DPL team can initiate these reset patches before the election during each cycle
18:26:38 <gouthamr> we had a good outcome from these reset patches to have a dialog with each of the teams this cycle
18:26:49 <fungi> "TC liaison: the TC liaison is one of the TC members who will follow the project activities at regular intervals and make sure the DPL model is reset every cycle. Project team who is planning to adopt the DPL model can reach out to the TC to find the TC liaison for their project." https://governance.openstack.org/tc/reference/distributed-project-leadership.html#required-roles
18:26:50 <gouthamr> thank you gmann for these patches and for the clear communication around the process
18:27:17 <gouthamr> gmann says that other interested TC members can add themselves as liaisons for projects that they're interested to track
18:27:56 <gouthamr> the summary of this effort was that all teams except oslo will be continuing with the DPL model
18:28:02 <gouthamr> some of them reset their liaisons
18:28:10 <gouthamr> oslo may also continue with the DPL model
18:28:18 <gouthamr> we'll know when we conclude the elections
18:28:29 <opendevreview> Merged openstack/governance master: Reset the DPL model for oslo project  https://review.opendev.org/c/openstack/governance/+/939485
18:28:37 <gouthamr> #topic A check on gate health
18:29:26 <gouthamr> fungi notes that there may be a couple of possible impacts from the pbr release
18:29:36 <gouthamr> #link https://lists.openstack.org/archives/list/release-announce@lists.openstack.org/thread/CNHDWEUGZU4F7Y2DWHR2QL5Y7VULGV2R/ (pbr 6.1.1 released!)
18:29:59 <gouthamr> project teams can notify #opendev in case they encounter any CI impacts with this
18:30:00 <cardoe> fungi: https://docs.openstack.org/pbr/latest/user/releasenotes.html the release notes aren't updated.
18:30:18 <gouthamr> fungi notes that some projects run a lot of CI jobs on every change
18:30:52 <gouthamr> some projects have consume lots of test nodes (50-60, if i heard that correctly, fungi?)
18:31:21 <gouthamr> this consumes a lot of bandwidth, and jobs remain queued for extended durations
18:31:31 <gouthamr> there's no list of projects we know
18:31:36 <gouthamr> that have a ton of jobs
18:32:29 <gouthamr> a kolla change was running 64 jobs, and that's possibly around a 100 nodes
18:32:52 <gouthamr> its possible project teams need to be reminded to rationalize their CI jobs
18:33:17 <gouthamr> we're three weeks to feature freeze
18:33:31 <gouthamr> and these weeks usually see a CI frenzy
18:34:10 <gouthamr> bauzas notes that this could be a lot of problems getting things into this release
18:35:01 <gouthamr> contributors probably lost track of how heavy project CI requirements became as a side effect of the new dashboard
18:35:23 <gouthamr> (the new dashboard compacts the job view)
18:35:42 <gouthamr> we don't want to encourage teams to not test adequately
18:37:13 <gouthamr> currently, we recommend people noticing CI jams to flag issues with job configuration
18:37:35 <gouthamr> prime things to look for: repos that have a ton of jobs, a lot of non-voting jobs, or perma-failing jobs
18:38:09 <gouthamr> gmann and bauzas are mentioning that nova and neutron teams regularly review their CI jobs
18:38:27 <gouthamr> we don't know if other teams are doing this sort of review
18:39:03 <gouthamr> other mitigation methods: combine jobs, move non-voting jobs and long running jobs to the periodic pipeline
18:41:03 <gouthamr> some more methods: queue and pipeline fairness - if there's a lot of demand to test a particular repo, slowness only affects taht repo or project team
18:41:35 <gouthamr> gmann suggests adding a topic to the TC- Project Leadership session at the upcoming PTG
18:41:45 <gouthamr> #action: gouthamr will add this to the etherpad ^
18:41:45 <gmann> for kolla-ansible jobs
18:41:47 <gmann> #link https://github.com/openstack/kolla-ansible/blob/9cb2e0db8965b35ff0dc872c5bd1ffe7d5124c0f/zuul.d/project.yaml#L11
18:42:15 <gouthamr> slaweq will look up some CI scripts that dansmith used in the past to review the CI usage across project teams
18:42:39 <gouthamr> this might be good material to bring to the TC-Project Leadership meeting at the PTG
18:43:49 <bauzas> can someone remind me how to query all the openstack repos by one time ?
18:43:49 <gouthamr> anything else about the gate this week?
18:43:53 <gmann> thanks fungi for bringing it up.
18:43:56 <gouthamr> ++
18:44:04 <bauzas> gotcha
18:44:10 <bauzas> codesearch.o.o
18:44:21 <gouthamr> #topic TC Tracker
18:44:24 <gouthamr> #link https://etherpad.opendev.org/p/tc-2025.1-tracker (Technical Committee activity tracker - 2025.1)
18:45:26 <gouthamr> on ubuntu noble migration
18:45:40 <gouthamr> heat and devstack-plugin-container seem like the only ones concerning right now
18:45:50 <gouthamr> and the docs jobs*
18:46:05 <gouthamr> there are patches resolving issues in skyline
18:46:16 <gouthamr> tkajinam is aware of the issue with heat, and is working on it
18:46:33 <gouthamr> gmann pinged hongbin regarding devstack-plugin-container jobs
18:46:53 <gouthamr> RBAC goal
18:47:19 <gouthamr> blazar and cloudkitty made some progress here
18:47:26 <gouthamr> its slowly getting better :)
18:47:41 <gouthamr> we'll add updates to the etherpad/s and review this again next week
18:48:28 <gouthamr> #topic Open Discussion
18:48:48 <gouthamr> slaweq and spotz[m] were at FOSDEM!
18:49:06 <gouthamr> slaweq saw more people than he expected
18:49:28 <gouthamr> there were a lot of operators, and there was a good discussion for about an hour - lots of questions
18:49:35 <gouthamr> there was an OpenStack Birthday Party in the evening
18:49:53 <gouthamr> as part of the OpenInfra meetup
18:50:23 <gouthamr> there was beer :) a better version of cake, slaweq says
18:52:47 <gouthamr> many FOSDEM rooms were packed, overwhelming to new people - but its probably the biggest free software meetups there is
18:52:54 <gouthamr> so that's expected
18:53:29 <gouthamr> 1118 speakers spread over 1074 events and 78 tracks
18:53:32 <gouthamr> :O
18:54:23 <gouthamr> gtema notes that its a good thing many of these sessions are recorded, so you're probably missing the socializing
18:54:33 <gouthamr> fungi: mentions belgian fried potatoes
18:55:13 <gouthamr> we still have 5 mins
18:55:14 <bauzas> interesting fact : only english people mention the geography of fries, which is btw. wrong
18:55:23 <gouthamr> any other topics for open discussion
18:55:56 <gouthamr> bauzas is starting a fire about fries before he logs off for the day
18:56:28 <gouthamr> alright we hopped off the video call
18:56:48 <gouthamr> i'll post the video recording to the YouTube channel soon, and summarize on the ML
18:56:52 <gouthamr> thank you all for attending!
18:56:57 <gouthamr> see you here next week
18:56:59 <gouthamr> #endmeeting