18:00:43 <gouthamr> #startmeeting tc
18:00:43 <opendevmeet> Meeting started Tue Mar  4 18:00:43 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:43 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:43 <opendevmeet> The meeting name has been set to 'tc'
18:01:05 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
18:01:08 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
18:01:11 <noonedeadpunk> o/
18:01:14 <gouthamr> #link https://www.youtube.com/channel/UCBuGwBXOmWHydSE09RM84wQ
18:01:18 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
18:01:21 <gouthamr> #topic Roll Call
18:01:23 <noonedeadpunk> o/
18:01:31 <gtema> o/ onmyway to zoom
18:01:42 <bauzas> o/
18:02:17 <gouthamr> noted absence: mn asiadka
18:02:42 <gouthamr> and f r i c k l e r
18:02:51 <gmann> o/
18:02:55 <gouthamr> courtesy-ping: spotz[m]
18:05:55 <spotz[m]> here!
18:06:05 <gouthamr> #topic Last week's AIs
18:06:25 <gouthamr> electoral roll generation patch to include TC repos
18:06:36 <gouthamr> #link https://review.opendev.org/c/openstack/election/+/941612
18:07:28 <gouthamr> reviews and check in for the "unmaintained"-->EOL transiton patches:
18:07:43 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/941458
18:07:49 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/942201
18:07:55 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/942218
18:08:57 <gouthamr> ^ patches haven't gotten any negative votes so far
18:09:11 <gouthamr> so we should be good to merge these on the deadline proposed: 2025-03-21
18:09:27 <gouthamr> next AI: sharing the CI usage pattern analysis on ML
18:11:09 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/DGLVXYQ77M7DEV3NQF5F67C5LUK4V4E7/ (CI resources usage optimization)
18:11:37 <gouthamr> next AI: expand PTG agenda
18:11:43 <gouthamr> #link https://etherpad.opendev.org/p/apr2025-ptg-os-tc (PTG Planning Etherpad)
18:12:42 <gouthamr> next AI: finalize the election results
18:12:58 <gouthamr> #link https://review.opendev.org/c/openstack/election/+/942506 (results posted)
18:13:56 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/942507 (governance updated)
18:14:04 <gouthamr> lots of first time PTLs this time around!
18:14:23 <gouthamr> so we're noting that this was a great round of leadership changes across project teams
18:14:54 <gouthamr> some of the PTLs are not yet core-reviewers on the projects
18:15:18 <gouthamr> noonedeadpunk is concerned that there may be a potential risk of drop off in project upkeep and activities
18:15:55 <gouthamr> cardoe asks if the reason is because its hard to be a core reviewer
18:16:17 <gouthamr> or if the core reviewers aren't interested, and so would like to have someone else lead project activities
18:16:32 <gouthamr> bauzas is explaining the situation with Uggla
18:17:20 <gouthamr> he says that the nova team doesn't think that the PTL doesn't have to be a core reviewer... they could work with the cores to get things merged
18:17:37 <gouthamr> the plan eventually is to have Uggla be a core reviewer
18:18:37 <fungi> if memory serves, pdeore was a ptl for several cycles without core reviewer perms
18:18:43 <gouthamr> this has occurred before, for instance, with Glance ^
18:19:22 <fungi> some teams approach it as more of a project manager role rather than a developer role
18:19:34 <gmann> fungi: ++
18:20:26 <gouthamr> noonedeadpunk is concerned about gerrit permissions to add/remove core reviewers
18:20:45 <gouthamr> bauzas is clarifying that anyone in the core groups can add/remove core reviewers from gerrit
18:21:17 <gouthamr> and that usually, those changes are discussed with other core reviewers and the community
18:22:38 <cardoe> fungi: yeah that's what I was trying to ask with my questions. Is it expected to be a developer role and it's hard to get to that point. Or is it more considered the project manager that doesn't have to be a core reviewer.
18:23:53 <fungi> mikal set the tone for it years ago when he started pushing that the "t" in ptl should be for "team" not "technical"
18:24:15 <gouthamr> the consensus seems to be that PTL decisions are typically team decisions
18:25:38 <gouthamr> the concern regarding resolving differences/conflicts, approving exceptions, etc should be left up to the teams and the PTL should be encouraged to drive consensus rather than take a unilateral call
18:25:40 <fungi> (we collectively stopped calling the position a "project technical lead" years ago, for this very reason)
18:25:47 <gouthamr> +1
18:28:15 <gouthamr> noonedeadpunk said when there are no elections, its hard for the TC to see if the candidate has the support of the team..
18:28:54 <gouthamr> gmann said that the fact that there were no other nominations, or objections to a nomination, the TC trusts that the candidate has the support of the team
18:29:15 <gouthamr> #link https://docs.openstack.org/project-team-guide/ptl.html (PTL duties in the project team guide)
18:31:32 <bauzas> fwiw, I always named myself a "paperwork team leader", never a 'technical lead" :)
18:31:46 <gouthamr> #action gouthamr wants to send out an email to all the PTLs reminding them of their role, refreshing liaisons, obscure/one time activities etc
18:31:48 <fungi> i like the suggestion to remind every ptl once a cycle about the checklist, and also encouraging them to all participate in a joint leadership session at the ptg
18:31:49 * bauzas wonders what a technical lead can be
18:32:05 <fungi> bauzas: every nova ptl before mikal ;)
18:33:07 <gouthamr> any other AIs that folks were working on in the past week?
18:33:19 <gouthamr> we've one more AI, but that's its own topic this week: leaderless teams
18:34:06 <gouthamr> #topic 2025.2 leaderless projects
18:34:14 <gouthamr> #link https://etherpad.opendev.org/p/2025.2-leaderless
18:35:08 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/942907 (Appoint Mauricio Harley as PTL for Barbican)
18:36:27 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/943226 (Add suzhengwei as PTL for Masakari)
18:37:50 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/943338 (Appoint Hao Wang as PTL for OpenStack Zaqar)
18:38:18 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/943254 (Appoint Felipe Reyes as PTL for OpenStack Charms)
18:38:42 <cardoe> Maybe they just got used to having it appointed?
18:39:21 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/942793 (Switch back Oslo to DPL model)
18:39:54 <gouthamr> we're discussing why some of these teams need an appointment each cycle
18:41:19 <spotz[m]> I had wondered if we needed longer nomination period in channel last week, there were definitely better comms from election officials this time. I know the last cycle that I was one we started everything late and probably didn't email enough
18:44:48 <gouthamr> regarding charms, bauzas will leave a comment summarizing teh questions the TC has
18:45:32 <fungi> spotz[m]: longer than 2 weeks? it was february 05-19 this time
18:45:55 <fungi> (and we started warning people weeks before that it was coming up)
18:47:06 <gouthamr> and there were emails that went out to contributors of teams without PTL nominees a few days before the deadline
18:47:24 <gouthamr> we also allowed/encouraged early nominations
18:48:14 <gouthamr> an idea from clarkb/others in the past: pre-create election directories for the next cycle way ahead
18:48:30 <noonedeadpunk> +1 also didn't know about that befroe this election
18:50:18 <gouthamr> #action: formalize the early-nominations guidance
18:51:22 <gouthamr> #topic TC Chair Election
18:51:22 <gouthamr> 
18:51:49 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/943203 (Add TC chair nomination folder for 2025.2)
18:51:55 <spotz[m]> Got dropped and can’t get back on
18:53:18 <gouthamr> #link https://governance.openstack.org/tc/reference/tc-chair-responsibilities.html (TC Chair Responsibilities)
18:56:07 <gouthamr> please self-nominate if you'd like to be tc-chair
18:56:15 <gouthamr> #topic Should we do monthly video+IRC meetings?
18:56:15 <gouthamr> 
18:58:29 <gouthamr> emails and eavesdrop don't have a way for us to track who's catching up with these meetings
18:59:07 <gouthamr> bauzas notes that seeing faces once in a while is good, and wants to defer this discussion to the PTG and ask the rest of the community as well
18:59:27 <fungi> we do have anonymous web stats published by opendev, get up with me later if you want a link
18:59:27 <gouthamr> bauzas also notes that the timezones that we're in makes this catchup hard
19:00:06 <gouthamr> there's a non-negligent amount of people that watch youtube summaries
19:00:25 <gouthamr> cardoe says that this is good as a secondary medium
19:01:13 <gouthamr> he's noting that IRC is proving to be hard to communicate on, case in point, a handful of people chat on #openstack-helm on OFTC, where a bulk of the conversation is happening on the Kubernetes Slack's #openstack-helm channel
19:01:41 <gouthamr> there's a generation of developers that will find using alternative platforms helpful
19:02:27 <clarkb> I would argue that a rogue group choosing a different platform doesn't inherently mean the other platform is hard to communicate on...
19:02:39 <clarkb> you'd need to understand the reasons first etc etc
19:02:55 <fungi> agreed, more that they have no interest in engaging with/being part of the project
19:03:28 <fungi> (or at least not enough interest to overcome the learning curve for a platform they've never used)
19:03:51 <gouthamr> we ended the meeting on Zoom
19:04:08 <gmann> ++ to discuss it in PTG and inclide frickler and other members also in the discussion
19:04:14 <gouthamr> ++ i'm going to add this topic to the PTG etherpad
19:04:38 <gouthamr> thanks everyone for joining us this week
19:04:46 <gouthamr> we'll return to our weekly IRC meeting next week
19:05:00 <gouthamr> oh, there's SCALE NA this week
19:05:03 <opendevreview> Merged openstack/governance master: Add TC chair nomination folder for 2025.2  https://review.opendev.org/c/openstack/governance/+/943203
19:05:04 <opendevreview> Merged openstack/governance master: Add gouthamr's nomination for 2025.2 TC chair  https://review.opendev.org/c/openstack/governance/+/943204
19:05:25 <gouthamr> stop by and say hi to spotz[m] mnasiadka and myself if you're attending
19:05:38 <gouthamr> s/SCALE NA/OpenInfra Days NA alongside SCALE 2025
19:06:01 <gouthamr> any last thoughts to add to the minutes before i close this out?
19:07:05 <gouthamr> #endmeeting