17:00:34 <gouthamr> #startmeeting tc
17:00:34 <opendevmeet> Meeting started Tue Apr  1 17:00:34 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:34 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:34 <opendevmeet> The meeting name has been set to 'tc'
17:00:39 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
17:00:59 <gouthamr> #link https://www.youtube.com/@openstack-tc
17:01:16 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:01:20 <gouthamr> #topic Roll Call
17:01:29 <gtema> o/
17:01:48 <gmann> o/
17:02:07 <gouthamr> Today's meeting agenda, and the Zoom details can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:03:15 <noonedeadpunk> o/
17:04:19 <gouthamr> noted absence: s p o t z
17:04:23 <gmann> noonedeadpunk: its video call today
17:04:34 <noonedeadpunk> doh
17:04:47 <bauzas> o/
17:05:01 <gouthamr> courtesy-ping: cardoe mnasiadka
17:05:03 <bauzas> ah joining
17:05:13 <cardoe> ah Zoom today.
17:05:28 <noonedeadpunk> ok, at least I was not alone :)
17:06:25 <gouthamr> #topic Last Week's AIs
17:06:39 <gouthamr> PTG Topic Scheduling – Organize discussions into time slots next week.
17:06:39 <gouthamr> #link https://etherpad.opendev.org/p/apr2025-ptg-os-tc
17:08:46 <gouthamr> just noted on the video call that i'll be adding timeslots to these discussions
17:08:53 <gouthamr> i'll alert you when that's done
17:09:11 <gouthamr> if you have requests to schedule topics to specific time slots, let me know
17:09:20 <gouthamr> and if you're looking to add topics, please don't wait :)
17:09:47 <gouthamr> next AI: Skyline Security Concerns, reproducibility of the build (noonedeadpunk) and next steps
17:10:34 <gouthamr> noonedeadpunk tried reproducing the skyline-console (?) build, comparison wasn't feasible because of lots of changes
17:10:51 <gouthamr> but, the changes were minor and reasonable, given how recent these static files were committeed
17:11:10 <gouthamr> noonedeadpunk also pinged skyline contributors
17:11:31 <gouthamr> they proposed tagging a new tag for skyline-console for the epoxy release
17:11:43 <gouthamr> there was no response to noonedeadpunk's ping
17:11:59 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/6IMESH5VFHFETLNLOM53DBPCPVI6QSDW/ ([blazar] Blazar-dashboard contains non-free files (ie: minified Javascripts))
17:12:06 <noonedeadpunk> I did that not in a best way - so pinged in a patch they proposed to releases repo: https://review.opendev.org/c/openstack/releases/+/945285
17:13:53 <gouthamr> maybe we can have some skyline contributors joining the TC PTG
17:14:29 <fungi> see also the blazar-dashboard thread today, same problem essentially
17:14:31 <gouthamr> #action gouthamr will connect with skyline folks
17:14:47 <fungi> though at least they have a fix up to switch to a non-minified file
17:15:18 <gouthamr> ++
17:15:46 <fungi> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/6IMESH5VFHFETLNLOM53DBPCPVI6QSDW/ [blazar][security-sig][tc] Blazar-dashboard contains non-free files (ie: minified Javascripts)
17:16:01 <fungi> oh, sorry, you already mentioned it
17:16:04 <fungi> #undo
17:16:11 <gouthamr> #link https://review.opendev.org/c/openstack/blazar-dashboard/+/946019
17:16:23 <fungi> (sorry, on another conference call)
17:16:25 <gouthamr> ^ this is the patch to replace the minified js libraries
17:16:29 <gouthamr> totally fine, fungi
17:17:41 <gouthamr> any other AIs that folks were tracking?
17:18:56 <gouthamr> gmann is filling us in on the tempest/devstack/grenade updates to accommodate the changes needed for 2025.2 upgrade testing
17:19:42 <gouthamr> he's adding a upgrade job from Epoxy-->Flamingo as an integrated test job
17:19:55 <gouthamr> it's being set to voting by default
17:20:55 <gouthamr> gmann will look at all the projects running grenade jobs that are not "integrated" and make updates
17:21:02 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/A4P3JBRMFC6GQIV3GWW7PSJEPJWLCYRS/
17:21:17 <gouthamr> #topic No IRC meeting next week (Apr 8th) in lieu of the PTG
17:21:17 <gouthamr> 
17:22:09 <gouthamr> we typically avoid weekly meetings  during  PTG week
17:22:13 <gouthamr> any concerns with this?
17:22:39 <gouthamr> i'll send out an email to the list to state this, but you should also see a flurry of "No Weekly Meeting" emails as usual :)
17:24:35 <gouthamr> #topic A check on gate health
17:24:35 <gouthamr> 
17:24:37 <noonedeadpunk> oh, btw, kinda forgot about skyline-console... yarn build is failing with modern openssl, so it's failing on noble
17:24:46 <gouthamr> oh ty noonedeadpunk
17:25:13 <gouthamr> gmann states that nova's (and all other integrated) ceph jobs are failing
17:25:52 <fungi> there is a new replacement for yarn, i remember looking into it for zuul because it has some nice new features like a cyclonedx sbom plugin
17:25:53 <gouthamr> there's no RCA yet, folks are still discussing on the nova channel
17:26:39 <clarkb> fungi: pnpm
17:26:44 <fungi> (yarn "berry")
17:27:25 <gouthamr> bauzas says that the ceph multistore jobs run periodically, and the failure is very recent
17:27:55 <noonedeadpunk> I was able to make it work by passing --openssl-legacy-provider but still
17:28:10 <gouthamr> right now, check queue is blocked
17:28:10 <noonedeadpunk> if it had CI on noble - it would fail :)
17:28:42 <bauzas> gouthamr: no, sorry the ceph multistore job runs on check pipeline
17:28:48 <fungi> noonedeadpunk: right, that's why i was looking at what it takes to upgrade a project from yarnpkg 1.x to yarnpkg berry
17:29:03 <gouthamr> #link https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/927806
17:29:10 <gouthamr> ^ we're trying to update the version of ceph
17:29:13 <bauzas> what I said is that I think the issue is quite new, as we haven't seen this issue before
17:30:31 <gouthamr> ack, there's more triage needed.. please follow the discussion on #openstack-nova
17:31:42 <gouthamr> last week, clarkb fixed up devstack to avoid some apache restarts:
17:31:47 <gouthamr> #link https://review.opendev.org/c/openstack/devstack/+/945637 (Reduce unnecessary apache restarts)
17:31:54 <gouthamr> this stabilized jobs in openstack/manila for one
17:32:02 <gouthamr> and probably lots of other places too
17:33:14 <gouthamr> any other CI issues to note?
17:34:18 <noonedeadpunk> #link https://review.opendev.org/c/openstack/heat/+/946021
17:34:20 <gouthamr> noonedeadpunk spotted a failure on heat, the fix may be trivial
17:35:59 <gouthamr> gtema will look at this to see if this was an inadvertent change in keystone itself
17:36:10 <noonedeadpunk> error is here
17:36:12 <noonedeadpunk> #link https://zuul.opendev.org/t/openstack/build/82abcade797e42ca9b313c634b28ecc9
17:36:21 <frickler> the rax-dfw issue was solved
17:36:45 <gouthamr> gtema remembered that case sensitiveness was being hidden by the openstackclient
17:37:37 <frickler> ah, that was the reason that we don't have a current osd release right now, wasn't it?
17:37:50 <gouthamr> osd release?
17:37:59 <frickler> osc even, fingers read about ceph before ;)
17:38:04 <gouthamr> > the rax-dfw issue was solved
17:38:04 <gouthamr> ++
17:40:21 <gouthamr> any other CI news to share?
17:40:37 <gouthamr> #topic TC Tracker
17:40:37 <gouthamr> #link https://etherpad.opendev.org/p/tc-2025.1-tracker (Technical Committee activity tracker - 2025.1)
17:41:23 <gouthamr> ^ lets step through things here and weed things out that we don't want to carry into 2025.2
17:41:34 <gouthamr> on the user survey topic, gouthamr has been procrastinating
17:41:58 <gouthamr> #action: gouthamr will ping foundation staff to find out the logistics of the next user survey
17:43:27 <gouthamr> on goals, "migrate-to-noble" was completed, thanks gmann
17:43:44 <gouthamr> goals: secure-rbac, eventlet are WIP
17:44:02 <gouthamr> on the rootwrap to privsep migration, there hasn't been a lot of updates
17:44:39 <gouthamr> we need to circle back on what's left and who's working
17:44:42 <gouthamr> on this goal
17:44:51 <gouthamr> eventlet migration may bring this back to the top
17:45:33 <gouthamr> hberaud was mentioning that the OSLO team would rather not worry about eventlet migration in rootwrap if all the projects stopped relying on it
17:46:10 <gouthamr> we need to check the pulse here
17:46:32 <gouthamr> #action: to follow up with ralonsoh on how things are going with this
17:46:58 <fungi> codesearch has a lot of hits for rootwrap still
17:46:58 <gouthamr> the other goal that's in a similar state is FIPS compliance
17:47:10 <gouthamr> #link  https://governance.openstack.org/tc/goals/selected/fips.html
17:47:25 <gouthamr> not a lot of recent updates besides break fixes for CI failures
17:48:00 <frickler> is there still active interest in that one?
17:48:12 <gouthamr> looks like we stopped working on this after hitting the paramiko blocker
17:48:32 <frickler> with active = developer-backed? ;)
17:49:13 <gouthamr> ack, worth checking
17:49:19 <gmann> frickler: ++
17:49:26 <gouthamr> #action to follow up with ade_lee on how things are going with this
17:49:57 <frickler> it sure would allow us to drop some complexity on the infra side if there was consensus to drop that goal
17:50:24 <gouthamr> ack
17:50:57 <fungi> where "complexity" is we go to lengths to support tests run in fips mode and outside fips mode
17:51:27 <gouthamr> ideally, this is like TLS: we just enable it everywhere by default
17:51:30 <fungi> (noting that switching to fips mode either needs a reboot or dedicated node images)
17:51:52 <gouthamr> but it is not because of challenges ^
17:52:07 <fungi> also just a reminder, fips is a usa government standard, other countries have their own standards which don't necessarily match
17:52:44 <gouthamr> yes
17:52:45 <fungi> so putting general contributor and community bandwidth toward solving usa government requirements may not necessarily be in the project's best interests
17:53:08 <gouthamr> on the tracker, we're looking at "i18n SIG efforts and Translation of OpenStack Documentation"
17:53:43 <gouthamr> bauzas will reconnect with seongsoocho and ianychoi about the current status
17:53:49 <frickler> I haven't heard from the new translation tools in a long time
17:54:03 <gouthamr> yes, since last PTG, bauzas is noting
17:54:39 <fungi> the weblate contract the foundation is paying for just got renewed for another year, and foundation staff did touch base with i18n sig chairs to make sure they were still working on it
17:54:48 <fungi> but we didn't really get any progress update
17:55:33 <gouthamr> ah thank you for the update fungi
17:55:38 <frickler> we might want to consider what to do when infra might have to shut down the old setup because of whatever issues
17:56:50 <gouthamr> ack
17:57:03 <gouthamr> #topic Open Discussion
17:57:22 <gouthamr> anything to add to the minutes today?
17:58:59 <gouthamr> we're discussing the usage of PostGresQL with openstack
17:59:14 <gouthamr> an ongoing thread on the openstack-discuss ML:
17:59:22 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/6I2X74ATIEPKLLVRUDDWG4NQXWMY67Z2/ ([nova] nova-manage fails when upgrading to Antelope)
17:59:37 <gouthamr> we don't test postgres in our jobs.. and we've clarified this multiple times
17:59:44 <fungi> in service of the "bridging the gap" effort, i'll be announcing a maintainer survey and a contributor survey to openstack-discuss later today
17:59:51 <gouthamr> nice
17:59:54 <fungi> hopefully people will get the word out to their teams during the ptg as well
17:59:57 <gouthamr> ++
18:00:11 <fungi> it's a good week to reflect on how the epoxy cycle went
18:01:42 <gouthamr> great that;s a wrap for this week's meeting
18:01:53 <gouthamr> thank you all for joining today
18:02:18 <gouthamr> a reminder, there will be no weekly meeting next week, we'll be catching up in-sync at the PTG instead on Monday and Friday
18:02:39 <gouthamr> see you there next week!
18:02:42 <gouthamr> #endmeeting