17:00:29 <gouthamr> #startmeeting tc
17:00:29 <opendevmeet> Meeting started Tue May  6 17:00:29 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:29 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:29 <opendevmeet> The meeting name has been set to 'tc'
17:01:09 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
17:01:27 <gouthamr> #link https://www.youtube.com/@openstack-tc
17:01:38 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:01:41 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:01:47 <gouthamr> ^ Zoom link here as well
17:01:54 <gouthamr> #topic Roll Call
17:02:07 <gmaan> o/
17:02:08 <gtema> o/
17:02:09 <noonedeadpunk> o/
17:02:18 <cardoe> o/
17:02:28 <opendevreview> Merged openstack/project-team-guide master: Drop "ossg" reference from Vulnerability Mgmt guide  https://review.opendev.org/c/openstack/project-team-guide/+/947150
17:03:34 <bauzas> o/
17:04:14 <gouthamr> courtesy-ping: mnasiadka
17:04:23 <gouthamr> also on the video call: spotz[m]
17:04:44 <gouthamr> #topic Last Week's AIs
17:05:29 <gouthamr> still working on bumping the mailing list thread on Skyline SBOM to restart discussion
17:06:38 <gouthamr> gmaan: mentioned that there's no new update wrt projects outside the integrated gate testing as far as grenade jobs are concerned
17:06:44 <gouthamr> he'll be checking later today
17:07:04 <gouthamr> we merged the VMT scope expansion resolution
17:07:29 <mnasiadka> o/
17:07:30 <gouthamr> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons#Vulnerability_management
17:07:46 <gouthamr> bauzas and i have been added here as TC/VMT liaisons
17:08:00 <bauzas> +1
17:08:28 <gouthamr> #link https://review.opendev.org/c/openstack/ossa/+/948836 (Enact TC resolution to oversee all repos)
17:08:53 <gouthamr> ^ follow up wrt the resolution
17:09:06 <gmaan> #link https://governance.openstack.org/tc/reference/new-projects-requirements.html
17:09:39 <gouthamr> ^ we could mention the VMT process here
17:10:02 <gouthamr> #action: add a link to the VMT overview/process to the new project requirements
17:10:24 <gmaan> ++, thanks
17:11:05 <gouthamr> further steps: we need to discuss with each project team and get them to refresh the security liaisons and coresec teams
17:11:28 <gouthamr> we've been encouraging this from the PTG and in subsequent TC meeting notes
17:11:47 <fungi> i have a brief lunch break, let me know when/where the tc escalation volunteers get published so we can link there in our process too
17:12:04 <gouthamr> fungi: added to https://wiki.openstack.org/wiki/CrossProjectLiaisons#Vulnerability_management
17:12:13 <fungi> oh already there, thanks!
17:12:25 <fungi> i'll get that bit of process written up soon
17:12:25 <gouthamr> bauzas is asking what documents should liaisons be aware of
17:12:39 <fungi> security.openstack.org
17:13:19 <gouthamr> ++ fungi
17:15:55 <gouthamr> TC liaisons will be looking at the same wiki to locate project liaisons, and coresec groups
17:16:17 <gouthamr> if these liaisons are unresponsive, PTLs could be the next escalation
17:16:28 <JayF> VMT is in #openstack-security as well, and willing to answer any questions/concerns that liasons might have (TC or project)
17:18:13 <gouthamr> ty JayF
17:22:06 <gouthamr> we are chatting about how to escalate an issue with an unresponsive PTL/Security Liaisons
17:22:35 <gouthamr> gerrit groups are a good goto resource to find other project contributors to loop in during those rare circumstances
17:23:41 <gouthamr> next AI:
17:23:54 <gouthamr> please update your OpenInfra Foundation profiles up to date with affiliation changes
17:24:02 <gouthamr> gah
17:24:07 <gouthamr> keep your OpenInfra Foundation profiles up to date with affiliation changes
17:24:42 <gouthamr> last AI was on improving  SIG documentation and onboarding
17:25:10 <gouthamr> no progress to note here
17:25:28 <gouthamr> we probably need some bright ideas, and can continue brainstorming that together
17:26:35 <cardoe> gouthamr: I think it was me for ansible collections?
17:26:55 <cardoe> So there'
17:27:13 <cardoe> So there's 2 reviewers. gtema and another. The other person has stepped back from OpenStack work.
17:27:26 <gouthamr> ah, ty cardoe
17:27:49 <cardoe> patches need 2 reviews to be merged.
17:28:45 <gouthamr> we're in a conundrum with SIGs, noonedeadpunk mentions - where we want to add some processes to keep SIGs sustainable
17:28:46 <cardoe> So we need to be able to identify a project that's lost quorum of sorts.
17:29:11 <gouthamr> but, SIGs are lightweight and bureaucracy free for a reason..
17:29:17 <gouthamr> cardoe: https://review.opendev.org/c/openstack/project-team-guide/+/948484
17:32:03 <gouthamr> we are discussing unresponsive SIG chairs
17:34:10 <gouthamr> and what to do when something a SIG maintains cannot be contributed to..
17:35:59 <gouthamr> if a SIG deliverable is deemed useful by project teams, they should take over.. if licensing allows for it, or in the end, fork the project
17:36:30 <gouthamr> there are examples being provided on the call about how contributors are interested in the openstack-ansible-collections repo, currently owned by the ansible SIG
17:37:38 <gouthamr> noonedeadpunk notes that the repo has 9 new/unique contributors in the past couple weeks
17:38:06 <gouthamr> its a useful project, but, project teams haven't stepped up to maintain it
17:40:36 <gouthamr> bauzas asks if we can annotate the project further to advertise its poor maintenance?
17:41:52 <gouthamr> the tests/CI jobs running against ansible-collections-openstack aren't sufficient
17:42:07 <gouthamr> that explains all the bug reports and activity against it
17:42:40 <gouthamr> openstacksdk-core participates in reviews, and gtema is an active maintainer here
17:43:05 <gouthamr> the only active maintainer per this list:
17:43:11 <gouthamr> https://review.opendev.org/admin/groups/0e01228e912733e8b9a8d957631e41665aa0ffbd,members
17:45:10 <gtema> sdk-cores is also in the list, and it is slightly bigger
17:45:25 <gtema> so it's technically more than a single maintainer
17:45:56 <gouthamr> we kinda stepped into the weeds here
17:46:01 <gouthamr> so stepping back
17:46:07 <gouthamr> any other AIs that anyone else was tracking
17:46:09 <gouthamr> ?
17:46:13 <gouthamr> sounds like none
17:46:16 <gouthamr> #topic OpenInfra OS/AI WG
17:46:32 <gouthamr> First Reference Architecture Show & Tell and will feature FPT Smart Cloud
17:46:32 <gouthamr> meeting is on Monday, May 12 at 10am CT / 1500 UTC. The agenda and dial-in information are available here
17:46:32 <gouthamr> #link https://etherpad.opendev.org/p/OpenInfra_AI (OpenInfra OS/AI WG meetings)
17:47:01 <bauzas> noted, will try to join ^
17:48:12 <gouthamr> if you're interested to join this, please save the date
17:48:15 <gouthamr> #link https://lists.openinfra.org/mailman3/lists/ai-openstack-wg.lists.openinfra.org/
17:48:42 <gouthamr> bauzas says that he'll join these calls regularly to share his GPU expertise with the group
17:48:52 <gouthamr> and can relay information that teh TC needs to care about
17:49:58 <gouthamr> #topic Working on our async workflow to be more effective in async workflows
17:50:17 <gouthamr> scheduling regular reviews of docs / policies / etc.
17:50:27 <gouthamr> establish an overall "developer experience" focus / review to attempt to improve the "developer experience" over the whole of OpenStack
17:51:09 <gouthamr> cardoe added these notes under the TC's PTG's section on improving the developer experience
17:51:15 <JayF> gouthamr: fwiw, that list is indicated as private
17:51:55 <gouthamr> JayF: ack, i brought that up on the call.. i can check with aprice why that's the reason.. but, it allows subscriptions
17:52:02 <JayF> ++ okie dokie
17:52:27 <fungi> it's a list for coordinating the whitepaper between the contributing org representatives who volunteered to work on it, afaik
17:52:43 <gouthamr> cardoe is seeking feedback from contributors about their challenges
17:52:49 <gouthamr> think fungi has a link for this!
17:53:23 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/HE7JRHIBES5TPCGMVHG3XYI5TYUY5KIS/ (Reminder: Contributor and maintainer surveys (was: Bridging the gap...))
17:53:36 <fungi> not handy, but the "bridging the gap" mailing list thread has links to resources about ongoing efforts for improving contributor experience
17:54:01 <fungi> (and maintainer experiences too)
17:54:10 <gouthamr> #link https://openinfrafoundation.formstack.com/forms/openstack_maintainer_satisfaction_survey (OpenStack Maintainer Satisfaction survey)
17:54:51 <fungi> we're still collecting submissions for both of those surveys too, and will take later feedback into account in followup analyses
17:55:08 <gouthamr> gmaan says that onboarding challenges were usually addressed through the First Contact SIG
17:55:26 <fungi> (when the fc sig was still active anyway)
17:55:36 <gouthamr> gmaan: its possible the SIG is less active these days, are there any particular gaps we're aware of anyway?
17:57:45 <gouthamr> cardoe says that the openstack contributor experience is fragmented, he's unsure its a first contact sig thing because he's a seasoned contributor to some projects, but a new contributor to other projects.. and finds things challenging
17:58:22 <gouthamr> gmaan has some feedback regarding team meetings
17:58:36 <fungi> this is definitely something the bridging the gap effort is seeking to address
17:58:38 <gouthamr> he says some teams don't hold the meetings they claim to hold
17:58:41 <gouthamr> fungi++
17:58:42 <gouthamr> i
17:59:01 <gouthamr> i've been taking notes, but am waiting to deliver the news that this is being worked on :)
17:59:02 <cardoe> gtema: sorry I wasn't trying to have people pick on Keystone. I just saw your name so I used it.
17:59:14 <gtema> no problem at all
17:59:16 <noonedeadpunk> for me most annoying thing as contributor is absence of reviews for a very long time. This includes actiuve projects as well. And going and asking in IRC for reviews may be a deal braker for many
17:59:34 <gouthamr> +1
17:59:34 <noonedeadpunk> and even if you asked - you still can be ignored there
18:00:02 <gouthamr> bauzas: asks, "who can i ping" is usually a question one has when they have a languishing patch on gerrit
18:00:11 <fungi> yes, that's feedback we've heard from multiple organizations/contributors and we've seen specific examples too
18:00:15 <cardoe> ^ yeah that's been an issue for my internal teams that have been trying to contribute. they haven't known who to ping and they come and ask me.
18:00:44 <gouthamr> #link https://docs.openstack.org/manila/latest/contributor/contributing.html#contacting-the-core-team
18:00:44 <gouthamr> ^ all projects must have a page like this, with a section like this
18:00:57 <fungi> e.g. someone has a languishing nova patch and pops into #openstack-nova to ask for reviews on the day after christmas
18:01:04 <noonedeadpunk> I'm not sure how helpful is that to be honest
18:01:13 <noonedeadpunk> as it's working very occasionally
18:01:21 <gouthamr> #link https://governance.openstack.org/tc/goals/completed/ussuri/project-ptl-and-contrib-docs.html
18:01:21 <gouthamr> these pages were added because of this TC goal ^
18:01:36 <noonedeadpunk> fungi: was it me ? :D
18:01:36 <gouthamr> time check on this meeting
18:01:56 <gouthamr> fungi: the cloud works on holidays :D
18:02:10 <noonedeadpunk> As I can recall popping in some channel around last Christmas
18:02:55 <noonedeadpunk> for me it would be fine to get replied once ppl are from holidays
18:03:13 <noonedeadpunk> and many get that it might be not a bussiness time or smth like that
18:03:19 <fungi> it wasn't you, but someone who was identified through member organization discussions with foundation bizdev folks
18:03:25 <noonedeadpunk> the problem when it's never replied
18:03:47 <fungi> someone from a member org trying to contribute and struggling and wanting to understand why they weren't getting uptake
18:04:57 <fungi> the only one time they tried to raise attention to their changes in irc happened to be on the day after christmas when there was almost no chance anyone was looking
18:05:11 <noonedeadpunk> :(
18:05:19 <cardoe> Well that's on specific case.
18:05:34 <fungi> yes, it was a more extreme example
18:05:44 <cardoe> But there are other cases where people bring up items outside of holiday times and it takes a while to get feedback.
18:06:29 <cardoe> We should encourage projects to review their contributor guides, core member list, and meeting details on some regular cadence.
18:06:52 <gouthamr> we wrapped up the call on Zoom, but adding a few final thoughts from there..
18:06:52 <gouthamr> bauzas was supportive of a survey, and brought up specific instances where contributor experience was broken because documentation was outdated.. and core reviewers have good intentions, but haven't probably got around to make the required doc updates
18:06:55 <fungi> my point was a lot of people attempting to contribute don't have enough awareness of the community dynamic to be able to leverage it well (and even people who are very experienced in working within our community struggle to do so a lot of the time)
18:07:09 <bauzas> if 'bringing up' means "I created a gerrit change" and "no feedback" implies "no gerrit reviews" then I'm afraid this is not the right way to interact with a project
18:07:24 <cardoe> I know from managing some dev teams our worst docs tend to be the docs that the team members don't look at. Which is usually around on-boarding a new team member. So I was drawing a parallel between that and contributor guides.
18:07:29 <gouthamr> this reminds me that cardoe initially said that even doc patches from new contributors are languishing without reviews
18:07:46 <gouthamr> all this is great feedback, and we should all take the survey fungi and the Foundation has set up
18:08:07 <fungi> surveys (there's a maintainer survey and a contributor survey)
18:08:11 <gouthamr> this is specifically in regard to the TC's concerns from the past regarding improving contributor experience
18:08:17 <bauzas> gouthamr: I was more supportive of an iterative way to modify our docs
18:08:32 <bauzas> which would be "please create the doc bug reports"
18:08:50 <gouthamr> fungi: can we extend the said "soft deadline" to the end of this month and continue gathering feedback?
18:09:15 <gouthamr> i want to pull the data at some point after prodding people a bit more
18:09:20 <fungi> yes, that's exactly what we're doing. like the user survey, people can keep filling it out and we'll incorporate later submissions into subsequent analysis
18:09:40 <cardoe> So I was thinking we essentially make a "PTL best practices". As we've said before, the PTL is like the Project Manager more than a Core Reviewer. So as the TC we should have something like "A good PTL does these things". And that would essentially include some developer / contributor experience items.
18:10:00 <fungi> we just wanted to make some headway analyzing feedback in the first month after the release before people get too bogged down working on the next one and the cycle's experiences are fresh in their minds
18:10:13 <gouthamr> i see...
18:10:24 <gouthamr> i'll boost the ML post again
18:10:30 <fungi> thanks!!!
18:11:00 <gouthamr> tc-members: can you please do the same within the projects you contribute, and share it with all your colleagues/ downstream contributors?
18:11:19 <gouthamr> with that, lets wrap up this meeting here..
18:11:23 <gouthamr> thank you all for attending
18:11:33 <gouthamr> #endmeeting