17:00:47 <gouthamr> #startmeeting tc
17:00:47 <opendevmeet> Meeting started Tue Jun  3 17:00:47 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:47 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:47 <opendevmeet> The meeting name has been set to 'tc'
17:01:18 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
17:01:23 <spotz[m]> o/
17:01:24 <gouthamr> #link https://www.youtube.com/@openstack-tc
17:01:33 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:01:37 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:01:41 <gouthamr> #topic Roll Call
17:01:43 <noonedeadpunk> o/
17:01:45 <gmaan> o/
17:01:50 <bauzas> o/
17:01:51 <gtema> o/
17:02:06 <bauzas> (joining Zoom in a sec, once my laptop is fully rejuvenated)
17:02:16 <cardoe> Zoom is installing an update... sorry...
17:03:35 <spotz[m]> I’m waiting on the wiki for link
17:03:58 <gouthamr> courtesy-ping: mnasiadka
17:04:41 <mnasiadka> Sorry - got a company wide meeting today - will not be very talkative
17:04:45 <mnasiadka> o/
17:05:29 <gouthamr> #topic Last Week's AIs
17:06:10 <gouthamr> the main one was around the DCO
17:06:30 <gouthamr> at this point most folks here have opined on the proposal:
17:06:43 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/950463  ([resolution] Replace CLA with DCO for all contributions)
17:07:07 <gouthamr> gmaan says that the translations sign off question raised on the patch can be treated separately
17:08:17 <gouthamr> there's no ICLA/CLA enforcement on Zanata
17:08:25 <bauzas> sorry folks, I have a headset issue
17:08:35 <bauzas> I can just hear from you now
17:09:01 <gouthamr> and ianychoi noted that he didn't enforce ICLA for translators
17:12:51 <gouthamr> we can't onboard any new contributors to Zanata
17:13:08 <gouthamr> weblate could enforce a CLA/DCO
17:13:26 <gouthamr> but right now, a translator can't signup on OpenStack weblate either
17:13:38 <gouthamr> things are in-flight to productize weblate as we know
17:14:22 <gouthamr> we have 4 interns from CMU Pittsburgh and Qatar working over the next ~12 weeks to port  scripts working with Zanata today to Weblate
17:15:08 <cardoe> Wondering if we can break up the DCO change into steps instead of the big pivot that it is right now.
17:15:19 <gouthamr> so, we can't block the DCO enforcement for code/doc contributions on the issue of enforcing it for translators
17:16:01 <gouthamr> clarkb says weblate will allow the enforcement that zanata lacked
17:16:29 <gouthamr> zanata is abandoned upstream, and we may have security bugs - and there's an urgency to finish our migration off of it
17:16:57 <cardoe> +1 to gmaan's suggestion
17:16:58 <gouthamr> gmaan agrees that we should separate the concerns and the TC resolution is a blocker for the whole DCO effort
17:17:47 <gouthamr> noonedeadpunk is concerned that we'll be tacking on more tech-debt
17:18:03 <gouthamr> clarkb says that we need a stop gap for translators that we can work out
17:18:43 <gouthamr> maybe a translator can send a note to the openstack-discuss with the DCO sign off
17:18:50 <clarkb> fwiw I'm not sure we need one, just suggesting that that might be an option
17:19:02 <gouthamr> +1
17:21:12 <gouthamr> #agreed on the zoom call to separate the translation CLA concern into a separate resolution and proceed with merging the existing resolution
17:22:15 <gouthamr> that was the major AI we had
17:22:30 <gouthamr> the other one was around gate failures in out-of-tree ML2 plugins
17:22:48 <gouthamr> JayF: did you happen to report a bug against devstack or neutron for the issue you mentioned last week
17:23:14 <gouthamr> was anyone else tracking anything else?
17:23:18 <JayF> gouthamr: it's not really a bug? Just a combination of devstack tech debt being cleaned up, which made us cleanup some tech debt too, but it wasn't really straightforward.
17:23:18 <gouthamr> in terms of AIs
17:23:25 <gouthamr> ah ack JayF
17:23:37 <JayF> frustrating and time consuming but kinda unavoidable unless devstack wants to gate against ironic
17:23:42 <gouthamr> i see
17:23:44 <JayF> and I'm not sure I want that :)
17:24:06 <gouthamr> ack, sounds good .. good to see that ironic fixed the issue in the plugin
17:24:13 <gouthamr> there's a question on Zoom
17:24:23 <JayF> Just please folks keep in mind that Ironic often has to reconfigure things in our plugin, so be kind to that use case
17:24:27 <gouthamr> about the tooling patches to add "signed-off-by" to automated bot changes
17:24:34 <gouthamr> JayF++
17:24:35 <JayF> (the UWSGI config pattern makes that extremely difficult)
17:25:01 <gouthamr> fungi says there's no blocker, we can approve all the open tooling changes
17:25:29 <gouthamr> ttx is checking with legal if there are any implications if bots add this sign off
17:26:39 <gouthamr> bauzas is seeking clarifications regarding Gerrit Web UI patch updates post the DCO enforcement dates
17:27:59 <gouthamr> he's concerned that the formatting of the sign off will not be properly enforced
17:28:15 <gouthamr> fungi says that we'll have this pain temporarily
17:28:37 <gouthamr> he says we need to mention this in the contributor documentation for this
17:29:23 <gouthamr> #action: gouthamr will update https://review.opendev.org/c/openstack/contributor-guide/+/950839 to address this concern
17:29:35 <gmaan> ++
17:30:33 <spotz[m]> I think Sylvain is talking about the corner case I talked about last week
17:33:44 <gouthamr> alright, we might have some teething pains regarding this
17:33:58 <gouthamr> the sooner we do this the better, that's been the thought
17:34:18 <gouthamr> #topic Pending governance proposals and review timelines
17:34:18 <gouthamr> 
17:34:39 <gouthamr> #link https://review.opendev.org/q/project:openstack/governance+status:open
17:35:27 <cardoe> Another one that could get some eyes is https://review.opendev.org/c/openstack/project-team-guide/+/948484
17:35:28 <gouthamr> any concerns with any open changes that we need to chat about right now
17:36:16 <gouthamr> bauzas is requesting a summary of our course of action on the governance proposal
17:37:15 <gouthamr> cardoe: thank you for pointing it out..
17:37:24 <gouthamr> we can workflow it after two core reviewers have approved
17:37:40 <gouthamr> #topic Changing OpenInfra User Survey Questions
17:37:40 <gouthamr> 
17:38:26 <gouthamr> we won't be changing any questions for the 2025 user survey
17:38:34 <gouthamr> we could be prepared in advance for the next one though
17:38:49 <gouthamr> please feel free to edit the topic on the tc tracker etherpad
17:38:56 <gouthamr> #topic Improving Contributor experience, contd.
17:39:43 <gouthamr> #link https://etherpad.opendev.org/p/tc-2025.2-tracker (the summary of the Contributor/Maintainer surveys for Epoxy)
17:40:43 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/3YCEOEVDZRG5UU3FMPEP4F6EZIXDAVGU/ (summary posted by ildikov on the ML)
17:41:32 <gouthamr> the survey responses indicated that maintainers have trouble getting review attention
17:41:33 <gouthamr> :(
17:41:44 <gouthamr> that's  73% of their issue
17:43:30 <gouthamr> the same question was posed to contributors, and 68% of the time that "Trouble getting reviews" was the reason/challenge indicated
17:44:09 <gouthamr> bauzas says the root of this is a communiciation problem
17:44:36 <spotz[m]> Sounds like a good Forum session? It's a more advanced version of a talk I've submitted for summit
17:44:51 <gouthamr> it's good for live feedback
17:44:57 <opendevreview> Merged openstack/project-team-guide master: Add notes on reviving projects/deliverables  https://review.opendev.org/c/openstack/project-team-guide/+/948484
17:46:05 <gouthamr> as PTL bauzas had talked to contributors/operators multiple times over the years to show them how the Nova team prioritizes reviews..
17:48:20 <gouthamr> spotz[m] says operator hours at the PTG probably didn't gather enough critical audience or have clear outcomes of what to get out of them.. because we didn't plan early enough
17:48:50 <gouthamr> ops meetups in person (like the one alongside the Summit in Berlin, 2022) worked better
17:49:34 <gouthamr> lets take advantage of the upcoming Paris summit to have an in-person ops meetup, and for project updates as well so maintainers can talk to contributors
17:50:23 <gouthamr> noonedeadpunk says that it is problematic to understand how each project team prioritizes things
17:50:35 <gouthamr> (as a contributor to multiple projects)
17:51:19 <gouthamr> he thinks we should be reinforcing guidelines to project teams
17:53:20 <gouthamr> some problems:
17:53:20 <gouthamr> - heavy etherpad usage to track review priorities - these aren't easily findable unless they're linked prominently from docs/wiki
17:53:20 <gouthamr> - review priority label isn't being used, even by project teams that have enabled them
17:54:45 <gouthamr> bauzas is suggesting that we direct projects to update their CONTRIBUTING.rst file at the root of the projects
17:59:31 <gouthamr> bauzas is saying maintainers are humans, with human flaws - contributors must be talking to PTLs and finding "sponsors" to review their code.. its hard, but the only way things can improve..
18:00:24 <gouthamr> cardoe says its hard for seasoned contributors to find review help in nova - they attempted chatting with folks during nova meetings, IRC etc
18:00:43 <clarkb> note anyone should be able to unabandon their own changes. Not sure if they would immediately get reabandoned by tooling through
18:00:46 <clarkb> *though
18:01:01 <clarkb> (and opendev actually suggests against auto abandoning anything)
18:02:13 <gouthamr> cardoe says that -1s would be more helpful to the contributor than long silence from maintainers..
18:02:32 <gouthamr> ~~~ time check ~~~~
18:04:19 <gouthamr> bauzas says that we need to ensure we have cross project discussions prioritized at the Oct PTG to address issues like the one that cardoe brought up
18:04:41 <gouthamr> (cardoe's example of a patch that got stuck was around a nova/neutron feature)
18:04:45 <cardoe> clarkb: https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/941355 is one of them. I believe Vasyl wasn't able.
18:05:16 <cardoe> gtema: there's 2 changes for the openstack-ansible which have +1's from folks and pass tests. I think we can merge those 2 and make a release?
18:05:42 <gouthamr> we wrapped up the video meeting
18:05:45 <fungi> tc-members: point i was saving for open-discussion relatd to the foundation joining lf...
18:05:50 <cardoe> For context, the spec change is this... https://review.opendev.org/c/openstack/nova-specs/+/471815
18:05:52 <gtema> ack cardoe, I am past my working hours, try to look tomorrow at those
18:05:56 <gouthamr> we will continue this topic during the next week's meeting
18:06:15 <gouthamr> noonedeadpunk: will be running next week's meeting.. thank you noonedeadpunk!
18:06:19 <cardoe> gtema: absolutely. I just returned from PTO so just working through my backlog and wanted to mention it.
18:06:26 <gouthamr> i'll follow up with the meeting summary/AIs as usual..
18:06:30 <cardoe> fungi: we can discuss it async?
18:06:41 <gouthamr> thank you all for joining today, and for bringing all these insights to the discussion!
18:06:46 <gouthamr> see you here next week!
18:06:49 <gouthamr> #endmeeting