17:00:10 <gouthamr> #startmeeting tc
17:00:10 <opendevmeet> Meeting started Tue Jun 17 17:00:10 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:10 <opendevmeet> The meeting name has been set to 'tc'
17:00:18 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:00:26 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:00:30 <gouthamr> #topic Roll Call
17:00:52 <frickler> \o
17:01:37 <gtema> o/
17:02:10 * gibi lurks as well
17:02:12 <gouthamr> noted absence: c a r d o e, m n a s i a d k a
17:02:36 <gouthamr> courtesy ping: gmaan bauzas spotz[m] noonedeadpunk
17:02:42 <gmaan> o/
17:03:35 <bauzas> o/
17:05:14 <gouthamr> okay, lets get started..
17:05:21 <gouthamr> #topic Last Week's AIs
17:05:29 <gouthamr> we took a couple of AIs
17:06:05 <gouthamr> one of these is about project activity in cyborg (and vitrage) - we have a separate topic for this so lets dive into this when we get to the topic
17:06:32 <gouthamr> the other was following up on DCO related changes
17:06:52 <gouthamr> this might be a quick one, so lets cover the state of open things now
17:06:55 <fungi> some of those have started to merge
17:07:23 <gouthamr> #link https://review.opendev.org/q/hashtag:+dco-signed-off-by
17:07:50 <gouthamr> on the contributor guide change, we have 1 +2..
17:08:03 <gouthamr> i don't recall if we discussed if it can be merged prior to July 1st
17:08:09 <gouthamr> #link https://review.opendev.org/c/openstack/contributor-guide/+/950839 (Replace CLA instructions with DCO)
17:08:51 <gouthamr> dropping the CLA bits may confuse any new contributors between now and July 1st.. but, we need to land the DCO content there asap
17:08:59 <frickler> well currently a new contributor would still need to follow the CLA process, right? so I wouldn't merge it too early
17:09:28 <gouthamr> okay, what's a good date to merge? a week prior?
17:09:48 <gouthamr> really short term pain/gain
17:10:17 <fungi> i suppose if anyone has questions in the meantime on what the future guidance is going to be, we can point them at the contributor guide change (or zuul's draft rendering of the future state of the built document)
17:10:24 <frickler> yes, that would be next week, I think that's fine
17:11:10 <gouthamr> ack on both points
17:11:15 <gouthamr> any objections to that?
17:12:19 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/950760 ([tools] Add 'signed off by' tag to scripts)
17:12:19 <gouthamr> did you have consensus (with ttx perhaps?) regarding this one?
17:12:45 <gouthamr> fungi ^
17:13:45 <fungi> gouthamr: his last comment looked consensus-ish?
17:14:11 <fungi> ah, it was on a different change
17:15:04 <gouthamr> ack, good stuff.. i was wondering if we had any blockers
17:15:27 <gouthamr> i think the pending issue with translations is the only remaining concern
17:15:56 <fungi> #link https://review.opendev.org/950770 (openstack/project-config)
17:16:12 <gouthamr> ty fungi
17:16:14 <fungi> the comments there covered it
17:17:09 <gouthamr> we can buy some time for DCO enforcement in translations , i will chat with ianychoi and seongsoo about this.. the student interns were onboarding as of this week, and making good progress.. i'm hopeful we'll have something substantial towards M-3 as far as our weblate transition goes
17:17:32 <gouthamr> that's all i had for DCO this week, and that's all of the AIs i could gather as well
17:17:43 <gouthamr> noonedeadpunk: thank you again for running the meeting!
17:17:55 <gouthamr> were there any other AIs you were tracking?
17:19:48 <gouthamr> #topic Improving Contributor experience, contd..
17:20:20 <gouthamr> we had an update on the ML from ildikov
17:20:28 <fungi> ildikov had a follow-up post to the ml yesterday with a bunch of review metrics analysis
17:20:34 <gouthamr> wrt the contributor/maintainer surveys
17:20:39 <fungi> yeah, that one
17:20:43 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/NTBNI7YIDCWBR6BTPEKVZIODWTVUIOXO/ (Re: [all][dev][ops][tc] Bridging the gap between community and contributing orgs)
17:21:28 <gouthamr> more interesting analysis there
17:21:33 <fungi> we also joined the nova meeting a few minutes ago and gave some project-specific analysis, i'm planning to do the same for cinder tomorrow
17:21:54 <gouthamr> ah very nice; how many teams are you able to do this with?
17:22:42 <fungi> probably 6 initially over the next month or so, basically prioritizing any that got multiple contributor and maintainer survey responses for now
17:23:10 <gouthamr> good stuff, thank you for doing this
17:23:13 <fungi> but as more people fill out those surveys we'll have better data and a clearer picture, i think, so can probably do more
17:23:41 <gouthamr> we did have a few ideas through the brainstorm we had here in the past few weeks
17:24:05 <gouthamr> i want to pause here, and wait to see what opinions you gather from the project teams in their meetings
17:24:25 <fungi> i'm not expecting these early analyses to be extra illuminating, probably full of things we already know, but maybe with some more concrete evidence to back them up. as for ways to turn any of it around, that's harder obviously and something most open source projects struggle to solve
17:24:51 <gouthamr> mainly interested if we can see different pain points, and practices teams are taking that are helping, and things theyre planning to adopt
17:25:10 <fungi> yeah, i hope that starts to come out of this
17:25:48 <gouthamr> ++
17:26:04 <fungi> i also expect it to take time, this is not going to be a short journey
17:26:33 <fungi> first we need a solid picture of where we are before we can figure out ways to maybe get closer to where we want to be
17:26:54 <gouthamr> yes, i think if we can go into the Oct PTG better informed and share some best practices it'd be a win :)
17:27:11 <fungi> agreed, that seems like a reasonable next goal
17:27:35 <gouthamr> anything else for $topic today?
17:27:46 <fungi> i didn't have anything
17:28:03 <gouthamr> ty
17:28:17 <gouthamr> #topic Cyborg project status
17:29:36 <gouthamr> did we have any update in the past week wrt this?
17:29:41 <gmaan> this is something we discussed in last meeting also
17:30:06 <bauzas> yup
17:30:35 <gouthamr> sorry, i was confused with the wiki updates.. i was under the impression we took an AI to follow up over the past week?
17:30:56 <gmaan> as m-2 release team deadline to have a final list of deliverables to release for his cycle, we should see if we need to mark it inactive or need to wait more for core reviewer to become active?
17:31:39 <bauzas> that's what we said, see in July whether Cyborg would be back
17:31:43 <gmaan> issue is core members are not active. AI was try to reachout to them, ML, gerrit has no response
17:32:51 <gmaan> bauzas: but we should decide before m-2 which is july 3rd otherwise we miss the timeline to mark project inactive though we can have exception for that
17:33:02 <bauzas> ah right
17:33:37 <gmaan> nova also has the cyborg job which is failing and non voting. having a clear status on project will help cross project/CI effort also
17:34:13 <frickler> is there any interest to look into other projects, too?
17:35:02 <gmaan> yeah, i think its time to bring all such projects. we have at least 2 weeks from m-2
17:35:45 <gmaan> sean brought this during cyborg fix and I brought it here but discussing more such inactive project if anyone knows is good timing
17:36:18 <frickler> IMO everyone in https://review.opendev.org/q/topic:%22create-2025.1%22+status:open would be worth a closer look
17:36:27 <gouthamr> sounds like we could have a patch to mark cyborg inactive
17:36:37 <gouthamr> and then update the original thread with a new subject?
17:37:26 <gouthamr> i understand asking the foundation staff to reach out to the cores would be unsustainable.. i don't want to resort to it personally..
17:37:26 <bauzas> we can try
17:37:32 <gmaan> frickler: ++ in first glance yes, most of those projects are less active in past too
17:38:15 <gouthamr> okay, anyone wants to own this action item?
17:38:37 <frickler> yes, repeat the same query with 2024.x and you see a pattern. but that is a strong argument for me that these should not be part of the regular release cycle if they don't have much updates anyway
17:38:48 <fungi> i have pinged horace (our china community manager) since he might have some idea of the level of continued engagement from the employer of the cyborg maintainers
17:39:16 <fungi> if he has any ideas i'll immediately pass them along
17:40:23 <gouthamr> thank you fungi
17:42:36 <fungi> he already got back to me, suggested that the best next step is to probably ask the openstack community if anyone is interested in taking over cyborg maintainership going forward
17:43:00 <fungi> so sounds like their employer is probably not very engaged any longer
17:43:19 <gmaan> I can push change to mark it inactive and we can see if anyone interested to take over
17:43:29 <fungi> pairing that with the proposed inactive change sounds like a great combo, yes
17:43:29 <bauzas> ++
17:45:01 <gouthamr> ty for the update fungi and thanks for owning the next steps, gmaan
17:45:22 <gmaan> gouthamr: you can add action item on me, I will push change today
17:45:51 <gouthamr> #action: gmaan will propose a governance change to tag cyborg inactive for 2025.2
17:47:01 <gouthamr> frickler: ty for the link, not merging bot patches is sure an indication of how active a team is ..
17:48:11 <gouthamr> we need to tag these projects inactive just like we're doing with cyborg, and pair that with an ML post before M-2.. if you or anyone from the release team would like to do that, please do..
17:48:34 <gouthamr> anything else for this topic?
17:49:15 <gouthamr> #topic A check on gate health
17:49:24 <gouthamr> anything concerning in the gate this week?
17:50:24 <fungi> opendev is in the process of switching most zuul nodesets over from nodepool to zuul-launcher managed nodes. the change should be transparent, but we'll keep an eye out for any reports of problems
17:50:39 <fungi> we've already done this in other zuul tenants, just not the openstack tenant yet
17:50:56 <gouthamr> oh long live nodepool
17:51:21 <gouthamr> have you folks been finding any issues with the other tenants?
17:51:38 <fungi> not so far, no
17:52:12 <fungi> i mean other than when initially developing the funcitonality and dogfooding it in the zuul upstream community's zuul tenant
17:52:19 <gouthamr> transparent is good, i will miss nodepool :) spent several hours watching image builds and nodes being ready when maintaining third party CI in a past lifetime
17:52:39 <fungi> zuul-launcher will give you even more of that ;)
17:52:58 <fungi> it just relies on zuul jobs to build node images now
17:53:03 <gouthamr> speaking of, i know this was well communicated, but will nodepool continue to be supported for third party CI people that will need to switch over time?
17:53:32 <fungi> i don't know the current deprecation schedule for nodepool, but it won't be overnight
17:54:15 <gouthamr> ty..
17:54:35 <gouthamr> lets skip through the TC tracker and spend the next five mins with open discussion
17:54:38 <gouthamr> #topic Open Discussion
17:54:41 <bauzas> yes please
17:54:53 <mnasiadka> fungi: does that mean we can also use the 16g ram flavors after that switch?
17:54:53 <gouthamr> there was a late breaking topic regarding Eventlet Removal
17:55:13 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/BIC7BTAN72X6AA4BE6VVNSP7FYFOC362/ (eventlet removal deadlines)
17:55:20 <gouthamr> #link https://removal.eventlet.org/guide/sequencing-the-migration/#openstack-migration (current proposal)
17:55:23 <bauzas> so
17:55:25 <fungi> mnasiadka: probably best to ask in #opendev or during the meeting in #opendev-meeting at 19:00 today
17:55:46 <mnasiadka> fungi: ack
17:56:02 <bauzas> so, if you look at the above, services should be done to longer to use eventlet by 2026.1
17:56:19 <bauzas> and to remove eventlet by 2026.2
17:56:25 <bauzas> that's what gibi asked
17:56:36 <bauzas> in his thread
17:56:46 <bauzas> and I agree with him, we have concerns here
17:57:55 <bauzas> so I think we couldn't remove eventlet by 2026.2
17:58:07 <bauzas> gibi: I guess that's what you're saying ?
17:58:41 <gibi> based on the progress we made so far in nova we will need at least 2026.1 to transform the nova-comput service
17:59:07 <gouthamr> that still adheres to the community-wide plan, correct?
17:59:09 <gibi> and we was explicitly asked by operators on the PTG to have a way to switch from eventlet to threading outside of the upgrade window
17:59:23 <bauzas> and I think we need to take some time for our operators to verify whether they font some issue
17:59:25 <frickler> I think this is a bit related to which distros/python version we want to support? <=3.12 may work, but py3.13 or newer is critical with eventlet afaict
17:59:32 <gibi> so we need a release where both eventlet and threading is supported
17:59:42 <bauzas> frickler: correct, the problem appears with py3.13
17:59:59 <gmaan> yeah, we need to extend the py3.12 support also until then
18:00:04 <gouthamr> <<--- time check -->> please drop off if you're unable to stay, but we'll wrap up a bit later today
18:00:08 <bauzas> but distros could try to support py3.12 a bit later
18:00:13 <gmaan> which is what we might be doing I think
18:00:43 <frickler> trixie will have python3.13 only afaict. and Ubuntu 26.04 may have an even newer version
18:00:51 <bauzas> py3.12 would only be EOL by 2028-10
18:00:58 <bauzas> https://devguide.python.org/versions/
18:01:21 <bauzas> so we have more time, the problem only appears for distros that no longer support py3.12
18:01:49 <fungi> yeah, i think this is squarely in the realm of distros dropping their openstack packages because including openstack isn't enough justification to maintain older cpython interpreter packages and dependencies
18:01:59 <gouthamr> in the #openstack-eventlet-removal channel, hberaud noted that py3.13 support is an ongoing effort, with some fixes that were pending a new release of eventlet..
18:02:20 <bauzas> gouthamr: I'm not asking the eventlet team to support py3.13
18:02:31 <bauzas> this is no longer possible and this would take more time
18:02:37 <fungi> if eventlet can be made to work on cpython 3.13 and 3.14 then debian and ubuntu could probably continue to include openstack
18:02:38 <gibi> gouthamr: I think they fixed bugs but I'm not sure they fixed all the blocking bugs
18:02:51 <bauzas> so we know that the last py version would be py3.12 which will be EOL by 2028.2 timeframe
18:03:30 <gmaan> yeah, it is more of our timeline. I do not think we can accommodate every distro versions support
18:03:42 <fungi> yes, which is fine as long as you deploy on platforms that are going to maintain those older python versions, or get the from somewhere or compile them yourelf
18:03:53 <bauzas> here, I want to make it clear that it looks to me not possible to have nova to no longer support eventlet by 2027.1
18:03:58 <gmaan> at long as we can support py3.12, I think we should and have feasible timeline for eventlet plan
18:04:04 <bauzas> possibly 2028.1
18:04:39 <bauzas> but here my main concern (as a nova-core maintainer) is that I'd ask our operators to test the performance for threads for more than just one release
18:04:43 <fungi> i think that needs to be clearly called out on the ml thread, that we're talking about basically not supporting python 3.13 for a couple more years, and making sure the distros are aware of that fact asap
18:05:02 <gibi> I think I called it out on the ML
18:05:22 <frickler> maybe zigo can confirm, but I don't think the Debian ship will move backwards for this
18:05:43 <gibi> but feel free to ephesize it
18:05:57 <bauzas> frickler: the problem is not whether we want to drop eventlet or not
18:05:59 <fungi> if you read down into the message, yes, but there's e.g. nothing on the ml with the subject line "no python 3.13 for openstack until 2028"
18:06:13 <bauzas> frickler: but rather whether we should be able to drop it
18:06:19 <fungi> so we need to make sure it comes to their attention
18:06:24 <bauzas> and 2027.1 is just not possible
18:07:03 <bauzas> this is tbc unrealistic to drop our eventlet support by only one release
18:07:15 <gmaan> agree
18:07:39 <gmaan> and do we know if all other projects are ok with current timeline or what their progress is?
18:07:55 <bauzas> good question
18:08:18 <gmaan> I am afraid if 'no work started' is the silence there and we have this a bigger concern from many projects
18:08:18 <fungi> yeah, if openstack just plan isn't going to work on python 3.13, then it won't be packaged in debian, full stop. ubuntu might do extra work to keep a python3.12 interpreter and enough package builds of openstack dependencies for 3.12 to make it usable in 2026.04 but that's still some time out
18:08:52 <bauzas> I know that Neutron is aggresively removing evently
18:08:54 <bauzas> eventlet
18:09:10 <bauzas> but for Cinder, last time I heard was that they need more time
18:09:23 <bauzas> and honestly, Nova has concerns as I said by the performance
18:09:42 <bauzas> as gibi said, operators need to better tune their options with threads
18:10:05 <gibi> my concerns is about the speed we are able to progress with the removal in nova
18:10:08 <bauzas> I don't know for Neutron if operators are able or need to tune some performance usage for the services, but I'd guess this would be the same
18:10:21 <gibi> we simply won't be ready to drop eventlet when we planned
18:10:40 <bauzas> gibi: that, plus as I said the fact that I'd like our operators to test threads-only nova-scheduler not just by one release
18:11:01 <bauzas> yeah the dropping is the main concern
18:11:07 <gibi> our current plan is to have one release where both eventlet and threadin will be supported
18:11:18 <gibi> so that operators can switch outside of the upgrade window and tune
18:11:19 <bauzas> whether we could use other but eventlet could be possible
18:11:27 <bauzas> for the timeframe we said
18:11:41 <bauzas> but *dropping* the usage seems unrealistic as I said
18:14:57 <gibi> I'm past my 11th hour today so I cannot really add more to this discussion now
18:15:06 <bauzas> anyway, do we want to signal that as a TC ?
18:15:17 <gouthamr> okay, sounds like great points, but i don't think we can take a call on changing the timeline without checking with all the projects, and hberaud/oslo folks
18:15:21 <bauzas> gibi: heh, live my life :p
18:15:47 * bauzas reads the current goal
18:15:55 <gibi> bauzas: I have my own thanks :p
18:16:07 <bauzas> https://governance.openstack.org/tc/goals/selected/remove-eventlet.html#completion-criteria
18:16:08 <gouthamr> if you'd like, we could have a topic proposed to the next TC meeting, or, maybe weigh pros and cons on the #openstack-eventlet-removal channel and the ML post
18:16:27 <bauzas> gouthamr: I could propose a Gerrit change to the goal
18:16:41 <gibi> I prefer the ML post at the moment as there is some engagement already there
18:16:41 <gouthamr> yes, that would be a good place to hash out arguments
18:16:42 <bauzas> or gibi, as you want :)
18:16:49 <gmaan> ++ I think that will help to have wider discussion
18:17:02 <bauzas> gmaan: about the ML thread ?
18:17:07 <gmaan> I mean gerrit
18:17:12 <bauzas> the problem is that it goes into technical details
18:17:20 <bauzas> and I don't want to derail into those
18:17:26 <gmaan> gibi: ML is ok but I am not seeing other projects stating their state
18:17:51 <bauzas> OK, I can draft a gerrit patch against the goal with the help of gibi
18:17:59 <bauzas> gibi: would you be OK with that ?
18:18:14 <bauzas> and then we could promote the gerrit proposal into the ML thread
18:18:23 <gibi> bauzas: sure
18:18:26 <bauzas> cool
18:18:30 <gmaan> ++, thanks
18:18:32 <bauzas> gouthamr: put me an AI on it
18:19:12 <bauzas> I'm done on my side for that topic
18:19:13 <gouthamr> #action bauzas propose an update to the Eventlet Removal Goal
18:19:15 <bauzas> thanks for the discussion
18:19:16 <gouthamr> thank you
18:19:27 <gouthamr> final thing before i close this meeting:
18:19:45 <gouthamr> #link https://t.e2ma.net/message/mrxorh/ikxczt (The OpenInfra Summit '25 CFP for Forum Topics & Project Updates Is Now LIVE!)
18:20:03 <bauzas> oh yeah
18:20:09 <bauzas> good call
18:20:29 <gouthamr> ^ we definitely need to drum up more contributor and operator attendance at the Summit, so if you're thinking about it, please do propose your sessions
18:20:45 <gouthamr> anything else for the minutes today?
18:20:52 <bauzas> I think we could do again a nova meet-and-greet party there :)
18:21:12 <bauzas> I'd recommend other projects to do so
18:21:13 <gouthamr> nice, with fine bordeaux
18:21:26 <gouthamr> ill come hang with you fine folks :D
18:21:36 <gouthamr> thank you all for attending, and sorry this went on 21 minutes over
18:21:36 <bauzas> gouthamr: with cotes du rhone and savoie please
18:21:42 <gouthamr> #endmeeting