17:00:38 <gouthamr> #startmeeting tc
17:00:38 <opendevmeet> Meeting started Tue Jul 15 17:00:38 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:38 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <opendevmeet> The meeting name has been set to 'tc'
17:00:45 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:00:48 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:00:50 <gouthamr> #topic Roll Call
17:01:02 <gmaan> o/
17:01:03 <noonedeadpunk> o/
17:01:09 <frickler> \o
17:01:31 <cardoe> o/
17:01:43 <spotz[m]> o/
17:03:32 <gouthamr> courtesy-ping: gtema, mnasiadka, bauzas
17:03:38 <mnasiadka> o/
17:03:41 <bauzas> o/
17:04:39 <gtema> Sorry, forgot to mention earlier, I have another appointment
17:04:55 <gouthamr> ack gtema
17:04:58 <gouthamr> let's get started..
17:05:05 <gouthamr> #topic Last Week's AIs
17:05:17 <gouthamr> we had a few:
17:05:28 <gouthamr> bauzas was going to post an update to the eventlet timeline change proposal
17:05:43 <gouthamr> looks like he did:
17:05:49 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/952903 (Make Eventlet removal deadlines more acceptable for operators)
17:06:15 <gouthamr> i'd like hberaud to weigh in since he's the goal champion.. i'll poke him on #openstack-eventlet-removal
17:07:12 <gouthamr> i took an AI to remind project teams to clean out references to the CLA - this is WIP, i have a bunch of changes myself and i'll follow up with any teams individually, most of these look trivial
17:07:12 <bauzas> cool
17:07:57 <gouthamr> spotz[m] has submitted a proposal for a Forum session with the TC at the OpenInfra Summit, meet-and-greet style
17:08:49 <gouthamr> mnasiadka took an AI regarding adding a doc banner on inactive projects (monasca)
17:09:01 <gouthamr> ^ any updates to report here, mnasiadka?
17:09:25 <mnasiadka> Haven't got to that yet, will try this week - but if I fail to do so - I'm off 21st July to 4th August
17:09:49 <gouthamr> ack
17:09:52 <gouthamr> thanks mnasiadka
17:10:21 <gouthamr> reminds me to note that i'll be lurking here myself until the end of the month, but not "working" :)
17:11:00 <gouthamr> on the proposal to retire monasca.. we noted that there's a procedure to follow to actually pursue
17:11:02 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/953671
17:11:21 <gouthamr> ^ we wanted to get monasca's PTL and contributors chiming in ..
17:11:53 <gouthamr> i just copied the core team there and posed a couple of questions, but we'll take it to the ML in case these folks aren't subscribed to gerrit emails
17:12:05 <gmaan> did we send it on ML? maybe that can help
17:12:09 <gouthamr> #action start a mail thread on monasca's status (gouthamr)
17:12:17 <gouthamr> ^ nope, step 2
17:12:19 <gmaan> yeah, last time, PTl replied on ML
17:12:26 <gmaan> PTL
17:13:28 <gouthamr> ack, will do gmaan
17:13:36 <gmaan> ++
17:14:35 <gouthamr> the last AI was also around the CLA in gerrit.. clarkb and fungi noted that this will take some time and will be combined with other gerrit updates
17:14:54 <fungi> yeah, we've already announced the configuration removal
17:14:55 <gouthamr> i called out that we aren't enforcing the CLA in gerrit, except its still accepting signatures
17:15:43 <fungi> #link https://lists.opendev.org/archives/list/service-announce@lists.opendev.org/thread/GWG7G3WBMGSDOFVC72TPDCADR4VUE5N2/ Removal of CLA enforcement and configuration in Gerrit
17:15:55 <fungi> so friday of this week
17:16:01 <gouthamr> thank you, i was looking in service-discuss
17:16:21 <gouthamr> perfect
17:17:45 <gouthamr> wow, codesearch tells me there are 277 references to "requireContributorAgreement = true" in project-config
17:18:24 <gouthamr> that's all the AIs i see from the past week, was anyone tracking/working on anything else?
17:19:52 <gouthamr> alright lets move on..
17:19:56 <gouthamr> #topic Refreshing service-types-authority maintainers
17:20:08 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/953548
17:20:45 <gouthamr> ^ the discussion happened on the patch and on this channel
17:21:14 <gouthamr> iirc, we (the TC) inherited this repo.. and we're not actively "maintaining" it..
17:21:19 <gmaan> yeah, there are volunteer to maintain this repo
17:21:43 <gmaan> we can keep it under TC but can add more contributor to maintain it as core
17:21:44 <cardoe> Who volunteered?
17:21:51 <gmaan> sdk team
17:22:08 <gouthamr> what's the problem adding this group?
17:22:10 <gouthamr> #link https://review.opendev.org/admin/groups/df83b1d09c45aa21bd95f6a502c71e3c9b7d2999,members
17:22:19 <gouthamr> #undo
17:22:19 <opendevmeet> Removing item from minutes: #link https://review.opendev.org/admin/groups/df83b1d09c45aa21bd95f6a502c71e3c9b7d2999,members
17:22:21 <gouthamr> #link https://review.opendev.org/admin/groups/openstacksdk-core,members
17:22:29 <gmaan> well, frickler has good point of adding explicit member instead og group
17:22:30 <gmaan> of
17:22:45 <gouthamr> my problem is then maintaining that list of people :)
17:23:04 <gmaan> that is what will be explicit and people knows whom to ping to merge the things
17:23:15 <gouthamr> openstacksdk-core is actively maintained by the PTL/core folks of the project, and we can trust them to care for this repo, imo
17:23:30 <gmaan> I do not think that group is all up to dated
17:23:37 <gouthamr> ?
17:23:40 <gouthamr> it is
17:23:44 <gmaan> and that is why i do not think we should add
17:24:15 <gouthamr> do you see anyone there that isn't part of openstacksdk's maintenance?
17:24:21 <gmaan> are all these members active in sdks #link https://review.opendev.org/admin/groups/df83b1d09c45aa21bd95f6a502c71e3c9b7d2999,members
17:25:00 <gouthamr> yes, from what i can tell.. i've interacted with most of those folks on different topics for the sdk/cli
17:25:30 <gmaan> most but not all
17:25:50 <gmaan> anyways my point is if we want to add sdk group I would like to ask those member are ok to maintain it
17:26:23 <gmaan> if not all are ok then we should not add group and ask explicit members who are interested in maintaining service-types-authority
17:27:05 <gmaan> adding group as whole does not solve issue of things not getting merged but explicit interest from people and adding them can
17:27:30 <gouthamr> i feel like the "authority" in the repo's name is making this a special case.. openstacksdk and CLI are pretty canonical, but the TC doesn't actively maintain them.. this is in the same bucket, imho
17:27:50 <gouthamr> i don't know any other direct consumers of this stuff..
17:28:41 <noonedeadpunk> so um
17:28:48 <noonedeadpunk> I am a little bit confused then
17:28:58 <gouthamr> i'm okay for the TC to relinquish control of the repo to the sdk-core.. but, if you disagree, it's worth just adding them all as co-maintainers so they can have as much control over it as any TC member
17:29:05 <noonedeadpunk> as the repository basically defines a canonical names i nthe catalog?
17:29:32 <gouthamr> yes, that's all it does :) because at one time in our history we had a lot of "conflicting" services and arcane names
17:29:34 <gmaan> gouthamr: sure, but I do not want to add them without asking them and until they agree to maintain it
17:29:46 <noonedeadpunk> and pretty much any new type of service or re-naming in the catalog I'd assume should be going through the TC anyway?
17:29:52 <gmaan> we can ask it on ML and who all show interest then we can add them
17:30:13 <noonedeadpunk> so should not it be us at the first place to be interested in maintaining it?
17:30:43 <gmaan> noonedeadpunk: ++ consistent naming is important and TC has discussed in past.
17:30:58 <gmaan> my first preference is TC start maintain it as main repo but we did not
17:31:19 <noonedeadpunk> as it's really like one of "core" repos, based of which other projects are governed partially
17:31:20 <gmaan> I think it came under TC from doc SIG or so
17:31:22 <fungi> can't the sdks team just adopt it as a deliverable?
17:31:55 <gmaan> there was discussion about that in gerrit
17:31:56 <gmaan> #link https://review.opendev.org/c/openstack/governance/+/953548/comments/0cdf6463_6f83c47d
17:32:00 <frickler> that's what was proposed, but I'm arguing that it should stay with the TC
17:32:13 <noonedeadpunk> ++
17:32:15 <gmaan> ++ I agree ^^
17:32:37 <gouthamr> the argument that frickler had was "not only apply an SDK-centric view on this, but also involve developer and deployer perspectives"
17:32:37 <gouthamr> i agree with this
17:33:00 <gmaan> and if anyone interested to help I am not against of adding them but adding group or hand over to other group is not best solution
17:33:09 <noonedeadpunk> and given that tc is generally represented by such groups... :)
17:33:33 <noonedeadpunk> right
17:33:39 <gouthamr> but i still want the sdk team tacked on it as a whole.. don't want to piecemeal this.. because stephenfin or gtema may be interested in fixing something today, but tomorrow they can move on, and the TC wouldn't need to find other interested voices on the sdk team
17:34:00 <noonedeadpunk> though if we are adding extgra groups, we still should be keeping an eye on what's happening there
17:34:21 <gmaan> gouthamr: maybe one extra task for chair/meeting, but we should start tracking open reviews on TC own repo . at least that will remind us to reviews the repo other then governance
17:34:41 <gouthamr> +1 i can add it
17:34:42 <noonedeadpunk> we can get a review board
17:34:47 <gmaan> as a code maintainer and governance repo as governance things
17:34:47 <gouthamr> yeah
17:35:00 <gmaan> thanks
17:35:12 <noonedeadpunk> and also marked projhects we're responsible for as parents to TC in gerrit
17:35:13 <gmaan> so coming back to this topic
17:35:21 <noonedeadpunk> then we could use a filter like `parentproject`
17:35:40 <gmaan> should we ask volunteer on ML or TC commit to maintain it by themself ?
17:35:46 <noonedeadpunk> not sure if it's suitable in this case...
17:36:02 <noonedeadpunk> but eases maintaining a list you need to be on top of
17:36:06 <gmaan> it should stay under TC but question is do we need more maintainers or TC can handle
17:36:21 <gmaan> noonedeadpunk: ok
17:36:23 <noonedeadpunk> so I think that TC should be able to handle reviews there?
17:36:42 <noonedeadpunk> and contributions are always welcome, to any repo?
17:36:49 <gmaan> cool, I will add it in my review list
17:37:23 <noonedeadpunk> I could be wrong, I just brefily looked through the content of it
17:38:27 <gouthamr> #link https://service-types.openstack.org/
17:38:36 <noonedeadpunk> and it looked like this thing is the main asset there: https://opendev.org/openstack/service-types-authority/src/branch/master/service-types.yaml
17:38:47 <noonedeadpunk> rest is more or less supporting/hooks around it
17:39:01 <gouthamr> yeah it probably needs a bunch of cleanup
17:39:14 <gouthamr> there's old cruft there by the looks of it..
17:39:20 <noonedeadpunk> oh yes, sure
17:39:26 <gmaan> mostly schema etc too
17:39:49 <gmaan> it is very low maintenance things but important stuff to maintain as consistently
17:40:33 <gouthamr> which i think openstacksdk-core has the energy/motivation to do..
17:40:43 <noonedeadpunk> well, I mean. I don't need to have a +W on nova or cinder if I'm maintaining some driver or depend on it
17:41:39 <noonedeadpunk> I think I less care about schema/generation stuff ratgher then any potential changes to that yaml
17:41:59 <noonedeadpunk> which should be done pretty much only with tc approval
17:42:25 <gmaan> yeah make sense.
17:43:19 <noonedeadpunk> and also I don't really understand why absent +W prevents from doing some clean-up/changes in a repo
17:43:29 <gmaan> these are open changes, mainly trivial if anyone would like to merge. I am +2 on mostly
17:43:29 <noonedeadpunk> or proposing them,
17:43:38 <gmaan> #link https://review.opendev.org/q/project:openstack/service-types-authority+status:open
17:44:06 <gmaan> I think if we keep reviewing and merging the housekeeping work then its all good.  and keep eyes on any major change
17:44:29 <noonedeadpunk> ok, doing reviews is indeed smth we should do and I'll also go through them now
17:44:41 <gouthamr> +1
17:44:41 <gmaan> thanks
17:44:52 <mnasiadka> Not that I'm complaining, but is there a Gerrit dashboard that covers all TC maintained repos? I'm not that good in reading emails from Gerrit ;-)
17:45:04 <gouthamr> we should make a new one
17:45:15 <gmaan> I used to have one but not sure if that is there in my browser history
17:45:23 <gmaan> I can check and link here after meeting
17:45:32 <gouthamr> #link https://gerrit-dash-creator.readthedocs.io/en/latest/
17:45:47 <gouthamr> ^ maybe using this.. that's a good AI to come out of this :)
17:46:07 <gouthamr> i don't want to sound like a broken record, i don't think it's a good move for us to add interested maintainers since a team can handle maintenance of all logically connected things better than individuals can, and we'll bottleneck this.. but, it looks like gmaan and frickler have good points as to why adding individuals would be better.. anyone else have any strong opinions for or against?
17:46:46 <gouthamr> if not, i think the individuals you mean to add could start with stephenfin? do you want to offer it up to the ML?
17:47:29 <noonedeadpunk> oh, I thought it's also installed...
17:47:29 <gmaan> I think noonedeadpunk pointed that we should keep it in TC as core and welcome other to propose things or even review
17:47:43 <gouthamr> oh, how did i misread that?
17:47:59 <gmaan> if TC is ok to maintain which seems yes then I am ok to continue that as it is. no change in core group needed
17:48:12 <noonedeadpunk> though I failed so far to convert some of dashboard s to it :(
17:48:29 <gouthamr> so our AI would be that we try to get better at reviews for this repo/'
17:48:32 <gouthamr> ?*
17:48:52 <gmaan> ++ and include other TC owned repo also in the review checks in meeting or so
17:48:56 <gouthamr> yes
17:49:02 <gmaan> thanks
17:49:10 <gouthamr> okay, ty for bringing this up
17:49:19 <spotz[m]> ++
17:49:24 <gouthamr> #link https://governance.openstack.org/tc/reference/technical-committee-repos.html
17:49:30 <noonedeadpunk> or come up with dashboard and use it for reviews :)
17:49:41 <gmaan> yeah ^^
17:49:43 <gouthamr> yes, any volunteers to craft a fancy gerrit dashboard?
17:50:07 <noonedeadpunk> I can try that... I did for OSA a sweet dashboard, except failed to pass it to creator...
17:50:28 <gouthamr> i think creator was abandoned on the wayside
17:50:48 <gouthamr> but please do link us when you do noonedeadpunk
17:51:05 <fungi> i suspected it might be, but i saw commits merged in it last year
17:51:22 <gouthamr> ah, who's active there?
17:51:30 <fungi> looks like ironic folks were doing stuff in it
17:51:40 <gouthamr> i think the first contact SIG folks may be interested in maintaining that :)
17:51:44 <fungi> so guessing they're relying on it
17:52:05 <spotz[m]> First Contact SIG hasn't met in ages
17:52:10 <fungi> yeah, as chair i'd also be fine moving it under the tact sig
17:52:25 <fungi> since it's related to openstack's use of testing and collaboration tools
17:52:31 <gmaan> afaik,  first contact SIG is not active much, I am one of the member there and not seen any activity since year or long
17:52:45 <gouthamr> that'd be awesome fungi
17:53:24 <gouthamr> low maintenance i'd assume, but famous last words.. if this is active, we can encourage core teams to start throwing in dashboard links that they can make up
17:53:29 <fungi> i'm not committing to review changes or maintain it, just welcoming the people who are taking care of it under the sig so they get some additional recognition as an official effort within the community
17:54:11 <fungi> and it could also get renamed to openstack/gerrit-dash-creator if they're interested in doing so, if it were under a sig
17:55:00 <gouthamr> the activity on First Contact SIG has been mainly around university internships, spearheaded by diablo_rojo
17:56:14 <gouthamr> we've done like tens of these over the past few years, i think.. but, maybe the efforts like workshops at summits, other conferences etc are happening through different folks' efforts (spotz[m] for instance).. so the group exists, but, things are being driven pretty dynamically
17:57:48 <gouthamr> lets chat about this after the meeting if necessary.. i'm interested :)
17:57:55 <spotz[m]> Well the group met for a while but with the different timezones attendance declined to nothing. OUI hasn't been run in ages. I know diablo_rojo does stuff with the universities and they may use some of the materials but I personally wasn't aware that was being called part of the first contact SIG
17:58:07 <gmaan> one of the main  motive to form this group was monitor new contributors and help them to onbaord in projects
17:58:28 <gmaan> we used to do that with this biweekly work
17:58:31 <gmaan> #link https://wiki.openstack.org/wiki/First_Contact_SIG#Biweekly_Homework
17:58:39 <gmaan> which has been stopped for years
17:58:51 <gouthamr> i see, yeah some of that wasn't sustainable
17:59:16 <spotz[m]> And mentoring program died out, the cohort idea didn't turn things around as hoped
17:59:45 <gouthamr> ack..
18:00:10 <gouthamr> time check, we just have a minute left, i can ask if diablo_rojo_phone can join us in a future meeting to discuss the SIG
18:00:24 <gouthamr> (ugh, i took the minute to type that out)
18:00:34 <fungi> the original catalyst was the bursts of low-value changes getting proposed by companies trying to increase their stackalytics ranking, and the hope that the community could steer them toward more productive contributions
18:00:36 <gouthamr> does anyone have anything else to note in the minutes today
18:01:15 <gmaan> but anything we are stuck due to  First Contact SIG ? or we are checking on all SIG status?
18:01:40 <gouthamr> i think a while ago we wanted to check on all the SIGs
18:01:42 <gmaan> I am little confused on topic got diverted in  First Contact SIG
18:01:49 <fungi> in theory the sigs should all be checking in periodically so we can figure out which ones are still active
18:01:50 <opendevreview> Merged openstack/service-types-authority master: Replace deprecated classes, functions  https://review.opendev.org/c/openstack/service-types-authority/+/953559
18:01:57 <gmaan> yeah, we can do that as part of SIG check
18:02:06 <gmaan> fungi: ++
18:02:07 <gouthamr> if you'd like i can start a series of SIG checks during these meetings
18:02:15 <fungi> gmaan: it started with the suggestion of fc sig adopting gerrit-dash-creator
18:02:32 <gmaan> or maybe in PTG or every cycle like we started DPL model projects
18:02:35 <fungi> so yes, a tangent
18:03:37 <gouthamr> okay, i can think about how to do it at the PTG
18:04:04 <gouthamr> thanks for staying on the extra few minutes
18:04:12 <gouthamr> and for the review attention to service-types-authority
18:04:34 <gouthamr> lets catch up with this meeting again next week, don't drop the chatter in the meantime
18:04:40 <gouthamr> #endmeeting