17:00:29 <gouthamr> #startmeeting tc
17:00:29 <opendevmeet> Meeting started Tue Aug  5 17:00:29 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:29 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:29 <opendevmeet> The meeting name has been set to 'tc'
17:00:34 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
17:00:39 <gouthamr> #link https://www.youtube.com/@openstack-tc
17:00:47 <gouthamr> #link https://meetpad.opendev.org/openstack-tc-weekly
17:01:11 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:01:17 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:01:22 <gouthamr> #topic Roll Call
17:02:06 <gouthamr> gmaan is on the Meetpad
17:02:08 <gouthamr> as is fungi
17:03:39 <gmaan> o/
17:04:13 <gouthamr> not here today: mnas iadka, g t e m a, b a u za s, n o onedeadpunk
17:04:49 <gouthamr> courtesy-ping: spotz[m], cardoe
17:04:59 <gouthamr> so lots of people are out today
17:05:00 <mnasiadka> o/
17:05:02 <mnasiadka> I'm here
17:05:04 <gouthamr> hey there mnasiadka
17:05:21 <gouthamr> welcome back, we're here https://meetpad.opendev.org/openstack-tc-weekly
17:06:37 <gouthamr> #topic Last Week AIs
17:08:00 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/F4XQ7QU2S4WCNOVCGW3ZONI4IYX4KVFW/
17:08:06 <gouthamr> ^ we meant to follow up on this thread
17:08:32 <gouthamr> #link https://etherpad.opendev.org/p/monasca-retirement
17:09:17 <gouthamr> we can proceed with the retirement process here
17:09:17 <cardoe> I'm connecting
17:09:51 <gouthamr> gmaan is concerned about steps breaking the CI and needing a lot of time from a volunteer
17:10:13 <gouthamr> the retirement steps are well recorded
17:10:46 <gouthamr> i can volunteer to drive this
17:11:03 <gouthamr> it might be slow and buggy, but i'll seek help via reviews through the process
17:11:57 <gouthamr> next AI, we were discussing the runtime update required for the Gazpacho release
17:12:29 <gouthamr> no work has been done here yet, besides past discussions on what test platforms may be available and what we'll need to ensure we test eventlet removal
17:13:06 <gouthamr> gmaan is concerned about the python version that we'll test with
17:13:38 <gouthamr> we are testing with python 3.13 in a non-voting job now
17:14:11 <gouthamr> typically we determine the python version's support timeline vs the longevity/availability of the openstack release
17:15:05 <fungi> debian 13 (trixie) is releasing this weekend on saturday, 2025-08-09 with python 3.13 as its default and *only* python interpreter version
17:15:15 <gouthamr> besides that, we'll also look at what the distros are shipping with as default ^
17:15:51 <gouthamr> ty fungi
17:15:52 <clarkb> and eventlet compatibiltiy right?
17:16:04 <gouthamr> yes
17:16:24 <fungi> per last week's meeting, things are working in debian with 3.13 but i don't know what the shortcomings are wrt eventlet there
17:16:40 <mnasiadka> Debian Bookworm EOL is 2026-06-10
17:17:08 <mnasiadka> So Debian users will probably want to upgrade beyond this point to Trixie which is 3.13 only
17:20:01 <fungi> users on debian 12/bookworm will probably be able to take advantage of debian-lts after the official eol if they need to stay on it, but yes we shouldn't force them to do that
17:20:50 <gouthamr> frickler was working on a job with trixie
17:20:53 <gouthamr> #link https://zuul.opendev.org/t/openstack/build/383c2cdaf5714e2f851ad85f20ae4ed7/logs
17:20:58 <gouthamr> #link https://review.opendev.org/c/openstack/devstack/+/954653
17:21:22 <gouthamr> s/on a job with trixie/adding support to deploy on trixie
17:22:15 <fungi> opendev hasn't started mirroring packages for trixie, but will likely do so very soon (i think that job is temporarily just not using our mirrors to get around it)
17:22:20 <gouthamr> gmaan says that the test results look encouraging, the next step would be to go beyond the smoke tests that have run on this job
17:22:28 <gouthamr> ack fungi
17:22:44 <gouthamr> anything else about the impending runtime update?
17:23:09 <gouthamr> the last AI that i see is regarding defining "affiliation" in teh TC's charter
17:23:26 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/956024 (Define "affiliation" within the context of the TC)
17:25:29 <gouthamr> some TC folk are out for a couple more weeks, so we may not pick up the 2/3rds majority to get this in this week
17:25:53 <gouthamr> gmaan is hoping we can merge this change prior to teh nomination window closing
17:27:09 <gouthamr> that's all the AIs i was tracking
17:27:14 <gouthamr> was anyone else working on anything else?
17:28:59 <gouthamr> the last OpenInfra AI Working Group discussion was recorded
17:29:02 <gouthamr> #link https://lists.openinfra.org/archives/list/ai-openstack-wg@lists.openinfra.org/message/NLGRKUNLAIZTX6TBOJYSV3OX4E3F6OFC/
17:29:21 <gouthamr> ^ please find the recording and the etherpad capturing the discussion linked in this thread
17:29:44 <gouthamr> #topic A check on gate health
17:29:54 <gouthamr> any CI issues or updates to share this week?
17:30:30 <gouthamr> gmaan noted a prior failure with timeouts in the grenade skip level job
17:30:42 <gouthamr> they were being addressed by gibi's change as we noted last week
17:31:01 <gouthamr> has anyone noticed any other failures with this job (or any other job) to note here?
17:31:31 <fungi> there were some debian job failures for a few days because our mirror grew stale due to one of the older suites getting dropped from upstream debian mirrors
17:32:08 <fungi> also openmetal is doing maintenance on our cluster there, and we neglected to take it offline before they brought the mirror server down, resulting in some failures
17:32:30 <gouthamr> ack, the base Ceph job is the newest using debian bookworm, and has quite a good footprint.. i haven't seen any new failures
17:32:34 <fungi> (it's out of our configuraiton now, but thankfully doesn't account for a large amount of our total quota)
17:32:40 <gouthamr> ++ thanks fungi
17:33:06 <fungi> that's all i had for updates
17:33:18 <gouthamr> #topic TC Tracker
17:33:18 <gouthamr> #link https://etherpad.opendev.org/p/tc-2025.2-tracker (Technical Committee activity tracker - 2025.2)
17:34:35 <gouthamr> regarding the first item on the list: the user survey
17:34:37 <gouthamr> it
17:34:47 <gouthamr> is open to take until the end of this month
17:35:01 <gouthamr> but, we did see requests to update questions on the next user survey
17:35:23 * gouthamr will connect with aprice and helena and get them to coordinate with PTLs/project teams when we wrap this survey
17:36:47 <gouthamr> gmaan continues to work on the SRBAC goal
17:36:59 <gouthamr> in nova (manager and service roles are being added)
17:37:38 <gouthamr> he's concerned about projects that have not yet completed phase 1
17:38:56 <gouthamr> there's work also happening in tempest where the tests will use the least privileged user in different contexts
17:39:19 <gouthamr> the latest on this is on the etherpad:
17:39:27 <gouthamr> #link https://etherpad.opendev.org/p/rbac-goal-tracking
17:40:38 <gouthamr> we are discussing about bubbling this back up to the mailing list
17:40:52 <gouthamr> there could be bandwidth and time concerns to chase this down in Flamingo
17:41:10 <gouthamr> #link https://governance.openstack.org/tc/goals/proposed/migrate-from-wsgi-scripts-to-module-paths.html
17:41:20 <gouthamr> ^ we had a proposed goal that may be obselete now
17:43:27 <gouthamr> #action gouthamr will check with stephenfin and see if we can mark this complete
17:43:40 <fungi> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/WNI4PE2TZ3G52C3U5FT2YNVRUAJB3CMO/ Decommissioning RefStack and retiring related software
17:45:01 <gouthamr> fungi notes that python-tempestconf seems to be actively maintained
17:45:15 <gouthamr> this isn't an OpenStack deliverable today
17:45:49 <gouthamr> gmaan mentions that openstack-qa considered it in the past, however, it doesn't directly map to the testing tooling the team maintans
17:46:10 <gouthamr> Red Hat developers seem to be invested in this repository
17:46:51 <gouthamr> fungi says that Red Hat folks can fork the project and ship/maintain this further
17:47:07 <gouthamr> so the repos here can be cleaned up from the openinfra namespace on opendev.org
17:50:12 <gouthamr> the other concern was about the refstack-server being used to run a subset of tests to qualify a cloud
17:51:38 <gouthamr> we'll try to get these folks talking to openstack-qa to create a replacement procedure
17:51:46 <gouthamr> #topic Open Discussion
17:52:25 <fungi> oops, sorry i meant to bring the refstack thing up under open discussion, just thought you'd missed updating the topic
17:52:51 <gouthamr> #link https://review.opendev.org/q/project:openstack/governance+status:open
17:54:58 <gouthamr> okay we wrapped up on Meetpad
17:55:10 <gouthamr> with a note to review any open governance changes
17:57:10 <gouthamr> and other changes in repos owned by the TC, like:
17:57:10 <gouthamr> #link https://review.opendev.org/q/project:openstack/openstack-manuals+status:open
17:57:15 <gouthamr> thank you all for attending
17:57:20 <gouthamr> see you here next week!
17:57:22 <gouthamr> #endmeeting