17:01:20 <gouthamr> #startmeeting tc
17:01:20 <opendevmeet> Meeting started Tue Sep  2 17:01:20 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:20 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:20 <opendevmeet> The meeting name has been set to 'tc'
17:01:38 <gouthamr> #info Today's meeting is being held primarily via video call. Action items and meeting minutes will be documented in IRC but for a full replay of the meeting, please visit the OpenStack TC youtube channel, where the recording will be uploaded soon.
17:01:43 <gouthamr> #link https://www.youtube.com/@openstack-tc
17:03:23 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:03:27 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:03:37 <gouthamr> #topic Roll call
17:03:38 <noonedeadpunk> o/
17:03:44 <gtema> o/
17:03:45 <gmaan> o/
17:03:53 <spotz[m]> o/
17:04:25 <mnasiadka> o/
17:04:55 <gouthamr> courtesy-ping: jbernard
17:05:06 <gouthamr> in the video call: cardoe
17:05:19 <gouthamr> #topic Last Week's AIs
17:05:41 <cardoe> o/
17:05:47 <cardoe> I didn't speak up here sorry.
17:06:02 <gouthamr> no worries
17:06:29 <gouthamr> close the "Migrate from WSGI scripts to module paths" goal as completed.
17:06:44 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/958817
17:07:20 <gouthamr> continue the discussion on the Monasca repository retirement on Gerrit
17:07:46 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/953671
17:11:12 <gouthamr> the contributor will need to be told about forking projects into their own namespace on opendev.org
17:11:12 <gouthamr> gmaan suggests that the TC discussion/decision is warranted
17:11:48 <gouthamr> he's concerned about the perception that the TC proceeds with the retirement despite a volunteer showing up to continue maintaining it
17:12:47 <gouthamr> bauzas states that he'd like to be honest about the state of things - and indicate to users/operators not to use/rely on the project team or OpenStack contributors for continued support/development
17:13:17 <gouthamr> noonedeadpunk states that projects have started retiring monasca integrations already since our email communique
17:15:02 <gouthamr> bauzas is asking if namespace changes are trivial? if they are, why are we not suggesting this as a solid path forward
17:15:21 <gouthamr> gmaan states that this has happened before with a project under neutron team's governance
17:18:40 <gouthamr> we're currently discussing how things would work if the projects are in their own namespace
17:19:10 <clarkb> noonedeadpunk: note that they can continue to use the same jobs most likely. You are right taht the secrets will have to be updated if they have any
17:19:15 <gouthamr> test jobs will require a major update, and there may be issues - you'll need new user accounts/secrets configured
17:19:51 <noonedeadpunk> clarkb: but they're using jobs which are defined for a different tenant
17:19:54 <noonedeadpunk> like horizon job
17:20:07 <noonedeadpunk> I think they will need to re-define them for their tenant, no?
17:20:21 <clarkb> no, they just need to configure their tenant to load jobs from devstack, tempest, or horizon etc
17:20:35 <clarkb> jobs live in git repos. Tenants are configured to load zuul configuration (including jobs) from git repos
17:21:05 <noonedeadpunk> oh, yes, right, that's how zuul-jobs is consumed
17:21:10 <clarkb> I'm pretty sure we even have third party ci deplyoments running zuul for cinder jobs using the same jobs that are defined upstream
17:21:13 <noonedeadpunk> I clean forgot that
17:21:25 <clarkb> they just configure their entirely different zuul installation with their entirely separate zuul tenant to load jobs from devstack etc
17:21:50 <noonedeadpunk> ++ right, sorry, I clean forgot you can do that
17:21:55 <gouthamr> we're reminding ourselves that the Documentation, Git repos/README files etc need to be updated to reflect the state of maintenance
17:22:01 <clarkb> you are correct that a new different projectwith forked code will have different encryption secrets
17:22:09 <clarkb> so those aprticular bits will need updating if they are used
17:22:45 <noonedeadpunk> I'd guess these are related to releasing if exist, which we don't want them to have anyway...
17:22:59 <gouthamr> #link https://review.opendev.org/c/openstack/governance/+/958229
17:22:59 <gouthamr> ^ this is a missing annotation in our project tracking that will be helpful to implement an automated doc/readme update
17:27:32 <gouthamr> seeking reviews on this, and further comments on the governance change
17:27:50 <gouthamr> next AI was about elections
17:27:54 <gouthamr> blast existing members to remind them to renew their memberships for the upcoming elections
17:28:53 <JayF> I'd suggest another reminder to the list for folks to opt-in to CIVS emails as well
17:30:36 <gouthamr> JayF: ianychoi/slaweq are working on that
17:30:49 <gouthamr> #link https://review.opendev.org/c/openstack/election/+/958991
17:32:30 <gouthamr> another reminder is forward looking, i.e., the next cycle's election - i.e., to sign up for Foundation Individual Membership to be able to vote in these elections, or to renew their erstwhile membership
17:32:49 <gouthamr> i took an AI to bring the openstack election issue to the board meeting next week (9th Sep)
17:33:00 <gouthamr> #link https://board.openinfra.org/
17:33:36 <gouthamr> clarkb states that the board elections had an earlier cutoff than OpenStack elections (20th Aug)
17:34:06 <gouthamr> spotz[m] sent notes regarding the 180-day requirement (lost in matrix)
17:35:05 * gouthamr will ping jbernard for an update on the TC resolution for phone-home in OpenStack
17:35:42 <gouthamr> the last AI that i was tracking was the job templates for the 2026.1 runtime
17:36:05 <gouthamr> #link https://review.opendev.org/c/openstack/openstack-zuul-jobs/+/958616
17:36:19 <gouthamr> #link https://review.opendev.org/c/openstack/openstack-zuul-jobs/+/958617
17:36:33 <gouthamr> ^ the latter is WIP until we ship the RC for 2025.2
17:36:50 <gouthamr> that's all the AIs i was tracking, anything else from anyone else?
17:37:03 <gouthamr> #topic 2026.1 Elections - Leaderless teams
17:37:22 <gouthamr> #link https://etherpad.opendev.org/p/2026.1-leaderless
17:39:12 <gouthamr> these are teams with no PTL candidates, and we have 6 options on what to do next
17:39:42 <gouthamr> noonedeadpunk was the past PTL for vitrage and is providing a state of maintenance
17:39:58 <gouthamr> there are failing tests, and he's not had time to dig into the failures
17:41:25 <gouthamr> noonedeadpunk will likely take some time next week to address the test failures, and check on any release patches
17:42:19 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/CVWXC6RRTBWRDNQR2TTMT6FN4ZNUVJHH/
17:42:46 <gouthamr> vitrage, venus were part of the list compiled by elodilles with test jobs failing on master
17:45:17 <gouthamr> we have issues finding the PTL or contributors for OpenStack Charms on IRC
17:45:34 <gouthamr> we're tried going to external channels to reach them, including posting on reviews
17:45:57 <gouthamr> the project repos are constantly updates though
17:46:40 <gouthamr> bauzas states that the project doesn't fit OpenStack governance
17:46:58 <gouthamr> what if there's a serious/security issue that we need to communicate with the coresec/PTL for?
17:48:21 <gouthamr> #topic Tagging retired packages on PyPi
17:48:40 <gouthamr> #link https://etherpad.opendev.org/p/legacy-pypi-packages
17:49:10 <gouthamr> #link https://blog.pypi.org/posts/2025-08-14-project-status-markers/
17:49:18 <gouthamr> #link https://packaging.python.org/en/latest/specifications/project-status-markers/
17:51:25 <gouthamr> asking if there are any objections in doing this as part of the repository retirement steps in OpenStack
17:53:13 <gouthamr> the list on the etherpad are only the already-retired (i.e., a bulk of the monasca packages won't be there, only the already retired ones are)
17:53:46 <gouthamr> #action add this to the tracker and find time/volunteers to do this
17:54:40 <gouthamr> #topic A check on gate health
17:54:57 <gouthamr> have there been any gate concerns to share?
17:55:58 <gouthamr> clarkb notes that the debian trixie nodes were using debian-testing ; infra admins are updating it after the GA, there was a bug preventing the update - its being worked on
17:56:28 <gouthamr> #topic Open Discussion and Reviews
17:57:02 <gouthamr> we do have a couple of items here - if folks want to rep these/discuss them here, please feel free
17:57:16 <gouthamr> noonedeadpunk brought up default MySQL/MariaDB charset/collations
17:57:42 <gouthamr> there's a changed behavior in MariaDB 11.8
17:57:47 <gouthamr> #link https://mariadb.com/docs/server/reference/data-types/string-data-types/character-sets/supported-character-sets-and-collations
17:57:54 <gouthamr> #link https://mariadb.com/docs/server/reference/data-types/string-data-types/character-sets/setting-character-sets-and-collations#changing-default-collation
17:58:28 <gouthamr> noonedeadpunk wants to discuss this further, and highlight common updates we want to make
17:58:34 <noonedeadpunk> #link https://bugs.launchpad.net/magnum/+bug/2121797
17:58:51 <clarkb> the utf8mb3 -> utf8mb4 transition is lossless but does require a proper migration as the underlying storage gets rewritten aiui. However changing the collation has impacts on sorting, case sensitivity, and so on
17:59:18 <noonedeadpunk> #link https://mariadb.com/docs/release-notes/community-server/old-releases/release-notes-mariadb-11-5-rolling-releases/what-is-mariadb-115#other
17:59:30 <noonedeadpunk> mariadb has also changed collation and how it treats it
17:59:47 <noonedeadpunk> #link https://jira.mariadb.org/browse/MDEV-37544
18:00:04 <noonedeadpunk> as from 11.5 the default is uca1400_ai_ci
18:00:26 <noonedeadpunk> but then it does not respect the default the way it used to for a decade
18:00:28 <gouthamr> we'll discuss ^ and the alma linux testing topic next week
18:00:28 <gouthamr> does anyone have anything else to note for the minutes today?
18:00:56 <gouthamr> thank you all for attending
18:01:01 <cardoe> Thanks all. Have a good rest of the week.
18:01:18 <gouthamr> see you here next week!
18:01:20 <gouthamr> #endmeeting