17:00:11 <gouthamr> #startmeeting tc
17:00:11 <opendevmeet> Meeting started Tue Sep 30 17:00:11 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:11 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:11 <opendevmeet> The meeting name has been set to 'tc'
17:00:30 <gouthamr> Welcome to the weekly meeting of the OpenStack Technical Committee. A reminder that this meeting is held under the OpenInfra Code of Conduct available at https://openinfra.dev/legal/code-of-conduct.
17:00:33 <gouthamr> Today's meeting agenda can be found at https://wiki.openstack.org/wiki/Meetings/TechnicalCommittee
17:00:35 <gouthamr> #topic Roll Call
17:01:30 <frickler> \m/
17:02:15 <gouthamr> courtesy-ping: noonedeadpunk, spotz[m], gtema, cardoe, mnasiadka
17:02:18 <mnasiadka> o/
17:02:47 <cardoe> o/
17:04:06 * gouthamr waits
17:05:22 <gouthamr> alright, lets get started..
17:05:30 <gouthamr> #topic Last Week's AIs
17:06:23 <gouthamr> we took an AI to check on the "leaderless" teams:
17:06:23 <gouthamr> OpenStack Charms: this has a PTL nominee since our meetin g last week: https://review.opendev.org/c/openstack/governance/+/962121
17:06:48 <gouthamr> ^ please do check the comments for questions concerning the project, and its leadership that we had asked in past meetings
17:07:35 <gouthamr> it has the requisite votes to merge tomorrow.. in case you'd like to add yours, please do
17:08:01 <gouthamr> for the rest, lets look at:
17:08:01 <gouthamr> #link https://etherpad.opendev.org/p/2026.1-leaderless
17:08:34 <noonedeadpunk> oops sorry
17:08:35 <noonedeadpunk> o/
17:08:40 <gouthamr> the Venus project looks quite "abandoned" to me... i think its worth retiring the deliverables and the project team
17:09:05 <gouthamr> "There are 0 merged patches generated within 180 days"
17:09:39 <noonedeadpunk> sad it didn't fly. as idea was really nice of free and powerful central log solution
17:09:58 <frickler> don't we need to go via marking inactive first? like to give contributors a chance to show up?
17:10:07 <noonedeadpunk> especially if it would collaborate with vitrage for rca :D
17:11:19 <gouthamr> projects can directly be retired, there's no need to go through "inactive" phase: https://governance.openstack.org/tc/reference/dropping-projects.html#process
17:11:33 <gouthamr> but, i don't see any harm in going that route..
17:11:49 <noonedeadpunk> they can, but I think question was regarding of opprotunity to pick up the ball
17:12:14 <gouthamr> caveat: we still have the issue of visibility of an "inactive" project
17:12:19 <gouthamr> to end users and operators
17:13:22 <gouthamr> assuming we can worry about that as a separate issue.. are there any proponents of direct retirment here?
17:14:19 <gouthamr> if not:
17:14:19 <gouthamr> #action: mark venus as "inactive" and alert the openstack-discuss ML
17:14:41 <gouthamr> okay, lets chat about vitrage..
17:15:16 <gouthamr> we haven't had any volunteers show up here, despite the ML bump
17:15:52 <gouthamr> and there may be issues for maintainers to resolve in the meantime that could force our hand in case we're unable to get attention
17:16:28 <gouthamr> is it worth putting through the same bucket, i.e., marking "inactive"?
17:17:41 <cardoe> makes sense to me
17:17:42 * gouthamr thinks out aloud - an "inactive" project that remains in that state beyond the Gazpacho release will be retired in the "H" release
17:18:15 <fungi> remember that inactive projects become super fun to deal with when the vmt receives vulnerability reports for them
17:18:31 <frickler> G is 2026.1? why can't we give up on those confusing names?
17:18:32 <fungi> we'll be escalating those to the tc members, typically
17:19:13 <noonedeadpunk> Eh, well. I may step up at the end of the day for Vitrage
17:19:52 <noonedeadpunk> With summit arriving I just having less and less cycles available for anything though
17:20:08 <clarkb> frickler: I have to look at the release schedule every time to make sense of them
17:20:29 <clarkb> but yes https://releases.openstack.org/ confirms G is 2026.1
17:20:41 <noonedeadpunk> and my criteria of stepping in I set if I will get actually time to look into failing tempest tests
17:20:50 <noonedeadpunk> (and I have not have any time yet)
17:21:14 <gouthamr> its possible to tag the project "inactive" and if things get better by M-2, it can be added to the release
17:21:15 <noonedeadpunk> so seems like I've failed own criteria...
17:21:48 <noonedeadpunk> So Jan05
17:21:53 <noonedeadpunk> yeah, ok, sounds reasonable
17:22:08 <gouthamr> yes: Jan 05 - Jan 09, the "R-12" week is Gazpacho-2 milestone
17:22:16 <noonedeadpunk> so pretty much a revert for Inactive should be created and stepping in as PTL I guess?
17:22:36 <gouthamr> two separate things, imo
17:22:42 <gouthamr> inactive projects can have a PTL
17:23:00 <gouthamr> might need one really so they can form a team
17:23:07 <noonedeadpunk> but we move it to inactive because of absent ptl :)
17:23:15 <gouthamr> ye
17:23:43 <noonedeadpunk> so they're very related :) inactive can be with ptl, but not vice versa
17:24:09 <fungi> it can be without ptl if the team has a full slate of active dpl liaisons
17:24:19 <noonedeadpunk> oh, yes, sure
17:24:22 <noonedeadpunk> right
17:25:10 <fungi> but yes, a longstanding misconception is that dpl doesn't solve the problem of not having enough volunteers to lead the team, if anything it needs more volunteers
17:26:25 <gouthamr> #action: mark vitrage as "inactive" and alert the openstack-discuss ML
17:26:37 <gouthamr> the last project in this list is monasca
17:26:54 <gouthamr> the project stats for this have been confusing, but, we kinda knew that there was _some_ activity
17:27:13 <gouthamr> i.e., a couple of maintainers who now are okay with retirement
17:28:02 <gouthamr> so i floated a patch to mark the project "inactive" through 2025.2, i need some more eyes here: https://review.opendev.org/c/openstack/governance/+/959392
17:28:40 <gouthamr> we will NOT retire the project in 2025.2, but we may do so in 2026.1
17:29:11 <gouthamr> so, this update is procedural
17:29:56 * gouthamr will refresh the retirement change since it's gone into merge conflict
17:30:07 <frickler> "may do so"? what's blocking us from proceeding with the retirement right away?
17:30:29 <gouthamr> my time
17:31:13 <frickler> so just ask for a volunteer to create the necessary cleanup patches and we are fine?
17:31:34 <gouthamr> not a joke, i followed up with the requester, but didn't hear back - i'm unsure if they've gerrit emails filtered.. so i wanted to send them a note elsewhere
17:32:53 <gouthamr> but, i don't understand what problem we have with https://review.opendev.org/c/openstack/governance/+/959392
17:33:11 <gouthamr> i mean, it's the reality, correct? we're making no promises regarding 2026.1 on that change
17:33:16 <frickler> it doesn't help anyone, that's my problem
17:33:52 <gouthamr> sorry, i'm going to point out that it was a process that the TC adopted.. we can change the process if you'd like to stop doing it
17:34:51 <gouthamr> in all likeliness, we'll come around and undo the change in a few weeks, as part of the retirement
17:35:15 <gouthamr> i want to separate the concerns and make incremental progress
17:36:51 <frickler> well, just go ahead, then? no need to discuss this endlessly, let's move on
17:37:13 <gouthamr> well, i need votes on a "formal-vote" patch like this one
17:38:05 <gouthamr> noonedeadpunk: cardoe could you please review https://review.opendev.org/c/openstack/governance/+/959392.. it's okay to -1, it'll get dropped if there are enough -1s
17:38:19 <cardoe> I already +1'd it
17:38:29 <gouthamr> ah, didn't refresh
17:38:34 <gouthamr> okay, lets move on to other AIs
17:38:41 <cardoe> I'm okay extending.
17:38:54 <gouthamr> re: Default MySQL/MariaDB charset/collations changes, noonedeadpunk any updates on this?
17:39:42 <gouthamr> probably not..
17:40:00 <noonedeadpunk> I think I need to propose community goal for that
17:40:10 <noonedeadpunk> but it has not been done yet
17:40:16 <gouthamr> +1, no rush, just had that in my notes..
17:40:26 <gouthamr> the last AI that i had was around TC roles
17:40:33 <gouthamr> i nominated myself as chair
17:40:55 <gouthamr> and there were no other nominations.. so i'll proceed with the next step
17:41:17 <noonedeadpunk> thanks for stepping in!
17:41:22 <gouthamr> i do need a vice-chair nominee, if you're interested, please let me know
17:41:34 <gouthamr> (this extends to the others not here currently)
17:41:59 <gouthamr> i'll throw up a change for the chair, and it can be updated to add the vice-chair too
17:42:29 <gouthamr> the TC also had liaisons for (1) DPL projects and (2) OpenStack VMT
17:44:27 <gouthamr> freezer: https://opendev.org/openstack/governance/src/commit/1a2ac945da2fbcc1e0f391d2effeca362b63622f/reference/projects.yaml#L252-L254
17:44:27 <gouthamr> Oslo: https://opendev.org/openstack/governance/src/commit/1a2ac945da2fbcc1e0f391d2effeca362b63622f/reference/projects.yaml#L1969-L1971
17:44:27 <gouthamr> Release Management: https://opendev.org/openstack/governance/src/commit/1a2ac945da2fbcc1e0f391d2effeca362b63622f/reference/projects.yaml#L2259-L2261
17:44:27 <gouthamr> Requirements: https://opendev.org/openstack/governance/src/commit/1a2ac945da2fbcc1e0f391d2effeca362b63622f/reference/projects.yaml#L2298-L2299
17:45:00 <gouthamr> #link http://wiki.openstack.org/wiki/CrossProjectLiaisons#Vulnerability_management
17:45:17 <gouthamr> ^ we need to refresh these, and i would like volunteers please
17:45:52 <gouthamr> if you're interested, you can nominate yourself right away - propose changes to the governance repo directly by replacing gmaan..
17:46:36 <gouthamr> for the VMT, i'll continue, and b a u z a s may as well..
17:46:46 <fungi> much appreciated!
17:46:56 <gouthamr> he'll confirm async
17:47:44 <gouthamr> we can chat about all of this lazily, async.. so everyone has an opportunity to respond.. i'll just take note to make all of these changes by next week
17:47:58 <gouthamr> any questions, concerns?
17:48:29 <gouthamr> #topic Skyline Health / Release / Patch Merging
17:48:44 <gouthamr> i think this was a very positive interaction
17:48:51 <noonedeadpunk> ++
17:48:53 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/Z6TG6JLN2M25T3CIMZHATSVKUVAFJVDK/
17:49:48 <gouthamr> very glad that you took the lead on this, cardoe and the responses from wu-wenxiang were enlightening, and positive
17:50:03 <frickler> yes, good progress has been made, which may now stall for a bit due to a major chinese holiday
17:50:14 <cardoe> Yeah which is okay.
17:50:25 <gouthamr> i personally think it'll be nice to get sowmya added to the core maintainers team, and have them coordinate any further inclusions
17:51:10 <cardoe> I've told her that I'm happy to mentor her.
17:51:22 <frickler> showing some review activity would be a good next step IMO
17:51:56 <cardoe> That's what I was actually telling her yesterday.
17:52:32 <gouthamr> perfect, maybe a slot at the PTG may be a good place to gather anyone else that's interested
17:52:54 <gouthamr> anyone can propose these, fungi and diablo_rojo_phone can help create a spot assuming there's room
17:54:22 <gouthamr> i'd join and ask noob questions
17:55:08 <frickler> iiuc most current cores aren't comfortable with audio/video calls
17:55:41 <gouthamr> the maintainers may choose not to join, they prefer long form async communication as they've stated.. but, you may find other interested people willing to come speak
17:55:48 <gouthamr> frickler: yes
17:56:24 <gouthamr> but i'm sure they'll like the recorded feedback on an etherpad or an ML summary
17:56:45 <frickler> sure
17:57:10 <gouthamr> cardoe: this may need some of your handholding, if you think its a good idea
17:57:41 <gouthamr> anything else for $topic?
17:58:17 <cardoe> Yeah I'm trying to think.
17:58:19 <cardoe> I don't know.
17:58:45 <cardoe> I don't want to pressure the current folks with methods they aren't comfortable with or with timing that doesn't work.
17:58:55 <cardoe> But I certainly want to find a way to get more folks engaged.
17:59:38 <cardoe> I know that in the past for me when I'd see projects where only changes were being merged for co-workers its cause folks were done with the project and just forced to engage from their job.
17:59:45 <cardoe> So that's where I thought it was heading.
18:00:59 <gouthamr> yeah, its now apparent that the project survives because of the goodwill of the people that started it.. we need to augment the team to help it sustain/thrive nevertheless.
18:01:02 <gouthamr> time check
18:01:06 <gouthamr> we're over the hour
18:01:36 <gouthamr> #topic A call for PTG Topics (gouthamr)
18:01:36 <gouthamr> #link https://etherpad.opendev.org/p/oct2025-ptg-os-tc
18:01:36 <gouthamr> ^ this is just informational today, please do add any topics here for the PTG discussions. I reserved some room (Tuesday and Friday) tentatively, we can discuss async and add or remove slots
18:01:42 <gouthamr> #topic Open Discussion
18:01:49 <gouthamr> anything else to add to the minutes today?
18:02:37 <frickler> in combination with the discussion about the timing for the meeting, I'd also like to see confirmation whether there is still a majority that wants to do video meetings
18:02:44 <gouthamr> ^ yes
18:02:52 <gouthamr> we're coming up on one
18:03:01 <gouthamr> and i think its worth asking
18:03:39 <spotz[m]> I'm good either way. Before I forget I should be here next week but will be out the following 2
18:03:40 <gouthamr> lets run a poll! :)
18:03:40 <gouthamr> i'll add some "alternate" time slots that were missing from the original poll
18:03:51 <frickler> and I'd like to have a meeting slot that fits EU+APAC once a month, so something in the 8-12 UTC range
18:04:15 <frickler> and I'll also be offline the whole next week and maybe beyond, just ftr
18:04:25 <gouthamr> ack
18:04:38 <mnasiadka> frickler: The EU+APAC slot would probably imply an APAC or EU vice-chair?
18:04:44 <gouthamr> i'll share this poll
18:04:46 <gouthamr> mnasiadka: yes
18:05:02 <frickler> mnasiadka: that would sure be very helpful, thanks for volunteering :D
18:05:20 <mnasiadka> I didn’t say I’m volunteering - but if there’s no other volunteer - I can put my name forward…
18:05:39 <gouthamr> mnasiadka: +1 ty
18:05:54 <gouthamr> i'll run a poll with these questions too, so people can add their opinions async
18:06:02 <gouthamr> thanks everyone, lets wrap it up here
18:06:04 <gouthamr> #endmeeting