14:01:19 <sgordon> #startmeeting telcowg
14:01:20 <openstack> Meeting started Wed Feb 11 14:01:19 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:23 <openstack> The meeting name has been set to 'telcowg'
14:01:28 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
14:01:50 <sgordon> #topic roll call
14:01:55 <amitry> hello
14:02:02 <sgordon> \p>
14:02:04 <pczesno> hi
14:02:07 <gmatefi> hi
14:02:07 <dkusidlo> hi
14:02:08 <vks> hi
14:02:22 <adrian-hoban> Hello
14:02:33 <ajo> hi :)
14:02:36 <cloudon> hi
14:02:56 <wznoinsk> hi
14:03:07 <sgordon> #topic action items from last week
14:03:15 <sgordon> i dont see ijw yet so will skip his
14:03:25 <sgordon> #info mkoderer was to define scope of OpenStack HA use case clearly
14:03:30 <ian_ott> hi
14:03:45 <aveiga> o/
14:03:55 <sgordon> #info sgordon was to request git repo via infra
14:03:55 <ralfT> hi
14:04:04 <sgordon> #info sgordon to request git repo via infra
14:04:05 <sgordon> so
14:04:10 <vks> so is it up?
14:04:13 <sgordon> i haven't requested a git repo yet
14:04:26 <sgordon> as mkoderer pointed out we haven't actually had any feedback on the original test review
14:04:43 <sgordon> other than the thread on operators list that went well off topic
14:04:45 <beagles> o/
14:04:46 <sgordon> #link https://review.openstack.org/#/c/152940/1
14:05:11 <sgordon> i did add some info to the wiki
14:05:14 <sgordon> #link https://wiki.openstack.org/wiki/TelcoWorkingGroup/UseCases#Reviewing_Use_Cases
14:05:41 <adrian-hoban> If it helps, I'm just starting to review the SBC use case now...
14:05:47 <sgordon> it does!
14:05:53 <sgordon> :)
14:06:29 <sgordon> i think going down that path makes sense, but we do need people to try it out and see if it makes sense for them too
14:06:29 <raul__> hi
14:06:35 <sgordon> (adding comments etc. directly in gerrit)
14:07:23 <vks> i have a question, are we trying to move ahead with SBC exclusively for now?
14:07:54 <sgordon> we're using it to trial the mechanism for reviewing
14:08:02 <sgordon> if that is successful i will import the others too
14:08:21 <vks> ok
14:08:33 <vks> implementation???
14:08:46 <sgordon> basically i want to make sure creating launchpad accounts and reviewing using gerrit isn't too hard for anyone
14:08:59 <sgordon> implementation comes afterwards, we cant implement if we dont agree on the use case
14:09:07 <sgordon> and the requirements derived from it
14:09:09 <vks> ok
14:09:55 <vks> i assume we will be focussing on single site first. correct me if i am wrong
14:09:57 <aveiga> vks: the use cases are our way of getting input on requirements from non-developers
14:10:06 <sgordon> vks, yes that's correct
14:10:15 <aveiga> then we can do gap analysis on them and provide useful blueprints for implementation
14:10:19 <vks> aveiga, thats correct
14:11:30 <sgordon> so that i have names against the action item
14:11:43 <sgordon> who else is will to try add some comments to the SBC review this week to prove out the mechanism?
14:11:53 <sgordon> i have myself and adrian-hoban as lucky volunteers so far
14:12:01 <cloudon> I'll give it a shot too
14:12:31 <ian_ott> i will as well
14:12:54 <vks> well i will ask some questions to u guys ;)
14:13:18 <sgordon> #action sgordon, adrian-hoban, cloudon, ian_ott, vks  to review SBC use case and leave comments in Gerrit https://review.openstack.org/#/c/152940/1
14:13:27 <sgordon> vks, that's fine - and really the idea :)
14:14:05 <sgordon> so there were a few other discussion items i wanted to get to
14:14:23 <sgordon> adrian-hoban, pczesno i believe these are yours - particularly that Nova FFE?
14:14:39 <sgordon> #topic Nova FFE request for libvirt vhostuser
14:14:56 <pczesno> sgordon: yes, we would like to ask for support
14:15:34 <sgordon> so what is unclear to me at the moment, is if *any* nova FFEs will be granted
14:15:35 <pczesno> sgordon: the vhostuser support was on the table since juno
14:15:42 <sgordon> for things that aren't on the nova priorities list
14:16:06 <pczesno> sgordon: yes that remains to be seen
14:16:06 <sgordon> the feeling at the midcycle seemed to be a clear no
14:16:18 <sgordon> but there are sponsors etc. signing up to things on the M/L
14:16:52 <pczesno> currently we have nonw
14:16:54 <pczesno> none
14:17:12 <sgordon> #link     http://lists.openstack.org/pipermail/openstack-dev/2015-February/056312.html
14:17:27 <sgordon> #info Nova vhostuser FFE request requires support
14:17:46 <sgordon> ok
14:17:50 <pczesno> thanks
14:17:53 <sgordon> so
14:18:02 <sgordon> not directly related, but since you and adrian-hoban_ are here
14:18:10 <sgordon> i got asked about sriov ci yesterday
14:18:15 <adrian-hoban_> :-)
14:18:16 <sgordon> do you happen to know current status?
14:18:26 <adrian-hoban_> Just posted an update to the mailing list
14:18:28 <sgordon> #topic sr-iov ci
14:18:56 <adrian-hoban_> Mail subject was: "Testing NUMA, CPU pinning and large pages"
14:19:13 <sgordon> ah yes
14:19:29 <sgordon> thanks for that
14:19:33 <adrian-hoban_> np
14:19:41 <sgordon> i think the other concern was simply that someone be reporting into the nova meetings
14:19:52 <sgordon> i attend them most weeks if you need a relay
14:19:55 <sean-k-mooney> #link http://lists.openstack.org/pipermail/openstack-dev/2015-February/056583.html
14:19:59 <sgordon> but ideally it would be someone actually running it
14:20:10 <sgordon> #link http://lists.openstack.org/pipermail/openstack-dev/2015-February/056583.html
14:20:26 <adrian-hoban_> We'll have a guy at it next week (Ireland friendly time)
14:20:57 <sgordon> cool
14:21:00 <sgordon> thanks for that
14:21:09 <adrian-hoban_> Look out for "wznoinsk" on the chat...
14:21:25 <sgordon> #info Adrian provided SR-IOV/NFV CI update to M/L and will have someone attending Nova meeting next week.
14:21:38 <sgordon> ok
14:22:04 <sgordon> i did not have anything else for this week, if we get some input on that review then hopefully we can go ahead and create a repo
14:22:09 <sgordon> #topic repo naming
14:22:18 <sgordon> i was going to suggest the super original telcowg-usecases
14:22:21 <adrian-hoban_> Before we move past the CI for NFV....
14:22:37 <adrian-hoban_> Was going to ask for some feedback on our coverage from this team
14:23:11 <adrian-hoban_> Across our NFV CIs we plan on covering PCIe + SR-IOV + NUMA (CPU & I/O) + CPU Pinning + Huge Pages + networking-ovs-dpdk (mech driver)
14:23:27 <adrian-hoban_> Any gaps in that list for Kilo?
14:23:48 <aveiga> I have a question there
14:23:51 <sgordon> sure
14:23:53 <sgordon> #undo
14:23:54 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x9900a10>
14:23:56 <aveiga> how far out is port security?
14:23:59 <cloudon> large pages?
14:24:07 <cloudon> sorry, strike that
14:24:17 <sgordon> adrian-hoban_, that is good to my understanding
14:24:51 <sgordon> aveiga, you mean the ml2 port security extensions tuff?
14:24:59 <aveiga> sgordon: yes
14:25:18 <sgordon> so iirc that was what ijw had said he was going to check in on
14:25:19 <adrian-hoban_> sgordon: Thanks
14:25:23 <aveiga> considering a lot of the devices that can do SR-IOV also support some type of OVS model on the card to handle things like L2 mappings
14:25:27 <ijw> I was?
14:25:30 <aveiga> it would be nice to see if they can work together
14:25:32 <ijw> My ears are burning
14:25:41 <vks> adrian-hoban_, so all the listed ones got implemented
14:25:42 <vks> ?
14:25:48 <sgordon> yeah you made the mistake of volunteering yourself last week
14:25:49 <sgordon> <aveiga> how far out is port security?
14:25:49 <sgordon> <cloudon> large pages?
14:25:51 <sgordon> whoops
14:25:59 <sgordon> ijw_ checking with Sweta if any blocking issues on ML2 port security
14:25:59 <ijw> Let me check my email, I sent one in the meeting and forget the answer
14:26:47 <ijw> OK - apparently I didn't hit send, sorry.  Let me actually check the BP right now
14:27:03 <sgordon> #link https://review.openstack.org/#/q/topic:bp/ml2-ovs-portsecurity,n,z
14:27:46 <adrian-hoban_> vks: Some good progress with NUMA (CPU & I/O), CPU pinning, huge pages all part of kilo-2. Not much movement on SR-IOV. The new mech driver for ovs-dpdk-netdev is making good progress too.
14:27:48 <aveiga> sgordon: thanks
14:28:39 <sgordon> np
14:29:09 <sgordon> couple more comments since last week
14:29:20 <sgordon> no changes to the patch itself tho
14:30:48 <sgordon> ok
14:30:58 <sgordon> #topic repo naming
14:31:07 <sgordon> i was going to suggest the super original telcowg-usecases
14:31:10 <sgordon> any objections?
14:32:06 <aveiga> sgordon: that's fine
14:32:13 <vks> sgordon, can we have meeting at this time every week??
14:32:24 <vks> if no one has problem
14:32:26 <sgordon> ijw might kill me
14:32:37 <ijw> I would never do that.
14:32:40 <ijw> I have people for that.
14:32:43 <sgordon> basically we alternate to ensure we can cater to a variety of time zones
14:32:47 <vks> ok
14:32:49 <sgordon> as we have a broad spread of contributors
14:33:18 <sgordon> i manage to do both since they are at opposite ends of my work day to try and provide some continuity
14:33:42 <sgordon> we did used to meet at this time every week but there was a lot of feedback to offer another option
14:33:54 <vks> ijw, 1800UTC or 1900UTC ???
14:35:39 <ijw> vks: 1800UTC would be fine, but the point with the meeting times was to catch China one way and here and points west the other
14:36:09 <adrian-hoban_> vks: Are the two time slots that we have now not suitable?
14:36:17 <ijw> sgordon: Shweta's changes seem to be moving - there's quite a lot of review comments but they're the good sort
14:37:28 <vks> 2200UTC is problem.
14:38:20 <aveiga> unfortunately no matter what we pick, some people will not be able to make all the meetings
14:38:23 <aveiga> that's why we alternate
14:38:31 <vks> ok np
14:38:52 <mkoderer_cloud> sgordon: how do we want to call the launchpad group? just telcowg?
14:38:56 <aveiga> if we moved the 2200 meetings up four hours, you'll be waking people in East Asia up at 4 AM
14:39:11 <sgordon> mkoderer, or openstack-telcowg?
14:39:23 <mkoderer_cloud> sgordon: ok also fine
14:39:24 <sgordon> ijw, yeah that sounds good
14:40:10 <mkoderer_cloud> I will give an internal workshop to teach ppl "how to review"
14:40:27 <mkoderer_cloud> maybe I can invite more ppl and put it to ML
14:40:30 <sgordon> yeah, i am happy to help with that as well
14:40:53 <ijw> vks: the idea is that even missing every other meeting there should be enough people in common to get the work done
14:40:58 <sgordon> #info repo name will be telcowg-usecases
14:41:13 <vks> no issues
14:41:19 <sgordon> mkoderer, so are you creating the lp group etc.?
14:41:44 <mkoderer_cloud> sgordon: I am a bit busy currently.. but I can do
14:42:00 <sgordon> ok
14:42:08 <sgordon> just let me know what you can do and i will pick up the rest
14:42:13 <sgordon> just want to avoid duplicating effort
14:42:17 <mkoderer_cloud> sgordon: ok sounds great
14:42:31 <sgordon> cool
14:42:47 <sgordon> #action mkoderer and sgordon to work together on LP and repo creation
14:42:51 <sgordon> #topic other discussion
14:43:00 <sgordon> did anyone have anything else they would like to raise today?
14:43:08 <cloudon> would like to flag mkoderer's (I think) etherpad on orchestration @ https://etherpad.openstack.org/p/telco_orchestration
14:43:23 <cloudon> have added comments on my view of how OpenStack sits with the ETSI NFV orchestration model, particularly on the implications of the NFV Orchestrator spanning multiple clouds
14:43:38 <cloudon> may be surprising/controversial to some, so interested in feedback
14:43:55 <cloudon> net is it identifies Heat with the NFV VNFM component, and lists some gaps I see it having for that role
14:44:07 <mkoderer_cloud> cloudon: yeah we need to move forward with that disucssion in general
14:44:37 <mkoderer_cloud> cloudon: I think we should transform it to a "use case" and do a review
14:44:43 <vks> cloudon, i can help
14:45:19 <sgordon> #info cloudon flagged some comments on orchestration @ https://etherpad.openstack.org/p/telco_orchestration
14:45:54 <sgordon> mkoderer_cloud +1
14:47:31 <mkoderer_cloud> sgordon: regarding HA topic
14:47:52 <adrian-hoban_> Will we hold on it landing in gerrit before reviewing then?
14:48:08 <mkoderer_cloud> sgordon: there are some ppl very instressted on that. I will work together with them in the next weeks
14:48:19 <sgordon> mkoderer_cloud, ack
14:48:22 <sgordon> thanks
14:48:47 <mkoderer_cloud> I will put everything in here https://etherpad.openstack.org/p/telcowg-usecase-openstack-ha
14:50:10 <sgordon> #link https://etherpad.openstack.org/p/telcowg-usecase-openstack-ha
14:50:23 <sgordon> #action mkoderer to continue working on HA user case
14:50:26 <sgordon> #undo
14:50:27 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9430e50>
14:50:29 <sgordon> #action mkoderer to continue working on HA use case
14:52:48 <sgordon> ok
14:52:55 <sgordon> thank you all for your time
14:53:08 <sgordon> lots of good items today...
14:53:10 <sgordon> #endmeeting