19:00:07 <sgordon> #startmeeting telcowg
19:00:08 <openstack> Meeting started Wed Jul 22 19:00:07 2015 UTC and is due to finish in 60 minutes.  The chair is sgordon. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:09 <sgordon> #link https://etherpad.openstack.org/p/nfv-meeting-agenda
19:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:12 <sgordon> #topic roll call
19:00:13 <openstack> The meeting name has been set to 'telcowg'
19:00:13 <sgordon> \o/
19:00:24 <cloudon> hi
19:00:24 <ralfT> hi
19:00:26 <sgordon> who is around for the telco working group meeting?
19:00:38 <ralfT> me
19:00:46 <cloudon> +1
19:00:59 <AndroUser> +1
19:01:11 <sgordon> ok
19:01:21 <sgordon> some quick house keeping updates
19:01:29 <sgordon> #topic openstack operator's mid-cycle
19:01:49 <sgordon> the operator's mid-cycle has been announced and is fast approaching for those interested
19:01:51 <sgordon> #link http://lists.openstack.org/pipermail/openstack-operators/2015-July/007634.html
19:02:12 <sgordon> there is not currently any plan to propose a telco-specific session for this specific one
19:02:14 <sgordon> #link https://etherpad.openstack.org/p/PAO-ops-meetup
19:02:28 <sgordon> in my case that is because i wont actually be there due to a set of conflicting events in seattle
19:02:39 <sgordon> if somebody else wants to pick that up though feel free
19:03:03 <ralfT> i won't be there
19:03:50 <sgordon> stick with me a second, grabbing link for next topic
19:04:35 <sgordon> #topic product working group update
19:04:38 <sgordon> #link https://docs.google.com/document/d/1XpQ1PjyCqbtTIKUbPESp3AbdjUSuIP7GVjda6Cy0EY8/edit
19:05:16 <sgordon> just as an fyi the product working group continues to attempt to define itself and exactly how it will work with existing efforts like this group, large deployments group etc
19:05:34 <sgordon> the google doc linked is their template review, it is originally based on ours but is changing a bit as the feedback rolls in
19:05:55 <sgordon> so noting that, who added proposed new template format to the agenda :)
19:06:02 <cloudon> that would be me...
19:06:16 <cloudon> had a stab at changing my vIMS one to new format
19:06:36 <cloudon> reasonably painless - only one issue really
19:06:48 <cloudon> interested in feedback on how it reads
19:07:06 <cloudon> issue is the general vs. the specific
19:07:11 <sgordon> ok, i saw the push message in #openstack-nfv earlier :)
19:07:32 <sgordon> #info cloudon has updated vIMS submission to match updated format, needs feedback on how it reads
19:07:53 <cloudon> IIUC new template is encouraging use cases to be general, with specific implementations given as examples
19:08:21 <sgordon> yes
19:08:35 <ralfT> I'll forward the link to the user story template to my colleagues
19:08:41 <sgordon> looking at the feedback on the productwg version some may think even that is too specific !
19:08:48 <sgordon> but i think it's appropriate for this group
19:09:19 <ralfT> should we rewrite the use cases, which we are working on?
19:09:23 <cloudon> my $0.02: makes for tighter, more real-world & focussed use cases if based on specific
19:10:00 <cloudon> otherwise get lots of "but it could do X, Y or Z" comments
19:10:01 <sgordon> ralfT, for those that havent been merged yet i think it would be helpful to try re-work them
19:10:12 <sgordon> butttt let's talk about the next topic this clashes into
19:10:23 <sgordon> #topic repository management questions
19:10:30 <sgordon> #link http://lists.openstack.org/pipermail/openstack-operators/2015-July/007611.html
19:10:49 <sgordon> i sent the above out asking for feedback on two items regarding repository management for telcowg-usecases
19:10:59 <sgordon> #info Adding Daniel Schabarum and Yuriy Babenko as cores
19:11:09 <sgordon> #info Future location of repository?
19:11:22 <sgordon> the second part is perhaps more controversial than i first thought
19:11:33 <sgordon> i got several off list responses
19:11:46 <cloudon> quick aside on the mail; did you mean to send to operators ML?
19:11:51 <sgordon> the suggestion i had made was moving the repository from the stackforge/ namespace to the openstack/ one
19:12:14 <sgordon> i actually did as the use case management does not have much to do with dev, though i guess i now know not everybody filters both for NFV
19:12:17 <sgordon> (or telco)
19:14:52 <sgordon> anyhoo, the responses i got were quite varied:
19:15:03 <sgordon> * use product working group repo for telco use cases instead?
19:15:16 <sgordon> * move under user committee governance instead of technical committee?
19:15:32 <sgordon> * abandon and use neutron/nova rfe and backlog processes instead
19:15:57 <sgordon> by way of background the only reason that led me to suggest moving it at all is that there is a proposal up to deprecate and ultimately remove stackforge
19:17:26 <tariqk> So is the intent to leave it as is for now or do we have any viable options?
19:17:42 <sgordon> we have a plethora of viable options, see above ;)
19:17:50 <sgordon> * move to openstack/ under TC governance
19:17:57 <sgordon> * move to openstack/ under UC governance
19:18:05 <sgordon> * move into productwg
19:18:15 <sgordon> * radically change process/approach
19:18:41 <tariqk> I vote for openstack under UC governance
19:18:56 <cloudon> what practical differences are there in first 2 from what we have now?
19:19:06 <sgordon> limited
19:19:16 <sgordon> they are just different paths to the openstack/ namespace
19:19:32 <sgordon> user committee probably is a better fit/lower bar just based on what this group produces
19:19:50 <tariqk> Agree
19:19:56 <sgordon> TC would be more appropriate if we expected to produce code directly in our repo
19:20:03 <sgordon> but we dont
19:20:11 <cloudon> sounds like UC to me then
19:20:21 <ralfT> as we are writing user stories it's UC for me
19:20:39 <sgordon> ok sounds like it is unanimous from those here
19:20:56 <sgordon> #action sgordon to write list proposing to move under UC and openstack/ namespace
19:21:09 <sgordon> ok
19:21:12 <sgordon> #topic reviews
19:21:25 <sgordon> cloudon, already mentioned vIMS is ready for more reviews
19:21:33 <sgordon> #link https://review.openstack.org/179142
19:21:41 <sgordon> i see the SBC has some new updates as well
19:21:59 <sgordon> #link https://review.openstack.org/176301
19:22:05 <cloudon> yes - some links to BP which have been completed - just need to check status of them all and update
19:22:23 <sgordon> #info cloudon updated vIMS and SBC use case proposals
19:22:35 <sgordon> #info sgordon updated template and workflow proposals
19:22:41 <sgordon> #link https://review.openstack.org/178347
19:22:46 <sgordon> #link https://review.openstack.org/199654
19:22:57 <sgordon> i should note the template update is just to mark two sections as optional
19:23:06 <sgordon> as there was some confusion expressed in the product wg review of it
19:23:17 <sgordon> will not require further reframing/rewriting of existing proposals
19:27:41 <sgordon> ok
19:27:51 <sgordon> without further ado i will call this closed then
19:28:02 <sgordon> #info Yuriy and Daniel added to core
19:28:34 <sgordon> #endmeeting