15:01:28 <gordc> #startmeeting telemetry
15:01:28 <openstack> Meeting started Thu Jan 21 15:01:28 2016 UTC and is due to finish in 60 minutes. The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:32 <ityaptin> o/
15:01:32 <openstack> The meeting name has been set to 'telemetry'
15:01:34 <sileht> o/
15:01:44 <zqfan> hi
15:01:45 <cdent> o/
15:01:46 <liusheng> o/
15:01:50 <r-mibu> o/
15:01:54 <llu-laptop> o/
15:02:08 <ildikov> o/
15:02:09 <gordc> let's go.
15:02:15 <gordc> #topic roadmap items (new/old/blockers) https://wiki.openstack.org/wiki/Telemetry/RoadMap
15:02:24 <gordc> just a heads up
15:02:28 <idegtiarov_> hi!
15:02:41 <gordc> today i tagged and released m-2 releases for aodh and ceilometer
15:02:41 <achatterjee_> Hi
15:02:59 <gordc> i will start with liberty releases soon (if gate works)
15:03:16 <gordc> and i will also tag whatever is last commit in ceilometerclient
15:03:55 <gordc> plesae yell now if you need something (it's already too late for m-2)
15:04:19 <cdent> I NEED A PIZZA
15:04:38 <gordc> the pizza shop near me closed for renovations
15:05:34 <_nadya_> o/
15:05:42 <gordc> ok. well just a reminder, http://docs.openstack.org/releases/schedules/mitaka.html
15:06:04 <gordc> you have ~a month until feature freeze
15:06:23 <gordc> if anything is dragging, please raise concerns asap
15:06:44 <ildikov> I hope I can get the docco in by then for Aodh, I have a +2 now :)
15:07:04 <gordc> ildikov: :)
15:07:35 <gordc> ildikov: i don't want to debbie downer again but we will probably need to update again later: http://specs.openstack.org/openstack/ceilometer-specs/specs/mitaka/only-support-sqlalchemy-in-aodh.html
15:07:41 <gordc> ildikov: but let's get your patch in first.
15:08:53 <gordc> ok. let's talk about each project
15:08:59 <gordc> #topic aodh topics
15:09:45 <gordc> llu-laptop: do you think the event-alarm timeout and multi-worker bps will be done this cycle?
15:10:13 <llu-laptop> I should ask edwin-zhai about that.
15:10:27 <llu-laptop> looks like his bp still needs review
15:10:44 <ildikov> gordc: well, let's get this in first and then I'll update
15:10:54 <llu-laptop> for the multi-worker, I currently don't have the bandwidth for that, sorry
15:11:18 <ildikov> gordc: the packaging is still not sorted out either as far as I checked last time :(
15:11:21 <gordc> llu-laptop: sure, let's defer it then unless you find time.
15:11:46 <gordc> ildikov: i believe ubuntu just made package recently. EmilienM ?
15:11:57 <EmilienM> o/
15:12:08 <gordc> aodh ubuntu? ready finally?
15:12:09 <EmilienM> for aodh -> yes and it works on mitaka only (trusty and after)
15:12:11 <ildikov> gordc: would be cool, I will check SUSE too, haven't done it this week
15:12:16 <EmilienM> for gnocchi: nothing. I created the bug
15:12:19 <EmilienM> no reply
15:12:23 <llu-laptop> r-mibu: do you have time to review edwin's event alarm related spec?
15:12:31 <gordc> EmilienM: surprise.
15:12:32 <EmilienM> gordc: can I quit?
15:12:36 <ildikov> EmilienM: great, thanks for the update
15:12:36 <gordc> wrong window
15:12:41 <llu-laptop> https://review.openstack.org/239312
15:12:46 <EmilienM> lol
15:12:51 <llu-laptop> https://review.openstack.org/258163
15:13:00 <gordc> we all quit later. but it's secret
15:13:14 <r-mibu> llu-laptop: yep, i've already reviewed #239312
15:13:34 <gordc> pradk: do you think you'll get gnocchi alarm rules in soon?
15:13:39 <gordc> r-mibu: thanks!
15:13:49 <r-mibu> llu-laptop: will check #258163
15:13:58 <llu-laptop> r-mibu: thx
15:14:11 <llu-laptop> r-mibu: can you +2 for 239312?
15:14:23 <pradk> pradk, yea i saw some comments from llu i'll address today.. Zi said he wants to look at tests, i'll check what the status is
15:14:24 <r-mibu> llu-laptop: yes
15:14:35 <pradk> gordc, ^^
15:14:39 <r-mibu> llu-laptop: do we have spec for multi-worker?
15:14:57 <llu-laptop> r-mibu: i'm afraid not
15:15:02 <gordc> pradk: kk. i'm just waiting on tests i think.
15:15:03 <r-mibu> llu-laptop: ok
15:15:28 <gordc> r-mibu: we will probably delay it unles we get more resource.
15:15:39 <llu-laptop> pradk: what comment?
15:15:45 <r-mibu> gordc: agree
15:16:34 <pradk> llu-laptop, https://review.openstack.org/#/c/266073/
15:16:37 <gordc> pradk: let's aim for aodhclient release next week? ok with you?
15:16:51 <pradk> gordc, yea
15:16:59 <gordc> pradk: cool cool
15:19:21 <gordc> #action release aodhclient next week when gnocchi rules are in
15:19:30 <gordc> #action delay event multi-worker
15:19:38 <gordc> #topic ceilometer topics
15:20:38 <gordc> i guess nothing here. just keep working...
15:21:01 <gordc> _nadya_: any comments on https://review.openstack.org/#/c/267625/
15:21:28 <_nadya_> gordc: based on logs, it works better :)
15:21:48 <_nadya_> gordc: but delta graph is the same, we discussed that
15:22:04 <gordc> _nadya_: that's better.
15:22:28 <gordc> _nadya_: i see. i'll take a look at doc again. the deltas will definitely be off once any agent join/leaves
15:22:39 <gordc> _nadya_: thanks again for studying this.
15:22:46 <_nadya_> gordc: we need https://review.openstack.org/#/c/209799/ be merged
15:23:19 <gordc> _nadya_: ack. i'll take a look again.
15:23:19 <liusheng> _nadya_: thanks, I just updated the spec
15:23:34 <_nadya_> gordc: thanks!
15:23:42 <gordc> llu-laptop: jd__: sileht: if you have time to review polling spec ^
15:23:58 <_nadya_> liusheng: cool!
15:24:48 <_nadya_> jfyi, the PoC is here https://review.openstack.org/#/c/267078/3
15:25:22 <llu-laptop> this one?
15:25:23 <llu-laptop> https://review.openstack.org/#/c/209799/
15:25:33 <gordc> llu-laptop: correct
15:25:38 <_nadya_> ityaptin: do you have anything regarding this^^?
15:26:12 <llu-laptop> will do
15:26:31 <ityaptin> PoC is out-of-date, because the spec have been updated, but I made some tests
15:26:37 <gordc> llu-laptop: thank you.
15:26:46 <liusheng> _nadya_: the change will be smaller if we agree to a global cache directly by pollsters
15:27:01 <gordc> ityaptin: cool cool
15:27:15 <ityaptin> It's works good with metadata updating period = 600s and cpu and network polling interval = 1s, for the 50 VMs on devstack.
15:27:50 <gordc> ityaptin: nice. that sounds promising.
15:27:51 <ityaptin> Unfortunately, I don't have a good lab with many compute for testing it.
15:28:13 <gordc> ityaptin: it's optional right? 'global' cache?
15:28:55 <ityaptin> In the new spec variant I think yes.
15:29:31 <ityaptin> liusheng: Am I right? Without global cache we can to store cache in the polling agent cache
15:29:37 <gordc> k. sounds good.
15:30:01 <liusheng> ityaptin: if you have any suggestion about the spec, please feel free to comment
15:30:14 <ityaptin> liusheng: in progress :)
15:31:20 <liusheng> ityaptin: without global cache, it seems meaningless, right?
15:31:46 <gordc> liusheng: the suggestion is people can still continue to use polling as it currently works
15:32:11 <gordc> but if they want to minimise queries more, then can switch to global cache
15:32:23 <liusheng> gordc: yeah, I agree that
15:32:55 <gordc> cool cool.
15:33:03 <gordc> let's change to gnocchi.
15:33:09 <gordc> #topic gnocchi topics
15:33:31 <gordc> jd__: sileht: interesting stuff that needs to be discussed?
15:34:02 <gordc> should we publish an update to say what's been done for gnocchi since <time>?
15:34:54 <jd__> we could gather release note I guess
15:35:08 <jd__> I didn't spend time digging into reno, and if it can be integrated into our docco
15:35:22 <gordc> jd__: it's a lot of work. tbh
15:35:51 <jd__> gordc: to write it?
15:35:59 <gordc> yeah.
15:36:16 <gordc> you need to gen template, write something in a section...
15:36:35 <gordc> i guess it's just two steps... ijust don't like writing relesae notes i guess
15:37:07 <gordc> *drop either one of the 'i guess' from sentence above*
15:38:16 <gordc> let's move on.
15:38:31 <gordc> #topic open discussion
15:38:52 <gordc> just an fyi, we have same opportunity to ask a question in openstack survey this cycle
15:39:08 <gordc> i don't really have a question to ask but if anyone does, i need to submit something by today.
15:40:11 <gordc> i'll take that as no...
15:40:33 <gordc> last chance for any additional discussions in this meeting...
15:41:14 <llu-laptop> can we reuse our last cycle's question?
15:41:46 <llu-laptop> only 1 question?
15:41:50 <gordc> llu-laptop: was it helpful?
15:41:57 <gordc> llu-laptop: yes, one question. same format
15:42:32 <gordc> llu-laptop: i believe the reply from last cycle was pretty much 'we ues ceilometer data for everythiing'
15:43:19 <llu-laptop> i'm just wondering if this survey will have more response, because it's conducted by openstack official?
15:44:00 <gordc> llu-laptop: it probably will.
15:44:11 <gordc> i don't remember the actual numbers
15:44:25 <llu-laptop> last one seems about 20ish?
15:45:00 <llu-laptop> but only 1 question I doubt how it's helpful
15:45:09 <gordc> 154 replies
15:45:23 <gordc> from official survey
15:45:51 <ildikov> we can try that once more if we don't have anything else
15:46:01 <ildikov> prolly will not hurt
15:46:06 <llu-laptop> hmm, looks like my memory is in chaos
15:47:25 <gordc> ildikov: did we get a lot of value from learning 'use of ceilometer data'?
15:48:30 <ildikov> gordc: maybe not, we needed to improve things anyway regardless of the answer of everything
15:49:02 <gordc> correct. i believe the same question we ask last time was asked at ops midcycle as well.
15:49:03 <ildikov> gordc: I guess it's too early asking about Aodh as the packaging did not happen that fast
15:49:22 <gordc> ildikov: on ubuntu
15:49:26 <gordc> and suse
15:49:48 <gordc> but yeah, i don't think there's enough changes to aodh just yet
15:50:02 <ildikov> do we have anything to ask about Gnocchi?
15:50:19 <gordc> jd__: ^ ?
15:50:27 <ildikov> do we know whether people are using it with Ceilo or stand alone?
15:50:33 <gordc> ildikov: i believe that is only packaged in fedora
15:50:54 <ildikov> gordc: you mean Gnocchi?
15:50:58 <gordc> ildikov: correct
15:51:12 <gordc> and debuan.
15:51:15 <gordc> debian
15:51:29 <gordc> bug sitting around against ubuntu
15:51:38 <gordc> so same as aodh 5 months ago
15:52:14 <jd__> gordc: not really I guess
15:52:29 <gordc> jd__: kk
15:52:53 <llu-laptop> speaking of aodh, does anyone know that http://launchpad.net/aodh is part of http://launchpad.net/openstack ?
15:52:56 <ildikov> ok
15:53:19 <ildikov> no other question ideas :)
15:53:21 <gordc> llu-laptop: ildikov if you feel strongly about re-asking same question let me know after meeting. (not 100% against it)
15:53:27 <llu-laptop> because https://blueprints.launchpad.net/openstack/?searchtext=composite-threshold-rule-alarm gives me nothing, but I can access https://blueprints.launchpad.net/aodh/+spec/composite-threshold-rule-alarm
15:53:47 <gordc> llu-laptop: i'll take a look.
15:54:08 <gordc> i don't really use search in launchpad because it's not really useful
15:54:16 <llu-laptop> ot
15:54:31 <llu-laptop> it's generated by cliking bp tag in gerrit
15:55:06 <gordc> i see. i'll check after this.
15:55:15 <gordc> anything else? close this off?
15:55:56 <gordc> let's shut er down. thanks folks
15:56:01 <gordc> #endmeeting