15:01:12 <gordc> #startmeeting telemetry
15:01:16 <openstack> Meeting started Thu Feb 18 15:01:12 2016 UTC and is due to finish in 60 minutes. The chair is gordc. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:21 <openstack> The meeting name has been set to 'telemetry'
15:02:04 <r-mibu> o/
15:02:32 <_nadya_> o/
15:02:33 <sileht> o/
15:03:12 <ildikov> o/
15:03:27 <jd__> o/
15:03:36 <gordc> let's start this.
15:03:38 <liusheng> o/
15:03:48 <gordc> #topic recurring: roadmap items (new/old/blockers) https://wiki.openstack.org/wiki/Telemetry/RoadMap
15:03:51 <llu-laptop> o/
15:03:58 <gordc> i don't really have any items anymore
15:04:14 <gordc> we're freezing in ~2 weeks
15:04:37 <gordc> but realistically, the gate will be broken/flooded in 1 week
15:04:41 <pradk> o/
15:04:46 <jd__> hehe
15:04:48 <ityaptin_> o/
15:05:02 <gordc> so if you don't have a finalised working item by next wednesday. you are sol
15:05:15 <ildikov> gordc: +1
15:05:47 <gordc> anyone with critical bps/features should raise them this week
15:06:13 <gordc> if not, i'm not actually targetting anything for FFE, (assuming composite alarms merges)
15:06:28 <liusheng> can composite alarm feature be in? :)
15:06:44 <gordc> liusheng: yep. i'm waiting on that.
15:06:51 <liamji> gordc: can lbaas v2 in? :)
15:07:00 <gordc> i think once you apply jd__'s suggestion we can merge
15:07:28 * jd__ nods
15:07:46 <gordc> liamji: possibly? um. let's run through the projects and we can raise bps then
15:08:01 <gordc> #topic aodh topics
15:08:04 <liusheng> oh, I just found that comment , will address it
15:08:10 <liamji> gordc: okey, thanks
15:08:32 <gordc> anythin for aodh?
15:08:43 <gordc> liusheng?
15:09:06 <liusheng> gordc: I just want you suggestion about https://review.openstack.org/#/c/281175/
15:09:08 <gordc> i will probably create an aodhclient release based on whatever is in by end of friday
15:09:18 <ildikov> gordc: do we still plan SQL-support only for Aodh?
15:09:35 <liusheng> gordc: about the output form of alarm list command
15:09:37 <gordc> ildikov: i believe the deprecation item was merged
15:09:53 <gordc> liusheng: i'm ok with displaying less details in alarm list
15:09:55 <ildikov> gordc: ok, cool, I will add a note to the install docs then
15:10:08 <liusheng> gordc: OK, thanks
15:10:18 <gordc> ildikov: https://review.openstack.org/#/c/273865/
15:10:48 <gordc> liusheng: i have a small preference to still group by type but i don't really care that much
15:10:48 <ildikov> gordc: tnx!
15:11:14 <gordc> anyone else think we enforce type when listing alarms?
15:11:50 <liusheng> gordc: how about support query filters which can include type=xxx ?
15:12:32 <llu-laptop> when listing alarms, do we plan to list type specific attributes? or just list common attributes?
15:12:47 <gordc> liusheng: that would be mandatory if we drop type. currently everything we do enforces type so it does break the pattern slightly
15:13:10 <gordc> llu-laptop: common attributes. severity, active, status, etc...
15:13:40 <gordc> liusheng: maybe just split it in two. one that minimises the information display
15:13:56 <gordc> and another that proposes to drop mandatory --type
15:14:12 <liusheng> gordc: agree, I will try it
15:14:24 <gordc> liusheng: thanks
15:14:32 <liusheng> gordc: what do you think query filter support in alarm list command ?
15:15:05 <ljxiash> gordc: can we have alarm type in the output of alarm-list?
15:15:11 <gordc> liusheng: i didn't really look at that part... there is a search command already though
15:15:24 <liusheng> llu-laptop: you can use -c to specify column that is supportted by cliff
15:15:38 <gordc> ljxiash: yes, if we drop type
15:16:09 <liusheng> gordc: I personally don't think we need complex query for alarms, maybe we can support query filters and pagination ;)
15:16:49 <ildikov> liusheng: :( complex query is cool :)
15:17:14 <liusheng> ildikov: :) just personal thoughts
15:17:47 <jd__> I tend to agree with liusheng
15:18:21 <gordc> liusheng: let's leave it off. i'm pretty sure 'aodh alarm search' does what you want to accomlish
15:18:34 <gordc> r-mibu: do you think the tempest items will be finished?
15:18:58 <r-mibu> gordc: hmm, i'll try :)
15:19:13 <gordc> r-mibu: is this blocking us? https://review.openstack.org/#/c/255161/
15:19:33 <r-mibu> gordc: right
15:19:46 <r-mibu> I'll ask my colleagues to put +2
15:19:50 <gordc> lol
15:20:02 <ildikov> liusheng: no worries, I was just kidding, I still think it's cool, but I will not force you to add it if you don't want to :)
15:20:04 <gordc> it's been a few months so i guess you can start bothering people
15:20:27 <r-mibu> ok ;)
15:20:58 <gordc> r-mibu: we can maybe extend it for tempest tests since it's just testing we're adding
15:21:06 <gordc> we'll decide next week
15:21:12 <gordc> anything else aodh related?
15:21:34 <r-mibu> ok, nothing from my side
15:22:28 <gordc> #topic ceilometer topics
15:22:43 <gordc> is the caching topic from last week?
15:23:25 <ityaptin_> Folks, if you will have a minute could you take a look onto CR for the Nova metadata caching? super strong desire to put it into Mitaka :) https://review.openstack.org/#/c/267078/18
15:24:22 <_nadya_> gordc: what caching? :) metadata, transformers, events?
15:24:22 <gordc> sigh... that turned out to be much much larger than i hoped/expected
15:24:51 <_nadya_> gordc: it's because the current behaviour is supported
15:24:59 <liusheng> ityaptin_: it looks fine to me, I wil test it tomorrow, but only can be tested on libvirt :(
15:25:07 <liusheng> ityaptin_: thanks for your efforts
15:25:36 <ityaptin_> I checked XenAPI also and make other functions by Nova example
15:25:41 <gordc> _nadya_: i see. i'll take a look.
15:25:57 <gordc> liusheng: let me know how it goes.
15:26:25 <gordc> liamji: do you have your patches for lbaas v2 ready?
15:26:27 <liusheng> gordc: ok
15:26:30 <ityaptin_> I added a little scheme of how it works as the comment for the review. It may be useful
15:26:39 <_nadya_> jfyi, ityaptin_ is working on additional functional tests as well
15:26:48 <ityaptin_> Yep
15:26:59 <liamji> gordc: yes
15:27:04 <liamji> gordc: https://review.openstack.org/#/c/274518/
15:27:13 <gordc> ityaptin_: ack
15:27:26 <liamji> gordc: https://review.openstack.org/#/c/277434/
15:27:51 <liamji> gordc: these two patches are ready : )
15:28:09 <gordc> liamji: did you manage to get any neutron devs on it?
15:28:18 <gordc> would like their opinoin
15:29:01 <liamji> gordc: yes, during the developement, I have discussed with them and got some suggestions from them.
15:29:25 <gordc> can you add them to the patch to review as well
15:29:31 <liamji> gordc: based on the liusheng's suggestions, I write a doc to verify the changes.
15:29:46 <liamji> gordc: https://docs.google.com/document/d/1bsH7NQJ42guX1lZqL9ixw0V3gPqHXQnrAGsMFLeYxVo/edit
15:30:02 <gordc> kk
15:30:16 <liamji> gordc: I have captured some screens : )
15:30:46 <gordc> #action track composite alarms, polling cache, lbaasv2 for mitaka.
15:30:51 <gordc> liamji: kk
15:30:56 <gordc> anything else on ceilometer?
15:31:19 <ljxiash> gordc: Hi
15:31:23 <liamji> gordc: thanks
15:31:46 <gordc> ljxiash: o/
15:31:59 <ljxiash> gordc: about the spec - collect neutron port security group meters
15:32:57 <ljxiash> I need neutron member support for that
15:33:07 <gordc> ljxiash: is there code? if not, i'm going to say let's defer unless it's very very small
15:33:42 <gordc> ljxiash: feel free to post it. i'm not confident it'll get in for mitaka
15:34:20 <gordc> ljxiash: 'neutron member support'? you need a neutron developer to help you?
15:35:07 <ljxiash> gordc: we have basic code, and I can upload it.
15:36:01 <ljxiash> gordc: Could you get some more neutron member to review it?
15:36:20 <gordc> oh. i don't know anyone. sorry
15:36:32 <_nadya_> ljxiash: give me a lonk
15:36:40 <_nadya_> ljxiash: link
15:36:48 <gordc> maybe ask around internally. i'm sure you have a lot of neutron devs in your company
15:36:53 <ljxiash> _nadya_: https://review.openstack.org/#/c/273475/
15:37:13 <gordc> ok. let's move on i guess?
15:37:34 <ljxiash> gordc: _nadya_: thanks
15:37:39 <gordc> #topic gnocchi topics
15:37:54 <gordc> jd__: sileht: anything need to discuss?
15:38:03 <gordc> magic as always?
15:38:11 <jd__> I don't think so, yeah good magic
15:38:18 <jd__> I keep fingers crossed to tag 2.0.0 tomorrow
15:38:32 <jd__> mainly waiting for reviews at this point
15:38:36 <gordc> jd__: sounds good.
15:38:48 <jd__> we'll release gnocchiclient just after I guess
15:38:51 <gordc> jd__: i'm going to try and fix that test after this.
15:39:14 <jd__> gordc: 👍
15:39:49 <gordc> #topic open discussion
15:40:08 <gordc> nothing from me. i'll let this linger for a bit
15:40:27 <gordc> i guess if everyone can focus on the bps for next few days that'd be great
15:40:28 <ildikov> gordc: dumb question. are we still using launchpad for bp tracking?
15:40:37 <_nadya_> ad: summit talk https://www.openstack.org/summit/austin-2016/vote-for-speakers/presentation/8237 . Take a look, it's about ceilo
15:41:06 <gordc> ildikov: sort of. some of the stuff that was less controversial aren't track
15:41:20 <gordc> _nadya_: it's closed :)
15:41:29 <_nadya_> really?
15:41:31 <ildikov> gordc: a-ha, ok
15:41:44 <gordc> _nadya_: i think it closed yesterady
15:41:45 <ildikov> _nadya_: deadline was Wednesday AFAIK
15:41:54 <_nadya_> I'm a looser, baby
15:42:01 <gordc> it's ok. the button does nothing anyways
15:42:25 <gordc> tell your company to pay sponsorship and select it
15:43:20 <_nadya_> gordc: lol
15:43:38 <gordc> ildikov: we should have release notes though. i'll need to do a batch item for that again
15:43:45 <gordc> maybe next cycle.
15:45:02 <gordc> kk. let's call it.
15:45:07 <gordc> thanks folks
15:45:10 <gordc> #endmeeting=