18:00:45 <krtaylor> #startmeeting third-party
18:00:46 <openstack> Meeting started Mon Jul 14 18:00:45 2014 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:49 <openstack> The meeting name has been set to 'third_party'
18:01:00 <krtaylor> Who is here for third-party meeting? Anyone?
18:01:06 <mestery> o/
18:01:06 <asselin> hi
18:01:08 <fawadkhaliq> hello!
18:01:08 <luqas> o/
18:01:09 <ignacio-Embrane> Hi
18:01:09 <ignacio-Embrane> me
18:01:11 <banix> hi
18:01:11 <lyxus> o/
18:01:12 <sweston_> o/
18:01:13 <dougwig> o/
18:01:17 <kevinbenton> O/
18:01:40 <krtaylor> wow, great!
18:02:00 <krtaylor> looks like biggest group yet
18:02:02 <dane_leblanc> hello
18:02:07 <daya_k> hi, first time for me, i am handling the ibm sdnve 3rd party setup
18:02:23 <krtaylor> welcome all!
18:02:36 <krtaylor> here is the agenda for today's meeting:
18:02:41 <vjay> hi all
18:02:45 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#Agenda_for_next_meeting
18:02:46 <pmanur> Hi . all
18:02:49 <aysyd> hi
18:02:51 <lukego> hoi
18:03:03 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:03:14 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:32 <krtaylor> ok, review of last week
18:03:41 <krtaylor> #topic Review of previous week's open action items
18:04:10 <krtaylor> I recorded 2 actions, the first was to make sure timelines got communicated to neutron and cinder
18:04:22 <krtaylor> sweston and I were going to check on that
18:04:53 <sweston> yes, so I believe the timelines are fairly clear
18:04:55 <krtaylor> I think that was taken care of since we have neutron here today
18:05:15 <mestery> krtaylor: I sent a reminder email out with a summary of Neutron 3rd party CI last Friday.
18:05:34 <krtaylor> yes, it was very good
18:05:45 <krtaylor> and I have got a status from cinder core that we can build on for next week
18:05:58 <mestery> krtaylor: cool, thanks!
18:06:28 <vjay> mestery: vjay from citrix. NetScaler CI has been voting for a while.
18:06:30 <krtaylor> ok, the second was sweston starting a terms discussion, documenting the email thread
18:06:44 <krtaylor> and that has made quick progress
18:06:59 <vjay> it votes only on LBaaS changes though
18:07:15 <sweston> :-) thanks, krtaylor
18:07:17 <krtaylor> sweston posted email and link to etherpad
18:07:23 <krtaylor> #link https://etherpad.openstack.org/p/ThirdPartyVotingTerms
18:07:32 <mestery> vjay: I don't think we're at that agenda item yet, please wait until we get there.
18:07:48 <krtaylor> yes, please, hang on just a min
18:08:03 <vjay> mestery: my apologies. will wait
18:08:07 <krtaylor> sweston, anything you want to add?
18:08:14 <krtaylor> vjay, no worries
18:08:31 <mestery> Not a problem vjay, just helping to keep things on track :)
18:08:43 <sweston> I think the terms and definitions are very fair.   if anyone has anything they'd like to contribute, I'd say please do it quickly.
18:09:08 <krtaylor> yes, I encourage everyone to get involved
18:09:15 <sweston> that would be it, krtaylor, thanks :-)
18:09:21 <krtaylor> sweston, you will roll that up into a patch soon?
18:09:49 <sweston> krtaylor: If you would like to set a date, I will put it on the calendar
18:10:46 <krtaylor> #action discuss timeline for terms patch to third_party.rst  sweston krtaylor
18:10:59 <krtaylor> alright
18:11:37 <krtaylor> so last, I'd like to beg everyone to get involved and review the existing patchsets, we ard backed up on them and need to close them out
18:11:48 <krtaylor> #link https://review.openstack.org/#/q/status:open+project:openstack-infra/config+branch:master+topic:third-party,n,z
18:12:20 <krtaylor> following this topic would allow any new patches to be followed by this link
18:12:29 <mestery> krtaylor: Will do, they are in my queue.
18:12:47 <krtaylor> so topic any patches third-party
18:13:15 <krtaylor> did I miss anything from previous week?
18:13:39 <krtaylor> onward then
18:13:41 <krtaylor> #topic Announcements
18:14:01 <krtaylor> does anyone have any announcements?
18:14:29 <krtaylor> nope, ok next
18:14:31 <krtaylor> #topic OpenStack Program Items
18:14:53 <krtaylor> well, I jumped in too quick on the reviews, it should go here
18:15:13 <krtaylor> but, its worth saying twice
18:15:39 <krtaylor> any discussion on the existing patchsets?
18:16:05 <mestery> krtaylor: Just to make sure people review them :)
18:16:21 * krtaylor thinks everyone is just waiting to talk about neutron
18:16:37 <krtaylor> next then
18:16:42 <krtaylor> #topic Deadlines & Deprecations
18:16:53 <krtaylor> any new deadlines to communicate?
18:16:57 <krtaylor> I havent seen any
18:17:26 <krtaylor> good enough
18:17:35 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:17:46 <krtaylor> ok, mestery your up
18:17:52 <mestery> krtaylor: Is this my slot?
18:17:53 <mestery> :)
18:18:02 <krtaylor> want to summarize first?
18:18:04 <mestery> So, I'd like some order here.
18:18:06 <mestery> krtaylor: Sure.
18:18:08 <mestery> #link https://etherpad.openstack.org/p/neutron-thirdparty-juno
18:18:13 <mestery> That's the link I'm going to walk through.
18:18:17 <mestery> The background is this:
18:18:30 <mestery> About 6 weeks ago I sent email on a "state of third-party CI in Neutron"
18:18:47 <mestery> This is the followup discussion as we approach the Juno-2 deadline for all plugins and drivers to ahve this working
18:18:59 <mestery> Lets walk through each CI system which has trouble now, and we can see where people are at.
18:19:13 <mestery> The first one on the list is the Cisco CI.
18:19:17 <mestery> dane_leblanc: I see you here. Hi!
18:19:19 <dane_leblanc> hello
18:19:37 <dane_leblanc> We're missing logging for screen logs...
18:19:42 <mestery> dane_leblanc: OK.
18:19:46 <mestery> Any issues getting that implemented?
18:20:00 <dane_leblanc> Shouldn't be an issue
18:20:09 <mestery> dane_leblanc: Great!
18:20:14 <dane_leblanc> But disk space is something to think about
18:20:23 <dane_leblanc> We have 5 plugins, with 3 more on the way
18:20:24 <mestery> dane_leblanc: Yes, that was the other issue with the Cisco CI.
18:20:26 <mestery> Log retention
18:20:48 <dane_leblanc> So for 30 days retention, I'm gussing about 80 GB needed for logs
18:20:52 <mestery> dane_leblanc: Do you think you can solve these before Juno-2? Do you need help?
18:20:53 <mestery> dane_leblanc: ++
18:21:01 <dane_leblanc> We should have it covered.
18:21:05 <mestery> dane_leblanc: Great!
18:21:08 <mestery> dane_leblanc: Thanks for the update!
18:21:12 <dane_leblanc> Fixing it in a side system, which we'll switch to soon.
18:21:18 <dane_leblanc> Thank you.
18:21:20 <mestery> dane_leblanc: Perfect.
18:21:28 <mestery> Next up: Citrix. vjay, hi!
18:21:53 <Youcef> Vjay is just distracted for a second :)
18:21:55 <pmanur> parikshit from citrix. Hi
18:21:59 <mestery> Youcef: hi there!
18:22:03 <mestery> pmanur: Hi as well!
18:22:14 <vjay> NetScaler CI has been voting
18:22:16 <mestery> So, your plugin is running for LBaaS only commits? Maybe that's why I missed it's reporting.
18:22:22 <vjay> ok
18:22:25 <mestery> Can you folks paste a recent link to a succesful run?
18:22:31 <vjay> sure
18:22:36 <mestery> vjay: thanks!
18:23:28 <mestery> vjay: OK, please put a link to a succesful run in the etherpad.
18:23:31 <vjay> https://review.openstack.org/#/c/40296
18:23:31 <mestery> We'll move on to the next one.
18:23:37 <mestery> vjay: Perfect timing!
18:23:39 * mestery looks
18:23:45 <vjay> can you please give the link to the etherpad
18:24:04 <fawadkhaliq> vijendar: https://etherpad.openstack.org/p/neutron-thirdparty-juno
18:24:09 <mestery> thanks fawadkhaliq
18:24:09 <fawadkhaliq> vijay: https://etherpad.openstack.org/p/neutron-thirdparty-juno
18:24:20 <mestery> vjay: There are a few issues with your CI based on that link:
18:24:40 <mestery> It's not saving enough info (logs, including screen captures).
18:24:52 <mestery> vjay: I'll add that as a requirement in the etherpad.
18:25:40 <mestery> vjay: That should be straightforward, and you can work with people in this meeting each week for help. Also, #openstack-infra.
18:25:46 <krtaylor> vjay, also the link points to the job, not the log
18:26:03 <mestery> vjay: Does that sound ok?
18:26:05 <vjay> can you see the latest patchet 24
18:26:08 <vjay> vote
18:26:17 <vjay> the logs are present in http://125.22.100.252/Change_40296_PatchSet_24_2014-07-14_10_51_48
18:26:24 <vjay> it has all the screen captures
18:26:51 <pmanur> http://125.22.100.252/Change_40296_PatchSet_24_2014-07-14_10_51_48/devstack/log_dest/logs/ is the full path for screen logs
18:27:19 <mestery> vjay: I see that now.
18:27:22 <krtaylor> vjay, I see, you are using the build to index the logs
18:27:33 <mestery> vjay: I'll defer to krtaylor, but the links in the Jenkins voting look odd to me, but you are right, the logs are there.
18:27:37 <mestery> krtaylor: Thoughts?
18:28:10 <krtaylor> vjay, also, its a good idea to not use a specific IP address, it makes links break in the future if the ip changes
18:28:28 <vjay> ok. we are working on changing to a dns name
18:29:17 <mestery> OK, lets move on to the next one.
18:29:20 <mestery> Thanks vjay!
18:29:20 <krtaylor> mestery, not sure I am looking at the right thing, the last report is not a vote, just comment
18:29:47 <mestery> krtaylor: Looks here at the netscaler commeont on patchset 24: https://review.openstack.org/#/c/40296
18:30:02 <mestery> krtaylor: My comment was it's somewhat hard to parse that, thats all.
18:30:30 <krtaylor> mestery, yes, I was looking at the wrong review
18:30:30 <mestery> OK, now moving on.
18:30:34 <mestery> krtaylor: :)
18:30:37 <mestery> Next up: Embrane.
18:30:40 <ignacio-Embrane> hi
18:30:44 <mestery> ignacio-Embrane: Hi!
18:31:06 <mestery> Per the etherpad, there are two issues: 1) Logs are tarred up and not viewable in the browser, and the CI runs seem inconsistent.
18:31:10 <ignacio-Embrane> I can change the script to not compress the logs before uploading
18:31:16 <mestery> ignacio-Embrane: Perfect!
18:31:23 <ignacio-Embrane> but what do yopu meet with inconsistent runs?
18:31:32 <ignacio-Embrane> *you mean
18:32:02 <mestery> In looking at it, it wasn't clear what it was running against, and if hte results were consistent.
18:32:04 <mestery> I may be wrong
18:32:29 <krtaylor> dane_leblanc, is the last review on that netscaler patchset (24) yours? if so, same ip address comment applies
18:32:29 <ignacio-Embrane> it has been running for a while, latest is against this patchset
18:32:31 <ignacio-Embrane> https://review.openstack.org/#/c/102648/
18:33:08 <dane_leblanc> krtaylor: Not sure, but I know we have the same problem.
18:33:10 <mestery> ignacio-Embrane: that's what I mean: It only ran against patch sets 2 and 6 from that review.
18:33:33 <mestery> ignacio-Embrane: Sorry, 2, 4, 5 and 6.
18:33:45 <mestery> ignacio-Embrane: Did it skip 1 and 3 for some reasons?
18:34:18 <ignacio-Embrane> Some days ago I had to cut some accumulated jobs to make some changes
18:34:27 <ignacio-Embrane> since it had a bit of a backlog of patches to test
18:34:33 <mestery> ignacio-Embrane: OK, this could explain what I saw when looking at a few other patches as well.
18:34:46 <ignacio-Embrane> I wanted to ask what is the best way to run the minumum subset of tests
18:34:51 <ignacio-Embrane> to speed it up a bit
18:35:07 <mestery> ignacio-Embrane: This may be a broader problem which shoudl be discussed here though, and there is a mailing list thread on this as well from kevinbenton.
18:35:47 <mestery> ignacio-Embrane: It seems like the issues noted in the etherpad for embrane are easily solvable though.
18:35:51 <mestery> ignacio-Embrane: Thanks for the discussion here!
18:35:56 <mestery> Lets move on to the next one.
18:36:02 <mestery> IBM SDN-VE
18:36:02 <ignacio-Embrane> ok thanks
18:36:06 <mestery> Is banix or someone else here?
18:36:07 <daya_k> hi
18:36:10 <mestery> daya_k: Hi!
18:36:16 <banix> hi
18:36:27 <mestery> Hi banix and daya_k!
18:36:35 <mestery> banix: We had spoken last week, but it's good to document it here.
18:36:42 <mestery> The IBM CI is moving to a new group and setup, right?
18:36:45 <daya_k> we are moving to a zuul based system, in the works
18:36:50 <mestery> daya_k: ++
18:37:19 <daya_k> thanks, facing some issues, with triggers not starting a job, but manual runs on sandbox env running
18:37:41 <krtaylor> also, just be clear on what is being tested, IBM has several CI systems reporting
18:37:45 <mestery> daya_k: Cool! If you hit issues, the ML and #openstack-infra are your friends, as well as this meeting.
18:37:54 <krtaylor> ++
18:38:06 <sweston> ++
18:38:14 <daya_k> yes, thanks.
18:38:15 <banix> yes this is the CI for IBM SDN-VE Neutron plugin
18:38:42 <krtaylor> right, and that goes back to the system naming discussion
18:39:00 <krtaylor> also in the ML and patch comments
18:39:53 <daya_k> i can add the 'SDN-VE' in the vote. currently its  'IBM Neutron Testing'
18:40:37 <krtaylor> daya_k, yes, that was what I was getting at, something like ibm-sdnve-ci
18:40:46 <banix> krtaylor: daya_k we are given a new name; specific to sdn-ve
18:41:09 <banix> got the new name from anteaya; will double check to get ithe exact name
18:41:11 <mestery> banix daya_k: Sounds fine to me
18:41:17 <daya_k> i had one Q for the codes earlier, sorry to bring it back up, havent seen if any specific code is defined for 'passed' and will you be adding it to the openstack ci system itself
18:42:24 <krtaylor> daya_k, if you are referring to the terms discussion, it is just for discussion at this point
18:42:56 <daya_k> ok, so not part of the deadline
18:42:58 <daya_k> phew
18:43:01 <mestery> OK, looking at time, I'd like to move on.
18:43:05 <krtaylor> daya_k, right
18:43:10 <mestery> Thanks daya_k and banix, seems like things are under control here!
18:43:21 <mestery> Next up: One Convergence.
18:43:26 <mestery> is anyeone here from One Convergence?
18:44:14 <mestery> OK, moving on.
18:44:17 <mestery> Next up is OpenDaylight.
18:44:26 <mestery> I spoke to dave_tucker (who is in the UK) last week.
18:44:36 <mestery> ODL is moving to a new zuul based setup in the RAX cloud.
18:44:42 <mestery> It's a work in progress.
18:44:55 <mestery> I'll follow up with dave_tucker and the ODL team this week as well.
18:45:03 <mestery> Next up: PLUMgrid.
18:45:06 <mestery> fawadkhaliq: Hi!
18:45:08 <fawadkhaliq> hi
18:45:13 <fawadkhaliq> PLUMgrid CI looks good now. Finally, it has been updated to store all the required logs in the correct format as per https://wiki.openstack.org/wiki/NeutronThirdPartyTesting. Example against latest neutron patch: https://review.openstack.org/#/c/106365/.
18:45:32 <mestery> fawadkhaliq: Yes, it looks good to me too!
18:45:50 <mestery> fawadkhaliq: thanks for working to correct the issues around hte logs.
18:46:03 <mestery> OK, that one was quick. Next up: Radware.
18:46:10 <mestery> Is anyone here from Radware?
18:46:19 <emagana> fawadkhaliq: well done!
18:46:28 <mestery> The main issue with the Radware plugin is the fact the logs aren't viewable from the browser.
18:46:33 <fawadkhaliq> emagana: mestery: thank you
18:46:37 * mestery waits for 30 more seconds.
18:47:35 <mestery> OK, next up: Tail-F.
18:47:37 <mestery> lukego: Hi there!
18:47:42 <lukego> Tail-f NCS Jenkins: I brought this online again early in June and it has run around 400 tests since then. I'm monitoring daily during the week and sanity-checking the results, particularly negative ones, and retriggering tests that failed due to operational issues (happens occasionally). Example successful run: https://review.openstack.org/#/c/92541/
18:47:42 <mestery> Any updates on your CI?
18:47:42 <lukego> I have two known-to-me issues that I'd like help with. One is how to run more than the API tests, which is a requirement that I don't meet yet. The other is to look at a couple of suspicious failures and help see if they are due to some setup issue on my side e.g. http://88.198.8.227:81/html/ci-logs/2014-07-14_07-21-28/
18:47:43 <lukego> There are perhaps also unknown-to-me issues that will come to light now :).
18:48:58 <mestery> lukego: Looks good! For the first one, it's just a matter of running the basic and advanced networking ops tests in tempest in addition to the tempest API tests.
18:49:18 <lukego> I tried just doing that with testr, but they all failed for some strange reason, so I suspect by devstack and/or tempest conf is dodgy
18:49:22 <mestery> lukego: https://wiki.openstack.org/wiki/NeutronThirdPartyTesting#What_Tests_To_Run
18:49:24 <krtaylor> lukego, same ip address in the link comment
18:50:10 <krtaylor> lukego, I am looking, but also jump in #openstack-infra and we can help you through setup issues
18:50:28 <mestery> OK, thanks lukego, lets move on to the next one.
18:50:34 <mestery> lukego: I think you can solve these issues with some help.
18:50:45 <lukego> *nod*. will follow up in openstack-infra
18:50:46 <mestery> The last one is the vAmour FWaaS driver.
18:50:51 <mestery> Is someone from vAmour here?
18:51:07 <mestery> The issues with this one are the fact we can't view logs from runs, and some runs appear inconsistent.
18:51:12 * mestery waits for 60 seconds.
18:52:07 <mestery> krtaylor: That's all I've got, thanks for the time in your meeting!
18:52:35 <krtaylor> vArmour CI has the same IP addr issue
18:52:52 <mestery> krtaylor: #sadpanda
18:52:58 <krtaylor> mestery, thanks for bringing this to the meeting and driving the discussion
18:53:06 <mestery> krtaylor: Sure, anytime!
18:53:34 <krtaylor> we are almost out of time
18:53:36 <krtaylor> #topic Open Discussion
18:53:46 <krtaylor> does anyone have anything to discuss?
18:54:36 <krtaylor> I'll see if I can get cinder to come and discuss where they are next week
18:54:52 <mestery> krtaylor: ++
18:55:03 <krtaylor> #action krtaylor to contact cinder for status/help meeting
18:55:13 <krtaylor> anything else?
18:55:21 <luqas> mestery: just to make sure, the rest of the CIs we can assume we are not in a risky situation?
18:55:37 <mestery> luqas: From my analysis, correct. :)
18:55:51 * mestery hopes he didn't miss anything, but he spent a good amount of time last week checking ...
18:55:53 <luqas> mestery: cool :) thanks
18:56:00 <mestery> Certainly, people can feel free to correct me. :)
18:56:08 <krtaylor> mestery, and it has been well communicated
18:56:12 <mestery> krtaylor: ++
18:56:33 <krtaylor> I guess we can call it quits a bit early then
18:56:43 <krtaylor> thanks everyone, come back next week
18:56:49 <banix> thanks
18:56:51 <luqas> thanks!
18:56:52 <daya_k> thx
18:56:57 <sweston> krtaylor, mestery thanks!!
18:57:06 <krtaylor> #endmeeting