18:01:01 <krtaylor> #startmeeting third-party
18:01:02 <openstack> Meeting started Mon Dec 1 18:01:01 2014 UTC and is due to finish in 60 minutes. The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:06 <openstack> The meeting name has been set to 'third_party'
18:01:22 <krtaylor> anyone here for third-party?
18:01:27 <sweston> o/
18:01:33 <luqas> o/
18:02:07 <krtaylor> hi everyone
18:02:07 <adalbas> o/
18:02:45 <dougwig> note quite awake, but here
18:02:49 <dougwig> /note/not/
18:03:02 * jesusaurus lurks
18:03:08 <krtaylor> I hope everyone had a nice break, or at least a break from those that did have a break
18:03:28 <krtaylor> ok, let's get started
18:03:33 <krtaylor> #topic Welcome & Reminder of OpenStack Mission
18:03:41 <krtaylor> #info The OpenStack Open Source Cloud Mission: to produce the ubiquitous Open Source Cloud Computing platform that will meet the needs of public and private clouds regardless of size, by being simple to implement and massively scalable.
18:03:52 <krtaylor> today's agenda:
18:04:02 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#12.2F1.2F14
18:04:17 <krtaylor> and yes, I was late updating it
18:04:36 <krtaylor> #topic Review of previous week's open action items
18:05:01 <krtaylor> the only action from last week was mine, and I did not get that done
18:05:23 <krtaylor> it was to kick off the third-party documentation wg
18:05:52 <krtaylor> but, I wanted to be a part, and was about to leave for US holiday, so I punted
18:06:00 <krtaylor> but I will get that going asap
18:06:25 <sweston> yay :-)
18:06:30 <krtaylor> hehheh
18:06:40 <krtaylor> so next
18:07:02 <krtaylor> #action krtaylor to finish initial CI doc work group formation
18:07:02 <krtaylor>
18:14:14 <krtaylor> altright then, sweston had the second
18:07:21 <krtaylor> oops too many line pasted
18:07:33 <krtaylor> #topic Announcements
18:07:42 <krtaylor> any announcements?
18:08:23 <krtaylor> I guess I'll mention that infra manual sprint is happening now
18:09:17 <krtaylor> jump on that if interested, email announce went out
18:09:52 <krtaylor> although I cant find it atm
18:09:59 <krtaylor> any others?
18:10:28 <krtaylor> #topic OpenStack Program items
18:11:01 <sweston> ready?
18:11:11 <krtaylor> third-party CI documentation is a carry-over
18:11:27 <krtaylor> yeah, so you are up sweston
18:11:35 <sweston> I will respond to the comments already posted in the review today, still waiting for input from the other reviewers. When would you like the spec to be finalized?
18:12:25 <krtaylor> sweston, I think we had hoped for this month, before everyone disappears for more holiday festivities
18:12:44 <krtaylor> by the end of next week at the lates
18:12:48 <krtaylor> latest
18:13:03 <krtaylor> I dont think that is moving too quickly
18:13:17 <sweston> ok
18:13:27 <krtaylor> especially now since folks are back from holiday/vacation
18:13:48 <krtaylor> I have been playing around with the poc, it is nice
18:14:05 <krtaylor> search works good, etc
18:14:55 <krtaylor> and I need to re-read the spec and comment, hopefully jhesketh will too
18:15:07 <sweston> good :-) glad you like it. I am looking for input on how to put together some status areas for the top of the dashboard.
18:15:24 <krtaylor> yes, that would be good
18:15:57 <krtaylor> a small section with all the CI systems represented somehow and a color-coded status
18:16:13 <sweston> Ok. What are some good metrics to report on the status?
18:16:21 <krtaylor> maybe just a small font and 3 or 4 columns
18:16:26 <krtaylor> good question
18:16:58 <krtaylor> thats where we need to agree on the formula on what is a healthy system
18:17:29 <krtaylor> and how often it can be queried for a test re-queue, or some other demand status
18:17:39 <sweston> so are you thinking a table format, with some colors for systems in different states, maybe
18:17:59 <krtaylor> sweston, sure, that would work, I'm not too picky
18:18:24 <sweston> krtaylor: ok, I will come up with something nice for that
18:19:39 <sweston> next task is hooking into the gerrit event stream. I suspect that part will probably take the rest of the week, given the time I have set aside for this
18:19:55 <krtaylor> actually, maybe the top page is the status and the details you list there are linked to the name in the status table, just an idea
18:20:15 <krtaylor> sweston, your work on it is very much appreciated
18:20:21 <sweston> ok, that will work.
18:21:10 <krtaylor> for reference, here is the link for that page we are discussing:
18:21:13 <krtaylor> #link http://dashboard.triniplex.com/#
18:21:22 <sweston> krtaylor, thank you. that's all I have for this week.
18:21:50 <krtaylor> any other comments or suggestions on the dashboard spec or design?
18:22:00 <sweston> yes, if any one else has comments or input on the ui, please feel free to send me an email or ping me on irc
18:22:23 <krtaylor> thanks sweston
18:22:34 <sweston> krtaylor: np
18:22:39 <krtaylor> ok, next is self service accounts
18:22:53 <krtaylor> I posted the link to the doc changes, please review
18:23:13 <krtaylor> #link https://review.openstack.org/#/c/137240
18:23:45 <krtaylor> there is some nice re-write on the old wording there too
18:24:31 <krtaylor> anteaya, are you around to comment on self-service accounts?
18:24:59 <krtaylor> busy on infra manual sprint I am sure
18:25:31 <anteaya> yes
18:25:41 <anteaya> creating accounts will soon be self service
18:25:42 <krtaylor> anyway, everyone should follow this work
18:25:47 <krtaylor> hi anteaya
18:26:08 <anteaya> once that happens we will post an email to the mailing list instructing people about what to do now
18:26:16 <anteaya> to the -dev mailing list
18:27:14 <krtaylor> excellent
18:28:05 <krtaylor> so, everyone can help this along by staying active in the review for these patches
18:28:18 <anteaya> thank you
18:28:27 <krtaylor> if you have suggestions for how to improve the process, now is the time
18:28:32 <krtaylor> thanks anteaya
18:28:50 <anteaya> oh ping me when you are at open discussion please
18:28:58 <krtaylor> anteaya, will do
18:28:58 <anteaya> sorry not following the meeting
18:29:00 <anteaya> thanks
18:29:07 <krtaylor> anteaya, np
18:29:48 <krtaylor> onward then
18:29:49 <krtaylor> #topic Deadlines & Deprecations
18:30:01 <krtaylor> I don't know of any yet
18:30:23 <krtaylor> anything coming out of cinder? or neutron?
18:31:37 <krtaylor> I'll take an action to get with their cores and see if they would like to bring anything up to this group in the next few weeks
18:32:21 <krtaylor> #action krtaylor to ping cinder, neutron, nova for any CI testing deadlines
18:32:46 <krtaylor> anything else?
18:32:56 <krtaylor> next
18:33:05 <krtaylor> #topic Highlighting a Program or Gerrit Account
18:33:47 <krtaylor> so I have here a reminder for anyone that wants to jump in on the patches for splitting out puppet modules
18:34:09 <sweston> I have proposed a change to the system-config repo with the split script I created for the module split. reviews are welcome.
18:34:10 <krtaylor> I know sweston, mmedvede and asselin were working on some automation - any status
18:34:18 <sweston> ^
18:34:19 <krtaylor> sweston, thanks
18:34:38 <sweston> https://review.openstack.org/#/c/137991/
18:35:00 <krtaylor> #link https://review.openstack.org/#/c/137991/
18:35:16 <krtaylor> so it will show up on links summary :)
18:35:50 <sweston> the script is running live against my github account now. the initial filter for the branches takes about 10 minutes.
18:36:10 <krtaylor> ok, good to know
18:36:22 <sweston> the resync process takes less than a minute for each module with updates
18:36:39 <krtaylor> and only if there are updates, right?
18:36:49 <sweston> correct.
18:37:06 <sweston> no longer using the branch split, it was taking too long
18:37:11 <krtaylor> great
18:37:57 <sweston> I think that is all the info for this week, asselin is still on vacation today, I believe
18:38:08 <sweston> regarding the module split, that is
18:38:20 <krtaylor> ah, ok
18:38:37 <krtaylor> well there are plenty of tasks left
18:39:03 <krtaylor> mmedvede, anything to add?
18:40:09 <krtaylor> we dont have a third-party system to discuss this week
18:40:41 <krtaylor> so any systems that need help? currently down? reporting incorrectly?
18:41:14 <krtaylor> #topic CI system issues
18:42:13 <krtaylor> this is the part of the meeting where we will point out systems that we may have seen that are not working properly, or review systems that have previously had issues
18:42:45 <krtaylor> this will become more important later, as we become a more self-regulating wg
18:43:13 <krtaylor> ok then, open discussion time
18:43:24 <krtaylor> #topic Open Discussion
18:43:46 <sweston> ping anteaya open discussion time
18:43:57 <krtaylor> thanks sweston
18:44:03 <sweston> yup
18:44:34 <krtaylor> any systems that need help working through a problem they are seeing?
18:46:44 <krtaylor> hm, maybe anteaya got busy on infra manual
18:47:40 <krtaylor> ok, well if no one has any questions, then we can wrap this up
18:47:48 <krtaylor> last chance, anyone?
18:48:03 <anteaya> okay where are we on the email to have an additional meeting time
18:48:09 <anteaya> because I need that to happen
18:48:27 <anteaya> do we have an etherpad with some text yet
18:48:28 <krtaylor> anteaya, me too, I am driving that, need to finish now back to work
18:48:45 <krtaylor> anteaya, I was going to do that via email
18:48:49 <anteaya> krtaylor: okay so I need to have a link to an etherpad with a draft
18:48:59 <krtaylor> not sure it needs an etherpad, do you?
18:48:59 <anteaya> krtaylor: lets have an etherpad please
18:49:03 <anteaya> yes
18:49:10 <anteaya> put some text in an etherpad
18:49:13 <anteaya> link me
18:49:15 * krtaylor shrugs
18:49:17 <anteaya> we agree on content
18:49:18 <krtaylor> ok will do
18:49:21 <anteaya> we send it today
18:49:44 <krtaylor> content meaning a meeting time right?
18:50:09 <krtaylor> anteaya, ^^
18:50:15 <anteaya> content meaning the draft of the email asking for input on an additional meeting time
18:50:24 <krtaylor> oh, ok, sure
18:50:35 <anteaya> if I don't see an etherpad link in 70 minutes, I'll do it myself and link you
18:50:42 <anteaya> anyone else want to be linked?
18:50:57 <sweston> include me please
18:51:00 <krtaylor> I can't imagine it would take me that long
18:51:05 <luqas> me too
18:51:07 <anteaya> sweston: very good
18:51:13 <anteaya> luqas: great
18:51:19 <krtaylor> will do
18:51:22 <sweston> anteaya: thank you
18:51:22 <anteaya> krtaylor: okay thank you
18:51:30 * anteaya returns to sprint
18:51:37 <krtaylor> thanks anteaya
18:51:46 <krtaylor> alright, anyone else?
18:52:58 <krtaylor> ok, well thanks everyone for another good meeting, I'll get on these actions
18:53:05 <krtaylor> see everyone next week then
18:53:06 <sweston> Good meeting, krtaylor
18:53:13 <sweston> krtaylor: thanks
18:53:19 <krtaylor> sure, np
18:53:35 <krtaylor> #endmeeting