15:00:38 <asselin> #startmeeting third-party
15:00:39 <openstack> Meeting started Mon Jun 22 15:00:38 2015 UTC and is due to finish in 60 minutes.  The chair is asselin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:42 <openstack> The meeting name has been set to 'third_party'
15:01:01 <asselin> hi, anyone here for 3rd party meeting?
15:01:13 <lennyb_> asselin: Hi
15:01:22 <asselin> i'll filling in for anteya today
15:01:25 <asselin> hi lennyb_
15:01:28 <patrickeast> hi
15:01:49 <asselin> morning patrickeast
15:01:57 <lennyb_> if there are no agenda, I have a question regarding zuul
15:02:10 <marcusvrn_> Hi
15:02:28 <asselin> normally no formal agenda, but will double-check to see if anyone added something
15:02:34 <asselin> lennyb_, go ahead
15:03:08 * asselin didn't find agenda for today
15:03:13 * lennyb_ preparing paste
15:03:20 <krtaylor> o/
15:03:34 <asselin> hi krtaylor
15:03:51 <krtaylor> asselin, yeah, usually not an agenda for the office hours meetings
15:04:18 <asselin> anteaya did ask me to inform the team that she completed her action item
15:04:49 <asselin> there is now a footer in 3rd party announce e-mails to request people join these meetings
15:05:19 <krtaylor> excellent
15:05:21 <lennyb_> in case of dependencies in patchset I see that ZUUL_CHANGES=openstack/nova:master:refs/changes/80/72380/5^openstack/nova:master:refs/changes/81/72381/5^openstack/nova:master:refs/changes/82/72382/5^openstack/nova:master:refs/changes/12/182212/3^openstack/nova:master:refs/changes/13/182213/3 what key should I export, so my devstack will actually pick this up?
15:05:36 <asselin> #link http://eavesdrop.openstack.org/meetings/third_party/2015/third_party.2015-06-15-15.02.html
15:05:51 <asselin> #info anteaya to look into adding link to third party meetings in -announce ml footer -- DONE
15:06:00 <lennyb_> I tried to check logs of another CIs, but they usually pick only the last one.
15:06:56 <asselin> lennyb_, where do you see this?
15:07:01 <krtaylor> that was my biggest surprise from summit, that there were still so many new test operators that were not aware of this resource
15:07:14 * lennyb_ checkin
15:10:01 <asselin> lennyb_, i suppose that's the env variable exported by zuul/Jenkins into the jenkins slave running the job?
15:11:57 <lennyb_> asselin: yes. ZUUL_CHANGES is exported. example https://review.openstack.org/#/c/182213 patch 3, ZUUL_CHANGES=openstack/nova:master:refs/changes/80/72380/5^openstack/nova:master:refs/changes/81/72381/5^openstack/nova:master:refs/changes/82/72382/5^openstack/nova:master:refs/changes/12/182212/3^openstack/nova:master:refs/changes/13/182213/3  . but I should export PROJECT_BRANCH , so devstack will install this patch
15:11:57 <patchbot> lennyb_: https://review.openstack.org/#/c/3/
15:13:43 <asselin> lennyb_, which job on that patch are you looking at?
15:14:10 <asselin> lennyb_, normally, everything is setup automatically in the setup_workspace file
15:14:19 <asselin> e.g. http://logs.openstack.org/13/182213/3/check/check-tempest-dsvm-full/41e92a3/logs/devstack-gate-setup-workspace-new.txt.gz
15:14:59 * wznoinsk1 joins late, hi
15:15:38 <lennyb_> asselin: I cant export $PROJECT_BRANCH as ZUUL_CHANGES, since git can not recognize the syntax of the dependencies.
15:15:44 <lennyb_> asselin: http://144.76.193.39/ci-artifacts/182213/3/Nova-ML2-Sriov/
15:15:47 <asselin> lennyb_, and zuul already prepared the version of nova that should be used and is provided and used here: http://logs.openstack.org/13/182213/3/check/check-tempest-dsvm-full/41e92a3/logs/devstack-gate-setup-workspace-new.txt.gz#_2015-06-10_19_10_50_653
15:16:08 <lennyb_> asselin: normally there are no dependencies or at least ZUUL
15:16:24 <lennyb_> $ZUUL_CHANGES is a single-patch
15:18:20 <asselin> lennyb_, right, but zuul provides a single ref that is supposed to represent all of those changes
15:18:46 <asselin> lennyb_, 05:09:46 ZUUL_REF=refs/zuul/master/Z566957bb03a2438585b033252b4ff5b3
15:20:12 <asselin> in upstream, this ref is pulled in here: http://logs.openstack.org/13/182213/3/check/check-tempest-dsvm-full/41e92a3/logs/devstack-gate-setup-workspace-new.txt.gz#_2015-06-10_19_10_49_677
15:20:45 <asselin> if it doesn't exist, then it uses backup/default branches, usually master
15:22:00 <asselin> Does anyone else have other topics to bring up?
15:22:19 <lennyb_> asselin: thanks a lot, I will check it.
15:23:02 <asselin> I wanted to make people aware of this zuul bug fix: https://review.openstack.org/#/c/191216/
15:23:05 <asselin> #link https://review.openstack.org/#/c/191216/
15:23:27 <asselin> #info zuul Support external cross-project dependencies in ui now merged
15:23:43 <patrickeast> yay!
15:24:11 <patrickeast> asselin: thanks for fixing that
15:24:16 <asselin> it's been affecting lots of 3rd party folks, so definitely cherry-pick it if you cannot upgrade to master
15:24:52 <lennyb_> asselin: thanks for the fix.
15:25:11 <krtaylor> asselin, I wanted to bring up the new meeting time for the third party ci working group -> 1700UTC Tuesday (starting this week)
15:25:30 <asselin> #topic new meeting time for the third party ci working group -> 1700UTC Tuesday (starting this week)
15:25:42 * asselin remembers to set the topic
15:26:10 <asselin> krtaylor, thank you
15:26:50 <krtaylor> np, I'll also send out a meeting reminder
15:27:02 <asselin> +1 good idea
15:27:32 <asselin> #topic zuul: Add the ability to abort jobs on a patch merge
15:27:39 <asselin> #link https://review.openstack.org/#/c/192819/
15:27:56 <asselin> I also submitted this patch ^^ which should help 3rd party folks
15:28:22 <asselin> in case you have a slow system, avoid posting results a few days after it merges :)
15:28:45 <lennyb_> btw, what about https://review.openstack.org/#/c/188383/  will it be merged?
15:29:25 <asselin> leifz, seems it waiting on adding test cases
15:29:49 <asselin> #link https://review.openstack.org/#/c/188383/
15:30:18 <asselin> #info https://review.openstack.org/#/c/188383/ waiting on test cases for merge
15:31:26 <asselin> if I get a chance I'll see if I can do it since I added some tests recently for my zuul patch mentioned earlier
15:32:07 <asselin> but would be best if evgeny would do it. anyone know how to ping him?
15:32:44 <asselin> actually he did do it on a dependent patch
15:33:03 <asselin> #action asselin to ask jeblair to remove -1
15:33:40 <asselin> #link https://review.openstack.org/#/c/191588/2 <-- review
15:34:09 <asselin> Any other topics?
15:35:17 <asselin> #topic common-ci
15:35:36 <asselin> I'd like people to review the "zuul" patches here: https://review.openstack.org/#/q/topic:downstream-puppet+status:open,n,z
15:36:01 <asselin> I think we're close to merging, so getting extra eyes on those would be good.
15:36:53 <asselin> I think we can get that done this week, and then we're another big step closer to an in-tree common-ci solution!
15:37:45 <asselin> comments/questions?
15:38:30 <mmedvede> asselin: thanks for moving common-ci forward. Unfortunately, I was not able to be more involved in it
15:40:52 <asselin> mmedvede, every bit counts. After zuul I plan to target nodepool...there's lots of great changes going on there.
15:41:17 <asselin> #topic open discussion
15:41:18 <fbo_> asselin, I am ready and available to upgrade zuul patches if needed ... but yeah I guess we need more reviews on it :)
15:41:52 <asselin> fbo_, yeah, some of your patches merged friday, so the next set need to be updated
15:42:46 <asselin> fbo_, if you can do that soon that will help reviewers and testers
15:42:51 <fbo_> asselin, yes now the road is open to have those zuul patches merged and move to the next steps :)
15:43:21 <asselin> fbo_, +1 I really think it can be done this week!
15:43:39 <fbo_> asselin, yes sure I'll do that tomorrow and ping you for the review
15:43:46 <asselin> thank you
15:43:57 <fbo_> For sure we'll succeed to have that merged this week !
15:44:12 <fbo_> you are welcome
15:44:45 <asselin> Anything else from anyone? can give back 15 minutes
15:46:04 <asselin> #end-meeting
15:46:16 <krtaylor> thanks asselin !
15:46:18 <asselin> #endmeeting