17:00:48 <krtaylor> #startmeeting third-party
17:00:49 <openstack> Meeting started Tue Aug  4 17:00:48 2015 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:53 <openstack> The meeting name has been set to 'third_party'
17:01:16 <krtaylor> anyone here for Third party CI Working group meeting?
17:01:27 <asselin_> hi
17:01:56 <krtaylor> hi asselin_
17:02:00 <marcusvrn> hi
17:02:12 <mmedvede> o/
17:02:34 <rfolco> o/
17:02:42 <krtaylor> hi marcusvrn mmedvede rfolco
17:03:05 <krtaylor> so here is the agenda for today:
17:03:08 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/ThirdParty#8.2F4.2F15_1700_UTC
17:03:26 <krtaylor> basically a carry-over from last meeting
17:03:42 <krtaylor> mainly because I was on vacation all last week
17:03:58 * asselin_ was also on cavation last week
17:04:13 <krtaylor> ah, good to know
17:04:14 <asselin_> well...not in a cave :)
17:04:22 <krtaylor> hehheh
17:04:26 <marcusvrn> I was on vacation last month....hehehe
17:04:38 <krtaylor> looks like we landed some good patches and contributions in the repo
17:04:43 <krtaylor> good stuff
17:05:05 <krtaylor> so does anyone have any quick announcements? deadlines approaching?
17:05:39 <mmedvede> just an fyi, recent upper-constraints update broke f21 gate
17:05:45 <mmedvede> both us and upstream
17:05:54 <krtaylor> yes, thanks mmedvede
17:06:02 <mmedvede> well, upstream was broken already, but it broke it further :)
17:06:26 <krtaylor> anything else?
17:06:45 <krtaylor> #topic Common CI
17:06:56 <krtaylor> downstream puppet continues to move along
17:07:17 <krtaylor> anything you'd like to work through here asselin_ mmedvede
17:07:21 <asselin_> yes, nodepool refactoring is next
17:07:31 <asselin_> lots of progress has been made
17:07:53 <asselin_> would be good to focus reviews on those...it's a big change
17:08:37 <asselin_> #link nodepool patches to review are on etherpad: https://etherpad.openstack.org/p/common-ci-sprint
17:09:57 <krtaylor> #link https://review.openstack.org/#/q/topic:downstream-puppet,n,z
17:10:56 <asselin_> yes, the topic has a lot more changes
17:11:09 <krtaylor> was looking, lots of good work
17:11:42 <asselin_> it would be good to focus on nodepool since it is a big change
17:11:58 <krtaylor> yes and mmedvede, yours look to be reviewed and ready to go, just need approval
17:12:23 <mmedvede> krtaylor: mine a low priority. But yes, a couple of them are ready
17:13:21 <krtaylor> lots of depends-on links
17:13:31 <krtaylor> for nodepool, thats good
17:13:43 <asselin_> mmedvede, I have those on my list too, but have been prioritzing nodepool
17:15:07 <krtaylor> ok, anything else here, other than do reviews?
17:16:02 <krtaylor> ok, we can come back to it if needed in open discussion
17:16:12 <asselin_> i think that's it
17:16:21 <krtaylor> #topic Spec for infra hosting a monitoring dashboard
17:16:45 <krtaylor> this has got some good reviews, not for content, which is a good sign
17:17:42 <krtaylor> jhesketh didn't like the naming, which I can certainly change, but was hoping to just have the other spec moved by now
17:17:45 <krtaylor> #link https://review.openstack.org/#/c/194437/
17:18:42 <krtaylor> I did appreciate him not holding it up for naming in the rollcall, that was cool
17:18:52 <krtaylor> sweston, are you around?
17:19:11 <krtaylor> I didn't get a chance to follow up last week due to vacation
17:20:16 <krtaylor> ok, well, I'll ping him later - maybe we just need to move it with a new patchset to third-party-ci-tools
17:20:43 <krtaylor> and capture the comments in a txt file
17:21:32 <krtaylor> then we can abandon the infra spec
17:22:53 <krtaylor> so, also in the agenda and related is the last comment dashboard got merged to third-party-ci-tools
17:23:26 <krtaylor> patrickeast isn't in channel
17:23:43 <asselin_> #link last-comment https://git.openstack.org/cgit/stackforge/third-party-ci-tools/tree/monitoring/lastcomment-scoreboard
17:24:00 <krtaylor> I took an action to start an email discussion on which way to go - scoreboard or last comment
17:24:09 <krtaylor> I didn't get to that before vacation
17:25:13 <krtaylor> I personally feel like we should just stay with scoreboard for now, but I don't have a strong preference
17:25:23 <krtaylor> I just want to get something working now
17:25:27 <krtaylor> yesterday
17:25:27 <mmedvede> unrelated, could people with +2 take a look at https://review.openstack.org/#/c/194490/ and approve maybe (scoreboard square stats, instead of piecharts)
17:25:54 <krtaylor> mmedvede, will do
17:26:04 <mmedvede> thx
17:26:26 <krtaylor> also, I feel that waiting on an email discussion would slow this whole process down again
17:26:51 <krtaylor> but, we can, if it needs to happen
17:27:18 <krtaylor> ok, not much input here so I'll go to the mail list
17:27:38 <krtaylor> next then
17:27:41 <mmedvede> Do you think it would help if we throw together scoreboard POC puppet deploy?
17:28:11 <krtaylor> and have it depends-on the spec? yes I do think that woul dhelp
17:28:15 <krtaylor> would help
17:28:16 <asselin_> mmedvede, I think so, would be valuable regardless fo those setting it up
17:28:25 <krtaylor> ++
17:28:57 <mmedvede> asselin_: cool. I would look into creating module on github, or inside the third-party tools repo
17:29:28 <krtaylor> hm, repo is fine, I can refresh spec with a link
17:29:41 <asselin_> +1 for  third-party tools repo
17:29:59 <krtaylor> mmedvede, that would be very helpful
17:30:33 <mmedvede> asselin_: I am not clear on what would happen if infra would deploy it. Would they split out puppet module, or just use it as is out of third-party repo
17:31:16 <mmedvede> that is the only concern for creating a separate repo for the module
17:31:22 <krtaylor> that would be a guide template I would think, it would be a new module
17:31:28 <asselin_> mmedvede, yes tha's a good point.
17:31:45 <asselin_> so if it's in github already, you can just import it.
17:31:56 <krtaylor> right
17:32:11 <asselin_> ok, I change my vote to new github repo :)
17:32:20 <mmedvede> I assume they would want control over it, and would not be ok to deploy from third-party tools :)
17:33:32 <krtaylor> mmedvede I guess I was thinking it would be used and moved, just a place to put it while spec was approved
17:33:39 <mmedvede> separate github repo needs to happen, it is just a question whether we start in third-party tools, and then cut it out
17:33:49 <krtaylor> exactly
17:37:14 <krtaylor> ok, so, I guess it can be fixed any way it is done, mmedvede what ever you want to do would be great
17:37:19 <mmedvede> #action mmedvede look into creating puppet-scoreboard module
17:37:31 <asselin_> +1 mmedvede decides :)
17:37:37 <krtaylor> +1
17:37:39 <mmedvede> thanks :)
17:38:17 <krtaylor> thank you mmedvede , that will help - this is really important to start improving the trust in CI systems
17:38:25 <asselin_> +1
17:38:47 <krtaylor> anything we can do to make this as painless for infra to implement is a plus
17:39:00 <krtaylor> anything else on this?
17:39:41 <krtaylor> #topic TPCI Repo patches for review
17:39:55 <krtaylor> so I added a topic this week, that I like to see continue
17:40:21 <krtaylor> that is to remind everyone to go review our patches
17:40:53 <krtaylor> #link https://review.openstack.org/#/q/project:stackforge/third-party-ci-tools+status:open,n,z
17:41:13 <krtaylor> feel free to add patches that you feel need a broader audience
17:41:32 <krtaylor> like the one you brought up mmedvede
17:42:03 <krtaylor> if time permits, we can review/approve them in this meeting
17:43:23 <krtaylor> so, lets come back to that
17:43:38 <krtaylor> #topic Open Discussion
17:43:41 <krtaylor> anyone?
17:44:02 <krtaylor> else, I am looking at:
17:44:06 <krtaylor> #link https://review.openstack.org/#/c/194490/
17:45:19 <mmedvede> unfortunately amazon scoreboard instance is down
17:45:32 <krtaylor> yes, mine is not coming up
17:46:15 <mmedvede> the code is working. I did not want to ninja-merge it all on my own
17:46:44 <krtaylor> mmedvede, appreciated, I agree with your comment
17:46:47 <mmedvede> I asked to use bar charts instead of pie charts
17:46:51 <krtaylor> but it would be nice to see it
17:47:31 <krtaylor> pie is the "legacy" way of doing it, for those that remember radar
17:47:58 <krtaylor> I don't have a preference really
17:48:32 <krtaylor> mmedvede,  did it not look right?
17:48:57 <mmedvede> piecharts actually just a bad type of chart to use.
17:49:17 <mmedvede> hard to compare
17:49:21 <krtaylor> hehheh, ok, fair enough
17:49:31 <mmedvede> research is on my side :)
17:49:57 <mmedvede> yeah, that is not really important in the end, as long as we have something working
17:50:05 <krtaylor> +1000
17:50:34 <krtaylor> patrickeast may be on vacation, I'd hate to hold this up
17:50:54 <krtaylor> if you have seen it and it is close enough, I'll approve it
17:51:04 <krtaylor> I guess we could deploy it internally :)
17:51:56 <asselin_> I don't have it deployed yet, but I will review it still
17:52:26 <mmedvede> yes, I saw the patch work. I can switch to patch commit internally and test
17:52:27 <krtaylor> mmedvede, how hard is it to update our internal with this patch?
17:52:36 <mmedvede> krtaylor: very easy
17:52:39 <krtaylor> ++
17:53:52 <krtaylor> ok, we are getting close to time, anything else from anyone?
17:56:28 <krtaylor> thanks everyone!
17:56:34 <asselin_> thanks krtaylor
17:56:41 <mmedvede> thank you krtaylor
17:56:45 <krtaylor> #endmeeting