15:01:21 <anteaya> #startmeeting third-party
15:01:22 <openstack> Meeting started Mon Sep 14 15:01:21 2015 UTC and is due to finish in 60 minutes.  The chair is anteaya. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:27 <openstack> The meeting name has been set to 'third_party'
15:01:30 <anteaya> hello
15:01:45 <asselin_> o/
15:01:52 <asselin_> hi anteaya
15:02:15 <anteaya> hey asselin_
15:02:27 <anteaya> asselin_: how are you this morning?
15:02:45 <asselin_> anteaya, I'm fine :)
15:03:05 <anteaya> glad to hear it
15:03:17 <anteaya> anything third party wise you would like to discuss today?
15:03:54 <asselin_> nothing in particular
15:04:47 <anteaya> okay
15:05:01 <anteaya> any developments on the third party dashboard tool?
15:05:38 <asselin_> I don't think there's anything new. I'm planning on looking into them in more depth today
15:06:04 <asselin_> hopefully we can make a go-forward decision tomorrow
15:06:06 <anteaya> awesome
15:06:08 <anteaya> woooooo
15:06:22 <asselin_> but I still haven't heard back from Sweston regarding radar
15:07:53 <anteaya> okay
15:08:03 <anteaya> a data point to keep in mind
15:08:08 <asselin_> anteaya, have you seen the tool options? do you have any opinions?
15:08:20 <anteaya> I have seen a few
15:08:35 <anteaya> I am willing to look at your assessment of the tools
15:08:46 <anteaya> and I can offer an opinion if you like
15:09:31 <asselin_> ok I need to find the etherpad link
15:09:39 <anteaya> thanks
15:12:54 <asselin_> I can't find it. it's in the #openstack-third-party-ci room which isn't logged....
15:13:00 <anteaya> ah okay
15:13:06 <anteaya> well when you can find it
15:13:09 <anteaya> do share
15:13:33 <asselin_> sure I'll ping you later today when I find it
15:13:34 <anteaya> should I leave the meeting open do you think?
15:13:38 <anteaya> sure thanks
15:14:52 <asselin_> well..the other thing I'd like to discuss is https://review.openstack.org/#/c/189762/
15:15:09 <asselin_> but that is more infra related.
15:15:24 <anteaya> #link https://review.openstack.org/#/c/189762/
15:15:40 <anteaya> do you want to share your thoughts for the log?
15:15:43 <asselin_> but it does impact 3rd party, especially towards migrating to a common-ci solution
15:16:14 <asselin_> the patch introduces a backwards compatibility issue
15:16:43 <asselin_> so anyone deploying nodepool and not using the latest puppet scripts would need to create the new secure.conf file
15:17:17 <asselin_> my ci-s & infra are not affected b/c we're using the latest puppet-nodepool scripts.
15:17:55 <asselin_> clarkb mentioned last week since nodepool version < 1.0 we don't need to bump the version number per semver
15:18:02 <asselin_> #link http://semver.org/
15:19:32 <asselin_> there's also some question (Joshua Hesketh) as to where to put the nodepool test-job.
15:20:28 <anteaya> awesome
15:20:38 <anteaya> jhesketh: is sitting to my right
15:20:38 <asselin_> so it'd be great if we can iron out those issues and get the patch merged....
15:21:01 <anteaya> in about 5 more minutes after we finish going round the room I will get jhesketh to join us
15:21:32 <jhesketh> o/
15:22:03 <asselin_> it would be great to have yolanda pabelanger and jeblair as well
15:23:10 <jeblair> asselin_: hi there
15:23:15 <jhesketh> asselin_: ah right, that one (just catching up)
15:23:35 <jhesketh> asselin_: so I have an opinion about moving the test-job param, but it's just an opinion and not blocking on it at all
15:23:36 <anteaya> yay
15:23:51 <anteaya> so asselin_ has some thoughts as he has outlined above
15:24:10 <anteaya> anyone else care to share their perspective on asselin_'s goal and the patch linked?
15:24:52 <jeblair> what's the question? :)
15:25:09 <anteaya> asselin_: do you want to clearly form a question?
15:25:48 <asselin_> the goal is to get the patch merged, but there are some questions regarding the test job and backwards incompatibility
15:25:58 <jeblair> it's definitely backwards incompatible.
15:26:33 <asselin_> pabelanger, hi
15:26:39 <jeblair> but we make backwards incompatible changes a lot.  and we'll keep doing it.   but we can try to make sure people know about them.
15:26:40 <pabelanger> o/
15:27:32 <jeblair> and of course since we use puppet to continuously deploy, there will be a sequence of changes that stepwise implement the change without breakage
15:28:13 <asselin_> jeblair, right, for -infra & my 3rd party cis those changes have already merged (puppet-nodepool) I can look it up
15:28:38 <asselin_> #link https://review.openstack.org/#/c/188325/
15:29:56 <yolanda> hi asselin, i'll be around for short time, but i'm available now
15:30:22 <asselin_> yolanda, we're discussing your nodepool secure.conf change
15:30:36 <jeblair> the test-job should not go in the secure.conf file
15:31:10 <jeblair> if we move it, it should probably be to associate it with a label.
15:31:16 <yolanda> ah yes, we decided to move to the nodepool yaml, with jenkins targets, i remember
15:32:07 <jeblair> so therefore, it ought to be a different change.  i think it's a good idea, but we don't use it so it's not high on my list to do right now.
15:32:37 <jeblair> i think i said something to that effect in the comments already
15:32:48 <jeblair> but i can do it again if that is desired.
15:32:59 <yolanda> so as far as i know, i didn't include on secure.conf, but on yaml, is not like that?
15:33:14 <jhesketh> jeblair, asselin_: yes, the discussion we had is here: https://review.openstack.org/#/c/189762/21/nodepool/nodepool.py
15:33:17 <jhesketh> #link https://review.openstack.org/#/c/189762/21/nodepool/nodepool.py
15:34:21 <pabelanger> Ya, I'd like to see if move forward. Breaking working nodepool configuration leaves some sour taste in my mouth.  Any way to make secure.conf optional?
15:34:26 <jeblair> probably test-job would have been moved to label a long time ago if we actually used it.  :)
15:35:23 <jhesketh> my point about test-job was simply that rather than breaking compat twice, we do it all in one job
15:35:27 <pabelanger> if not, I am fine with that. We just need to make sure everybody downstream knows of the change
15:35:34 <jhesketh> but as jeblair points out, we don't promise non-breakage, so it's not overly important
15:35:38 <jeblair> pabelanger: nodepool isn't nearly well designed enough to carry around that kind of baggage :(
15:36:11 <pabelanger> fair enough
15:36:19 <yolanda> this change is already complex enough to add more features to it
15:36:39 <yolanda> so i'd prefer to move test-job to an independent change
15:36:41 <pabelanger> well, a version bump should be simple :)
15:37:11 <yolanda> i agree that we should bump version with that secure.conf addition, as we are breaking backward compatibility
15:37:45 <pabelanger> Ya, don't get me wrong, I like the change. So I don't want to hold it up longer then already it has been.
15:38:41 <yolanda> i'm afraid of breaking downstream really. In our side, we consume a custom branch, and we manage syncs manually. But i'm not sure on all use cases, people consuming directly from upstream may have bad surprises
15:38:55 <yolanda> maybe sending an announcement to the mailing list, before approving, can work?
15:39:33 <jeblair> yeah, announce to -infra list would be prudent i thin
15:39:35 <jeblair> think
15:39:51 <jeblair> also, in zuul, we keep a NEWS file with notes on breaking changes
15:39:55 <pabelanger> Ya, anything to give a heads up helps.  For me, I have old clients that are running nodepool. So, if I can point them to a simple ML post, that helps
15:39:59 <asselin_> and -dev [third-party]
15:40:25 <jeblair> asselin_: let's focus these messages on -infra
15:40:27 <jeblair> that's what it's fore
15:40:45 <yolanda> ok, so this needs to be coordinated, maybe sending the announce on mailing list, with an exact day of the change
15:40:50 <yolanda> to give time for people to be prepared
15:41:01 <yolanda> and also point to the changes done in puppet to get a general idea on the new config
15:41:20 <asselin_> jeblair, I'm not sure how my third party folks subscribe to that list, but maybe that's something we can note that they do up-front.
15:41:49 <yolanda> sending that to opentack-dev, with the right topic, cannot hurt...
15:42:01 <jeblair> asselin_: i think that people using our tools should subscribe to it.  it's not necessary information for third-party ci folks not using our tools.
15:42:23 <jeblair> yolanda: i think we should avoid sending every message to every list.  let's try to keep them on topic.
15:42:29 <asselin_> jeblair, ok I can send the note to -dev and reference the -infra post
15:42:32 <jeblair> this is not related to openstack development
15:42:40 <jeblair> this is related to nodepool development
15:44:10 <yolanda> ok
15:44:42 <yolanda> so how do we move forward?
15:44:53 <asselin_> jeblair, ok, then we should ask third party folks to subscribe to -infra. I'll take that action.
15:45:02 <jeblair> asselin_: the ones using our tooling, yes :)
15:45:18 <asselin_> #action asselin_ ask third party operators using infra tooling to subscribe to -infra list
15:46:01 <jeblair> send announcement to -infra; merge change; (optional: move test-job); (optional: start a NEWS file in nodepool repo); (optional: release with version bump)
15:46:04 <jeblair> yolanda: ^
15:46:55 <yolanda> jeblair, how do you want to schedule that? maybe giving a week between the announcement and the deploy?
15:48:11 <jeblair> yolanda: no, i think immediate is fine.  we don't promise that we won't break CD systems running master.  if someone wants to run our tools CD, they should probably be using puppet and keeping on top of things.
15:49:36 <anteaya> are we getting to a way forward?
15:49:47 <yolanda> jeblair, you will take care? or do you want me to send the announcement to the ml?
15:49:49 <anteaya> anyone what to propose a plan of action?
15:50:05 <jeblair> anteaya: i thought i did.
15:50:11 <anteaya> great
15:50:14 <jeblair> yolanda: would you please send it?
15:50:27 <anteaya> so jeblair has proposed a plan of action, can we all agree to it?
15:50:42 <yolanda> jeblair, sure
15:50:47 <yolanda> will it be landing today?
15:55:19 <yolanda> jeblair, asselin, so i need to step out for a while. I'll come back later and write some announcement, first i'll send you for review. Are you ok with that?
15:55:29 <jeblair> yolanda: sounds good, thanks
15:55:29 <yolanda> pabelanger as well ^
15:55:32 <yolanda> ok
15:55:37 <asselin_> yolanda, agree
15:55:43 <pabelanger> ack
15:56:44 <anteaya> I do believe I have to end the meeting
15:56:46 <asselin_> anteaya, I think that's it. we can take the rest offline. We have a plan forward now.
15:56:53 <asselin_> thanks everyone
15:56:53 <anteaya> have we reached a happy place?
15:56:56 <anteaya> thank you
15:57:05 <anteaya> sorry I was multitasking with the qa sprint
15:57:06 <yolanda> thanks all, nice to have it moving forward
15:57:13 <anteaya> thanks all for contributing to the conversation
15:57:15 <anteaya> I appreciate it
15:57:19 <anteaya> #endmeeting