16:59:48 <asselin> #startmeeting third-party
16:59:48 <openstack> Meeting started Tue Nov 24 16:59:48 2015 UTC and is due to finish in 60 minutes.  The chair is asselin. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:53 <openstack> The meeting name has been set to 'third_party'
17:00:22 <asselin> HI, who's here for 3rd party ci working group meeting?
17:00:51 <mmedvede> o/
17:01:04 <asselin> hi mmedvede
17:01:10 <mmedvede> hi asselin
17:01:33 <asselin> #link agenda https://wiki.openstack.org/wiki/Meetings/ThirdParty
17:01:58 <krtaylor> o/
17:02:10 <asselin> hi krtaylor
17:02:19 <krtaylor> hey everybody
17:02:46 <asselin> #topic announcements
17:02:58 <asselin> Jenkins security issue (for those with publicly accessible Jenkins setups)
17:03:05 <asselin> #link https://jenkins-ci.org/content/mitigating-unauthenticated-remote-code-execution-0-day-jenkins-cli
17:03:12 <asselin> #link https://review.openstack.org/#/c/242787/ (merged)
17:03:50 <asselin> any other announcements?
17:04:15 <asselin> #Topic CI Watch
17:05:03 <asselin> mmedvede, and apporva (sp?) have been making a lot of progress on this
17:05:22 <asselin> mmedvede, want to give a quick update?
17:05:34 <mmedvede> asselin: sure
17:06:16 <mmedvede> I have been working on a couple of bugs that would have prevented it from working smoothly once deployed
17:06:43 <mmedvede> the most recent one is gerrit event listener not recovering after connection loss
17:07:02 <mmedvede> #link https://review.openstack.org/248919
17:07:28 <mmedvede> Overall, I'd like to concentrate on getting some unit tests implemented
17:07:39 <mmedvede> right now there are zero :)
17:07:44 <kcalman> o/
17:08:19 <asselin> +1
17:08:32 <mmedvede> Active work is tracked under ci-dashboard topic
17:08:36 <mmedvede> #link https://review.openstack.org/#/q/status:open+%28topic:ci-dashboard%29,n,z
17:09:19 <mmedvede> asselin: that is a gist of it
17:09:50 <mmedvede> oh, and there is a lunchpad bugs for it as well
17:09:58 <asselin> mmedvede, yeah, was looking at that patch. reuse is definitely a good thing!
17:10:10 <mmedvede> #link ciwatch bugs  https://bugs.launchpad.net/ciwatch
17:11:32 <Swanson> hi
17:11:56 <mmedvede> this is all I have on ciwatch for now
17:12:39 <asselin> mmedvede, thanks for working on this.
17:12:56 <asselin> anything else anyone wants to add re ci-watch?
17:13:39 <asselin> #topic Common-CI Solution
17:14:05 <asselin> So we have a "working" solution merged: Merged! http://lists.openstack.org/pipermail/openstack-dev/2015-November/080058.html
17:14:07 <asselin> #link Merged! http://lists.openstack.org/pipermail/openstack-dev/2015-November/080058.html
17:14:17 <mmedvede> \o/
17:14:39 <asselin> there were a few issues found regarding integrating the log server
17:14:51 <asselin> #link Allow external Jenkins Plugins https://review.openstack.org/248223
17:14:58 <asselin> #link Install custom OpenStack scp jenkins plugin https://review.openstack.org/248226
17:15:21 <asselin> I think just those 2 patches left not yet merged ^^
17:15:52 <asselin> Swanson, how is your setup going?
17:16:22 <Swanson> I got everything running.  Just doesn't work yet.  If you get my meaning.
17:16:53 <asselin> Swanson, not sure I get your meaning....
17:17:30 <Swanson> Jenkins is up.  Nodepool is up.  Log server is up.  Devstack is up.  Having merge issues and nothing is spinning off nodes.
17:17:30 <ja3> sounds like all the components are "running", just not correct output yet
17:18:30 <asselin> Swanson, do you want to discuss your issues now or later/offline?
17:19:05 <Swanson> Where is the best place to look for the failure
17:19:12 <Swanson> (To start to look for the failure.)
17:19:29 <asselin> I see...a troubleshooting section is needed
17:19:58 <Swanson> 2015-11-24 09:25:11,686 INFO zuul.MergeClient: Merge <gear.Job 0x7f00383a4b50 handle: H:127.0.0.1:44 name: merger:merge unique: 89e15a9ff54a478fa17ad1136d428a4c> complete, merged: False, updated: False, commit: None
17:20:17 <Swanson> That's the sort of thing I'm wondering about.
17:21:18 <asselin> Swanson, that looks like zuul-merger pulled down a patch.
17:21:40 <asselin> Swanson, in /var/log/zuul/debug.log you should see more details
17:22:00 <asselin> perhaps search for those ids 89e15a9ff54a478fa17ad1136d428a4c
17:23:07 <Swanson> That would be the lone line.
17:23:34 <Swanson> (At least with that Id
17:23:41 <asselin> Swanson, anything in the /var/log/zuul/merger-debug.log file?
17:24:25 <Swanson> Well, based on the fact I don't see a merger-debug.log file I'm going to guess that that is my problem.
17:24:51 <asselin> Swanson, there should be 3 processes running: https://git.openstack.org/cgit/openstack-infra/puppet-openstackci/tree/contrib/README.md#n221
17:25:14 <Swanson> Nope, there it is.  Too many windows and fingers aren't working...  sigh.
17:26:06 <Swanson> Could not read from remote repository.
17:26:21 <Swanson> host key verification failed.
17:26:52 <asselin> Swanson, you're using the default? review.openstack.org?
17:27:23 <Swanson> Yep
17:27:52 <asselin> ok....let's take it offline
17:27:54 <mmedvede> I would try manually cloning any repo on zuul. Puppet does setup review.o.o host key, but it does not always work
17:28:35 <asselin> #action asselin investigate host key verification failed issue with Swanson
17:29:16 <asselin> yeah, I'd like to see why it doesn't always work. I think I remember someone else having a similar issue
17:29:38 <Swanson> It wouldn't be as simple as me needing to accept the RSA fingerprint would it?
17:30:26 <asselin> Swanson, yes, as zuul user
17:30:27 <mmedvede> Swanson: it might be. But you might need to 'su zuul' first
17:30:39 <asselin> or sudo su - zuul
17:31:12 <asselin> Swanson, but that should be setup correctly
17:31:24 <asselin> Swanson, you can take a look at /home/zuul/.ssh/known_hosts
17:32:40 <Swanson> I see no keys.  Guessing that would be my issue.  :)
17:33:04 <asselin> Swanson, if you rerun puppet apply /etc/puppet/manifests/site.pp does it create it?
17:33:10 <asselin> (run as root)
17:33:28 <asselin> puppet apply -v
17:33:32 <asselin> (verbose)
17:35:52 <asselin> kcalman, hi, I don't think we met. While Swanson checks his system, would you like to introduce yourself?
17:36:19 <Swanson> It ccreates a known host.  No other keys, however.
17:36:28 <Swanson> And we can take this offline.
17:36:56 <asselin> ok
17:37:04 <asselin> #topic open discussion
17:37:25 <asselin> any other topics to discuss?
17:38:48 <mmedvede> I can add on ciwatch - I am running a personal VM with the most recent ciwatch deployed http://52.23.200.77:5000/, if people want to test it. No guarantees, can go down any time
17:39:23 <asselin> #link mmedvede's public test ci watch deployment  http://52.23.200.77:5000/
17:40:31 <mmedvede> thx asselin
17:40:36 <asselin> ok, if there's nothing else we can end the meeting.
17:40:46 <asselin> #endmeeting