17:00:11 <rluethi> #startmeeting training-guides
17:00:13 <openstack> Meeting started Mon Aug 11 17:00:11 2014 UTC and is due to finish in 60 minutes.  The chair is rluethi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:17 <openstack> The meeting name has been set to 'training_guides'
17:00:20 <dbite> hello
17:00:22 <dbite> roll call
17:00:28 <matjazp> hi
17:00:33 <sayali_> Hello
17:00:34 <rluethi> sarob cannot be with us today.
17:00:35 <MeganR> Hi
17:00:45 <rluethi> hi everyone.
17:01:00 <dbite> hello guys
17:01:15 <rluethi> dbite: update on docs?
17:01:21 <dbite> yes
17:01:28 <dbite> set the topic?
17:01:34 <dbite> *can you set the topic
17:01:38 <rluethi> #topic docs
17:02:06 <dbite> #info docs team was previously called stable team
17:02:33 <dbite> basic install guide needs to be updated for Icehouse
17:03:03 <dbite> some of the sections like ML2 plugin etc. are missing and older OVS plugin for Neutron is still in use
17:03:12 <dbite> sarob_: hello
17:03:27 <sarob_> Hey. I'm on a short break
17:03:33 <rluethi> yes. a comparison with the openstack-manuals install-guide for icehouse will show the necessary changes.
17:03:50 <dbite> is the Comcast team there with us?
17:04:08 <MeganR> I'm here
17:04:10 <matjazp> dbite: for basic install guide, just report relevant bugs... so we can all chip in
17:04:47 <dbite> I agree with rluethi, for getting better idea we can compare with install guides under openstack-manuals project
17:05:01 <dbite> matjazp: Yes, I will start logging bugs
17:05:29 <rluethi> MeganR: I you guys want to help out, you don't need lots of prior knowledge for this task.
17:05:34 <dbite> MeganR: have you guys been working on the install guides part? Last time we discussed we were planning on migrating to something very close to install guides
17:06:09 <MeganR> rluethi: we would be happy to help out - especially if not a lot of previous knowledge is needed
17:06:15 <dbite> sayali_: also can you get in touch with MeganR and her team to get better idea for working on install-guides
17:06:31 <sayali_> dbite, alright
17:06:59 <dbite> MeganR: it has a learning curve, but with the current labs section its easier to test out the install guides
17:07:01 <rluethi> MeganR: there shouldn't be. Everything in training-guides that deviates from the openstack-manuals install-guide is suspicious.
17:07:30 <dbite> to be more precise basic-install-guides under training-guides
17:07:39 <MeganR> ok - we can discuss this in more detail offline, I will look at scheduling some time on Thursday, when Shilla is back
17:07:48 <rluethi> what dbite said :).
17:07:51 <dbite> sure thing
17:08:02 <dbite> rluethi: you just freaked me out ;)
17:08:33 <dbite> any questions for the docs sub-team?
17:09:46 <dbite> rluethi: lets move on
17:10:05 <rluethi> #topic upstream
17:10:18 <sarob_> I got a sec
17:10:32 <rluethi> sarob: cool. your stage.
17:10:45 <sarob_> I can't get epicslide to build on osx
17:10:56 <sarob_> Only ubuntu
17:11:05 <matjazp> sarob_: what about landslide?
17:11:11 <sarob_> So I PDF support will be delayed a bit
17:11:18 <sarob_> Landslide is it
17:11:19 <dbite> matjazp: the problem with landslide is PDF support
17:11:37 <sarob_> So HTML slides only for right now
17:12:02 <sarob_> Id like to get some feedback on the dir structure
17:12:11 <rluethi> sarob: any idea how hard it would be to fix epicslide?
17:12:14 <sarob_> For the current upstream patch
17:12:37 <matjazp> dbite: maybe we can ask Foundation for help with PrinceXML for PDF geenration? I know its not opensource, but in the mean time... it gets things moving
17:12:39 <sarob_> Rluethi: not sure. Something to work on longer term
17:13:00 <sarob_> Short term we only need HTML I believe
17:13:04 <dbite> matjazp: we need to push opensource as much as possible
17:13:18 <sarob_> Dbite: agreed
17:13:32 <rluethi> #info epicslide doesn't build on OS X. We need to stay with landslide for the time being (which means no PDF generation).
17:13:38 <dbite> sarob_: I think we should proceed with landslide and try to get the PDF support in eventually
17:13:55 <matjazp> sarob_: dbite: sure, but I see it as a tool--- much like Oxygen for XML editing...
17:14:02 <sarob_> Gotta go
17:14:08 <sarob_> Agreed
17:14:13 <rluethi> matjazp: Oxygen is another problem, not an example to follow :).
17:14:16 <sarob_> Cheers
17:14:27 <dbite> matjazp: Oxygen is not exactly a good example in this case
17:14:32 <dbite> sarob_:bye
17:14:40 <dbite> I use VIM to write XML code
17:14:45 <matjazp> yes, I know.. but it gets the job done
17:14:50 <rluethi> sarob: we can't give such tools to volunteers and students, that's bad.
17:14:53 <dbite> with LandSlide we officially lock down
17:15:04 <dbite> the RST is there to be used by people
17:15:16 <dbite> so someone can volunteer in and use PrinceXML
17:15:23 <dbite> but we should try to keep it out of upstream code
17:15:36 <dbite> does it make sense?
17:16:09 <rluethi> #action sarob will try to get upstream material merged soonish.
17:16:28 <matjazp> dbite: no, I mean that PrinceXML can be used only at Foundations's servers, for ppl to load PDFs... not as a tool that everyone needs to have on theirs coms
17:16:44 <dbite> ok, makes sense
17:16:59 <matjazp> we just need to deliver PDFs to DL
17:17:02 <dbite> I would suggest asking this to Sarob during the next meeting
17:17:06 <matjazp> OK
17:17:07 <rluethi> sorry, I got everyone off track. Any comments on the directory structure?
17:17:22 <rluethi> directory structure for upstream materials?
17:17:27 <dbite> I think what reed has proposed is a good direction to start with
17:17:34 <dbite> for the presentation
17:18:10 <matjazp> rluethi: just start the ball rolling, we can change it later ;)
17:18:21 <reed> rluethi, afaik landslide generates pdf
17:18:24 <rluethi> if anyone else is interested, have a look here:
17:18:29 <rluethi> #link https://review.openstack.org/#/c/100999/
17:18:48 <rluethi> reed: I thought it only does so with PrinceXML.
17:19:14 <matjazp> reed: did you try to do it without PrinceXML?
17:19:16 <reed> rluethi, you may be right, I never tried pdf
17:19:27 <rluethi> reed: there's your problem then :).
17:19:36 <reed> i don't see the point of pdf anyway :)
17:19:53 <rluethi> reed: nice for handouts, I guess.
17:19:54 <matjazp> reed: students like to DL pdfs...
17:20:02 <matjazp> rluethi: exactly
17:20:04 <dbite> can we not use another technology/project for generating PDF's ?
17:20:13 <reed> students are wrong :)
17:20:18 <matjazp> rluethi: they are bugging me if I don't give them materials for DL
17:20:21 <dbite> reed: they are the future ;)
17:20:35 <reed> god save us from that future :)
17:20:42 <dbite> hehe
17:20:48 * rluethi sighs
17:20:53 <rluethi> moving on?
17:21:08 <rluethi> #topic testing
17:21:14 <rluethi> matjazp: ?
17:21:27 <matjazp> I started with associate guide
17:21:34 <matjazp> missing quizzes
17:21:47 <matjazp> I have bugs reported
17:22:11 <rluethi> matjazp: you reported bugs or you just have them?
17:22:50 <matjazp> rluethi: I reported bugs, so ppl looking for something to contribute can chip in
17:23:05 <rluethi> matjazp: are you getting help?
17:23:10 <sayali_> We could use bartaz.github.io/impress.js/#/bored  for the presentation
17:23:22 <matjazp> rluethi: no, not at the moment
17:24:01 <rluethi> MeganR: that may be another thing your folks might be able to help out, learning stuff in the process.
17:24:18 <MeganR> ok, we will add it to the list!
17:24:48 <rluethi> matjazp: could you give them some help getting started on tests?
17:24:50 <dbite> sayali_: can you take a lead on this?
17:24:53 <matjazp> maybe we can all report as many bugs as we can, so ppl can see where they can contribute
17:25:05 <matjazp> rluethi: yes, sure
17:25:39 <sayali_> dbite, sure, we can generate pdfs too using that
17:25:40 <rluethi> great. all: please remember to see the "low hanging fruit" tag for bugs that are easy.
17:25:52 <rluethi> what's the proper tag again?
17:27:27 <agentleone> low-hanging-fruit
17:27:42 <rluethi> is it? cool, thanks!
17:27:56 <rluethi> anything else for testing?
17:28:00 <matjazp> nope
17:28:19 <rluethi> #topic infrastructure
17:28:38 <rluethi> dbite?
17:28:41 <dbite> #info training-guides team mark low-hanging-fruits for easy bugs
17:28:58 <dbite> we have good progress for the labs
17:29:05 <dbite> controller node is almost done
17:29:21 <dbite> I would suggest running the osbash.sh script for generating multi-node environment
17:29:26 <dbite> but its not ready yet
17:30:03 <matjazp> dbite: but if I remember correctly, base disks are finished, right?
17:30:20 <rluethi> matjazp: never finished, but working.
17:30:27 <dbite> what do you mean by base disks to be precise?
17:30:32 <dbite> its not finished
17:30:58 <matjazp> rluethi: yes... as long its functional, its ok ;)
17:31:16 <dbite> matjazp: the openstack deployed on it is not yet functional
17:31:19 <rluethi> the only change in basedisks in the past weeks was moving to Ubuntu 14.04
17:32:26 <rluethi> however, we are at a point where several services should be up and running after the scripts have run.
17:32:37 <dbite> to be precise, we could claim that base disk is ready
17:32:43 <rluethi> you can test the services and see if they work.
17:33:13 <dbite> openstack deployed on it is only completed for Keystone, Glance for Controller Node
17:33:27 <dbite> Neutron and Nova for controller node are WIP
17:33:35 <matjazp> rluethi: dbite: yes, I'm looking at your code and scripts from time to time.. nice progress
17:34:04 <rluethi> I try to keep Vagrant working, but I'm not testing very often.
17:34:12 <rluethi> It will lack some features.
17:34:19 <dbite> matjazp: thanks, but it needs lot of work
17:34:30 <rluethi> I don't know yet how to work automated snapshots into vagrant.
17:35:08 <rluethi> dbite: anything else on labs/infrastructure?
17:35:50 <matjazp> rluethi: I know I read somewhere about snapshost in wagrant.. If I find it, will forward
17:36:11 <dbite> nope
17:36:32 <rluethi> matjazp: there was a plugin, I tested it. but we don't have host-side scripting on Vagrant.
17:36:56 <rluethi> matjazp: we have to finish the scripts first, anyway.
17:37:06 <rluethi> #topic misc
17:37:19 <rluethi> anybody confused, shocked, depressed?
17:37:36 <rluethi> any questions/issues you would like to have discussed?
17:37:42 <dbite> or puzzled or just landed here by mistake?
17:37:56 <rluethi> dbite: then I don't care :).
17:38:11 <dbite> haha :)
17:38:12 <sayali_> can you think about impress.js for the lanslide issue?
17:38:45 <rluethi> sayali_: have you tried both? how do they compare?
17:38:46 <dbite> do you mean landslide?
17:38:55 <sayali_> yes dbite
17:39:03 <matjazp> sayali_: how does it generate PDFs?
17:39:07 <dbite> does it support PDF features?
17:39:11 <sayali_> bartaz.github.io/impress.js/#/bored
17:39:35 <sayali_> rluethi, I haven't tried landslide, but impress is pretty good. It supports pdf too
17:40:02 <rluethi> sayali_: I know impress (and similar tools) look cool, but easy of use for slide authors is very important.
17:40:41 <dbite> if it can be created using MD or RST its should be tested out
17:40:41 <rluethi> sayali_: impress might be too complex. if you have experience that shows otherwise, at least I would be interested.
17:41:18 <sayali_> rluethi, you can generate it using MD which is pretty easy
17:41:48 <sayali_> I could look into it further and check the complexity
17:42:24 <rluethi> sayali_: upstream materials should land in the repo soon, maybe you could translate it (or some of it) to impress.
17:42:37 <rluethi> sayali_: that would give us something to compare.
17:43:03 <rluethi> sayali_: working PDF generation would definitely be a plus, since that's our current problem with landslide.
17:43:34 <sayali_> rluethi, ok I will put up an initial patch to show how it works
17:44:28 <rluethi> #action sayali will create a patch to help us evaluate impress.js as a possible alternative to landslide.
17:44:40 <rluethi> anything else?
17:45:14 <rluethi> thanks everyone for being here!
17:45:19 <rluethi> #endmeeting