17:00:01 <rluethi> #startmeeting training-guides
17:00:02 <openstack> Meeting started Mon Sep  1 17:00:01 2014 UTC and is due to finish in 60 minutes.  The chair is rluethi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:06 <openstack> The meeting name has been set to 'training_guides'
17:00:19 <rluethi> roll call. anyone there?
17:00:37 <rluethi> or here, as the case may be?
17:00:52 <rluethi> hi matjazp
17:00:58 <matjazp> hi
17:01:16 <dbite> hello
17:01:18 <sayali> Hello
17:01:30 <rluethi> hi all.
17:01:53 <rluethi> sarob can't be here today, he'll be back for the meeting next week.
17:02:16 <dbite> ok, sounds good
17:02:31 <rluethi> #topic praise
17:02:45 * dbite hehe
17:02:58 <rluethi> so, sarob asked me to praise you guys for all the good work, and welcome the new contributors.
17:03:11 <rluethi> welcome new contributors! good work everyone!
17:03:24 <dbite> welcome new contributors, awesome work everyone!
17:03:24 <sayali> hehe
17:03:46 <rluethi> we got quite a bit of work done last week.
17:04:00 <dbite> rather last few weeks (maybe month)
17:04:21 <rluethi> #topic audio visual subteam
17:04:35 <rluethi> sayali: do you have an update on the proposal?
17:04:53 <rluethi> (re: audio visual subteam content and structure)
17:05:08 <sayali> I sent out an email asking about the content to be included
17:05:38 <sayali> We thought we could re use some of the existing clips first
17:07:03 <rluethi> So we are waiting for replies from whom?
17:07:12 <sayali> But i was also thinking we could first draw out the structure and then add the old clips and new content
17:07:13 <matjazp> sayali: should we also include others into planning? or do we do that later, with draft proposal?
17:07:37 <dbite> I suggest planning on Etherpad as usual, would be much better
17:07:51 <dbite> as we dont know how to inculde audio or video
17:08:06 <dbite> it may be a good idea to not push them to the repository
17:08:18 <rluethi> +1 for anything tangible so everyone gets an idea of what is being proposed and worked on.
17:08:19 <matjazp> sayali: will you start an Etherpad?
17:08:27 <sayali> matjazp: sure
17:08:42 <sayali> matjazp: the existing email thread could also be sent to everyone
17:08:46 <matjazp> sayali: and we'll just continue there
17:08:58 <sayali> sounds good
17:09:12 <matjazp> sayali: sure.. or just publish that on ehtherpad
17:09:35 <sayali> matjazp: alright
17:10:16 <matjazp> #action sayali starts new Etherpad, we all chip in with suggestions
17:10:50 <rluethi> sayali: don't forget to broadcast the link to the etherpad somehow.
17:11:01 <matjazp> rluethi: wiki?
17:11:08 <dbite> better send it over mailing list and add it to wiki
17:11:29 <rluethi> matjazp, dbite either/both work for me.
17:11:39 <sayali> ok will do
17:11:40 <dbite> I meant ehterpad for the design
17:11:46 <dbite> and spread the word via. mailing list
17:12:09 <rluethi> okay, next up:
17:12:11 <rluethi> #topic review queue
17:12:19 <rluethi> #link https://review.openstack.org/#/q/status:open+project:openstack/training-guides,n,z
17:12:41 <rluethi> there are some entries in this list that have been sitting there for way too long.
17:12:53 <dbite> https://review.openstack.org/#/q/project:openstack/training-guides+status:open,n,z
17:12:59 <dbite> we have three reviews open
17:13:18 <rluethi> please check them out and see if you can do something to get them passed.
17:13:31 <rluethi> or abandoned, if necessary :).
17:13:38 <matjazp> rluethi: what happens with "orphaned" reviews?
17:14:01 <rluethi> matjazp: now that's a good question. anyone knows the answer?
17:14:36 <dbite> I am waiting for Megan and Shilla to push
17:14:39 <matjazp> rluethi: we should email author, if nothing happens for X days, someone else can finish it?
17:14:39 <dbite> their changes
17:15:20 <rluethi> matjazp: I suspect that sometimes (depending on workflow) things fall through the cracks, so emailing them might be a good idea.
17:15:29 <matjazp> It's a shame for any effort to go to waste
17:15:48 <rluethi> dbite: they may not realize the ball is in their court.
17:16:28 <dbite> hmm, I will shoot them an email once
17:16:30 <matjazp> rluethi: email or IRC?
17:16:33 <dbite> and see what they have to say
17:16:42 <dbite> we need to freeze IceHouse soon
17:16:53 <matjazp> dbite: when?
17:16:53 <rluethi> matjazp: whatever works for getting in touch :)
17:17:35 <dbite> matjazp: we need to talk to Sean for this
17:17:37 <rluethi> #info a few patches spend too much time in review, need to contact authors
17:17:56 <rluethi> good enough. I just wanted to mention it. thanks.
17:18:02 <rluethi> #topic upstream slides
17:18:21 <rluethi> slides have been uploaded and merged.
17:18:26 <dbite> reed: are you in the house?
17:18:35 <dbite> rluethi: is that all the slides?
17:18:49 <matjazp> rluethi: it's awkward to review them.... maybe an update to tools with automatic slide generation?
17:18:51 <rluethi> dbite: I have no idea.
17:19:30 <rluethi> matjazp: we were supposed to have a discussion via gerrit, but it somehow didn't happen.
17:19:33 <dbite> one min I will check
17:19:36 <dbite> with the blueprint
17:19:44 <matjazp> rluethi: dbite: we can crosscheck material from https://wiki.openstack.org/wiki/OpenStack_Upstream_Training/Info
17:20:06 <dbite> for your information, I have built and re-verified all the content being pushed into the review queue
17:20:10 <rluethi> matjazp: the awkwardness you mentioned may have been a major reason for that.
17:20:38 <rluethi> dbite: I built most of them, too. some of the text got cut off at the bottom when I looked at the slides.
17:20:42 <dbite> track the progress with this blueprint https://blueprints.launchpad.net/openstack-training-guides/+spec/merge-upstream-university-training
17:20:50 <matjazp> dbite: it should be automatic..
17:20:57 <dbite> rluethi: that is tolerable for now
17:21:16 <rluethi> dbite: I thought it might be, but didn't know, so I stopped reviewing.
17:21:22 <dbite> matjazp: we need to push some basic content for now, designing tests will be next step
17:22:01 <rluethi> what's the plan for the slides now that they are merged?
17:22:07 <dbite> rluethi: I think it is ok to have some issues like clipping of images for now, we can fix them once we are done with other more important things
17:22:41 <dbite> rluethi: I will push the python tool to generate pdf files and then we push them on docs.openstack.org after we discuss it with Anne and Sarob
17:23:09 <matjazp> dbite: great
17:23:16 <rluethi> dbite: sweet.
17:23:32 <dbite> matjazp: we also need loads of test cases for our labs section
17:23:37 <matjazp> dbite: IIRC, you already tested PDF generation, right?
17:23:43 <dbite> but we cannot do everything at once
17:23:51 <rluethi> #action dbite will push the python tool to generate pdf files, discuss with Anne and Sarob
17:23:57 <dbite> matjazp: yes PDF generation works perfectly
17:24:25 <dbite> I will push a few PDFs for reviewing before pushing the python patch
17:24:52 <dbite> and yes, I think the upstream content is pushed as per the blueprint
17:26:02 <rluethi> #link https://wiki.openstack.org/wiki/OpenStack_Upstream_Training/Info
17:26:10 <rluethi> #link https://blueprints.launchpad.net/openstack-training-guides/+spec/merge-upstream-university-training
17:26:16 <rluethi> #topic quizzing
17:26:29 <rluethi> matjazp: how's it going?
17:26:33 <matjazp> conpute node quiz is done
17:26:42 <matjazp> i still have to push the patch
17:26:50 <matjazp> working on network node
17:27:06 <rluethi> matjazp: is this the first quiz? I don't remember ever seeing one.
17:27:20 <matjazp> meganr offered help, we synced over email as we were both absent last week
17:27:44 <matjazp> rluethi: no there are 2 quizzes
17:28:13 <matjazp> for associate guide
17:28:51 * rluethi is an ignorant fool.
17:29:20 <matjazp> there are 5 quizzes + 1 assessment
17:29:29 <rluethi> eventually?
17:29:36 <matjazp> yes
17:29:38 <rluethi> ETA?
17:30:03 * dbite follows rluethi and learns from him to become one
17:30:04 <matjazp> if megan helps with the last one (Object storage), it could be done in a week
17:30:17 <rluethi> matjazp: awesome.
17:30:30 <rluethi> very cool.
17:30:31 <matjazp> that is, everything except assessment
17:30:53 <matjazp> assessment will be done later, when we discuss other things
17:31:39 <matjazp> that is the plan anyway...
17:31:56 <rluethi> matjazp: well, looks like you are well on your way.
17:32:14 <rluethi> talking about which...
17:32:15 <rluethi> #topic labs scripts
17:32:23 <rluethi> dbite: ?
17:32:41 <dbite> rluethi: Cinder and Neutron have problem
17:32:58 <dbite> when we follow the install guides as it is
17:33:07 <dbite> I will be editing it and pushing the changes asap
17:33:20 <matjazp> dbite: whats wrong?
17:33:21 <rluethi> dbite: and you waited for the IRC meeting to tell me.
17:33:44 <rluethi> dbite: :)
17:34:06 <dbite> rluethi: I wanted to keep some surprises ;)
17:34:30 <rluethi> dbite: well, I did not see that one coming.
17:34:34 <dbite> I was doing some background checks on why I had a few things different than install-guides in my previous versions
17:34:49 <dbite> and figured it out, that we need some changes more RnD to do in that arae
17:34:50 <dbite> *area
17:35:02 <dbite> with ML2 plugin out, I dont have a solution for it yet
17:35:06 <dbite> the OVS part works as required
17:35:20 <rluethi> dbite: okay, we can discuss this one on one later on.
17:35:23 <dbite> but the instances are not getting IP addresses and Cinder Volumes refuses to work as required
17:35:37 <dbite> I, agree
17:35:49 <dbite> note this also affects basic-install-guides
17:36:05 <dbite> as we are focused on VirtualBox based cluster/architecture
17:36:32 <rluethi> #info some issues with the cluster setup, but basic software ready for testing.
17:36:56 <dbite> I think its ready to be released
17:37:04 <rluethi> thanks to matjazp for his valuable feedback.
17:37:33 <rluethi> #topic incubation
17:37:43 <rluethi> #link https://wiki.openstack.org/wiki/Training-guides#Incubation_Plan
17:38:05 <rluethi> sarob would like to start incubation preparation next meeting.
17:38:23 <matjazp> rluethi: are we there yet?
17:38:24 <rluethi> you may want to have a look at the link above.
17:38:52 <rluethi> matjazp: not for me to decide. I for one am currently a bit reluctant to say yes :).
17:38:55 <dbite> matjazp: we are nearly there, also we are pushing lot of content which differs from the manuals teams road map
17:39:19 <dbite> but the best judges for this again are Anne Gentle and Sean Roberts
17:39:26 <dbite> we need to ask them for guidance and advice
17:39:50 <matjazp> annegentle: you here?
17:40:19 <dbite> I think we should discuss this later on
17:40:23 <dbite> what do you guys think?
17:40:45 <matjazp> ML?
17:40:46 <rluethi> dbite: agreed. read the info in the link above, it's a good preparation.
17:41:28 <rluethi> #topic other issues
17:41:41 <rluethi> anything else I missed?
17:42:14 <sayali> document updation for the labs section
17:42:22 <rluethi> #topic docs
17:42:31 <rluethi> of course, thank you sayali!
17:42:50 <rluethi> both for reminding me and for the updates.
17:42:58 * rluethi smacks himself
17:43:16 <sayali> At this point do we need/want to include the HACKING.rst?
17:43:23 <sayali> rluethi: no problem :)
17:43:35 <sayali> in all the sub folders I mean
17:43:51 <dbite> sayali: once you are finished with pushing the content, can you also convert all the markdown files to rst files?
17:43:53 <rluethi> sayali: which subfolders?
17:44:10 <dbite> sayali: we just need one Hacking.rst
17:44:19 <dbite> at the location /labs/
17:44:21 <sayali> the sub foders in the labs folder rluethi
17:44:25 <dbite> we do not need it for each subfolder
17:44:28 <sayali> ok dbite
17:44:36 <rluethi> sayali: agree with dbite
17:44:52 <sayali> ok then I can just detail  that one
17:45:00 <dbite> rluethi: what do you think the content of hacking.rst should be? I was thinking it to be more in line with other projects hacking.rst's
17:45:05 <matjazp> sayali: yes, one Hacking.rst will do
17:45:42 <rluethi> dbite: following other projects is usually a good idea, even if it's just to meet the expectations of the users.
17:46:12 <rluethi> dbite: I definitely want the all the information for devs to get started somewhere.
17:46:26 <rluethi> dbite: some of the other projects are sorely lacking in this regard.
17:47:01 <sayali> rluethi: sure, Ill try covering most of it!
17:47:14 <dbite> yes, I meant follow them for the initial kickstart
17:47:22 <rluethi> sayali: I'll chip in with some information, too.
17:47:42 <sayali> rluethi: great :)
17:48:45 <rluethi> #topic other issues reloaded
17:48:53 <rluethi> anything else I also missed?
17:49:46 <dbite> nothing much from my side
17:49:56 <rluethi> I take that as a no (phew).
17:50:04 <rluethi> Thanks everyone, see you next week.
17:50:12 <rluethi> #endmeeting