17:02:08 <dbite> #startmeeting training-guides
17:02:09 <openstack> Meeting started Mon Sep 29 17:02:08 2014 UTC and is due to finish in 60 minutes.  The chair is dbite. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:12 <openstack> The meeting name has been set to 'training_guides'
17:02:18 <dbite> #topic audio-visual
17:02:54 <dbite> sayali: go on, you are the team lead
17:03:16 <dbite> reed: can we discuss it here, sorry for the inconvenience
17:03:35 <reed> sure
17:03:47 <sayali> So I was planning on recording our first videos for the AV content since ill be going to a university for an OpenStack event
17:04:07 <dbite> the only concern from my side for a private video channel is that its content will be privately owned
17:04:15 <dbite> otherwise I dont mind using private channel
17:04:20 <sayali> So I was thinking since I will be giving a talk on devstack and a demo of the osbash it would be good to record it
17:05:00 <sayali> and we can have a test patch too for new recordings
17:05:06 <dbite> reed: good news, you can create another channel with the given user id in google
17:05:23 <reed> dbite, I understand the concern of having an individual owning a shared resource but I don't see an easy way out because of the way YouTube manages identities
17:05:41 <dbite> I see, but for me I can create another channel
17:05:48 <dbite> which ialso creates another G+ account for me
17:06:30 <ShillaSaebi> what about vimeo?
17:06:38 <ShillaSaebi> a shared account maybe?
17:06:53 <sayali> who will fund that?
17:07:01 <dbite> https://www.youtube.com/channel/UCgOEmbfu5XVW4g_HP-0URGQ?guided_help_flow=3&ytsession=4mvBhRcHZjaT9YlEBCC8bfkIt6GQk2R-P7Q1keJOuLIjHNHSKGob26V_5mgQQ05xCR2FXS-nimEDgH7XD308qPp4fKGvjreuuKuh5YIln7fLxstqHWapQNCeDJmxuwpBEGaYiuqJ6iuJdiJLujg5DagOv21TGzKayZhFs2UV9aDl5Ba-HCc3SuzjQlMII8_7XR9B3oMmUZJ8LmdwwivhU1JMd88L4iPorSi9Fq0YfdVuiYcsb32bcoiW5LWVlXzvLo1R11z6a_8_xIrx-ODJKSam0V1yOM5-c8A-oi2-7HjzfP2FRVeDRm7qijKk-QOypurguCFvIhni2GnoADxNxQ
17:08:26 <ShillaSaebi> i thought vimeo had free basic membership as well
17:08:53 <reed> dbite, cool
17:10:24 <dbite> what do you think?
17:10:29 <dbite> what should be the solution for this
17:11:03 <sayali> I think if we can change the ownership after a while it would be good
17:12:23 <rluethi> It may be hard to change ownership with any of these services. What are the assets you really want to transfer? Videos? Playlist? Playlist name?
17:12:39 <sayali> the entire channel
17:12:47 <dbite> rluethi: it is easy and possible to transfer the ownership
17:12:52 <sayali> under the official openstack foundation
17:13:04 <sayali> As of now acess to all of us would be good
17:13:14 <rluethi> dbite: if you say so. that's good then, problem solved!?
17:14:01 <dbite> yes, for now I will own the channel
17:14:08 <dbite> I will try to share the ownership with the team
17:14:27 <dbite> so that I dont feel like being a sell out :(
17:15:03 <rluethi> anyway, they can change their terms anytime. we should design the process to be robust no matter than the hosting service or any of our contributors does.
17:15:28 <dbite> yes
17:15:36 <dbite> moving on from this topic
17:15:42 <ShillaSaebi> cool
17:15:55 <dbite> anyone has any questions?
17:16:05 <sayali> ShillaSaebi: Also you had some videos too right?
17:16:31 <sayali> comcast training videos you had mentioned
17:16:35 <reed> looking good, dbite
17:17:54 <ShillaSaebi> yeah i have some internal ones we use
17:17:59 <ShillaSaebi> i can show them to you
17:18:09 <sayali> sure, that would be good
17:18:13 <ShillaSaebi> ok
17:18:44 <sayali> also a short sumary of the content covered in them would be useful to screen them
17:18:50 <sayali> summary*
17:19:33 <ShillaSaebi> ok
17:20:10 <dbite> #info Audio Visual channel for now is located here https://www.youtube.com/user/trainingguides
17:20:23 <dbite> anything else for AV?
17:21:05 <sayali> #action ShillaSaebi will send comcast internal video
17:21:31 <ShillaSaebi> yup
17:21:47 <dbite> moving on then
17:21:54 <sayali> #info Will be recording devstacka nd osbash videos at OpenStack event in Amity university.
17:22:02 <dbite> #topic infra
17:22:15 <dbite> infra team, hows it going?
17:22:36 <rluethi> dbite: talking to yourself? :)
17:22:45 <dbite> you are the lead too!
17:23:05 <rluethi> Well, I would like to hear how osbash testing has been going for core reviewers.
17:23:19 <dbite> from my side, it works on my three machines
17:23:22 <dbite> perfect it works
17:23:44 <dbite> for 4 GB i5, 8GB i5 and i7 16 GB machines
17:23:45 <dbite> for me
17:24:29 <rluethi> so I guess we are ready to push it outside our group!?
17:24:45 <dbite> yes from my side
17:25:02 <rluethi> apparently there is nobody else :)
17:25:11 <sayali> works for me too :)
17:25:20 <dbite> there are a few weird use cases which we did not consider
17:25:20 <rluethi> sayali: good to hear
17:25:26 <dbite> I guess we should discuss it later after the meeting
17:25:37 <sayali> i will be running it at the university too as a demo
17:25:42 <rluethi> dbite: yes, I am aware of some limitations, too
17:26:06 <rluethi> I have a proof of concept single node script.
17:26:09 <dbite> more than limitations its like we did not consider some scenarios
17:26:15 <dbite> clea
17:26:21 <rluethi> not sure if it saves much and is worth it, though.
17:26:25 <dbite> clearly we need to add more usecases
17:26:28 <rluethi> and it's rather experimental.
17:26:34 <rluethi> but it does seem to work.
17:26:43 <dbite> ok
17:26:47 <dbite> feel free to push it
17:27:18 <dbite> anything else to report?
17:27:37 <rluethi> sarob came just back to report about his test results.
17:27:55 <rluethi> no?
17:27:57 <dbite> rluethi: are you joking or you serious?
17:28:12 <dbite> ok, moving on then
17:28:16 <rluethi> I don't know. I saw him come back, I'd love to hear what he found.
17:28:36 <rluethi> yeah, let's move on
17:28:39 <dbite> #topic docs
17:29:23 <dbite> docs needs updates, I had a meeting with Ajaeger and finally concluded that we need to push the tools to tools folder under the repository
17:29:30 <dbite> for the initial phase
17:30:22 <dbite> any questions?
17:30:29 <dbite> suggestions?
17:30:41 <rluethi> when do you expect the push?
17:30:56 <dbite> its ready
17:31:03 <dbite> I will push it in a day or two
17:31:08 <rluethi> k
17:31:13 <dbite> I need to figure out how to get it triggered
17:31:20 <dbite> withe the jenkins jobs
17:31:24 <dbite> and with tox
17:32:54 <rluethi> oh, by the way: I'd like to add some docs for the labs scripts, probably on the wiki. something that can be changed without going through reviews.
17:32:57 <dbite> any thing else on docs?
17:33:08 <dbite> rluethi: wiki part sounds great
17:33:21 <dbite> also I was thinking of providing a short chapter on how to use oslabs
17:33:27 <rluethi> I don't think there is a wiki page for the scripts yet.
17:33:29 <dbite> since people need to know how to use it!
17:34:03 <rluethi> at least I couldn't find one. So I will just go ahead and create one, if nobody objects.
17:34:09 <dbite> #action dguitarbite will create oslabs wiki page and add chapter in the docs
17:34:13 <dbite> ahh, yes no issues
17:34:26 <dbite> #action rluethi will work on the wiki for labs section
17:34:35 <dbite> moving on
17:34:56 <dbite> #topic testing
17:35:04 <dbite> Matjazp around?
17:35:24 <dbite> can anyone fill in for him?
17:36:24 <dbite> ok, lets postpone this for next meeting
17:36:33 <dbite> #topic anything else
17:37:41 <dbite> anyone wants to share something
17:38:14 <sayali> I would like any inputs on whats need to be added or showcased specifically to the osbash related stuff I would be demonstrating
17:38:40 <dbite> rluethi: glory time!
17:38:45 <dbite> matjazp: hello
17:38:46 <matjazp> hi guys
17:38:54 <rluethi> matjazp: hey
17:38:58 <dbite> can you fill in for testing?
17:39:00 <dbite> #topic testing
17:39:09 <rluethi> sayali: let's talk about this after the meeting.
17:39:10 <matjazp> sorry for beeing so late.. we have a grand opening of our new building... Duty calls
17:39:16 <sayali> rluethi: sure
17:39:20 <dbite> matjazp: you are right on time
17:39:26 <matjazp> great
17:39:34 <sayali> hi matjazp
17:39:41 <matjazp> nothing new to report for Testing
17:39:57 <matjazp> still working on Network node Quiz
17:40:05 <dbite> ok
17:40:11 <matjazp> hi sayali
17:40:26 <dbite> #topic general discussion
17:40:47 <dbite> sayali: can you propose what you are planning to demonstrate during the university presentation?
17:42:15 <sayali> Well the audience that would be present at the event are students who have little or no idea about OpenStack and cloud in general. Which are the people we are targetting for the training guides
17:42:37 <sayali> So I was thinking of one demo on devstack for those interested in development
17:43:01 <sayali> and the other showcasing osbash for them to be able to start playing around with multi node
17:43:29 <rluethi> sayali: I assume you will be using Linux!?
17:43:53 <sayali> yes I have arch linux on my machine, so it will be on that
17:43:58 <dbite> with Windows8 theme mod
17:44:08 <sayali> lol
17:45:28 <sayali> what would be that main things to be focused on where osbash is concerned?
17:46:28 <rluethi> some of the main points are:
17:46:41 <rluethi> works (or should work) out of the box, no configuration required
17:46:59 <rluethi> multi-platform (Linux, OS X, and Windows)
17:47:09 <rluethi> no dependencies other than VirtualBox
17:47:10 <dbite> I would not involve Windows for now
17:47:32 <dbite> because we need linux hosts to generate windows scripts
17:47:40 <rluethi> dbite: agreed.
17:48:16 <rluethi> dbite: OTOH, if you want to try OpenStack and all you have is a Windows system, it's pretty much the option you've got.
17:48:26 <dbite> yes
17:48:40 <dbite> but I also can imagine 90% of the students asking her to run it for her
17:48:44 <dbite> *for them
17:48:55 <dbite> it would be a nightmare
17:49:15 <rluethi> you only need to run it once. we could even host them somewhere.
17:49:16 <alexpilotti> rluethi: if you have a Windows system, like Windos 8 or 8.1, you can run Hyper-V and the rest of Hyper-V components in a Linux VM
17:49:51 <dbite> is hper-V provided for free on Windows?
17:49:52 <matjazp> rluethi: +1 for hosting Win scripts directly
17:49:52 <alexpilotti> rluethi: using Hyper-V itself as Nova compute node
17:49:56 <dbite> *hyper-v
17:49:56 <rluethi> alexpilotti: and what's building the cluster?
17:50:01 <alexpilotti> dbite: yes
17:50:08 <dbite> ahh, for the home users?
17:50:14 <alexpilotti> dbite: for everybody
17:50:15 <dbite> I dont know it as I dont use windows
17:50:20 <dbite> that sounds great
17:50:55 <matjazp> rluethi: we could make a custom job to run scripts for Win and publishes them when we merge new patch
17:51:11 <dbite> alexpilotti: our concern on how to run shell scripts on windows
17:51:16 <rluethi> matjazp: sure.
17:51:21 <dbite> as we need to run them as of now, to generate batch scripts
17:51:42 <dbite> matjazp: It should go in my pocket of toolsets I am implementing
17:52:14 <matjazp> dbite: yes... in the mean time, we could do it manually
17:52:15 <dbite> #action dguitarbite add osbash trigger to generate windows scripts on every change to the repository
17:52:19 <alexpilotti> dbite: you can run bash scripts on Windows, but in general it’s easier to use a Linux VM
17:52:22 <dbite> matjazp: agreed
17:52:35 <dbite> alexpolotti: may be using Cygwin
17:52:43 <dbite> but our job is to keep it simple for our users
17:52:44 <alexpilotti> dbite: Windows has it’s own scripting language, called Powershell
17:53:11 <alexpilotti> dbite: msys or cygwin
17:53:18 <rluethi> guys, we are trying to build a solution that is easy to use, not something only Windows power users can install.
17:54:03 <alexpilotti> rluethi: people using a shell are power users for you? :-)
17:54:07 <rluethi> alexpilotti: powershell is on my wishlist. right now we have batch scripts.
17:54:27 <alexpilotti> rluethi: I’d go with a Linux VM on Windows ATM
17:54:28 <rluethi> alexpilotti: Windows users who install cygwin are.
17:54:43 <dbite> alexpilotti: can I also run KVM on windows?
17:54:50 <alexpilotti> rluethi: Windows users that use git are power users for you?
17:55:01 <alexpilotti> rluethi: because git comes with msys
17:55:10 <alexpilotti> rluethi: so you have bash and all the rest
17:55:12 <rluethi> alexpilotti: pretty much, yes.
17:55:33 <dbite> alexpilotti: we are trying to teach people OpeNstack if we add other stuff on top of it then it will be a nightmare for the students
17:55:44 <rluethi> alexpilotti: maybe my expectations for Windows users are too low.
17:55:57 <dbite> and yes people who know stuff like Cygwin, Git etc. are prettymuch powerusers of Windows
17:56:02 <alexpilotti> rluethi: I guess that if someone is installing OpenStack and has no clue about git, there’s quite a long road ahead :-)
17:56:09 <dbite> rluethi: may be even mine!
17:56:40 <alexpilotti> rluethi: assumptions are not good
17:56:52 <rluethi> alexpilotti: right. I just want people to be able to try a cluster on their computer without installing and learning other tools.
17:57:14 <dbite> alexpilotti: we are talking about the people who are just learning the dashboard
17:57:15 <rluethi> alexpilotti: we are _always_ making assumptions.
17:57:22 <dbite> we cannot expect them to learn or use git and other similar tools
17:57:25 <matjazp> let's just publish the scripts and see the feedback from Win users :)
17:57:29 <dbite> they just need a one click install solution!
17:57:48 <alexpilotti> dbite: we’re working on that for WIndows
17:58:16 <dbite> alexpilotti: I would love to discuss it with you in detail, but it is out of scope for our project
17:58:25 <dbite> supporting Hyper-V is not in our roadmap
17:58:39 <alexpilotti> dbite: sure, I’ll keep an eye on it
17:58:40 <dbite> till Hyper-V open ups its source code
17:58:50 <rluethi> alexpilotti: who is working on that for Windows? is there a project page?
17:59:01 <reed> dbite, sounds weird that you want to educate new openstack sysadmins without them knowing git... what sort of students are these?
17:59:06 <alexpilotti> dbite: well, Hyper-V is offcicially a supported hypervisor in OpenStack
17:59:17 <dbite> reed: the initial training on the dashboard and CLI tools
17:59:22 <dbite> they do not need to learn Git
17:59:39 <dbite> and its not about a book
17:59:42 <dbite> it is about the labs section
17:59:45 <dbite> under the training guides
17:59:51 <reed> dbite, so they don't need to deploy openstack, it's already running for them?
17:59:56 <dbite> we want the labs to be build with a single command
18:00:03 <dbite> time up
18:00:08 <rluethi> reed: yes
18:00:09 <dbite> lets continue on docs channel
18:00:09 <matjazp> yes bye all
18:00:15 <dbite> #endmeeting