17:00:04 <sarob> #startmeeting training-guides
17:00:04 <openstack> Meeting started Mon Oct  6 17:00:04 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:07 <openstack> The meeting name has been set to 'training_guides'
17:00:17 <sarob> hello hello
17:00:31 <dbite> hello
17:00:40 <rluethi> hey
17:01:29 <sayali> hello
17:02:07 <sarob> #topic docs
17:02:38 <matjazp> hi all
17:02:43 <dbite> hello matjazp
17:02:49 <rluethi> hi matjazp
17:02:51 <MeganR> Hello
17:02:52 <sarob> evening matjazp
17:03:10 <rluethi> ...and MeganR :)
17:03:11 <dbite> More fixes coming up this month. I am fixing the XML syntax to bring it up to the level of other documentation projects
17:03:58 <dbite> I think that is it for docs this time
17:04:02 <sarob> cool
17:04:08 <sarob> anyone else?
17:04:33 <dbite> any questions/suggestions/new contributors?
17:05:01 <sarob> im eager to discuss user group training
17:05:24 <sarob> unless a new contributor has a question
17:05:42 <sarob> #topic user group training
17:05:47 <dbite> should we keep user group training for the extras section?
17:05:52 <dbite> rather than discuss in docs?
17:06:15 <sarob> i just changed the topic
17:06:17 <dbite> ahh :)
17:06:25 <rluethi> what is user group training?
17:06:27 <sarob> unless you need more time
17:06:37 <dbite> no I am good
17:06:45 <sarob> cool
17:06:50 <sarob> #link http://lists.openstack.org/pipermail/openstack-docs/2014-October/005274.html
17:07:33 <sarob> now that i am mostly moved over in my new digs
17:07:53 <sarob> i have some time and new people to work with
17:08:40 <sarob> the general idea is that we run the associates training
17:08:44 <dbite> yep, good news
17:08:49 <sarob> in between the summits to start
17:09:00 <dbite> also more feedback from the trainers for keeping the content quality better
17:09:06 <sarob> we attract trainers to help out
17:09:15 <sarob> dbite, yeah def
17:09:44 <sarob> it will help us fine tune the great body of work that we have to work with
17:09:56 <sarob> work out bugs faster
17:10:05 <sarob> get new contributors
17:10:42 <sarob> i have 3-4 people willing to help run a 2 hour training session in the SF bay area
17:11:02 <sarob> i have a proposed schedule in the email linked above
17:11:07 <MeganR> That is great - then are you looking to expand to other meet-ups throughout the country?
17:11:14 <dbite> if possible we need 1-2 regular contributors for docs sub-team too
17:11:29 <sarob> meganr yes very much so
17:11:45 <MeganR> sarob, this looks great
17:12:06 <sarob> meganr ;)
17:12:33 <matjazp> sarob: looks promising
17:12:45 <sarob> sooo, i see some stuff that needs to be prioritized IF we as a team want to support this
17:12:58 <sarob> think of it as our coming out party
17:13:54 <sayali> sounds good sarob :)
17:14:12 <matjazp> btw guys, we could also discuss this at the summit?
17:14:27 <sarob> first up, can I get a sense of what the team thinks of this as one of our priorities for the next cycle?
17:14:32 <sarob> matjazp: def
17:15:33 <sarob> let me put this a different way
17:15:53 <sarob> i would let to set our kilo priorities as
17:16:20 <sarob> 1: current with juno release
17:16:47 <sarob> 2: audio visual tools and videos
17:17:09 <sarob> 3: running the associate training guide in the user groups
17:17:37 <sarob> 4: coordinating the training guides with the upstream training
17:17:45 <sarob> off the top of my head
17:18:01 <sarob> im not asking for a vote or anything
17:18:16 * rluethi notices a distinct lack of scripts
17:18:17 <sarob> just throughing it out there for discussion
17:18:35 <dbite> I think first we need to come up with a model for releases
17:18:48 <matjazp> I think #4 is already starting to branch.. we update/cleanup their content.. do they use training-guides repo or their own?
17:18:59 <dbite> for instance which release should we work while in the current release cycle
17:19:16 <dbite> should we be one release behind ? or follow the current release while developing the content
17:19:23 <matjazp> rluethi: scripts are implicit :)
17:19:42 <rluethi> matjazp: I don't like being implicit :).
17:20:05 <annegentle> I think video is farther down the road in priorities, get your docs and script house in order
17:20:10 <sarob> matjazp, rluethi: infra is required for our success
17:20:32 <matjazp> rluethi:  hehehe... yes, true :)
17:20:45 <annegentle> dbite: I would advise one release behind for your audience (unless your target audience changes to devs)
17:20:54 <sarob> annegentle: the numbers are meant as priority
17:21:06 <annegentle> sarob: saying 2 for video should be more like 5
17:21:07 <dbite> annegentle: yes I was asking for everyones views on this
17:21:11 <sarob> annegentle s/are/are not/
17:21:14 <dbite> thanks for the suggestion :)
17:21:18 <annegentle> sarob: ah :)
17:21:28 <annegentle> sarob: that not makes a big difference
17:21:42 <rluethi> annegentle: at least with the scripts we need to track the openstack-manuals trunk or they will become useless for doc authors.
17:21:47 <sarob> annegentle always does ;)
17:22:01 <dbite> sarob: I am working on the infra part, infact here is the first patch to automate upstream-training builds https://review.openstack.org/#/c/126246/
17:22:03 <sarob> rluethi very true
17:22:47 <sarob> dbite nice
17:23:30 <dbite> annegentle: the scripts should be good tools for install guides team
17:23:32 <dbite> what do you think?
17:23:33 <annegentle> rluethi: okay... but even devstack has a stable/<relname> branch each release
17:23:47 <sarob> okay lets get back to the topic
17:23:48 <rluethi> annegentle: understood.
17:24:06 <dbite> and we had an argument about openstack multinode not running on VirtualBox, the scripts will install openstack on multinode env. using virtualbox
17:24:10 <sarob> i messed it up by listing stuff
17:24:11 <dbite> and it works fine
17:24:14 <annegentle> dbite: honestly it's early to say
17:24:29 <annegentle> dbite: rluethi: can't wait to see what people do with the scripts
17:25:02 <sarob> annegentle agreed scripts are pretty awesome
17:25:20 <annegentle> sarob: you have quite good contributor numbers this release, with many training-focused people in the top ten for docs
17:25:20 <sarob> soo the user group training topic
17:25:45 <sarob> annegentle, the team is amazing agreed ;)
17:26:39 <sarob> so team. we will continue to discuss our priorities for the summit
17:27:14 <rluethi> sarob: do we have a meeting in paris scheduled?
17:27:19 <sarob> are we generally in favor of my user group training plan here #link http://lists.openstack.org/pipermail/openstack-docs/2014-October/005274.html ?
17:28:24 <dbite> yes, I in favour
17:28:30 <dbite> *I am
17:28:43 <MeganR> yes
17:29:00 <sarob> rluethi: session not settled yet
17:29:03 <rluethi> actually, "a laptop with enough mem or disk" should not be hard to come by.
17:29:03 <ShillaSaebi> agree yes
17:29:22 <rluethi> RAM requirements: 4 GB for the cluster
17:29:23 <sayali> me too
17:29:29 <matjazp> sarob: can we make a session on Thursday?
17:29:42 <annegentle> sarob: for docs, we have cross project and a pod
17:29:47 <dbite> sarob: our requirements are 4GB/ i5 machine
17:29:52 <dbite> it should/may work on i3
17:29:58 <matjazp> sarob: I have some logistic problems and will have to go back on Friday morning
17:30:30 <sarob> annegentle: okay, i need to work out a session slot with you this week if poss
17:30:48 <dbite> sarob: ok, my time is quite flexible throughout the week
17:30:57 <dbite> so I guess we give preference to matjazp
17:31:36 <sarob> dbite, matjazp okay , fri is out, so summit session prefered tue to thur
17:31:43 <annegentle> sarob: right, looks like you need the pod Thursday then
17:31:47 <matjazp> so Mo-Th is prefered
17:32:07 <sarob> matjazp mon is slammed for me already :(
17:32:29 <sarob> annegentle thursday looks good
17:33:09 <matjazp> sarob: we can use doodle? everyone enters appropriate slots..
17:33:48 <sarob> action sarob create a training guides kilo summit doodle for design session slot options
17:34:26 <sarob> #action sarob create a training guides kilo summit doodle for design session slot options
17:35:25 <sarob> #action sarob start the etherpad on training guides kilo release cycle priorities and design session topics
17:35:55 <sarob> lets talk scripts shall we?
17:35:59 <annegentle> sarob: we have the Documentation etherpad here https://etherpad.openstack.org/p/docstopicsparissummit
17:36:23 <sarob> annegentle: cool, I will just add another section then
17:36:42 <sarob> #undo
17:36:43 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x266fa10>
17:37:07 <sarob> #action sarob update Documentation etherpad here https://etherpad.openstack.org/p/docstopicsparissummit with priorities and topics
17:37:29 <sarob> #topic infra
17:39:19 <dbite> as stated earlier, custom builds/tests are on the way
17:39:35 <dbite> I have started with building upstream training content
17:39:35 <dbite> https://review.openstack.org/#/c/126246
17:39:42 <rluethi> scripts are usable now. I have some patches pending, but there are no major bugs as of now.
17:39:43 <dbite> please clone this patch and run $tox
17:40:07 <dbite> and you can have the HTML and PDF under upstream-training/target/ folder
17:40:31 <dbite> for now the patch will have to wait till we clear our a few dependencies with infra project
17:41:06 <sarob> that would be awesome if reed can reference the repo during the pre summit training
17:41:25 <dbite> yes
17:41:31 <dbite> he can definatly do that
17:41:38 <reed> sarob, in what sense 'reference'?
17:41:54 <dbite> reed: use the repo directly for presenting
17:42:03 <reed> dbite, that's the intention, yes
17:42:05 <dbite> generating the ppts in the repo using the tools
17:42:09 <sarob> dbite reed yup
17:42:15 <dbite> reed: I think you will love the patch in that case :)
17:42:34 <dbite> the pdf files do not have the background theme, I will be working on it a bit later if that is ok with you
17:42:51 <rluethi> we will have zip/tgz files with the labs directory content, hopefully in the not too distant future (also depending on how urgent people feel it is)
17:43:06 <dbite> I have one question regarding the upstream-training content which directly impacts infra
17:43:20 <dbite> how do we expose the html and pdf files on docs.openstack.org/training-guides ??
17:43:27 <dbite> and suggestions/solutions?
17:43:36 <matjazp> rluethi: what about DL of prepared images? we talked about that few moths back...
17:43:48 <matjazp> *months
17:44:13 <reed> dbite, indeed, cool stuff. I am issuing a call for help with the html theme
17:44:21 <dbite> matjazp: I think it is better not to prepackage Images
17:44:26 <dbite> reed: sure :)
17:44:43 <matjazp> dbite: why?
17:44:43 <dbite> we do not have the resources (h/w limitations)
17:44:52 <dbite> and its more easier to build the scripts
17:45:03 <sarob> if we continue on the creating slides from script theme
17:45:06 <dbite> we need jenkins jobs, someone has to verify the images etc. etc.
17:45:29 <sarob> then perhaps we could start making it user configurable
17:45:46 <sarob> and saving the user configured for others to reuse
17:46:03 <rluethi> matjazp: we can still do it. the problem is exporting/importing the cluster, in particular network configuration. do you have a solution for that?
17:46:25 <matjazp> rluethi: hmm... Vagrant?
17:46:54 <matjazp> rluethi: oh.. you mean automatic export of netw?
17:46:58 <rluethi> matjazp: I am seriously considering dropping Vagrant altogether. It has too many limitations.
17:47:09 <rluethi> matjazp: plus nobody seemed to be using it.
17:49:38 <matjazp> rluethi: netw conf is more or less static, right? we could manually create proper netw config with Vagrant (or batch), and DL already prepared images
17:50:39 <rluethi> matjazp: I am a bit skeptical, because I am trying to reduce complexity, but I'd be happy to discuss this with you.
17:50:49 <matjazp> rluethi: ok
17:50:55 <dbite> matjazp: let us discuss this over the summit, what do you think?
17:51:17 <matjazp> sure... I'm all for it
17:51:25 <dbite> matjazp: you will loose snapshots and other issues which we face
17:51:33 <matjazp> dbite: yes, I know
17:51:36 <dbite> with bundled images
17:51:48 <dbite> if we make the scripts 100% (near) reliable
17:51:58 <sarob> dbite will do when i get into the office
17:52:01 <rluethi> matjazp: for instance, rebooting during provisioning is sort of lacking in Vagrant
17:52:11 <dbite> sarob: you need to run the scripts, they are awesome
17:52:26 <sarob> dbite :)
17:52:33 <dbite> sarob: :)
17:53:43 <matjazp> rluethi: hmmm.. there seems to be some workarounds
17:54:19 <matjazp> rluethi: but yes... maybe the added complexity is not worth it
17:55:14 <sarob> time check peoples
17:55:41 * rluethi checks watch
17:55:46 <sarob> #topic any other business to discuss
17:55:59 * dbite dbite wonders if its swiss watch!
17:56:22 <sarob> i have started placing items into #link https://etherpad.openstack.org/p/docstopicsparissummit
17:58:31 <sarob> i guess i got everyone onto the etherpad :)
17:58:43 <dbite> :D
17:59:06 <sarob> i will call this latest version of the training guides team meeting at a close
17:59:15 <MeganR> Have a good week!
17:59:19 <sarob> thanks for all your hard work
17:59:31 <sarob> cheers!
17:59:38 <dbite> bye
17:59:48 <sayali> Bye
18:00:03 <sarob> #endmeeting