17:00:44 <sarob> #startmeeting training-guides
17:00:45 <openstack> Meeting started Mon Oct 13 17:00:44 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:49 <openstack> The meeting name has been set to 'training_guides'
17:00:56 <sarob> hello all
17:00:57 <dbite> hello
17:00:59 <matjazp_> hi
17:01:00 <rluethi> hey
17:02:22 <sarob> so lets follow up on items from last week
17:02:53 <sarob> here is the doodle poll for kilo design time #link http://doodle.com/4hp7a89e3geykmhy
17:03:06 <sarob> i will send it over the ML as well
17:03:54 <sarob> any questions about us meeting over the kilo summit?
17:04:18 <sarob> #topic actions from last meeting
17:05:01 <sarob> okay
17:05:07 <sayali> Hello
17:05:12 <matjazp_> hi sayali
17:05:15 <sarob> hi there
17:05:20 <dbite> hey
17:05:26 <sarob> we are going over actions from last week
17:05:29 <dbite> check the logs for doodle link
17:06:01 <sarob> here is the docs program kilo summit etherpad #link https://etherpad.openstack.org/p/docstopicsparissummit
17:06:38 <sarob> i dumped some training guides topic ideas into there for our design meet
17:06:50 <sarob> i ask that you all do the same
17:07:00 <sarob> so we have a solid agenda for the summit
17:07:06 <sayali> okay
17:07:16 <matjazp_> ok
17:07:22 <sarob> any questions about this?
17:08:41 <sarob> btw, my topic ideas are not the agenda per say
17:08:52 <sarob> i want the group to set the agenda
17:08:59 <sarob> i just got it started
17:09:27 <sarob> #action team updates kilo summit agenda with their topics #link https://etherpad.openstack.org/p/docstopicsparissummit
17:10:06 <sarob> #action team updates the kilo summit doodle poll with their preferred time to meet #link http://doodle.com/4hp7a89e3geykmhy
17:10:39 <sarob> okay moving on
17:10:50 <sarob> #topic docs updates
17:11:11 <sarob> what up d?
17:11:30 <dbite> no progress on docs last week
17:11:53 <dbite> two things remain, update the basic install guides for Icehouse some fine tuning needed
17:12:21 <dbite> and fix XML schema to make it upto mark with docs
17:13:54 <sarob> should we list these as critical bugs to prioritize?
17:14:09 <dbite> yes that is a good way to start with it
17:14:35 <dbite> #action dbite address pending work on docs sub-team by logging bugs
17:14:47 <sarob> cool
17:15:11 <sarob> work that needs to get done asap marked as critical
17:15:22 <dbite> yes
17:15:25 <sarob> anything else?
17:15:31 <dbite> no, Im done
17:15:35 <sarob> coolo
17:15:45 <sarob> #topic infra updates
17:15:49 <matjazp_> well... looking at bug list... we need to address it more fequently..
17:16:45 <sarob> i am going to start keeping up on the schedule, wiki, and bug tracking better
17:16:57 <dbite> infra is moving a bit faster now
17:16:57 <sarob> i have been lax
17:18:01 <dbite> first of all, we are almost ready to publish first of our custom jenkins jobs to build HTML and PDF presentations
17:18:18 <dbite> https://review.openstack.org/#/c/126246/
17:18:49 <dbite> this will make it easier for infra to publish more jobs eventually
17:18:50 <sarob> ill will run again this morning
17:18:52 <matjazp_> dbite: what was with  wkhtml2pdf and weasyprint?
17:19:26 <dbite> the dependencies with wkhtml2pdf were a bit Icky so I found out a better solution
17:19:36 <dbite> which was weasyprint with no dependencies apart from python
17:19:44 <dbite> packages
17:20:03 <dbite> wkhtml2pdf also had some issues with the way it was using CSS for generating the PDF files
17:20:30 <dbite> and was having broken dependencies like QT4 which are not expected on a server while building it
17:20:39 <matjazp_> dbite: ok.. what's the status for this patch? Infra team is ok with it?
17:21:38 <dbite> the patch is ready
17:21:52 <dbite> we are waiting for global requirements to accept the patch
17:22:07 <dbite> after which we will push remaining scripts in training guides
17:22:24 <dbite> https://review.openstack.org/#/c/127472/
17:22:42 <dbite> we need to update global requirements before we can merge this https://review.openstack.org/#/c/126877/
17:23:09 <dbite> which is in turn required to automatically build this script using tox https://review.openstack.org/#/c/126246/
17:23:32 <sarob> want me to answer doug's question?
17:23:47 <sarob> we can ask reed to weigh in
17:24:13 <dbite> I did not get doug's question
17:24:35 <sarob> he is asking why we are not using Sphinx
17:24:57 <dbite> ahh yes
17:25:08 <dbite> we need to ask Reed to answer this
17:26:02 <sarob> reed you onlilne?
17:26:27 <sarob> huurmph
17:26:51 <sarob> #action dbite, sarob get reed to comment on #link https://review.openstack.org/#/c/127472/
17:26:51 <dbite> I added him to the review so that he may notice this
17:27:26 <sarob> i just added him a sec ago
17:27:28 <dbite> reed seems to be offline for now
17:27:34 <sarob> yeah
17:28:07 <sarob> what else
17:28:15 <sarob> you got cooking?
17:28:26 <matjazp_> sarob: dbite: I think landslide is optimized for presentations, Sphinx is not?
17:28:44 <dbite> matjazp_: It makes me happy to think this way :)
17:28:59 <rluethi> matjazp_: I think so too, but it's worth finding out
17:29:07 <sarob> matjazp_ that is my understanding from reed
17:29:40 <matjazp_> So this is the reason we use landslide and weasyprint :)
17:29:57 <dbite> to generate presentations from sphinx needs similar tools like landslide which have more dependencies in turn!
17:31:00 <sarob> if it is nothing more than better quality output, i will back up that argument
17:31:53 <sarob> moving on?
17:31:58 <dbite> yes
17:31:58 <matjazp_> yes, me too... Presentations need to be of high quality (more than docs), or trainers won't use them
17:32:09 <sarob> yup
17:32:15 <sarob> #topic testing update
17:32:23 <matjazp_> slow progress
17:32:36 <matjazp_> compute node Quizz is more or less done
17:32:48 <matjazp_> moving to network node
17:33:42 <matjazp_> I have few questions in my txt files, need to submit as patches for network node quiz
17:33:51 <sarob> cool
17:34:11 <sarob> any thoughts on moodle or something else to add testing automation
17:34:24 <matjazp_> sarob: I hope to discuss this at the summit
17:34:57 <sarob> okay good
17:35:10 <matjazp_> I'll also ping M. Rice from LPI
17:35:26 <sarob> ideas on how to put the assessment test together?
17:35:52 <sarob> LPI input would be good
17:36:02 <dbite> what is LPI and who is M. Rice?
17:36:02 <matjazp_> hmmm.. I would like to have hands on test, but this is way harder than "just" normal test
17:36:04 <sarob> as least as reference info
17:36:23 <sarob> for the associate training, hands on may be too much
17:36:43 <matjazp_> sarob: it could be simplified
17:36:59 <matjazp_> usually there is a problem with resources and time limits
17:37:16 <sarob> it could be too much for us to support
17:37:19 <sarob> yeah
17:37:30 <matjazp_> dbite: Linuz Profesional Institute, they make Linux certifications
17:38:02 <dbite> ok
17:38:04 <sarob> Rice is one of the guys at LPI that reached out to us about 4 months ago
17:38:07 <sarob> member?
17:39:01 <matjazp_> one idea is just to have a larger pool of quastions and the assesment could be a random x quastions form that pool
17:39:08 <sarob> LPI works with a few different orgs on setting up and support trainers and testing certs
17:39:08 <matjazp_> questions
17:39:08 <dbite> ok
17:39:17 <dbite> yes I recollect
17:39:31 <sarob> matjazp_ i like that
17:39:59 <sarob> matjazp_ perhaps when automated quiz and test could pull from the same poll
17:40:01 <sarob> pool
17:40:02 <matjazp_> sarob: this means no hands on, unfortunately
17:40:45 <sarob> matjazp_ could still have a separate test section that is hands on
17:41:01 <sarob> matjazp_ that results get entered manually
17:41:53 <sarob> matjazp_ but while we are still getting started, id like to punt on the extra complexity
17:42:25 <sarob> matjazp_ can always come back to the test methods and options later
17:42:37 <matjazp_> sarob: agree.. so maybe it is easier to start with a getting a larger pool of "simple" questions
17:42:52 <sarob> matjazp_ i like that
17:43:19 <sarob> moving on?
17:43:25 <matjazp_> yes
17:43:53 <sarob> matjazp_ can you get the remaining quizzes done by the summit?
17:44:14 <matjazp_> for associate quide? yes, I hope so
17:44:25 <sarob> matjazp_ assign network and object storage quiz as critical bugs to yourself?
17:44:38 <matjazp_> ok
17:45:06 <sarob> #action matjazp assign network and object storage quizzes as critical bugs
17:45:10 <matjazp_> megan is helping me with object storage quiz... I have to ping her for the progress
17:45:27 <sarob> or assign to meganr as well
17:45:30 <sarob> up to you
17:45:40 <sarob> #topic audio visual update
17:46:32 <sayali> So I have been testing a few tools for on screen recording on linux and windows
17:48:08 <sayali> I have created a sample video using an open source tool mydesktoprecorder it came out quite good.
17:48:19 <sarob> nice
17:48:26 <sayali> I will have a proper one ready by tomorrow so that the team can review it
17:48:43 <sarob> great news
17:48:55 <sayali> and then we could ask the user group to start using these tools
17:49:28 <sayali> so no extra camera or anything is required if the sound quality and video quality is good enough and it will be easy to use as well.
17:49:54 <sarob> low tech is good
17:50:18 <sarob> anything else?
17:50:24 <dbite> sarob: I would suggest getting a proper recording mic
17:50:28 <dbite> with a pop filter
17:50:32 <sayali> nope thats all from my side
17:50:39 <dbite> atleast for the sake of keeping the audio quality good
17:50:56 <sarob> #action sayali will share AV first works with team
17:51:27 <sarob> dbite lets see/hear how the first version of this sounds
17:51:53 <sarob> dbite if we can get away with not needing it, much more the better
17:52:10 <sayali> ya that would be better because we want the user groups all over to use it
17:52:25 <sarob> #topic any other business
17:53:08 <sarob> im going to work on the associate training through user groups plan this week some more
17:53:47 <sarob> i think we will need another meeting just for logistics
17:54:20 <sarob> this team will not need to attend unless you plan on being a trainer
17:54:50 <matjazp_> meeting will be in person? Hangout? IRC?
17:54:51 <sarob> i have a few likely suspects as trainers
17:55:10 <dbite> ok, sounds good
17:55:22 <sarob> matjazp_ id prefer irc, but this is a different type of person(s)
17:55:41 <sarob> irc experience not as likely
17:56:02 <sarob> matjazp_ ill see if the trainer team goes for it
17:56:28 <matjazp_> sarob: we still need presentations for the associate guide
17:56:37 <matjazp_> like we have for Upstream training
17:56:38 <sarob> true that
17:56:57 <matjazp_> There is a demand for this stuff
17:57:06 <sarob> which stuff?
17:57:17 <matjazp_> "ppt"s
17:57:32 <sarob> matjazp_ sure
17:57:46 <sarob> matjazp_ everyone loves slideware
17:57:51 <sarob> ;)
17:58:17 <sarob> making slides will help us with fine tuning the material
17:58:28 <sarob> almost last call
17:58:42 <matjazp_> ...and we'll get more feedback on what works and what we need to improve
17:58:52 <sarob> #action sarob report on the trainer team setup progress at next week's meeting
17:59:04 <sarob> matjazp_ yup
17:59:27 <sarob> times up everyone
17:59:33 <sarob> until next week
17:59:35 <rluethi> cheers
17:59:49 <sarob> cheers!
17:59:49 <sayali> bye bye
18:00:04 <matjazp_> bye
18:00:09 <sarob> #endmeeting