17:00:40 <sarob> #startmeeting training-guides
17:00:41 <openstack> Meeting started Mon Oct 20 17:00:40 2014 UTC and is due to finish in 60 minutes. The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:45 <openstack> The meeting name has been set to 'training_guides'
17:00:49 <sarob> Hi all
17:01:18 <rluethi> a special welcome to timfreund, who fixed the landslide css.
17:01:38 <timfreund> thanks rluethi, happy to help.
17:01:52 <sarob> :)
17:02:51 <sarob> #topic outstanding actions from last week
17:03:01 <rluethi> ahem. doodle.
17:03:33 <sarob> Start there sure
17:04:01 <rluethi> it's kind of difficult to fill out, because many session topics are still tbd.
17:04:11 <sarob> True
17:04:21 <rluethi> annegent_: when are the openstack-docs sessions at the summit?
17:04:33 <annegent_> rluethi: they are during the cross project times
17:04:36 <rluethi> we would like to attend whenever possible.
17:04:37 <dbite> we need to know when can we schedule our training guides sessions
17:04:40 <annegent_> rluethi: which will decided at this afternoon
17:04:43 <annegent_> s tc meeting
17:04:55 <sarob> Cool
17:04:58 <annegent_> rluethi: dbite: I don't think you'll get a sesssion I think you need to plan for a meetup at the pod
17:05:18 <annegent_> cross project is already packed and it's possible I'll fight for 2 docs ones
17:05:21 <sarob> Pod runs open all week?
17:05:53 <dbite> annegent_: that would be really good
17:06:06 <rluethi> annegent_: we don't need our own meetings, but we would like to listen in on the docs ones.
17:06:34 <sarob> So team. It sounds like we use the pod
17:06:55 <rluethi> sarob: sounds good.
17:07:05 <sarob> I'll put the doodle poll back out on the ml after the TC meet
17:07:41 <sarob> #action sarob repost doodle poll after latest TC meet
17:08:01 <sarob> Dbite how's the bug posting going?
17:08:53 <annegent_> sarob: Four days for the pods
17:09:14 <annegent_> rluethi: yeah I'll be posting to the mailing list as soon as I know
17:09:19 <dbite> sarob: I already have a few bugs up there
17:09:28 <rluethi> annegent_: thanks!
17:09:49 <dbite> annegent_: we do not need a cross project talk for training guides but may be one session where we sit with the docs team and discuss a few things out
17:10:19 <sarob> Dbite true
17:10:40 <dbite> sarob: I need to do a better job posting bugs but I am getting a bit overburdened with Germany bureaucracy and other personal things eating up my time
17:10:53 <sarob> Dbite understood
17:11:31 <sarob> Dbite delegate?
17:12:17 <sarob> Dbite work on it for the summit design meet is the focus
17:12:19 <dbite> hmm, I need a volunteer
17:12:47 <sayali> I don't mind helping out
17:12:59 <dbite> sarob: yes, I am trying my best ... I should get a lot of time this week
17:13:22 <dbite> sayali: thanks a lot
17:13:33 <matjazp> hi all
17:13:40 <sarob> Dbite understood. I do you are working at it
17:13:47 <sarob> Matjazp hey
17:13:51 <dbite> matjazp: hello
17:13:53 <dbite> sarob: roger that
17:13:57 <sayali> dbite: no issues, let me know what needs to be done
17:13:58 <rluethi> matjazp: hey
17:14:07 <sayali> hello matjazp
17:14:34 <sarob> #action sayali will help dbite on docs bug logging in prep for the summit design session
17:15:00 <sarob> Review #link https://review.openstack.org/#/c/127472/
17:15:43 <dbite> reed: hello, you around?
17:15:52 <reed> yes
17:15:53 <sarob> This is pending reed reviewing dhellman option looks like
17:16:23 <reed> I haven't had time to test hyerogliph, sorry
17:16:38 <timfreund> I can volunteer to do that testing.
17:16:43 <sarob> -1000 demerits for reed
17:16:48 <dbite> reed: ok, try it out asap please
17:16:53 <reed> timfreund, fantastic
17:16:54 <dhellmann> I don't want to block your work on this stuff, but we're trying really hard to get a handle on our huge list of dependencies :-/
17:17:15 <sarob> Thx timfreund
17:17:22 <dbite> timfreund: sure, I actually tried it out but my views will be partial since I am working on the patch
17:17:29 <sarob> Dhellman understood
17:17:36 <dbite> dhellmann: I understand your request
17:17:46 <reed> the reason I picked landslide is because it felt like it was a more modern version of hierogliph but I'm not married to it
17:17:47 <rluethi> dbite and I tried hieroglyph, it's quite a pain. but if reed is happy with it, we can run with it, too.
17:17:59 <dbite> rluethi: true
17:18:09 <reed> ah! that's good feedback :)
17:18:16 <dbite> dhellmann: reed: another issue with using hieroglyph is not only really poor developer docs
17:18:17 <dhellmann> reed: it's entirely possible it's a better tool
17:18:25 <dbite> but also we loose the PDF file using weasyprint
17:18:32 <dhellmann> reed: at least we're having the conversation :-)
17:18:46 <dbite> the other way to generate PDF files is converting them to LaTeX first which would not be preferred
17:18:47 <sarob> #action timfreund reed will test out hieroglyph as alt to weasyprint as per #link https://review.openstack.org/#/c/127472/
17:18:47 <reed> PDF is such a low priority... I'd call it a negative priority
17:19:01 <dbite> reed: you may be wrong there
17:19:10 <dbite> we need PDF support for the machines which do not support HTML5
17:19:14 <reed> sarob, wait, if dbite and rluethi have tried it already, why do we still need to?
17:19:15 <rluethi> pdf is quite important if you do presentations in a unpredictable environment.
17:19:16 <dbite> which I can see happening in many Unis!
17:19:19 <matjazp> PDFs- I know you guys don't like PDFs, but I can speak from my experience that one of the first things I get asked is where are PDS :)
17:19:38 <matjazp> PDFs
17:19:48 <sarob> #undo
17:19:49 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x33bb1d0>
17:19:55 <dhellmann> PDFs do tend to work better when uploading to some of the slide-sharing sites, too
17:19:58 <matjazp> rluethi: dbite: exactly
17:20:01 <reed> matjazp, teaching means educating people that PDF is dead :)
17:20:19 <matjazp> reed: I like to choose my battles wisely ;)
17:20:25 <timfreund> So one experiment might be to get sphinx/hieroglyph slides to print via weasyprint? That sounded like a blocking item from the review.
17:20:30 <reed> dhellmann, you don't need those if you can host the html files yourself
17:20:38 <rluethi> reed: I love HTML presentations, but PDF is very much alive, and will be for quite some time.
17:20:39 <dbite> timfreund: I tried that
17:20:42 <dbite> it does not work!
17:21:03 <reed> rluethi, not if you help kill it :)
17:21:06 <dbite> hieroglyph also proposes massive changes to the RST and CSS since the indentation. alighment etc. is lost
17:21:15 <dbite> may be because it is optimized for landslide
17:21:27 <reed> dbite, what was the issue with hieroglhyp?
17:21:39 <rluethi> I know people how stopped bringing printed transparent slides only a couple of years ago. always have a fallback position :).
17:21:47 * reed has never spelled hierogphlyp the same way
17:21:48 <matjazp> reed: I could be worse... few years back they asked for PPTs or word files :)
17:21:50 <dbite> reed: the text was way out of the position as compared to landslide
17:22:12 <reed> dbite, do you mean the HTML output?
17:22:32 <dbite> reed: I figured it out that there are a lot of changes required for the rst files to make it compliant to Hieroglyph and also change the CSS files a bit
17:22:37 <dbite> reed: yes
17:22:44 <dhellmann> reed: true, though they do help with discoverability
17:22:48 <reed> dbite, yes, I noticed that the syntax is different
17:23:17 <dbite> reed: it may be a lot of work, we have the slides ready for landslide and weasyprint
17:23:29 <reed> dhellmann, we're talking about slides that are not meant to be discovered. These are training material for *in class* teaching, not DIY
17:23:34 <dbite> also lesser dependencies than Hierogylph
17:23:45 <dhellmann> reed: ah, ok then :-)
17:24:16 <reed> that's why I want to keep this conversation in scope: Upstream Training has nothing new in it, it's all content that is on the wiki but the crucial bit is the in-class experience
17:24:37 <dbite> dhellmann: we already have DFS algo implemented to scan and search for RST files :)
17:24:43 <reed> the slides are just to keep the tempo in the classroom, nothing else. That's why I don't care about the pdf
17:25:30 <reed> there is really no need to print anything and where someone has no HTML5 browser we can't expect them to be successful openstack contributors
17:25:32 <sarob> Reed students will be using source from where?
17:25:41 <dbite> reed: I understand but we do need to consider other uses demands too. And I want to think that Universities will not have updated machines which are capable of running HTML5
17:25:48 <rluethi> reed: if you name the toolchain and give us the input files that work with it, we're all happy.
17:26:08 <reed> sarob, can you rephrase?
17:26:22 <rluethi> reed: we just don't to have to port landslide to hieroglyphs, or figure out if and how it is possible :).
17:26:35 <reed> dbite, other uses for what? Are we talking about Upstream Training or a wider topic?
17:26:44 <sarob> Reed For 1-2 nov training, source material for students from where?
17:26:54 <reed> sarob, from the repository
17:27:04 <sarob> Training-guides?
17:27:21 <reed> sarob, Tim Freund and Sylvain and me and Loic are fixing those docs, in training-guides
17:27:40 <sarob> Reed just double chk
17:28:06 <sarob> Reed so can we proceed with landslide weasyprint for the summit
17:28:11 <reed> so, I'm happy to use landslide for Paris and switch after the summit
17:28:31 <sarob> Reed and then figure out if it is a long term solution?
17:28:33 <reed> the automatic build can be postponed until we have time to properly check hieryglypf
17:28:44 <reed> sarob, agreed
17:29:12 <matjazp> sarob: in the mean time, we could at least merge Tim's patch for presentation building from rst?
17:29:41 <dbite> matjazp: we will merge my patch
17:29:50 <dbite> but not make it trigger with jenkins
17:30:07 <reed> matjazp, I was thinking of adding it to my repo and .gitignore it anyway :)
17:30:08 <matjazp> dbite: ok than... I thought that it was blocked because of dependencies
17:30:28 <dbite> matjazp: the dependencies are there even for the bash script
17:31:01 <matjazp> dbite: yes but not for weasyprint, right?
17:31:41 <matjazp> reed: :))) you can .gitingore PDFs too, right ;)
17:31:41 <dbite> matjazp: for now weasyprint too
17:31:55 <dbite> we will provide the option for building html or pdf
17:32:11 <dbite> and also gitignore the entire directory which contains HTML and PDF
17:32:22 <rluethi> matjazp: the requirements are only needed for automatic building.
17:32:22 <sarob> #action Let's get everything cleaned up for the training minus Jenkins building the slideware, using hieroglyph is pushed til after the summit
17:32:28 <reed> I'm strongly opposed to generate PDFs for Upstream training
17:32:46 <sarob> #undo
17:32:47 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x3201d90>
17:33:23 <sarob> #action Let's get everything cleaned up for the kilo summit upstream training minus Jenkins building the slideware, using hieroglyph is pushed til after the summit
17:33:25 <dbite> reed: please tell me if you want me to provide you with PDF support?
17:33:29 <reed> if someone really wants to get PDFs, they can do it autonomously from the source
17:33:35 <dbite> even with landslide
17:33:50 <reed> I don't care about PDF as an option, really
17:34:18 <rluethi> reed: there's quite a difference between "I don't care about" and "I'm strongly opposed to".
17:34:29 <reed> meaning that if you want to spend time documenting it, fine, do it, I am not going to use it and I would oppose to generating the PDF automatically at build time
17:34:30 <dbite> if you are strongly opposed '<reed> I'm strongly opposed to generate PDFs for Upstream training' I would suggest that you discuss it out with matjazp properly
17:34:58 <dbite> reed: all the other docs do that
17:35:26 <reed> dbite, if others do it it's their choice... I"m talking about Upstream Training material
17:35:46 <reed> for Upstream Training, PDF is not needed and I don't think we should spend more time discussing it
17:36:06 <dbite> ok
17:36:06 <sarob> Dbite lets table this for summit discussion
17:37:23 <sarob> Segway to #link https://etherpad.openstack.org/p/docstopicsparissummit
17:38:22 <matjazp> damn... summit discussion.. I still have to fill out our Doodle timetable
17:38:36 <sarob> Let's get our stuff jammed in here so we can prioritize the agenda
17:39:00 <sarob> Matjazp I like doing it backwards :)
17:39:56 <matjazp> sarob: backwards? How can you see on your laptop if it's not facing you? ;))
17:40:24 <sarob> I hope I am not the only one that has something to say on the agenda
17:40:40 <sarob> Matjazp X-ray vision yo
17:41:04 <rluethi> sarob: I already added several items.
17:41:05 <sarob> Matjazp that at least what the kids think
17:41:18 <sarob> Rluethi thx
17:41:38 <sarob> Rest of y'all get in there
17:42:32 <sarob> Sayali you have an av update for the team?
17:42:38 <sayali> yep
17:42:46 <sayali> the first video is up here http://youtu.be/8KYi1fPd6Tw.
17:42:46 <sarob> Sayali hit
17:42:47 <sarob> Me
17:43:07 <sayali> I have made it unlisted so everyone can see it
17:43:34 <sayali> so please check and an write back the feedback on etherpad or by mail
17:43:37 <matjazp> sayali: the video is for noobs, right?
17:43:50 <sarob> Sayali it's listed as private
17:44:04 <sayali> matjazp: yes this one is on installing devstack on virtualbox
17:44:29 <sarob> Sayali nice. Sounds good.
17:44:45 <dbite> sarob: it is unlisted not private, it should work
17:45:00 <sarob> Sayali maybe it's an iOS thing
17:45:04 <sayali> ya i had changed it
17:45:09 <timfreund> sayali: you said that everyone should be able to see it? I get a "This video is private" when I click the link.
17:45:26 <sarob> Timfreund me too
17:45:26 <rluethi> it worked for me, without a google account.
17:45:34 <sayali> dbite: unlisted works for everyone right?
17:45:51 <timfreund> I tried while logged in and in a private browser window, both showed private.
17:46:11 <dbite> sayali: you are giving the wrong link!
17:46:18 <dbite> I will publish the correct one
17:46:21 <sarob> Dbite oh
17:46:31 <sarob> Dbite that may help ;)
17:46:45 <dbite> http://youtu.be/7rdju1VrFWk
17:46:45 <sayali> ah my bad!
17:46:55 <timfreund> there we go!
17:47:03 <sayali> thanks dbite
17:47:04 <dbite> #link First AV Link http://youtu.be/7rdju1VrFWk
17:47:10 <dbite> sayali: nps :)
17:47:27 <sarob> Sayali looks excellent
17:47:29 <dbite> sarob: unlisted is public video which can only be accessed by those who have the URL!
17:47:31 <sayali> I have mentioned on etherpad the tools used
17:47:44 <sayali> https://etherpad.openstack.org/p/openstck-training-guides%28Audio_Visual_Content%29
17:48:03 <sayali> thanks sarob!
17:48:40 <sarob> So the last update is on the trainer group
17:49:01 <sarob> I got slammed last week so I'm working on it today
17:49:14 <sarob> I have some of the prep work done
17:49:29 <sarob> And another trainer lined up
17:50:17 <sarob> I'm going to publish another irc meeting for community-trainers
17:50:30 <dbite> awesome, need a lot of feedback for our content
17:50:49 <sarob> This will be the team that consumes what this team creates
17:51:24 <sarob> Should help with the bleed over so we can focus more on content less on execution
17:51:41 <sayali> sounds great
17:52:00 <sarob> #action sarob publish community-trainers irc meeting
17:52:18 <sarob> I think we are all caught up from last week
17:52:30 <sarob> #topic any other business
17:52:43 <matjazp> Openstack proposal bot
17:52:51 <matjazp> do we merge or not?
17:53:06 <dbite> matjazp: link
17:53:28 <matjazp> #link https://review.openstack.org/#/c/129228/
17:53:38 <dbite> matjazp: ohh yes
17:53:44 <rluethi> the proposal bot may be pushing things that are juno or kilo.
17:53:45 <dbite> Ill give it a +1 workflow
17:53:55 <matjazp> look at discussion with roger
17:53:59 <rluethi> we haven't branched off from icehouse yet.
17:54:18 <rluethi> we haven't yet agreed on how to deal with OpenStack releases.
17:54:19 <matjazp> rluethi: yes, but we don't use this directly, do we?
17:54:20 <clarkb> if there is a reason to not merge openstack proposal bot changes please update the bot/jobs so that we stop proposing code that will not merge
17:54:42 <rluethi> matjazp: but does it get pulled into all guides we produce?
17:54:52 <dbite> rluethi: the proposal bot is pulling glossary from Juno
17:54:57 <matjazp> japanese translation not
17:54:59 <dbite> I configured this one !
17:55:42 <rluethi> it's no big deal, but we need to define how to deal with releases soon.
17:55:47 <matjazp> glossary is more or less not tied to a specific release
17:55:57 <dbite> matjazp: unless you find something very conflicting I do not think that we should worry about it
17:55:57 <rluethi> in Paris, if we can't get it done earlier.
17:56:01 <dbite> matjazp: true, I agree
17:56:15 <dbite> one of our main agendas is to figure out when to release and how to release
17:56:16 <matjazp> so whats get merged now, is ok
17:56:34 <matjazp> do we need to discuss this at he meeting in paris?
17:56:38 <sarob> when to tag for release
17:56:51 <sarob> Matjazp yes
17:57:05 <sarob> And once tagged, backport policy
17:57:10 <dbite> sarob: we need to manage the releases from the Launchpad Release Management feature too!
17:57:16 <matjazp> in the mean time, we merge as we did untill now
17:57:25 <sarob> True dbite
17:57:25 <dbite> lets push these points in the etherpad
17:57:47 <sarob> Dbite agreed we need to start acting all grown up
17:58:24 <sarob> Anything else folks?
17:58:42 <dbite> sarob: yes, true
17:58:49 <dbite> im good :)
17:59:00 * dbite dbite is dancing like a kid :D
17:59:11 <rluethi> I'm good. time's up.
17:59:18 <matjazp> bye all
17:59:20 * sarob has trouble acting grown up
17:59:24 <sayali> bye
17:59:25 * dbite join me
17:59:30 <sarob> Okey dokey
17:59:38 <dbite> bye :)
17:59:45 <sarob> Until
17:59:48 <sarob> Next
17:59:50 <sarob> Time
17:59:56 <rluethi> cheers.
18:00:03 * sarob joins dbite
18:00:12 * dbite yay! :D
18:00:12 <sarob> #endmeeting