17:01:56 <rluethi> #startmeeting training-guides
17:01:57 <openstack> Meeting started Mon Nov 10 17:01:56 2014 UTC and is due to finish in 60 minutes.  The chair is rluethi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:00 <openstack> The meeting name has been set to 'training_guides'
17:02:07 <sarob> Thx
17:02:21 <sarob> I wanted to get the action items
17:02:33 <sarob> Into the meeting record
17:02:43 <sarob> And I have to go
17:03:01 <sarob> Pardon my slight mess
17:03:37 <rluethi> thanks to sarob, we now have an agenda at #link https://wiki.openstack.org/wiki/Meetings/training-guides
17:03:54 <dbiten> hey im back
17:04:29 <rluethi> #topic Review the kilo design session next steps
17:05:07 * sarob Identify action items which are blockers and finish them with high priority to start with release cycle.
17:05:20 <sarob> #ACTION: Identify action items which are blockers and finish them with high priority to start with release cycle.
17:06:01 <rluethi> Let me just say real quick that I don't intend to insert refs to the scripts into the manuals any time soon, in contrast to what the minutes suggest. Other than that, the item is being worked on.
17:06:25 <sarob> #ACTION: Sarob needs to configure the minimum reviewers for training-guides patches
17:06:54 <dbiten> do we already have an agreement for the minimum reviewers?
17:07:08 <sarob> #ACTION: Stef will figure out if landscape alternative is viable. We need to automate the slide builds
17:07:15 <dbiten> are we going forward with the standard 2 +2s and 1 +1
17:07:42 <sarob> #Action: published through tarballs and HTML slides
17:08:08 <rluethi> dbiten: probem is, it's hard to find more than one interested reviewer for some of our typical patches.
17:08:32 <sarob> Dbiten I am going to add the cores
17:08:36 <dbiten> rluethi, yes, I was wondering if we decided about this before?
17:09:03 <sarob> Dbiten we wanted to do something else?
17:09:14 <dbiten> sarob, I am not sure
17:09:24 <dbiten> I do not remember that is why I asked
17:09:34 <rluethi> sarob: I remember having a discussion months back, but I don't remember a resolution.
17:09:46 <dbiten> rluethi, we are in the same boat then
17:09:57 <sarob> It's to automatically add the cores to each gerrit review
17:10:50 <rluethi> sarob: meaning?
17:11:20 <sarob> #ACTION: team will work on cross referencing the install guide to build scripts. Reference to the scripts in the install guides, discussing to start on docs ML
17:11:56 <rluethi> sarob: what is meant by "Reference to the scripts in the install guides"?
17:12:08 <sarob> Rluethi so we can see the patches when on gerrit
17:12:33 <sarob> Rather than having to view trading guides queue
17:12:34 <rluethi> sarob: don't we? isn't looking at open patches for training-guides sufficient?
17:12:55 <rluethi> sarob: fine, I don't see a downside right now.
17:13:16 <dbiten> I would say lets have that feature
17:13:24 <sarob> Rluethi extra bit , maybe I misunderstood but I thought it was asked for
17:13:39 <rluethi> sarob: actually, maybe I do. I invite other reviewers specifically to patches that I hope they would be interested in.
17:14:25 <rluethi> sarob: I can't add reviewers if they are all added automatically. but maybe I misunderstood what is proposed.
17:14:47 <sarob> Do you guys want to go through and review the action items in the etherpad before I add them here
17:14:52 <dbiten> rluethi: reviewers are added automatically to the patch for review
17:15:24 <rluethi> sarob: WRT the install-guides, I don't think the manuals team is keen on us changing them right now. I will just report to the mailing list, that's all for now.
17:15:24 <sayali> I don't think that will eliminate the option of adding more reviewers
17:15:48 <rluethi> let's try it, unless it is something that is hard to undo.
17:15:53 <dbiten> sarob, annegentle asked me to show her how it is to be done
17:15:58 <dbiten> before starting the discussion
17:16:11 <dbiten> I will create the required patches and push, then we should start the discussion
17:16:17 <dbiten> otherwise it may not be that useful
17:16:47 <sarob> I have to go
17:17:00 <dbiten> sarob, let us discuss on the action list once
17:17:04 <dbiten> and next meeting we finalize it
17:17:11 <dbiten> does that sound good?
17:17:18 <sarob> Can I get you guys to debate the etherpad action items
17:17:27 <rluethi> dbiten: discuss now?
17:17:34 <dbiten> skim through
17:17:39 <dbiten> and finalize the list
17:17:39 <sarob> Dbiten zehr gut
17:18:29 <sarob> I will review the mtg results and give feedback
17:19:06 <rluethi> sarob: okay
17:19:10 <sarob> We prob should do some of this over the ml as well
17:19:20 <sarob> I gots to go
17:19:43 <sarob> Leaving sacred heart church
17:20:05 <sarob> It was great seeing all of you
17:20:18 <rluethi> sarob: indeed.
17:20:42 <sayali> sarob: bye
17:20:50 <sarob> Bye
17:20:58 <dbiten> bye
17:22:12 <rluethi> #link https://etherpad.openstack.org/p/training-guides-kilo-summit for those who haven't seen the minutes
17:22:45 <rluethi> the minutes contain a list of action items.
17:23:19 <rluethi> I guess it's quickest to run through them one by one and check if there are comments. comments?
17:23:32 <sayali> rluethi: let's start then
17:23:36 <rluethi> k.
17:23:42 <fthamura> how the usergroup do training guide? do you have abstract>
17:23:44 <dbiten> First point
17:23:47 <rluethi> * we will converting xml content to rst
17:23:48 <dbiten> target audiance
17:24:10 <rluethi> fthamura: let's take this to the end of the meeting.
17:24:22 <dbiten> fthamura, for that write to Sean on email, it would be better for him to answer this
17:24:35 <rluethi> dbiten: okay, where are you reading? I am looking at the minutes.
17:24:49 <dbiten> ahh
17:25:02 <dbiten> there are two minutes, my bad
17:25:07 <rluethi> let's try that again: 1) we will converting xml content to rst
17:25:08 <dbiten> lets run through them fast
17:25:44 <rluethi> it is my understanding that dbiten will cut/trim first, conversion will be afterwards and not assigned yet.
17:25:48 <rluethi> correct?
17:25:54 <dbiten> yes
17:26:04 <dbiten> let me update the action items subpoints on the etherpad
17:26:24 <rluethi> #ACTION dbiten will cut/trim existing guides
17:27:10 <dbiten> agree, next
17:27:32 <rluethi> 2) Sarob needs to configure the minimum reviewers for training-guides patches
17:27:51 <rluethi> already mentioned, we need to discuss what we can afford to do.
17:28:07 <dbiten> lets say that we have 2 or 3 minimum reviewers
17:28:13 <dbiten> who are going to be added to every patch
17:28:36 <rluethi> most patches seem to go in with one reviewer now.
17:29:05 <rluethi> two is pushing it, three seems unworkable.
17:29:34 <rluethi> at least if we want +1 or +2 to actually mean something rather than just rubberstamping.
17:29:42 <dbiten> no
17:29:50 <dbiten> I am not sure if it means anything
17:29:58 <dbiten> just that the patches have those reviewers on them by default
17:30:09 <dbiten> and receive a notification
17:30:17 <dbiten> next
17:30:24 <rluethi> so it's a minimum on assigned reviewers, not actual reviews?
17:30:31 <sayali> yes rluethi
17:31:09 <rluethi> I wonder how this is helpful. you can already get an automated email for every patch in our repo.
17:31:47 <sayali> rluethi: It makes sure stleast x number of reviewers will have to review the patch
17:31:53 <sayali> atleast*
17:32:03 <rluethi> no, they won't, according to what you said.
17:32:05 <dbiten> yes, so thats why I said lets go to the next point
17:32:07 <rluethi> they don't have to review.
17:32:31 <rluethi> this confusion needs clarification, but not now.
17:32:33 <dbiten> we can discuss this point later on when we have more time
17:32:37 <dbiten> yes
17:32:44 <dbiten> once we address the more important points
17:33:08 <rluethi> #ACTION sarob sends an email to the ML or team members explaining minimum reviewers requirements.
17:33:32 * rluethi loves delegation
17:33:57 <rluethi> 3) Stef will figure out if landscape alternative is viable. We need to automate the slide builds
17:34:00 * dbiten is jumping off a cliff
17:34:26 <dbiten> well, is reed attending this meeting/
17:34:27 <dbiten> ?
17:34:34 <rluethi> doesn't look like it.
17:34:43 <dbiten> I think he is not, lets postpone this action item
17:35:14 <dbiten> next ?
17:35:14 <rluethi> #ACTION stefano looks into sphinx/hieroglyph viability for training slides.
17:35:29 <rluethi> 4) roger will work on cross referencing the install guide to build scripts. Reference to the scripts in the install guides, discussing to start on docs ML
17:35:49 <rluethi> like I said twice already, I don't intend to push anything to the install-guides for now.
17:36:01 <rluethi> this is just about measuring the gap and reporting about it.
17:36:42 <dbiten> yes
17:37:00 <rluethi> andreas suggested it would be better to report on diffs to juno, but that's quite a bit of work because the instructions were re-ordered for juno.
17:37:22 <rluethi> so I may choose to send out preliminary findings.
17:37:34 <dbiten> yes, I agree with this
17:37:45 <dbiten> next?
17:38:13 <rluethi> #ACTION rluethi will report on differences between install-guides and labs-scripts
17:38:30 <rluethi> 5) movie script in RST for AV, deeplink to RST on github off wiki
17:38:48 <rluethi> sayali?
17:39:16 <sayali> atleast*i didn't think of the scripts to be written in RST
17:39:28 <sayali> *I
17:39:33 <rluethi> okay. I don't remember that, either. postpone?
17:39:49 <dbiten> yeah, postpone, may be action item for Sayali to do more research on this
17:39:51 <dbiten> for next meeting
17:39:54 <sayali> but if we want to push it to a wiki it sounds good
17:39:55 <sayali> else
17:40:17 <sayali> it would be unnecessary to write it in RST
17:40:19 <sayali> I feel
17:40:36 <sayali> alright we could postpone it for the next meeting
17:40:57 <rluethi> sayali: okay. we shouldn't push extra work on you unless there is an actual use case.
17:41:07 <rluethi> 6) Slides will need a bug link for trainers and non-contributors to log bugs
17:41:29 <rluethi> that's a wishlist item.
17:41:48 <rluethi> presumably important, but not urgent.
17:42:28 <rluethi> dbiten: do we have a place for stuff like this if it's not labs-scripts?
17:42:43 <sayali> we need the slides first right :)
17:42:47 <dbiten> no do not worry about that please
17:42:52 <rluethi> #idea Slides will need a bug link for trainers and non-contributors to log bugs
17:42:55 <dbiten> it is not now, later on
17:43:06 <rluethi> 7) upstream training videos
17:43:08 <dbiten> its just a html page linking to our launchpad bug page
17:43:16 <rluethi> not sure about that, somewhat unspecific.
17:43:27 <rluethi> sayali, do you know what it meant?
17:43:56 <sayali> rluethi: I need to talk to the upstream guys to make the videos of the training
17:44:14 <rluethi> sayali: I thought tim is going to make one?
17:44:30 <sayali> which will involve a lot of editing and a demo video of a mock training session
17:44:43 <sayali> yes need to get that working with tim
17:46:01 <rluethi> #ACTION sayali is working with upstream-training to produce demo video
17:46:06 <rluethi> sayali: is this correct?
17:46:12 <sayali> rluethi: yep
17:46:18 <rluethi> great. moving on.
17:46:26 <rluethi> 8) matjazp will come up with a newish name for the testing sub-team
17:46:43 <rluethi> anyone with a better name?
17:46:52 <dbiten> not me
17:46:59 <dbiten> and matjazp joins at the perfect time!
17:47:01 <rluethi> hey, matjazp !
17:47:03 <matjazp> hi all
17:47:04 <dbiten> hey mathazp
17:47:09 <rluethi> just in time.
17:47:11 <sayali> hi matjazp
17:47:23 <matjazp> damn winter/summer time
17:47:27 <rluethi> we were just on your action item:
17:47:30 <rluethi> matjazp will come up with a newish name for the testing sub-team
17:47:34 <rluethi> :)
17:47:40 <matjazp> hmmm
17:48:02 <matjazp> Action item was for this Monday?
17:48:03 <rluethi> (it's from the kilo summit minutes)
17:48:27 <rluethi> matjazp: no, we are going through the minutes and discuss action items.
17:48:39 <rluethi> minutes: https://etherpad.openstack.org/p/training-guides-kilo-summit (somewhat down the page)
17:49:30 <rluethi> this is not urgent, anyone against noting this just as an idea?
17:49:48 <sayali> nope not me
17:50:01 <matjazp> yes, I will collect few ideas and we'll discuss them
17:50:02 <rluethi> #idea matjazp will come up with a newish name for the testing sub-team
17:50:32 <rluethi> matjazp: sorry, did you mean "yes, I am against it"?
17:50:41 <rluethi> matjazp: would you like ACTION instead?
17:50:42 <matjazp> I'm inclining towards Assesment, but I'm not sure it is better than Testing (although Roger will not agree with that ;)
17:51:02 <matjazp> rluethi no, it's ok
17:51:20 <sayali> I feel Assesment is better too. Testing is misleading.
17:51:23 <annegentle> o/ I 'm here just trying to also get/eat lunch :)
17:51:29 <rluethi> matjazp: I do agree. I am also leaning towards assessment, and I am also not sure it's better than testing (but pretty sure :) ).
17:51:33 <rluethi> anyhow, moving on.
17:51:37 <dbiten> Assessment it is
17:51:38 <annegentle> so feel free to holler if you need
17:51:49 <matjazp> annegentle: hi
17:52:02 <rluethi> hi annegentle
17:52:15 <dbiten> annegentle, hello
17:52:22 <rluethi> 9) setup moodle for basic quiz taking over the next few weeks
17:52:33 <rluethi> whose plate is this on?
17:52:44 <dbiten> sarob or matjazp?
17:52:52 <rluethi> matjazp?
17:52:53 <matjazp> mine I guss?
17:52:56 <matjazp> guess
17:53:07 <rluethi> matjazp: sarob is not here, so it is your choice :)
17:53:30 <matjazp> the problem is not in Moodle Q&A, its in the linking of identities
17:53:30 <rluethi> #ACTION matjazp will setup moodle for basic quiz taking over the next few weeks
17:54:00 <matjazp> plugin for Moodle does not support Launchpad
17:54:20 <matjazp> rluethi: I will dig throug my old notes and summarize our choices
17:54:27 <rluethi> okay.
17:54:34 * dbiten time check - 5 minutes remain
17:54:38 <rluethi> so, we only have five minutes left.
17:54:51 <dbiten> matjazp, it would be great to have moodle with launchpad integration or similar
17:54:56 <rluethi> I propose we postpone the discussion of the remaining items to next week.
17:54:57 <matjazp> rluethi: I believe there is no way around some programming (extending existing Moodle plugin)
17:55:27 <sayali> most of them include sarob so it will be better to postpone it
17:55:34 <rluethi> matjazp: yeah, it might be useful if everyone had some idea of the problems you are facing.
17:55:46 <dbiten> I gtg now, I will see you guys later
17:55:46 <dbiten> bye
17:55:56 <matjazp> bye dbiten
17:56:07 <sayali> bye
17:56:15 <rluethi> #agreed discussion of remaining items on minutes postponed to next week.
17:56:57 <rluethi> anything else that should be mentioned before we close the meeting?
17:57:22 <sayali> rluethi: I guess not
17:57:29 <rluethi> thanks everyone for coming, see you next week.
17:57:30 <matjazp> I'm fine
17:57:31 <rluethi> #endmeeting