17:00:10 <sarob> #startmeeting training-guides
17:00:13 <openstack> Meeting started Mon Dec 8 17:00:10 2014 UTC and is due to finish in 60 minutes. The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:16 <openstack> The meeting name has been set to 'training_guides'
17:00:30 <sarob> agenda #link https://wiki.openstack.org/wiki/Meetings/training-guides
17:00:55 <sarob> roll call
17:01:04 <matjazp> hey
17:01:11 <sayali> hello
17:01:18 <MeganR1> Hi
17:02:03 <sarob> any pref on the order of items on the agenda?
17:02:08 <sarob> any adds?
17:02:59 <matjazp> maybe we start with status reports?
17:03:11 <dguitarbite> hello
17:03:13 <sarob> sure
17:03:27 <sarob> evening dguitarbite
17:03:37 <sarob> just asking about the agenda
17:03:39 <dguitarbite> morning sarob
17:03:54 <sarob> #topic status reports
17:03:58 <matjazp> on branching
17:04:12 <sarob> ahh
17:04:13 <dguitarbite> yes, I need to finish the branching and its part of the release
17:04:29 <dguitarbite> I got caughtup in some urgent work outside technical domain
17:04:40 <dguitarbite> and could not do much here, I just need to push a patch
17:04:48 <dguitarbite> and then ping the infra guys for the release and branching
17:05:19 <sarob> basically this #link https://wiki.openstack.org/wiki/Branch_Model right?
17:06:01 <matjazp> so old XML text will become what? stable/icehouse?
17:06:15 <dguitarbite> yes, but it may not be the exact same model
17:06:22 <dguitarbite> matjazp: yes the old content will be stable/icehouse
17:06:28 <dguitarbite> then we start working on Juno
17:06:33 <dguitarbite> which should be the new slides
17:07:17 <sarob> branch/icehouse this week?
17:08:11 <dguitarbite> yes
17:08:14 <matjazp> when new branch is made, we need to update wiki page... there's old stuff on it
17:08:24 <sarob> #action dguitarbite will work with infra team on committing stable/icehouse branch
17:08:58 <sarob> matjazp: very true, from summit etherpad plans
17:09:33 <sarob> matjazp: you want me to do that or you want to take it on?
17:09:40 <matjazp> we all update our sections?
17:10:02 <sarob> matjazp: sounds right
17:10:05 <matjazp> and I'll update common text
17:10:16 <sarob> matjazp cool thx
17:10:49 <matjazp> #action subproject leads update their wiki sections, matjazp updates common text
17:11:05 <sarob> #action matajzp post stable/icehouse branch, update common wiki text, team will update their sections
17:11:22 <sarob> moving on?
17:11:53 <dguitarbite> yers
17:11:55 <dguitarbite> *yes
17:12:00 <matjazp> sure
17:12:03 <dguitarbite> unless anyone has any other point to add
17:12:11 <sayali> nope not me
17:12:34 <sarob> #topic trainers group
17:12:53 <sarob> soo, i finally have this started up
17:13:09 <sarob> see #link https://wiki.openstack.org/wiki/Meetings/trainers
17:13:39 <sarob> the first big question is how to drive requirements
17:14:11 <sarob> the trainers will do their thing from the materials this team creates
17:14:46 <sarob> the trainees and trainers need to provide us ideas and feedback
17:15:13 <sarob> we have used bug reports in the past with mixed results
17:15:32 <sarob> i think we still use bug reports
17:15:40 <matjazp> feedback on slides should be just file bugs on stuff in repo
17:15:43 <sarob> but need to add new ways
17:16:05 <dguitarbite> do we need to attend the trainers meeting?
17:16:15 <sarob> i dont think so
17:16:31 <sarob> you might lurk if you want to
17:16:45 <sarob> of course you can attend if you want to
17:16:58 <sarob> i just dont want to overload you guys
17:17:37 <sarob> the trainers meet is meant to discuss the sessions, whats working and how to improve
17:17:41 <dguitarbite> sounds good to me
17:17:48 <sarob> materials will only be a part of that
17:17:53 <dguitarbite> the time is kind of awkard for this time zone
17:18:07 <sarob> 6pm?
17:18:20 <dguitarbite> 7 PM
17:18:25 <sarob> ah
17:18:30 <dguitarbite> and 8 pm during the summers
17:18:38 <sarob> i forget you are GMT+2
17:18:55 <sarob> got GMT stuck in my head
17:19:30 <dguitarbite> ok
17:20:10 <sarob> so you guys want me to gather the feedback manually for now
17:20:26 <sarob> from the trainees and trainers and drop on docs ML?
17:20:31 <dguitarbite> well teem meetings will be recorded
17:20:38 <sarob> true
17:20:45 <sarob> duh
17:20:51 <dguitarbite> the meeting results could be good
17:21:00 <sarob> of course you are correct
17:21:03 <dguitarbite> the action items etc. may be good summary so we do not need to do anything manually
17:22:00 <matjazp> sarob: you have any feedback on labs? from last week?
17:22:05 <sarob> #action sarob training-guides team will review trainers action items as part of weekly meeting agenda
17:22:40 <sarob> matjazp: not anything useful yet as we don't have the slides and structure down yet
17:23:21 <sarob> matjazp adding the labs into the mix would be super difficult as a starting point
17:23:59 <sarob> matjazp im shooting for jan as we should have slides and some structure ready by then
17:24:21 <dguitarbite> sarob: labs are ready for Icehouse
17:24:28 <dguitarbite> and debugged and tested really well
17:24:47 <sarob> dguitarbite agreed
17:25:10 <matjazp> I used labs on my course... but I used Ubuntu as a host (they will test windows at home)
17:25:19 <sarob> dguitarbite: we need to get the trainer stuff all org
17:25:54 <sarob> matjazp: we only have a small window and volunteers so i need to keep this very easy
17:26:04 <sarob> baby steps
17:26:24 <matjazp> it went ok... two guys had problems on their mac (smth. with locale settings caused keystone to not install), but as soon they used US, eveything went ok
17:26:29 <sarob> labs are the most ready
17:26:59 <sarob> but i cant through the trainees into the labs without some foundation
17:27:30 <sarob> BTW the 35+ trainees are very interactive and engaged bunch
17:27:32 <dguitarbite> matjazp: good to know :)
17:27:36 <sayali> matjazp: we could record the issues they face and work on it..
17:27:46 <sarob> we have had two sessions
17:27:55 <dguitarbite> it is true that we cannot generate the feedback on our selves
17:28:00 <sarob> most have been to both sessions
17:28:02 <dguitarbite> *one our machines
17:28:32 <sarob> ideas on how to get feedback on the trainees?
17:28:42 <sarob> im going to ask the trainers as well
17:28:48 <sayali> log bugs for the errors they run into?
17:28:51 <sarob> how to get the feedback
17:28:57 <matjazp> sayali: yes, I forgot to tell them to explicitly record all errors... but it was based on using Slovene local settings on Mac
17:29:05 <sarob> sayali sure for materials that works
17:29:14 <sarob> bout the rest
17:29:45 <sayali> sarob: materials that work?
17:30:10 <sarob> sayali not sure i understand the question
17:30:39 <sayali> sarob: I meant log bugs for errors while running the scripts
17:31:05 <sarob> or video :)
17:31:18 <sayali> bugs for video?
17:31:29 <matjazp> but I agree with sarob, trainees should have a super easy method for giving feedback - I'm not convinced filing bugs are easy enough?
17:31:32 <sarob> the feedback has to be interactive
17:31:45 <sarob> we get bugs
17:31:55 <sayali> I guess they can write feedback on the videos..
17:32:01 <sarob> launchpad is way over most people's heads
17:32:04 <dguitarbite> we could keep an hangout
17:32:08 <dguitarbite> every month or two
17:32:17 <ShillaSaebi> hello
17:32:25 <sarob> shillsaebi hi
17:32:39 <sarob> we are discussing how to get feedback from trainees
17:32:50 <matjazp> if they can't write down their thoughts after an event, they sure aren't gonna do it later...
17:32:54 <sarob> we could have a scheduled feedback time
17:32:55 <MeganR1> Is there a way to solicit feedback through a survey
17:33:11 <sarob> matjazp: yeah the feedback should be timely
17:33:14 <dguitarbite> hello ShillaSaebi MeganR1
17:33:27 <matjazp> sarob: maybe trainer can act as a collector and write few lines after each session?
17:33:27 <sayali> hello ShillaSaebi
17:33:38 <matjazp> hey ShillaSaebi
17:33:40 <sarob> meganr1 maybe surveymonkey per event is the way to go
17:33:44 <MeganR1> that way you could direct the questions, especially if you are seeing continued issues/questions
17:33:54 <ShillaSaebi> yeah survey monkey per event sounds good
17:33:59 <MeganR1> sarob - I have had good success with Survey Monkey
17:34:00 <sarob> matjazp plus the trainer
17:34:44 <MeganR1> maybe even write in 10 min at the end of the training to complete the survey
17:35:10 <sarob> #action sarob will take first pass at surveymonkey template for trainer sessions, share with trainers and training-guides teams
17:35:43 <sarob> other ideas?
17:36:44 <sarob> okey dokey
17:37:14 <sarob> im stuck with a git push error
17:37:45 <sarob> lets do this in order
17:37:54 <sarob> i hold on to that for a minute
17:38:08 <sarob> any more on trainers team?
17:38:48 <sarob> #topic criteria and candidates for core reviewership
17:39:01 <sarob> i think rluethi posted this to the agenda
17:39:40 <sarob> rluethi have you joined?
17:40:04 <sarob> i ask him over ML
17:40:23 <sarob> #topic Kilo blueprints signup
17:40:29 <dguitarbite> rluethi is not going to make this meeting
17:40:46 <dguitarbite> he is out of town till 20th December
17:41:09 <sarob> dguitarbite: ah right
17:41:13 <dguitarbite> he asked me to start with this discussion
17:41:19 * sarob never enuf coffee
17:41:33 <sarob> #link https://etherpad.openstack.org/p/training-guides-kilo-summit
17:42:07 <sarob> at the bottom are the bp/topic i believe summarize what we have planned/discussed for kilo
17:42:22 <sarob> i created bp from them
17:42:46 <sarob> before i jump into push specs,
17:43:20 <sarob> finally etherpad is working again
17:43:47 <sarob> whatca all think?
17:45:06 <sayali> sarob: everyone need to add their name to it
17:45:23 <sarob> thats the general idea
17:46:34 <sarob> and the date you think you can contribute to completing the bp
17:46:52 <sarob> i used the milestone
17:47:06 <sarob> you can use just a date if you prefer
17:47:21 <ShillaSaebi> ok
17:47:35 <matjazp> some items depend on other ppl (e.g. infra team for Moodle instance, integration with Launchpad IDs)
17:48:17 <sarob> true, those dependencies go into the spec
17:48:28 <sarob> once you sign up for a bp
17:48:48 <sarob> pushing the spec to openstack/docs-specs/kilo is the next step
17:49:18 <sarob> so the team can review and comment on the bp details in the spec
17:50:25 <sarob> dguitarbite: you are already working on 3
17:51:01 <sarob> dguitarbite: can i get you to commit to M1 for automate the slide build
17:51:29 <matjazp> sarob: creating new slide material is covered in convert-the-xml-into-rst?
17:51:35 <dguitarbite> sarob: I think stefanos team should be able to do this
17:51:46 <dguitarbite> I did that before and the time and effort was wasted
17:51:54 <dguitarbite> I do not want to do it till its very clear
17:52:05 <sarob> dguitarbite: agreed
17:52:43 <matjazp> I believe things will change regarding slide's infra and tools... as we get feedback
17:52:45 <sarob> dguitarbite: reed needs to figure out the requirements, then you can restart
17:53:10 <sarob> matjazp: some sure, but the content needs to get out there for the trainees
17:54:22 <sarob> dguitarbite: if I broker a resolution in what tools dhellman and reed want us to use, can you take this on?
17:54:44 <sarob> dguitarbite: since you already did most of the work
17:55:25 <dguitarbite> sarob: I am supposed to do that as infra sub team lead
17:55:29 <sarob> sayali: what do you think of bp #14?
17:55:32 <dguitarbite> I am waiting for feedback from reed
17:56:00 <dguitarbite> I will do the required things once I get feedback from reed
17:56:03 <sayali> sarob: just updated that part with my name
17:56:19 <sarob> dguitarbite: nope, not at all. i just thought you are in the best postion since you have already done work on it
17:56:39 <dguitarbite> sarob: yes
17:57:00 <sarob> sayali: cool
17:57:21 <sarob> ideas on dates for bp?
17:57:32 <sayali> I think ShillaSaebi would also like to add her name there
17:57:35 <sarob> we have a couple of minutes left
17:57:59 <sarob> shillsaebi: all are welcome :)
17:58:30 <sarob> any other last minute issues?
17:58:39 <matjazp> since BP #3 is important, we should comment on the spec for it as soon as possible
17:59:07 <sarob> okay
17:59:27 <sarob> I will push the spec with reed and dhellman feedback
17:59:45 <sarob> dguitarbite can weigh in on if its doable
17:59:57 <sarob> i think that is it
18:00:08 <sarob> i have a git push issue
18:00:11 <dguitarbite> it is doable
18:00:22 <sarob> talk on docs channel if you have a minute
18:00:24 <dguitarbite> but I cannot assume feedback
18:00:25 <dguitarbite> yes
18:00:32 <sarob> #endmeeting