17:02:11 <sarob> #startmeeting training-guides
17:02:12 <openstack> Meeting started Mon Dec 22 17:02:11 2014 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:15 <openstack> The meeting name has been set to 'training_guides'
17:02:29 <sarob> Hello
17:02:34 <dguitarbite> hello
17:02:35 <rluethi> hey
17:02:41 <matjazp> hi
17:02:49 <sayali> Hi
17:03:12 <sarob> Let's dig in
17:03:30 <sarob> #topic branching
17:03:56 <sarob> Dguitarbite how's it going?
17:04:09 <dguitarbite> waiting for docs team to merge the spec, the required changes are implemented
17:04:37 <dguitarbite> #link https://review.openstack.org/#/c/141369/
17:05:43 <sarob> Got my posture
17:05:43 <matjazp> anne already gave +2 so it's just a matter of time (and proofreading :) sean will give +2 too, right :)
17:05:46 <sarob> Arg
17:05:51 <sarob> Positive
17:06:07 <sarob> Just did
17:06:11 <dguitarbite> sarob: thanks
17:06:34 <sarob> New patch so need annegentle to review it once more
17:07:03 <dguitarbite> sarob: AFAIK shes happy with the patch and we are waiting for Andreas to comment on it
17:07:19 <sarob> Question about juno branch
17:07:28 <dguitarbite> sarob: shoot
17:09:01 <rluethi> that must be one helluva question.
17:10:03 <sarob> So
17:10:03 <sarob> If we branch with only xml and scripts
17:10:03 <sarob> We merge RST
17:11:07 <sarob> Update scripts to include juno
17:11:07 <sarob> Then branch again,
17:11:07 <sarob> Quickly?
17:11:07 <sarob> So we can focus on kilo?
17:11:07 <sarob> Whatca think?
17:11:35 <dguitarbite> sarob: I think we discussed this earlier
17:11:38 <dguitarbite> but ill repeat
17:11:55 <dguitarbite> Juno till Feb 15 ~ depending on various things ofcourse it may be delayed
17:12:02 <dguitarbite> and then release Juno
17:12:14 <dguitarbite> go on with Kilo hopefully with the docs team
17:12:14 <sarob> Dguitarbite did we?
17:12:24 <rluethi> sarob: yes
17:12:25 <dguitarbite> *Feb 2015
17:12:55 <dguitarbite> so by the Kilo release we should expect training-guides to be on track with other projects (release schedule wise)
17:12:57 <sarob> Hmm, so I don't forget again
17:14:28 <sarob> #action sarob create another bp and spec to track the goal of juno branch by 2015 feb
17:14:43 <sarob> So I don't forget again ;)
17:15:06 <sarob> Let's move on then
17:15:22 <sarob> #topic kilo blueprints status
17:15:36 <sarob> I can go first
17:15:45 <dguitarbite> sure
17:16:34 <sarob> I've got a few patches out there
17:16:43 <sarob> Pending branch
17:17:40 <matjazp> sarob: there7s still a question of how to progress after we branch.. see #link https://review.openstack.org/#/c/142350/ comments at the end
17:17:47 <sarob> I will be posting the rest next few days
17:18:40 <matjazp> what do others think of this? merge as a starting point so we can all contribute ASAP?
17:19:38 <sayali> I think we should wait till we branch
17:19:44 <rluethi> matjazp: as long as we are confident that it will come out of draft mode in the foreseeable future...
17:19:49 <sarob> Matjazp the plan is to branch icehouse with xml only
17:19:49 <sarob> I'm hopeful we can branch today or tomorrow
17:19:54 <rluethi> sayali: absolutely.
17:19:59 <dguitarbite> matjazp: first thing would be to wait for branch, after that delete the XML content which should be one single patch and then start pushing Juno stuff into master branch
17:20:03 <dguitarbite> till we release Juno
17:20:13 <dguitarbite> sayali: I agree
17:20:42 <matjazp> yes, that's why I said AFTER we branch.. of course we branch first
17:21:04 <sarob> Dguitarbite we shouldn't make any huge changes
17:21:28 <sarob> I think deleting all the content is a huge change
17:21:55 <rluethi> sarob: I thought that's what we've been saying since Paris.
17:22:09 <sarob> We can move through the chapters as patches pretty quickly
17:22:40 <sarob> 18 dec goal is about making this change quickly
17:22:44 <dguitarbite> sarob: I do see a point in deleting content chapter wise
17:22:55 <sarob> For getting the rst up
17:22:55 <dguitarbite> may be book wise would be good
17:23:07 <sarob> But don't want to break it
17:23:13 <dguitarbite> sarob: break what?
17:23:30 <sarob> The published content
17:23:39 <dguitarbite> sarob: that will be taken care of
17:23:48 <dguitarbite> the end-users will not see any downtime if that is what you mean
17:23:56 <sarob> Yeah I know we can do it
17:23:57 <dguitarbite> the XML content will still be published as it is now
17:24:21 <sarob> While we are getting the rst HTML fixed up
17:24:38 <sarob> We still have the rest published
17:24:52 <sarob> Could be as short as a day
17:24:58 <sarob> Transitsition
17:25:19 <sarob> But with patch review and holidays
17:25:23 <sarob> Never know
17:26:25 <sarob> And there is reeds patch for hieroglyph
17:27:03 <reed> yeah, I was just thinking about that ... hieroglyph is not bad
17:27:09 <rluethi> sarob: so what do you propose?
17:27:48 <sarob> Rluethi we branch so we can move forward
17:27:54 <sarob> We start merging rst
17:28:04 <reed> but I am not sure mixing slides and text-based content in the same file is really a viable option
17:28:41 <rluethi> sarob: I think we all agree that we want to branch soon. Do you want to vote on that?
17:28:52 <sarob> In parallel we agree or disagree on landslide or hieroglyph
17:29:06 <reed> i personally agree on hieroglyph
17:29:07 <matjazp> there are some projects that can generate different HTML5 presentations from RST source.
17:29:28 <reed> although I don't disagree on anything else either
17:29:32 <rluethi> if reed prefers hieroglyph, I support it, too.
17:29:43 <sarob> And once we are ready to publish slides we switch
17:29:47 <dguitarbite> sarob: I agree on Hieroglyph
17:29:55 <dguitarbite> I think we should have a vote on this
17:30:00 <sarob> And then patch to remove xml
17:30:24 <dguitarbite> sarob: I thought first thing after branching is cleaning up the XML content
17:30:37 <dguitarbite> we will have it in the Icehouse branch
17:31:01 <sarob> But we still need the published xml
17:31:03 <matjazp> reed, how do you propose to keep text (eg. presenatation notes)?
17:31:17 <matjazp> reed: separate document?
17:31:28 <reed> matjazp, notes should stay in the hieroglyph file
17:31:31 <sarob> As HTML
17:31:51 <reed> hiero can build notes as presenter's notes :)
17:31:58 <reed> just like landslide
17:32:17 <matjazp> reed: ok, thanks
17:32:25 <sarob> Dguitarbite shouldn't we wait to reemove xml until rst is ready to be HTML published
17:32:49 <dguitarbite> sarob: we have the content in Icehouse, it will not have any effect on the docs.openstack.org page either
17:33:04 <dguitarbite> I prefer cleaning up the mess as its difficult to do that once the RST content is in
17:33:17 <dguitarbite> and I am afraid of new people patching on the XML code
17:33:19 <sarob> Dguitarbite hmm, okay
17:33:31 <dguitarbite> thats another thing I prefer to totally avoid
17:33:58 <rluethi> exactly.
17:34:00 <matjazp> dguitarbite: patches will come as ppl will use icehouse version of the docs, I'm afraid
17:34:07 <sarob> Dguitarbite avoiding zombie xml patches
17:34:19 <matjazp> dguitarbite: so some proosed patches will come nevertheless
17:34:24 <dguitarbite> matjazp: bugs mostly and they can be backported I will love to have them
17:34:38 <dguitarbite> but if the same patches are there in the master branch  then we need to maintain two copies
17:34:46 <dguitarbite> and backport them etc. etc.
17:34:53 <dguitarbite> should we not make our lives easier?
17:35:28 <sarob> Dguitarbite yes easier is good
17:35:33 <matjazp> dguitarbite: I'm sold on "make our lives easier" ;)
17:35:50 <dguitarbite> I am not saying that XML content will be completely removed :), they will be maintained in the Icehouse branch
17:35:52 <dguitarbite> :)
17:35:53 <sayali> yes makes sense :)
17:38:08 <sarob> And sense it's part of the branching spec I +2
17:38:14 <sarob> ;)
17:38:42 <sarob> So we need more specs
17:39:05 <sarob> If you have signed on for a bp
17:39:05 <sayali> I have pushed 1 patch https://review.openstack.org/#/c/143270/
17:39:12 <sayali> but it needs some more work
17:39:24 <sayali> And one more will come soon
17:39:32 <sarob> I see
17:39:46 <sarob> Sayali I will review
17:39:52 <sayali> I need to do some more findings for the 2nd one
17:40:25 <sarob> Sayali okay, get it pushed as soon as you can
17:40:31 <sayali> sure, you can do that after I upload the new patchset
17:40:53 <sarob> Matjazp we need a couple of specs for your bp as well
17:40:55 <matjazp> I'm still a bit behind on my specs. Some urgent work before holidays kick in I'm afraid..
17:41:20 <sarob> Matjazp understood
17:41:23 <matjazp> will try to finish both of them asap
17:41:39 <sarob> Matjazp we are all volunteers here
17:41:49 <sarob> Matjazp so we do what we can
17:42:03 <rluethi> My spec has been in limbo for two weeks and I am very okay with where it is. https://review.openstack.org/#/c/137299/
17:42:34 <rluethi> It won't make it in kilo.
17:42:40 <matjazp> I was talking with my coworker Miha about joining in occasionally...
17:42:54 <dguitarbite> may be you need to learn from inception and try and get it out of limbo asap or you may get lost!
17:43:32 <sarob> Rluethi I was distracted with the other work
17:43:45 <sarob> Rluethi I will comment
17:43:51 <rluethi> sarob: excuses, excuses :)
17:44:14 <sarob> Rluethi I've got hundreds of em
17:44:42 <sarob> Let's move on
17:44:42 <rluethi> seriously, though, we don't have the resource to do it. but hopefully we will get additional information in this cycle that will helps with it eventually.
17:44:44 <matjazp> hehe-- there are always Christmas miracles, right? Maybe Santa can deliver  some quality Specs under my tree
17:45:01 <rluethi> matjazp: good luck with that :)
17:45:26 <sarob> Rluethi yes, I believe we are getting traction
17:45:30 <dguitarbite> hehe
17:45:50 <sarob> Rluethi we keep the work going
17:46:06 <sarob> Rluethi more help will come
17:46:33 <sarob> Rluethi esp with the user group visibility
17:47:05 <sarob> Down soapbox
17:47:25 <rluethi> sarob: of course we are all interested in feedback from the pilot
17:47:58 <sarob> I'm getting the trainers group started up
17:48:09 <matjazp> I've got some feedback for you rluethi
17:48:35 <sarob> I've created a survey
17:48:36 <rluethi> matjazp: excellent.
17:48:45 <rluethi> sarob: cool!
17:49:04 <matjazp> everything works as it should (minus small issue with locale settings you already fixed)
17:49:36 <sarob> #action sarob share user group training survey results with training team
17:49:48 <rluethi> matjazp: nice. I suppose you had no Windows users?
17:49:57 <matjazp> there are some issues with performance - nested virtualization on Virtual Box could be too slow for some advanced testing
17:50:40 <rluethi> matjazp: dguitarbite and sayali are working on KVM support, that should help with performance.
17:51:00 <sarob> Rluethi I want to get the user group using osbash
17:51:00 <matjazp> rluethi: no, I didn't push it ;) We explicitly booted Linux (Ubuntu). But I will have more feedback after holidays, when they test at home
17:51:23 <sarob> Rluethi need the trainers to include
17:51:50 <rluethi> matjazp: cool. feel free to give them my email address.
17:51:51 <sayali> yes performance is much fater. dguitarbite had it running on KVM
17:51:51 <sarob> Rluethi and learn how to manage with 30 people
17:52:19 <sayali> faster*
17:52:58 * sarob osbash KVM spec.....
17:53:33 <matjazp> rluethi: maybe we should also look again at Vagrant- it already has many providers supported (KVM an HyperV inscluded)
17:54:17 <sayali> sarob: that should also be pushed by eom as far as I remember my discussion with dguitarbite
17:54:28 <rluethi> matjazp: problem with vagrant is that it's non-trivial to install, even more so if you want to use its plugins.
17:54:40 <sarob> Sayali okay
17:54:42 <rluethi> matjazp: _and_ rebooting during install is a PITA.
17:54:47 <matjazp> rluethi: non trivial? how so?
17:55:00 <matjazp> rluethi: yes, rebooting is an issue
17:55:41 <sarob> Real quick
17:55:50 <sarob> Before we run out of time
17:56:12 <rluethi> matjazp: the versions of vagrant that come with various distros are quite different, so we might have to ask users to manually install an update.
17:56:28 <sarob> I want to propose we use the nova method for proposing new core reviewers
17:56:55 <matjazp> rluethi: yes, but this is covered on the net in countless blog posts
17:57:04 <rluethi> matjazp: on Windows, last time I checked there were environment variables to set, and installing plugins required extra work.
17:57:14 <dguitarbite> sayali: eom?
17:57:52 <sarob> #link https://wiki.openstack.org/wiki/Nova/CoreTeam#Adding_or_Removing_Members
17:57:57 <sayali> dguitarbite: was it later? I could have misunderstood
17:58:11 <sarob> Read up and let's discuss next meeting
17:58:12 <dguitarbite> sarob: first thiings first, release
17:58:19 <dguitarbite> I dont want to do 100 things at the same time
17:58:38 <sarob> I'm good with that
17:58:39 <matjazp> dguitarbite: its a small thing to agree to
17:58:43 <sarob> Last thing
17:58:52 <sarob> Let's miss the next meeting
17:59:01 <reed> :)
17:59:09 <sarob> Next meeting 06 January
17:59:22 <sarob> That's two meeting miss
17:59:36 <rluethi> k
17:59:39 <matjazp> ok
17:59:40 <sarob> Everyone good with that?
17:59:46 <sayali> yep
17:59:54 <rluethi> wait, on a tuesday?
18:00:09 <sarob> Oops that week the
18:00:13 <sarob> The
18:00:16 <sarob> Then
18:00:20 <rluethi> okay, 5th then.
18:00:26 <sarob> Right
18:00:34 <sarob> Time to go
18:00:42 <rluethi> bye
18:00:45 <matjazp> bye all
18:00:45 <sarob> Merry Christmas everyone
18:00:49 <matjazp> happy hollidays
18:00:53 <sayali> bye!
18:00:54 <sarob> And cheers!
18:00:58 <dguitarbite> happy holidays :)
18:01:01 <dguitarbite> bye
18:01:15 <sarob> #endmeeting