17:00:20 <sarob> #startmeeting training-guides
17:00:21 <openstack> Meeting started Mon Jan 19 17:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:24 <openstack> The meeting name has been set to 'training_guides'
17:00:27 <sayali> hello
17:00:33 <rluethi> hello again
17:01:30 <sarob> roll call
17:01:49 <rluethi> I am here
17:01:55 <sayali> Me too
17:02:47 <sarob> hello everyone
17:03:10 <matjazp> hey guys
17:03:18 <rluethi> hi
17:03:31 <sarob> #topic state of branching
17:04:05 <sarob> no dguitarbite yet...
17:04:28 <rluethi> It's not on the agenda anyway.
17:04:34 <rluethi> Unless you count the third item.
17:04:39 <sarob> it was
17:04:47 <sarob> when you guys update the agenda
17:04:50 <sayali> hey may not be able to join today
17:04:57 <sarob> make sure you just add
17:04:58 <sayali> he*
17:05:02 <sarob> okay
17:05:11 <matjazp> agenda was for last week
17:05:31 <sarob> gerrit is sloow
17:05:38 <matjazp> should we always just copy last weeks agendas?
17:06:02 <rluethi> matjazp: it would likely grow too much.
17:06:15 <matjazp> rluethi: exactly. Thats why I deleted it
17:06:15 <sarob> matjazp: mean carry on what was not finished?
17:06:32 <sarob> branching is pretty critical
17:06:45 <sarob> so we need to conclude it asap
17:06:45 <rluethi> matjazp: maybe we should mark those items we want to keep with a date so they don't get deleted accidentally
17:07:03 <rluethi> sarob: agreed, but there's not much we can do right now.
17:07:05 <matjazp> rluethi: agree
17:07:23 <rluethi> sarob: we can prepare for the time after the branch, though.
17:07:26 <sarob> agreed
17:07:51 <sarob> #topic assessment and Q&A rst chapt format
17:08:01 <matjazp> yes... I was working on that
17:08:30 <matjazp> I propose common document with all q&a, and includes for suitable q&a's for slideware
17:08:41 <matjazp> #link https://review.openstack.org/#/c/148315/
17:09:07 <matjazp> problem is, that not all questions are suitable to show them on slides in front of trainees
17:09:10 * sarob reading
17:09:49 <matjazp> this way, we can include from common document just a selected ones
17:10:10 <rluethi> matjazp: can you elaborate? what questions are suitable or not suitable?
17:10:35 <matjazp> rluethi: e.g. can't put long questions on a slide
17:11:10 <rluethi> matjazp: IC
17:11:28 <matjazp> but they are really helpful when reviewing stuff (e.g. at home after the training session)
17:12:03 <rluethi> matjazp: makes sense.
17:12:03 <matjazp> but when discussing in front of trainees, some questions are really good for facilitating discussion
17:12:29 <matjazp> so we just select those and put them on slides for the trainers to discuss with trainees
17:12:52 <sarob> matjazp: excellent, i like it
17:12:54 <matjazp> that review is just to show what I mean
17:13:02 <matjazp> not a finished product
17:13:15 <matjazp> two files: one has all the questions
17:13:18 <sayali> that sounds good matjazp
17:13:24 <matjazp> the other is slideware
17:13:25 <sarob> matjazp: can you update the patch https://review.openstack.org/#/c/142333/
17:14:07 <sarob> or make it dependent on it
17:14:12 <matjazp> sarob: I was waiting for you guys if you like the concept
17:14:26 <sarob> matjazp: i like, much
17:14:27 <matjazp> sarob: I can make it dependant
17:14:49 <sarob> matjazp: cool
17:15:03 <matjazp> or.. if the branching wont be soon, update the sarobs patches
17:15:25 <rluethi> I wonder if there is a way to make the nature of each file more obvious for newcomers.
17:15:34 <sarob> matjazp: so is there an online testing tool that would let you do exactly what you have here
17:15:39 <rluethi> maybe name them "slides" or something maybe!?
17:15:43 <matjazp> rluethi: different filenames?
17:16:01 <sarob> matjazp: but embed the test question so the
17:16:12 <sarob> matjazp: result updates the remote
17:16:19 <sarob> matjazp: with the question results?
17:16:26 <sarob> matjazp: answer
17:16:34 <matjazp> rluethi: just comment on https://review.openstack.org/#/c/148315
17:17:25 <matjazp> sarob: hmm.. dont know
17:17:29 <rluethi> matjazp: good to know you want feedback, I usually leave patches that are marked WIP alone.
17:18:18 <matjazp> rluethi: dodn't have time to proper look at this and I intended to ask you guys on IRC anyway
17:19:26 <matjazp> removed WIP, so maybe others will comment on it
17:19:49 <rluethi> matjazp: I'll try to take a closer look tomorrow.
17:20:03 <matjazp> rluethi: ok
17:21:00 <sarob> matjazp: think about how a online testing system can use these questions and answers
17:21:12 <matjazp> sarob: I am
17:21:33 <matjazp> problem is, we still havent decided what we will use... Moodle or smth else
17:21:33 <sarob> matjazp: anything else?
17:21:42 <matjazp> sarob: nope
17:22:06 <sarob> matjazp: can i find you some more help?
17:22:33 <matjazp> sarob: that would be great
17:23:09 <sarob> matjazp: i have a few that may be able to help on the online testing specifically
17:24:07 <sarob> #action matjazp will make #link https://review.openstack.org/#/c/148315/ dependent on #link https://review.openstack.org/#/c/142333/
17:24:11 <matjazp> sarob: anyone that can programm? I guess we still need to integrate our online system with Launchpad
17:24:46 <sarob> #action sarob will find matjazp some help with the online testing tool
17:25:09 <sarob> matjazp: more like openID integration
17:25:30 <sarob> matjazp: launchpad days are numbered
17:25:44 <matjazp> sarob: oh... not a moment too soon ;)
17:25:55 <sarob> moving on
17:26:21 <sarob> #topic list of kilo videos to be made
17:26:56 <sarob> #link https://etherpad.openstack.org/p/openstck-training-guides%28Audio_Visual_Content%29
17:27:12 <sayali> I wanted to ask if there is any specific need for videos from the trainers?
17:27:50 <sayali> osbash is currently been worked on but other than that if there was any requirement
17:28:06 <sarob> sayali: we havent done it enough yet
17:28:13 <sarob> sayali: for them to know
17:28:32 <sarob> sayali: and with the format changing, and
17:28:48 <sarob> sayali: starting to include osbash
17:29:10 <sarob> sayali: they are just keeping up
17:29:13 <sayali> have you guys used osbash yet?
17:29:19 <sarob> sayali: not yet
17:29:43 <matjazp> sayali: I used it in my class this semester
17:29:51 <sarob> sayali: i was hoping to start this week, but trainers are getting off to a rough start
17:30:05 <sayali> ah ok. only rluethi reviewed the script on etherpad..
17:30:21 <sayali> matjazp: how did that go?
17:30:24 <rluethi> matjazp: any new feedback?
17:31:02 <matjazp> sayali: ok, worksa as intended
17:31:55 <matjazp> rluethi: I miss some new features... we didn't have them so I had to switch to devstack
17:32:27 <matjazp> rluethi: eg. swift, LBaaS
17:32:35 <rluethi> matjazp: I don't remember seeing a list of missing features.
17:32:43 <rluethi> matjazp: ah
17:32:56 <matjazp> rluethi: NEW new features ;)
17:33:05 <matjazp> rluethi: wishlist
17:33:23 <rluethi> matjazp: I'd like to add whatever is necessary to make it useful.
17:33:26 <sayali> matjazp: that's cool. if you get some time you coud add to the scripts if you find something missing in the setup.
17:33:49 <matjazp> sayali: ok, I'll try to look at it later this week
17:33:51 <rluethi> matjazp: I think swift is covered in the install-guides, but LBaaS?
17:34:06 <sayali> matjazp: cool, thanks!
17:34:42 <matjazp> rluethi: nope :( but it's a really nice feature for demo
17:34:44 <sayali> rluethi: we don't have to go as per the install guides do we?
17:34:53 <sarob> sayali: dumped some notes into the etherpad
17:35:05 <sayali> sarob: great, ill take a look
17:35:06 <rluethi> matjazp: we would need some documentation similar to the install-guide. I just don't want to figure out everything by myself :).
17:35:29 <matjazp> rluethi: we just file a bug to the docs  team :)
17:36:01 <rluethi> matjazp: I was hoping for something faster.
17:36:05 <matjazp> rluethi: ... and wait for "official" documentation
17:37:18 <matjazp> rluethi: yes, I know. some of it is in wiki, but maybe we could just reuse devstack scripts that install it
17:37:58 <rluethi> sayali: I'd like to stick to the install-guide for everything covered in there. for additional things, we can make up our own procedures.
17:38:16 <matjazp> but maybe lbaas is just my personal preference to show some neat features (I also need to teach them about ha concepts)
17:38:36 <rluethi> matjazp: at least for inspiration, that might work. I would still need some smoke test to see if it works (is properly installed).
17:38:37 <sayali> rluethi: yep I meant to ask about the additions only
17:39:04 <sarob> matjazp: thought about recording some of your classwork sessions?
17:39:07 <rluethi> matjazp: I do like the lbaas idea.
17:39:13 <matjazp> sarob: they are in slovene
17:39:34 <rluethi> excellent. we already have sessions in exotic languages!
17:39:45 <sarob> matjazp: hmm, maybe i should brush up on my slovene
17:39:54 <matjazp> exotic? ;)
17:40:01 * sarob maybe i should learn slovene
17:40:03 * matjazp feels special
17:40:05 <rluethi> matjazp: exotic from where I stand :).
17:40:23 <sarob> exotic sounds warm
17:40:30 <matjazp> rluethi: hey, you're just few hundred KMs on the left from me :)
17:40:57 <rluethi> matjazp: yeah, but nothing's exotic here, I assure you. And it's pretty cold, too.
17:40:59 <sarob> 100KM+ = exotic
17:41:16 <rluethi> sarob: from where I live, definitely.
17:41:31 <rluethi> sarob: I wonder why an American would say that, though :).
17:41:40 <sarob> 100KM+= drive to work for me ;)
17:41:48 <rluethi> sarob: they call 500KM+ a "daytrip".
17:42:12 <sarob> 2.5 hour each way now during commute time
17:42:21 <sarob> fun stuff
17:42:39 <rluethi> I bet.
17:43:24 <sarob> soooo, it would be cool to have some real life use of openstack, osbash, and training
17:43:32 <matjazp> sarob: hmmm and I complain... and I have work just few KMs from where I live
17:43:39 <sarob> matjazp: even if in slovene
17:43:50 <sarob> matjazp: could always translate
17:43:56 <rluethi> sarob: I think we can all agree on that.
17:43:56 <sarob> matjazp: with subtitles
17:44:05 <matjazp> sarob: this week is the last week of semester
17:44:18 <sarob> matjazp: maybe next time
17:45:02 <sarob> matjazp: showing how many different people are using openstack is good for this project and also openstack
17:45:06 <sarob> matjazp: at large
17:45:35 <sayali> yeah those recordings will be very useful
17:45:46 <sarob> sayali: anything else on AV?
17:46:10 <sayali> umm the spec is out for review
17:46:17 <sayali> for AV
17:46:31 <rluethi> sayali: we are hoping to get some version of the test script script soonish, it might be worth waiting for that and including it.
17:46:46 <rluethi> sayali: depending on your schedule and plans, of course.
17:47:21 <sarob> sayali: i will give the spec review
17:47:28 <sayali> rluethi: I can wait but do we want to club that in the same video?
17:47:43 <sarob> sayali: club?
17:48:30 <sarob> annegentle: any eta on training-guides branching?
17:48:49 <sayali> sorry I lost connection
17:48:55 <rluethi> sayali: club?
17:49:08 <sarob> annegentle: we are blocked on branching
17:49:51 <sayali> ya asin make one video or a sequel to the post setup for osbash with the test scripts
17:50:08 <sarob> #action sarob annegentle training-guides branching, unblock so we can get to kilo branch on schedule
17:50:24 <rluethi> sayali: I like the sequel idea.
17:50:54 <sarob> sayali: sounds good
17:50:57 <rluethi> sarob: ISTR that the spec is almost merged but needs rebasing.
17:51:07 <matjazp> sayali: better to make a lot of short, focused videos than one all.in.one
17:51:26 <sayali> rluethi: cool, so the we can go ahead with the first one then once the test scripts are ready we could work on that
17:51:34 <sayali> matjazp: yep I agree
17:51:40 <sarob> rluethi: is merged #link https://github.com/openstack/docs-specs/blob/master/specs/kilo/training-guides-icehouse-release.rst
17:51:50 <rluethi> sarob: then it's a matter of andreas and pranav having time to do the actual branching work (or request infra to do it).
17:52:41 <sarob> rluethi: agreed, just referencing annegentle that it is blocking us
17:53:12 <sarob> sayali: short videos are good
17:53:44 <sayali> sarob: yep
17:54:03 <sarob> rluethi: dguitarbite and andeasj are working on it
17:54:25 <sarob> rluethi: reminding annegentle is part of the process
17:54:58 <sarob> rluethi: if they get blocked then we could go to infra directly, just wanted to follow the steps
17:55:13 <sarob> rluethi: rather than jumping ahead
17:55:15 <rluethi> sarob: I did not know that. Thanks for the explanation.
17:55:52 <sarob> rluethi: guessing on some of  this since we have never branched before
17:56:18 <sarob> #topic any other business
17:56:27 <sarob> few minutes left
17:56:54 <sarob> we all cores should review specs
17:57:03 <sarob> merge if ready
17:57:20 <rluethi> specs in docs-specs?
17:57:23 <matjazp> specs are in docs-specs repo
17:57:44 <rluethi> we are not core there, nor can we merge anything.
17:58:03 <sarob> rluethi: duh, sorry
17:58:10 <sarob> rluethi: not enuf coffeee
17:58:36 <sarob> rluethi: review though
17:58:52 <sarob> any thing else?
17:58:56 <rluethi> wouldn't hurt to send out an email pointing out specs that we should review.
17:59:20 <rluethi> I'm good.
17:59:30 <sayali> nope nothing
17:59:32 <sarob> #action sarob ML update on patches to review
17:59:36 <matjazp> ok, bye all
17:59:39 <sarob> sweet
17:59:43 <rluethi> bye
17:59:43 <sarob> bye people
17:59:47 <sayali> bye
17:59:58 <sarob> #endmeeting